source: projects/specs/branches/6/p/pdflib-lite/pdflib-lite-vl.spec @ 2371

Revision 2371, 5.4 KB checked in by owa, 13 years ago (diff)

update pdflibs

Line 
1%define binding_langs perl python
2Summary: Portable C library for dynamically generating PDF files
3Summary(ja): PDF ファイルを動的に生成できる取扱い易い C 言語ライブラリ
4Name: pdflib-lite
5Version: 7.0.5
6Release: 1%{?dist}
7License: Distributable
8Group: Development/Libraries
9URL: http://www.pdflib.com/
10Source: http://www.pdflib.com/binaries/PDFlib/704/PDFlib-Lite-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12Vendor: Project Vine
13Distribution: Vine Linux
14Conflicts: pdflib <= 4
15
16%description
17PDFlib is a development tool for PDF-enabling your software,
18or generating PDF on your server. PDFlib offers a simple-to-use API
19for programmatically creating PDF files from within your own server-
20or client-side software. PDFlib doesn't make use of third-party software
21for generating PDF, nor does it require any other tools.
22
23%package devel
24Summary: Development files for pdflib
25Group: Development/Libraries
26Requires: %{name} = %{version}-%{release}
27
28%description devel
29PDFlib is a development tool for PDF-enabling your software,
30or generating PDF on your server. PDFlib offers a simple-to-use API
31for programmatically creating PDF files from within your own server-
32or client-side software. PDFlib doesn't make use of third-party software
33for generating PDF, nor does it require any other tools.
34
35This package contains the files needed for compiling programs that will use
36the PDFlib library.
37
38%package python
39Summary: Python shared library for pdflib
40Group: System Environment/Libraries
41BuildRequires: python-devel
42Requires: %{name} = %{version}-%{release}
43Provides: python-pdflib = %{version}-%{release}
44
45%description python
46PDFlib is a development tool for PDF-enabling your software,
47or generating PDF on your server. PDFlib offers a simple-to-use API
48for programmatically creating PDF files from within your own server-
49or client-side software. PDFlib doesn't make use of third-party software
50for generating PDF, nor does it require any other tools.
51
52This package contains the library needed for python programs
53that will use the PDFlib library.
54
55%package perl
56Summary: Perl shared library for pdflib
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
60Provides: perl-pdflib = %{version}-%{release}
61
62%description perl
63PDFlib is a development tool for PDF-enabling your software,
64or generating PDF on your server. PDFlib offers a simple-to-use API
65for programmatically creating PDF files from within your own server-
66or client-side software. PDFlib doesn't make use of third-party software
67for generating PDF, nor does it require any other tools.
68
69This package contains the library needed for perl programs
70that will use the PDFlib library.
71
72
73%prep
74%setup -q -n PDFlib-Lite-%{version}
75sed -i -e "s|^PYTHONLIBDIR.*|PYTHONLIBDIR = %{python_sitearch}|" config/mkcommon.inc.in
76sed -i -e "s|^PERLLIBDIR.*|PERLLIBDIR = %{perl_vendorarch}|" config/mkcommon.inc.in
77
78
79%build
80# java, ruby and tcl disabled.
81# File a bug with RFE and patch if you need it (by fedora12).
82%configure \
83        --enable-large_files \
84        --enable-tiffwrite \
85        --disable-static \
86        --with-pyincl=%{_includedir}/python%{pyver} \
87        --with-py=yes \
88    --with-java=no \
89    --with-ruby=no \
90    --with-tcl=no \
91        --with-openssl \
92%ifarch x86_64
93        --enable-64bit \
94%endif
95        ;
96
97%{__make} %{?_smp_mflags}
98for lang in %{binding_langs}; do
99        %{__make} -C bind/pdflib/$lang
100done
101
102
103%install
104rm -rf %{buildroot}
105mkdir -p %{buildroot}%{python_sitearch}
106mkdir -p %{buildroot}%{perl_vendorarch}
107make install DESTDIR=%{buildroot}
108for lang in %{binding_langs} ; do
109        make -C bind/pdflib/$lang install DESTDIR=%{buildroot}
110done
111
112install -p -m 0644 bind/pdflib/cpp/pdflib.hpp %{buildroot}%{_includedir}/pdflib.hpp
113chmod +x %{buildroot}%{_libdir}/libpdf*
114chmod +x %{buildroot}%{python_sitearch}/pdflib_py.so*
115chmod +x %{buildroot}%{perl_vendorarch}/pdflib_pl.so*
116
117rm -rf examples
118mkdir -p examples/{c,cpp,perl,php,python}
119cp -r bind/pdflib/data examples/data
120cp bind/pdflib/c/*.c bind/pdflib/c/Makefile bind/pdflib/c/readme.txt \
121        examples/c
122cp bind/pdflib/cpp/*.cpp bind/pdflib/cpp/Makefile bind/pdflib/cpp/readme.txt \
123        examples/cpp
124cp bind/pdflib/perl/*.pl bind/pdflib/perl/Makefile bind/pdflib/perl/readme.txt \
125        examples/perl
126cp bind/pdflib/python/*.py bind/pdflib/python/Makefile bind/pdflib/python/readme.txt \
127        examples/python
128cp bind/pdflib/php/*.php bind/pdflib/php/readme.txt \
129        examples/php
130cp bind/pdflib/php/examples.php5/*.php \
131        examples/php
132
133
134%post -p /sbin/ldconfig
135%postun -p /sbin/ldconfig
136%clean
137rm -rf %{buildroot}
138
139
140%files
141%defattr(-, root, root)
142%doc readme.txt
143%doc doc/pdflib/PDFlib-Lite-license.pdf
144%{_bindir}/pdfimage
145%{_bindir}/pdflib-config
146%{_bindir}/text2pdf
147%{_libdir}/libpdf.so.*
148
149%files devel
150%defattr(-, root, root)
151%doc doc/pdflib/PDFlib-Lite-license.pdf
152%doc doc/pdflib/changes.txt doc/pdflib/compatibility.txt
153%doc doc/pdflib/PDFlib-API-reference.pdf
154%doc doc/pdflib/PDFlib-tutorial.pdf
155%doc doc/pdflib/readme-source-unix.txt
156%doc examples
157%{_bindir}/pdflib-config
158%{_includedir}/pdflib.h
159%{_includedir}/pdflib.hpp
160%{_libdir}/libpdf.so
161%exclude %{_libdir}/*.la
162
163%files python
164%defattr(-, root, root)
165%doc doc/pdflib/PDFlib-Lite-license.pdf
166%{python_sitearch}/pdflib_py.so*
167%exclude %{python_sitearch}/*.la
168
169%files perl
170%defattr(-, root, root)
171%doc doc/pdflib/PDFlib-Lite-license.pdf
172%{perl_vendorarch}/pdflib_pl.*
173
174
175%changelog
176* Mon Dec 20 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.5-1
177- initial build for VineSeed
178
Note: See TracBrowser for help on using the repository browser.