source: projects/specs/branches/6/p/pciutils/pciutils-vl.spec @ 1942

Revision 1942, 10.3 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        PCI bus related utilities.
3Summary(ja):    Linux PCI ユーティリティ
4Name:           pciutils
5Version:        3.1.2
6Release:        4%{?_dist_release}
7License:        GPLv2+
8URL:            http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
9Group:          Applications/System
10
11Source:         %{name}-%{version}.tar.gz
12Patch1:         pciutils-2.2.4-buf.patch
13Patch2:         pciutils-2.1.10-scan.patch
14Patch3:         pciutils-havepread.patch
15Patch6:         pciutils-2.2.1-idpath.patch
16Patch8:         pciutils-3.0.2-multilib.patch
17Patch9:         pciutils-dir-d.patch
18Patch10:        pciutils-2.2.10-sparc-support.patch
19Patch11:        pciutils-3.0.1-superh-support.patch
20
21Buildroot:      %{_tmppath}/%{name}-%{version}-root
22ExclusiveOS:    Linux
23BuildRequires:  sed
24Requires:       hwdata
25Requires:       %{name}-libs = %{version}-%{release}
26
27
28%description
29The pciutils package contains various utilities for inspecting and
30setting devices connected to the PCI bus. The utilities provided
31require kernel version 2.1.82 or newer (which support the
32/proc/bus/pci interface).
33
34%description -l ja
35このパッケージには PCI バスに接続された各種デバイスの状態を見たり
36設定したりする為のユーティリティが収められています.
37このパッケージに収められたユーティリティはカーネル 2.1.82 以降
38(/proc/bus/pci インタフェースがサポートされているもの) を必要とします.
39
40%package devel
41Summary: Linux PCI development library.
42Summary(ja):    Linux PCI 開発ライブラリ
43Group: Development/Libraries
44Requires: %{name}-libs = %{version}-%{release}
45
46%description devel
47This package contains a library for inspecting and setting
48devices connected to the PCI bus.
49
50%description devel -l ja
51このパッケージには PCI バスに接続された各種デバイスの状態を見たり
52設定したりするのに必要なライブラリが収められています.
53
54%package libs
55Summary: Linux PCI library
56Summary(ja): Linux PCI ライブラリ
57Group: System Environment/Libraries
58
59%description libs
60This package contains a library for inspecting and setting
61devices connected to the PCI bus.
62
63%package static
64Summary: Linux PCI satic library
65Summary(ja): Linux PCI スタッティックライブラリ
66Group: System Environment/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70This package contains a library for inspecting and setting
71devices connected to the PCI bus.
72
73## to build compat32 for x86_64 architecture support
74%package -n compat32-%{name}-libs
75Summary: Linux PCI library.
76Group: Development/Libraries
77Requires: compat32-%{name}-devel = %{version}-%{release}
78%description -n compat32-%{name}-libs
79This package contains a library for inspecting and setting
80devices connected to the PCI bus.
81
82%package -n compat32-%{name}-devel
83Summary: Linux PCI development library.
84Group: Development/Libraries
85%description -n compat32-%{name}-devel
86This package contains a library for inspecting and setting
87devices connected to the PCI bus.
88
89%prep
90%setup -q -n pciutils-%{version}
91%patch1 -p1 -b .buf
92%patch2 -p1 -b .scan
93%patch3 -p1 -b .pread
94%patch6 -p1 -b .idpath
95%patch8 -p1 -b .multilib
96%patch9 -p1 -b .dird
97%patch10 -p1 -b .sparc
98%patch11 -p1 -b .superh
99
100sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
101
102%build
103make SHARED="no" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
104mv lib/libpci.a lib/libpci.a.toinstall
105
106make clean
107
108make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
109
110#fix lib vs. lib64 in libpci.pc (static Makefile is used)
111sed -i -e "s|^libdir=.*$|libdir=%{_libdir}|" lib/libpci.pc
112
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117install -d $RPM_BUILD_ROOT/{sbin,%{_mandir}/man8,%{_libdir},%{_libdir}/pkgconfig,%{_includedir}/pci}
118
119install -p lspci setpci update-pciids $RPM_BUILD_ROOT/sbin
120install -p lspci.8 setpci.8 update-pciids.8 $RPM_BUILD_ROOT%{_mandir}/man8
121install -p  lib/libpci.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
122ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpci.so
123
124mv lib/libpci.a.toinstall lib/libpci.a
125install -p lib/libpci.a $RPM_BUILD_ROOT%{_libdir}
126/sbin/ldconfig -N $RPM_BUILD_ROOT%{_libdir}
127install -p lib/pci.h $RPM_BUILD_ROOT%{_includedir}/pci
128install -p lib/header.h $RPM_BUILD_ROOT%{_includedir}/pci
129install -p lib/config.h $RPM_BUILD_ROOT%{_includedir}/pci
130install -p lib/types.h $RPM_BUILD_ROOT%{_includedir}/pci
131install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
132
133
134%post libs -p /sbin/ldconfig
135
136%postun libs -p /sbin/ldconfig
137
138%post -n compat32-%{name}-libs -p /sbin/ldconfig
139
140%postun -n compat32-%{name}-libs -p /sbin/ldconfig
141
142
143%files
144%defattr(0644, root, root, 0755)
145%{_mandir}/man8/*
146%attr(0755, root, root) /sbin/*
147%doc README ChangeLog pciutils.lsm
148
149%files devel
150%defattr(0644, root, root, 0755)
151%{_libdir}/libpci.so
152%{_libdir}/pkgconfig/libpci.pc
153%{_includedir}/pci
154
155%files libs
156%defattr(0644, root, root, 0755)
157%{_libdir}/libpci.so.*
158
159%files static
160%defattr(0644, root, root, 0755)
161%{_libdir}/libpci.a
162
163%if %{build_compat32}
164%files -n compat32-%{name}-devel
165%defattr(0644, root, root, 0755)
166%{_libdir}/libpci.so
167%{_libdir}/pkgconfig/libpci.pc
168%{_includedir}/pci
169
170%files -n compat32-%{name}-libs
171%defattr(0644, root, root, 0755)
172%{_libdir}/libpci.so.*
173%endif
174
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179
180%changelog
181* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
182- rebuilt with rpm-4.8.1 for pkg-config
183
184* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-3
185- add Requires: %{name}-libs = %{version}-%{release} (devel package)
186
187* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-2
188- removed %%if !%%{build_compat32} case condition
189
190* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-1
191- new upstream release
192- add shared library
193- split shared library to -libs
194- split static library to -static
195
196* Fri Nov  7 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
197- new upstream release
198
199* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1vl5
200- new upstream release
201
202* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.4-1vl5
203- applied new versioning policy, spec in utf-8
204
205* Wed Dec 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
206- new upstream release
207
208* Sun Feb 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.1-1vl2
209- rebuilt for x86_64 architecture support
210- added compat32-* packages for x86_64 architecture support
211
212* Sun Dec 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.1-1vl1
213- updated to 2.2.1 based on fedora package
214  * Mon Mar 14 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-8
215  - add patch for glibc macros (#151032, <redhat-bugzilla@linuxnetz.de>)
216  * Tue Jan 25 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-6
217  - remove explicit kernel dep (#146153)
218
219* Sat Nov 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-4vl1
220- use hwdata for pci.ids database.
221- merged with rawhide package.
222  - update to 2.1.10
223  - fix dir perms on /usr/include/pci
224  - don't forcibly strip binaries
225  - require hwdata now that pci.ids is there
226  - man page is now owned by root
227
228* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.8-25vl1
229- based on 2.1.8-25 from Rawhide and rebuilt for Vine Linux
230
231* Wed Oct 17 2001 Bill Nottingham <notting@redhat.com>
232- dump all the patches, ship pci.ids direct out of sourceforge CVS
233
234* Wed Sep 26 2001 Bill Nottingham <notting@redhat.com>
235- broadcom bcm5820 id (#53592)
236
237* Fri Aug 10 2001 Bill Nottingham <notting@redhat.com>
238- more ids
239
240* Tue Jul 17 2001 Bill Nottingham <notting@redhat.com>
241- add newline in printf in PCI-X patch (#49277)
242
243* Mon Jul  9 2001 Bill Nottingham <notting@redhat.com>
244- update broadcom patch
245- add new ids from 2.4.6
246
247* Mon May 28 2001 Bill Nottingham <notting@redhat.com>
248- add a couple of e1000 ids
249
250* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
251- another megaraid id
252
253* Wed Mar 21 2001 Bill Nottingham <notting@redhat.com>
254- another megaraid id
255
256* Wed Mar 14 2001 Preston Brown <pbrown@redhat.com>
257- LSI SCSI PCI id
258
259* Wed Feb 21 2001 Nalin Dahyabhai <nalin@redhat.com>
260- fix formatting problems
261
262* Wed Feb 21 2001 Preston Brown <pbrown@redhat.com>
263- add IBM ServeRAID entries
264
265* Tue Feb 20 2001 Preston Brown <pbrown@redhat.com>
266- i860 entries.
267
268* Mon Feb 19 2001 Helge Deller <hdeller@redhat.de>
269- added various pci ids
270
271* Fri Feb  2 2001 Bill Nottingham <notting@redhat.com>
272- fix mishap in fixing mishap
273
274* Thu Feb  1 2001 Bill Nottingham <notting@redhat.com>
275- fix apparent mishap in pci.ids update from kernel (#25520)
276
277* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
278- pci.ids updates
279
280* Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
281- big pile of pci.ids updates
282
283* Tue Jul 25 2000 Nalin Dahyabhai <nalin@redhat.com>
284- clean up patches to not generate badly-formatted files
285
286* Tue Jul 25 2000 Preston Brown <pbrown@redhat.com>
287- Vortex fixes laroche originally applied on kudzu moved here.
288
289* Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
290- pci ids for i815, new ati hardware
291
292* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
293- automatic rebuild
294
295* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
296- yet more IDs
297- PCI-X support from Matt Domsch
298
299* Fri Jul  7 2000 Bill Nottingham <notting@redhat.com>
300- some more QLogic ids
301
302* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
303- more IDs from Dell
304
305* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
306- update to 2.1.8
307
308* Fri Apr 21 2000 Bill Nottingham <notting@redhat.com>
309- update to 2.1.7
310
311* Mon Apr 17 2000 Bill Nottingham <notting@redhat.com>
312- update to 2.1.6
313
314* Fri Mar  3 2000 Bill Nottingham <notting@redhat.com>
315- add a couple of ids
316
317* Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
318- update to 2.1.5
319
320* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
321- handle compressed man pages
322
323* Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
324- update to 2.1.4
325
326* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
327- update to 2.1.3
328
329* Fri Dec 24 1999 Bill Nottingham <notting@redhat.com>
330- update to 2.1.2
331
332* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
333- add -devel package
334
335* Thu May 20 1999 Bill Nottingham <notting@redhat.com>
336- update to 2.0
337
338* Mon Apr 19 1999 Jakub Jelinek  <jj@ultra.linux.cz>
339- update to 1.99.5
340- fix sparc64 operation
341
342* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
343- auto rebuild in the new build environment (release 2)
344
345* Thu Feb  4 1999 Bill Nottingham <notting@redhat.com>
346- initial build
Note: See TracBrowser for help on using the repository browser.