source: projects/specs/branches/6/p/parole/parole-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# by default don't build the browser plugin
2# use bcond_without to change the default
3%bcond_with mozilla
4
5Name:           parole
6Version:        0.2.0.2
7Release:        1%{?_dist_release}
8Summary:        Media player for the Xfce desktop
9Summary(ja):    Xfce デスクトップのメディアプレーヤー
10
11Group:          Applications/Multimedia
12License:        GPLv2+
13URL:            http://goodies.xfce.org/projects/applications/parole
14Source0:        http://archive.xfce.org/src/apps/parole/0.1/%{name}-%{version}.tar.bz2
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  gtk2-devel >= 2.16.0
18BuildRequires:  glib2-devel >= 2.16.0
19BuildRequires:  gstreamer-devel
20BuildRequires:  gstreamer-plugins-base-devel >= 0.10.11
21BuildRequires:  dbus-devel >= 0.60
22BuildRequires:  dbus-glib-devel >= 0.70
23BuildRequires:  libxfcegui4-devel >= 4.6.0
24BuildRequires:  libxfce4util-devel >= 4.6.0
25BuildRequires:  libnotify-devel >= 0.4.1
26BuildRequires:  taglib-devel >= 1.4
27BuildRequires:  desktop-file-utils
28BuildRequires:  gettext
29BuildRequires:  intltool
30%if %{with mozilla}
31BuildRequires:  xulrunner-devel
32%endif
33BuildRequires:  gtk-doc
34Requires:       gstreamer-plugins-good
35
36%description
37Parole is a modern simple media player based on the GStreamer framework and
38written to fit well in the Xfce desktop. Parole features playback of local
39media files, DVD/CD and live streams. Parole is extensible via plugins.
40
41The project still in its early developments stage, but already contains the
42following features:
43* Audio playback
44* Video playback with optional subtitle
45* Playback of live sources
46
47%description -l ja
48Parole は GStreamer フレームワークに基づき Xfce デスクトップに
49馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
50Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
51特色とします。
52Parole はプラグインを介して拡張が可能です。
53
54このプロジェクトはまだ開発の初期段階ですが、
55既に以下の機能がふくまれています。
56* オーディオの再生
57* 任意のサブタイトルがあるビデオの再生
58* ライブストリームの再生
59
60
61%package        devel
62Summary:        Development files for %{name}
63Summary(ja):    %{name} の開発ファイル
64Group:          Development/Libraries
65Requires:       %{name} = %{version}-%{release}
66Requires:       gtk-doc
67
68%description    devel
69The %{name}-devel package contains header files for developing plugins for
70%{name}.
71
72%description    devel -l ja
73%{name}-devel パッケージ は %{name} のプラグインを開発するための
74ヘッダファイルを含みます。
75
76%if %{with mozilla}
77%package mozplugin
78Summary:        Browser plugin for %{name}
79Group:          Application/Internet
80Requires:       %{name} = %{version}-%{release}
81
82%description    mozplugin
83Parole is a modern simple media player based on the GStreamer framework and
84written to fit well in the Xfce desktop. This plugin allows it to be embedded
85in a web browser.
86%endif
87
88%prep
89%setup -q
90
91%build
92%configure --disable-static --enable-gtk-doc \
93%if %{with mozilla}
94 --enable-browser-plugin
95%else
96 --disable-browser-plugin
97%endif
98make %{?_smp_mflags} V=1
99
100
101%install
102rm -rf $RPM_BUILD_ROOT
103make install DESTDIR=$RPM_BUILD_ROOT
104find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
105%find_lang %{name}
106
107desktop-file-install                                    \
108  --delete-original                                     \
109  --dir=%{buildroot}%{_datadir}/applications            \
110  %{buildroot}/%{_datadir}/applications/%{name}.desktop
111
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116
117%post
118touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
119update-mime-database %{_datadir}/mime &> /dev/null || :
120
121
122%postun
123if [ $1 -eq 0 ] ; then
124  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
125  gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
126fi
127update-mime-database %{_datadir}/mime &> /dev/null || :
128
129
130%posttrans
131gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
132
133
134%files -f %{name}.lang
135%defattr(-,root,root,-)
136%doc AUTHORS COPYING README TODO THANKS
137%{_bindir}/%{name}
138%dir %{_libdir}/%{name}-0/
139%{_libdir}/%{name}-0/*.so
140%{_datadir}/applications/%{name}.desktop
141%{_datadir}/icons/hicolor/*
142%{_datadir}/%{name}/
143
144
145%files devel
146%defattr(-,root,root,-)
147%doc %{_datadir}/gtk-doc/html/Parole-Plugins/
148%{_includedir}/%{name}/
149
150
151%if %{with mozilla}
152%files mozplugin
153%defattr(-,root,root,-)
154%{_libexecdir}/%{name}-media-plugin
155%{_libdir}/mozilla/plugins/%{name}-player.so
156%endif
157
158%changelog
159* Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
160- new upstream release
161
162* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
163- new upstream release
164
165* Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
166- new upstream release
167- added BuildRequires:  glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
168
169* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
170- new upstream release
171- added BuildRequires: gstreamer-devel
172- splitted mozplugin package
173
174* Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
175- new upstream release
176- dropt all pathces
177
178* Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
179- initial build for VineSeed
180
181* Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
182- BuildRequire taglib-devel and fix libnotify requirement
183
184* Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
185- Update to 0.1.90
186- Loads of additional translations
187
188* Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
189- Initial package
Note: See TracBrowser for help on using the repository browser.