source: projects/specs/branches/6/o/openbabel/openbabel-vl.spec @ 1979

Revision 1979, 8.1 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
2%define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%define ruby_arch %(ruby -rrbconfig -e 'puts Config::CONFIG["archdir"]')
6
7Name:             openbabel
8Version:          2.2.3
9Release:          4%{?_dist_release}
10Summary:          Chemistry software file format converter
11Summary(ja):      化学ソフトデータファイル変換プログラム
12License:          GPL
13Group:            Applications/Edutainment
14URL:              http://openbabel.sourceforge.net/
15Source:           http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
16
17BuildRoot:        %{_tmppath}/%{name}-%{version}-root
18BuildRequires: inchi-devel
19BuildRequires: libtool
20BuildRequires: libxml2-devel
21BuildRequires: perl
22BuildRequires: python
23BuildRequires: python-devel
24BuildRequires: ruby
25BuildRequires: ruby-devel
26BuildRequires: swig
27#TODO: enable when GUI is functional
28#BuildRequires: wxGTK-devel
29BuildRequires: zlib-devel
30
31Distribution:  Vine Linux
32Vendor:       Project Vine
33Packager:     inagaki
34
35%description
36Open Babel is a free, open-source version of the Babel chemistry file
37translation program. Open Babel is a project designed to pick up where
38Babel left off, as a cross-platform program and library designed to
39interconvert between many file formats used in molecular modeling,
40computational chemistry, and many related areas.
41
42Open Babel includes two components, a command-line utility and a C++
43library. The command-line utility is intended to be used as a replacement
44for the original babel program, to translate between various chemical file
45formats. The C++ library includes all of the file-translation code as well
46as a wide variety of utilities to foster development of other open source
47scientific software.
48
49%package devel
50Summary: Development tools for programs which will use the Open Babel library
51Summary(ja): %{name}の開発用ヘッダファイル
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: pkgconfig
55
56%description devel
57The %{name}-devel package includes the header files and libraries
58necessary for developing programs using the Open Babel library.
59
60If you are going to develop programs which will use this library
61you should install %{name}-devel.  You'll also need to have the
62%{name} package installed.
63
64%description devel -l ja
65%{name}の開発用ヘッダファイル
66
67%package -n perl-%{name}
68Summary: Perl wrapper for the Open Babel library
69Summary(ja): Open Babel ライブラリの Perl ラッパー
70Group: Development/Libraries
71Requires: perl > %(eval "`%{__perl} -V:version`"; echo $version)
72Obsoletes: %{name}-perl < 2.2.0
73Provides: %{name}-perl = %{version}-%{release}
74
75%description -n perl-%{name}
76Perl wrapper for the Open Babel library.
77
78%description -n perl-%{name} -l ja
79Open Babel ライブラリの Perl ラッパーです.
80
81%package -n python-%{name}
82Group: Development/Libraries
83Summary: Python wrapper for the Open Babel library
84Summary(ja): Open Babel ライブラリの Python ラッパー
85Obsoletes: %{name}-python < 2.2.0
86Provides: %{name}-python = %{version}-%{release}
87
88%description -n python-%{name}
89Python wrapper for the Open Babel library.
90
91%description -n python-%{name} -l ja
92Open Babel ライブラリの Python ラッパー
93
94%package -n ruby-%{name}
95Summary: Ruby wrapper for the Open Babel library
96Summary(ja): Open Babel ライブラリの Ruby ラッパー
97Group: Development/Libraries
98Requires: ruby >= 1.8
99Requires: %{name} = %{version}-%{release}
100
101%description -n ruby-%{name}
102Open Babel ライブラリの Ruby ラッパー
103
104%prep
105%setup -q
106chmod 644 src/formats/{mmcif,fchk}format.cpp
107
108%build
109autoreconf --force --install
110%configure --enable-shared=yes --enable-static=no --disable-inchi
111make %{?_smp_mflags}
112
113pushd scripts/perl
114LD_LIBRARY_PATH=../../src/.libs perl Makefile.PL INSTALLDIRS="vendor"
115make %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
116popd
117
118pushd scripts/python
119python setup.py build
120popd
121
122pushd scripts/ruby
123ruby extconf.rb --with-openbabel-include=../../include --with-openbabel-lib=../../src/.libs
124make %{?_smp_mflags}
125popd
126
127%install
128rm -rf $RPM_BUILD_ROOT
129make install DESTDIR=$RPM_BUILD_ROOT
130
131rm -f $RPM_BUILD_ROOT%{_libdir}{,/%{name}}/*.la
132
133pushd scripts/perl
134make install DESTDIR=$RPM_BUILD_ROOT
135popd
136rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
137rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/*/Chemistry/OpenBabel/{.packlist,OpenBabel.bs}
138chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
139
140pushd scripts/python
141python setup.py install --skip-build --root $RPM_BUILD_ROOT
142python setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
143popd
144
145pushd scripts/ruby
146make install sitearchdir=${RPM_BUILD_ROOT}%{ruby_arch}
147popd
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%post -p /sbin/ldconfig
153
154%postun -p /sbin/ldconfig
155
156%files
157%defattr(-,root,root,-)
158%doc AUTHORS COPYING ChangeLog README THANKS
159%doc doc/*.html
160%doc doc/README* doc/babel*.inc doc/dioxin.*
161%{_bindir}/*
162%{_mandir}/man1/*
163%{_datadir}/%{name}
164%{_libdir}/libopenbabel.so.*
165%{_libdir}/%{name}
166
167%files devel
168%defattr(-,root,root,-)
169%{_includedir}/%{name}-2.0
170%{_libdir}/libopenbabel.so
171%{_libdir}/pkgconfig/*.pc
172
173%files -n perl-%{name}
174%defattr(-,root,root,-)
175%{perl_vendorarch}/Chemistry/OpenBabel.pm
176%dir %{perl_vendorarch}/*/Chemistry/OpenBabel
177%{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
178
179%files -n python-%{name}
180%defattr(-,root,root,-)
181%{python_sitearch}/_openbabel.so
182%{python_sitearch}/openbabel.py*
183%{python_sitearch}/pybel.py*
184
185%files -n ruby-%{name}
186%defattr(-,root,root,-)
187%{ruby_arch}/openbabel.so
188
189%changelog
190* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-4
191- rebuilt with rpm-4.8.1 for pkg-config
192
193* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3
194- rebuild with python-2.6
195
196* Fri Nov 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.3-2
197- <BTS:0789> ruby binding install path changed to Config::CONFIG["archdir"]
198
199* Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
200- applied new versioning policy, spec in UTF-8
201- using system inchi package
202- added ruby-%{name} package
203
204* Mon May 14 2007 Susumu Tanimura <arumiant@gmail.com> 2.1.0-0vl1
205- Updated to 2.1.0
206
207* Tue May  1 2007  Susumu Tanimura <arumiant@gmail.com> 2.0.2-5vl1
208- built for VineLinux
209
210* Tue Oct 03 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-5
211- rebuilt for unwind info generation, broken in gcc-4.1.1-21
212
213* Wed Sep 20 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-4
214- .pyo files no longer ghosted
215- fix chicken-and-egg problem when building perl and python bindings
216
217* Tue Aug 29 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-3
218- simplified autotools invocation
219- mass rebuild
220
221* Mon Aug 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-2
222- simplified file lists and permissions
223- removed weird character from inchi summary and description
224- added missing pkgconfig Req: for -devel
225
226* Sat Aug 05 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-1
227- updated to 2.0.2
228- dropped GCC4 fix (upstream'd)
229- split off inchi package
230- added python and perl bindings packages
231
232* Sat Jan 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.0-1
233- updated to 2.0.0
234- fix compilation with GCC4
235- FE compliance
236
237* Thu Feb 10 2005 Dominik Mierzejewski <rpm@greysector.net> 1.100.2-1
238- rebuilt for Fedora 3
239
240* Tue Jan 18 2005 ALT QA Team Robot <qa-robot@altlinux.org> 1.100.2-alt1.1
241- Rebuilt with libstdc++.so.6.
242
243* Wed Mar 03 2004 Michael Shigorin <mike@altlinux.ru> 1.100.2-alt1
244- 1.100.2
245
246* Wed Dec 17 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt2
247- removed *.la
248- don't package static library by default
249
250* Mon Sep 22 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt1
251- 1.100.1
252- #2994 fixed; thanks to Alex Ott (ott@) for a pointer
253- spec cleanup (underlibification fixup)
254
255* Mon Jun 30 2003 Michael Shigorin <mike@altlinux.ru> 1.100.0-alt1
256- built for ALT Linux
257- based on Mandrake Cooker spec by:
258  * Lenny Cartier <lenny@mandrakesoft.com>
259  * Austin Acton <aacton@yorku.ca>
260- spec cleanup
Note: See TracBrowser for help on using the repository browser.