source: projects/specs/branches/6/o/ode/ode-vl.spec @ 2470

Revision 2470, 6.3 KB checked in by kazutaka, 13 years ago (diff)

新規追加

Line 
1Name:           ode
2Version:        0.11.1
3Release:        1%{?_dist_release}
4Summary:        High performance library for simulating rigid body dynamics
5Group:          System Environment/Libraries
6License:        BSD or LGPLv2+
7URL:            http://www.ode.org
8Source0:        http://downloads.sourceforge.net/opende/ode-%{version}.tar.bz2
9# This works around a bug in rpmbuild, where with localbuilds it will pass
10# the machine being build on as host param to configure instead of the machine
11# on which the code will run
12Patch0:         ode-0.10.0-no-pentium-on-i386.patch
13Patch1:         ode-0.11.1-multilib.patch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15BuildRequires:  libGL-devel libGLU-devel
16
17%description
18ODE is an open source, high performance library for simulating rigid body
19dynamics. It is fully featured, stable, mature and platform independent with
20an easy to use C/C++ API. It has advanced joint types and integrated collision
21detection with friction. ODE is useful for simulating vehicles, objects in
22virtual reality environments and virtual creatures. It is currently used in
23many computer games, 3D authoring tools and simulation tools.
24
25
26%package        double
27Summary:        Ode physics library compiled with double precision
28Group:          Development/Libraries
29
30%description    double
31The %{name}-double package contains a version of the ODE library for simulating
32rigid body dynamics compiled with double precision.
33
34
35%package        devel
36Summary:        Development files for %{name}
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       %{name}-double = %{version}-%{release}
40
41%description    devel
42The %{name}-devel package contains libraries and header files for
43developing applications that use %{name} or %{name}-double.
44
45
46%prep
47%setup -q
48%patch0 -p1
49%patch1 -p1
50# to stop autoxxx from getting regenerated because of our configure patch
51touch -r CHANGELOG.txt configure.in
52# stop rpmlint from complaining about executable files in the debug package
53chmod -x ode/src/stepfast.cpp include/ode/collision_trimesh.h \
54  include/ode/odeconfig.h
55
56
57%build
58%configure --enable-shared --disable-static --enable-double-precision
59make %{?_smp_mflags} X_LIBS=-lX11 \
60    libode_la_LDFLAGS="-release double -version-info 2:1:1"
61sed -i 's|-lode|-lode-double|g' ode-config ode.pc
62mv ode-config ode-double-config
63mv ode.pc ode-double.pc
64mv ode/src/.libs/libode-double.so.1.1.1 .
65make distclean
66
67CFLAGS="%{optflags} -ffast-math"
68CXXFLAGS="%{optflags} -ffast-math"
69%configure --enable-shared --disable-static
70make %{?_smp_mflags} X_LIBS=-lX11
71
72
73%install
74rm -rf $RPM_BUILD_ROOT
75make install DESTDIR=$RPM_BUILD_ROOT
76rm $RPM_BUILD_ROOT%{_libdir}/libode.la
77# DIY libode-double install
78install -m 755 ode-double-config $RPM_BUILD_ROOT%{_bindir}
79install -m 755 libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}
80ln -s libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}/libode-double.so.1
81ln -s libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}/libode-double.so
82install -m 644 ode-double.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
83
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%post double -p /sbin/ldconfig
94
95%postun double -p /sbin/ldconfig
96
97
98%files
99%defattr(-,root,root,-)
100%doc CHANGELOG.txt LICENSE*.TXT README.txt
101%{_libdir}/libode.so.1*
102
103%files double
104%defattr(-,root,root,-)
105%doc CHANGELOG.txt LICENSE*.TXT README.txt
106%{_libdir}/libode-double.so.1*
107
108%files devel
109%defattr(-,root,root,-)
110%{_bindir}/%{name}-config
111%{_bindir}/%{name}-double-config
112%{_includedir}/%{name}
113%{_libdir}/libode.so
114%{_libdir}/libode-double.so
115%{_libdir}/pkgconfig/%{name}.pc
116%{_libdir}/pkgconfig/%{name}-double.pc
117
118
119%changelog
120* Fri Jan 07 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.11.1-1
121- initial build for Vine Linux based on fedora development
122
123* Mon Nov  8 2010 Hans de Goede <hdegoede@redhat.com> 0.11.1-5
124- Add a -double subpackage providing a version of ode compiled with
125  double precision (#574034)
126
127* Tue Feb 16 2010 Hans de Goede <hdegoede@redhat.com> 0.11.1-4
128- Fix FTBFS (#564642)
129
130* Thu Nov 12 2009 Hans de Goede <hdegoede@redhat.com> 0.11.1-3
131- Fix multilib conflict in -devel sub package (#507981)
132
133* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.1-2
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
135
136* Mon May 25 2009 Hans de Goede <hdegoede@redhat.com> 0.11.1-1
137- New upstream release 0.11.1
138
139* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
141
142* Fri Jan 30 2009 Hans de Goede <hdegoede@redhat.com> 0.11-1
143- New upstream release 0.11
144
145* Mon Sep 15 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.1-1
146- New upstream release 0.10.1 (bz 460033)
147
148* Thu Apr  3 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-4
149- Force proper use of RPM_OPT_FLAGS during build
150
151* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9-3
152- Autorebuild for GCC 4.3
153
154* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-2
155- Drop workaround for stormbaancoureur crash, it is now fixed in
156  stormbaancoureur
157
158* Fri Oct 12 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-1
159- New upstream release 0.9 (final)
160
161* Fri Sep 28 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-0.1.rc1
162- New upstream release 0.9-rc1
163
164* Tue Sep 11 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8.1-0.1.rc1
165- New upstream release 0.8.1-rc1
166
167* Wed Aug 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8-2
168- Update License tag for new Licensing Guidelines compliance
169
170* Wed Feb 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8-1
171- New upstream release 0.8
172
173* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7-2
174 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
175
176* Fri Sep 22 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.7-1
177- New upstream release 0.7
178
179* Mon Aug 28 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.6-3
180- FE6 Rebuild
181
182* Wed Jul  5 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.6-2
183- Change name from libode to ode
184- Fix soname & /usr/lib64 usage
185- Patch configure to accept our CFLAGS instead of always using its own
186- Patch configure to never activate the generation of asm-code which is then
187  used unconditionally, the build CPU may be very different from the CPU on
188  which the package gets run.
189
190* Sun Jun 18 2006 Hugo Cisneiros <hugo@devin.com.br> 0.6-1
191- Initial RPM release
Note: See TracBrowser for help on using the repository browser.