source: projects/specs/branches/6/o/octave/octave-vl.spec @ 521

Revision 521, 7.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# From src/version.h:#define OCTAVE_API_VERSION
2%define octave_api api-v32
3
4%define vine4 0
5
6%define version 3.0.2
7%define release 1%{?_dist_release}
8%define name octave
9
10Summary: GNU Octave -- a high-level language for numerical computations
11Summary(ja): 数値計算のための高級言語
12Name: %{name}
13Version: %{version}
14Release: %{release}
15License: GPL
16Group: Applications/Engineering
17
18Source: ftp://ftp.octave.org/pub/octave/%{name}-%{version}.tar.bz2
19URL: http://www.octave.org
20BuildRequires:  bison flex less tetex lapack-devel blas-devel
21BuildRequires:  ncurses-devel zlib-devel curl-devel texinfo
22BuildRequires:  readline-devel glibc-devel fftw3-devel gperf ghostscript
23BuildRequires:  glpk-devel gnuplot desktop-file-utils
24BuildRequires:  hdf5-devel qhull-devel suitesparse-devel
25%if !%{vine4}
26BuildRequires:  gcc-gfortran
27%else
28BuildRequires:  gcc-g77
29%endif
30
31Requires: gnuplot
32Requires(post): /sbin/install-info
33Requires(postun): /sbin/ldconfig
34Requires(post): /sbin/ldconfig
35Requires(preun): /sbin/install-info
36Buildroot: %{_tmppath}/%{name}-%{version}-root
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42GNU Octave is a high-level language, primarily intended for numerical
43computations. It provides a convenient command line interface for
44solving linear and nonlinear problems numerically, and for performing
45other numerical experiments using a language that is mostly compatible
46with Matlab. It may also be used as a batch-oriented language.
47
48Octave has extensive tools for solving common numerical linear algebra
49problems, finding the roots of nonlinear equations, integrating
50ordinary functions, manipulating polynomials, and integrating ordinary
51differential and differential-algebraic equations. It is easily
52extensible and customizable via user-defined functions written in
53Octave's own language, or using dynamically loaded modules written in
54C++, C, Fortran, or other languages.
55
56#'
57
58%description -l ja
59GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
60問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
61を行うための使いやすいコマンドライン・インタフェースを備えています。
62バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
63一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作
64等を行うことができます。Octave の言語でユーザが関数を定義したり、C++,
65C, Fortran その他の言語で書いた動的ライブラリを用いて容易に拡張やカスタ
66マイズを行うことができます。
67
68%prep
69%setup -q
70# Check that octave_api is set correctly
71if ! grep -q '^#define OCTAVE_API_VERSION "%{octave_api}"' src/version.h
72then
73  echo "octave_api variable in spec does not match src/version.h"
74  exit 1
75fi
76
77%build
78%define enable64 no
79%if !%{vine4}
80%define f77 gfortran
81%else
82%define f77 g77
83%endif
84export CPPFLAGS=-I%{_includedir}/glpk
85%configure --enable-shared --disable-static --enable-64=%enable64 --with-f77=%{f77} --with-curl
86make %{?_smp_mflags} OCTAVE_RELEASE="VinePlus %{version}-%{release}"
87
88#CXXFLAGS="$RPM_OPT_FLAGS"
89#export CXXFLAGS
90#configure --enable-dl --enable-shared --enable-lite-kernel --enable-picky-flags --disable-rpath --with-g77 --without-mpi
91
92%install
93rm -rf $RPM_BUILD_ROOT
94make install DESTDIR=$RPM_BUILD_ROOT
95rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
96
97find %{buildroot} -name "*.oct" | xargs strip
98
99# Make library links
100mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
101echo "%{_libdir}/octave-%{version}" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/octave-%{_arch}.conf
102
103# Remove RPM_BUILD_ROOT from ls-R files
104perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT%{_libexecdir}/%{name}/ls-R
105perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT%{_datadir}/%{name}/ls-R
106
107# Clean doc directory
108pushd doc
109  make distclean
110  rm -f *.in */*.in */*.cc refcard/*.tex
111popd
112
113# Create desktop file
114rm $RPM_BUILD_ROOT%{_datadir}/applications/www.octave.org-octave.desktop
115desktop-file-install --vendor vine --add-category X-Fedora \
116        --dir $RPM_BUILD_ROOT%{_datadir}/applications examples/octave.desktop
117
118# Create directories for add-on packages
119HOST_TYPE=`$RPM_BUILD_ROOT%{_bindir}/octave-config -p CANONICAL_HOST_TYPE`
120mkdir -p $RPM_BUILD_ROOT%{_libexecdir}/%{name}/site/oct/%{octave_api}/$HOST_TYPE
121mkdir -p $RPM_BUILD_ROOT%{_libexecdir}/%{name}/site/oct/$HOST_TYPE
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%post
127/sbin/ldconfig
128/sbin/install-info --info-dir=%{_infodir} --section="Programming" \
129        %{_infodir}/octave.info || :
130
131%preun
132if [ "$1" = "0" ]; then
133   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/octave.info || :
134fi
135
136%postun -p /sbin/ldconfig
137
138%files
139%defattr(-,root,root)
140%doc COPYING NEWS* PROJECTS README README.Linux README.kpathsea ROADMAP
141%doc SENDING-PATCHES THANKS emacs examples doc/interpreter/octave.p*
142%doc doc/faq doc/interpreter/HTML doc/refcard
143
144%{_bindir}/*
145%config(noreplace) /etc/ld.so.conf.d/*
146%{_libdir}/octave-%{version}
147%{_includedir}/octave-%{version}
148%{_datadir}/applications/*
149%{_datadir}/octave
150%{_libexecdir}/octave
151%{_mandir}/man*/*
152%{_infodir}/octave*
153#{_menudir}/%{name}
154#{_iconsdir}/%{name}.xpm
155#{_miconsdir}/%{name}.xpm
156#{_liconsdir}/%{name}.xpm
157
158%changelog
159* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
160- update to 3.0.2
161- applied new versioning policy, spec in utf-8
162
163* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
164- update to 3.0.0
165
166* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
167- rebuilt for VineSeed
168
169* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
170- update to 2.9.13
171- rebuilt with new toolchain and environment
172
173* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
174- update to 2.0.17
175- rebuild with new toolchains
176- add BuildRequires: gcc295, gcc295-c++
177
178* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
179- ver.up
180
181* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
182- build for Vine Linux 2.1
183
184* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
185- automatically added BuildRequires
186
187* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
188- Macros, BM, add multiple icons sizes
189
190* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
191- strip oct file
192- add menu entry
193 
194* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
195- corrected for new groups
196
197* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
198- mandrake build
199- v2.0.16
200
201* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
202- update to 2.0.13.90
203
204* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
205- repackage in powertools.
206
207* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
208- Add %attr, build as user.
209
210* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
211- Add BuildRoot, installinfo, require gnuplot, description from
212  Octave's web page, update to Octave 2.0.13.
213- Adapt from existing spec file.
214
215* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
216- removed libreadline stuff from the file list
217
218* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
219- changed configure command to put things in $RPM_ARCH-rehat-linux,
220  rather than genereated one... was causing problems between building
221  on i686 build machine.
222
223* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
224- moved buildroot from /tmp to /var/tmp
225
226* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
227- Upgraded to version 2.0.9 and built for glibc system
228
229* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
230- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.