source: projects/specs/branches/6/o/ocaml/ocaml-vl.spec @ 6181

Revision 6181, 10.4 KB checked in by inagaki, 12 years ago (diff)

updated: global, ocaml, facile

Line 
1Name: ocaml
2Summary: The Objective Caml compiler and programming environment
3Summary(ja): Objective Caml コンパイラとプログラミング環境
4Version: 3.12.1
5Release: 2%{?_dist_release}
6Source0: http://caml.inria.fr/distrib/ocaml-3.12/ocaml-%{version}.tar.bz2
7Source1: http://caml.inria.fr/distrib/ocaml-3.12/ocaml-3.12.1-refman-html.tar.gz
8Source2: http://caml.inria.fr/distrib/ocaml-3.12/ocaml-3.12-refman.ps.gz
9Source3: http://caml.inria.fr/distrib/ocaml-3.12/ocaml-3.12-refman.info.tar.gz
10Source4: ocaml-info-entry
11
12# Vine Source(s)
13Source10: caml-mode-install.sh
14Source11: caml-mode-remove.sh
15
16License: QPL/LGPL
17Group: Development/Languages
18URL: http://caml.inria.fr/
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: ncurses-devel gdbm-devel emacsen
22BuildRequires: libX11-devel
23BuildRequires: tk tcl expect thread
24Provides: ocaml(runtime) = %{version}
25Requires(post): install-info
26Requires(preun): install-info
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31Packager: inagaki, kenta
32
33%define debug_package %{nil}
34
35%global __ocaml_requires_opts -c -f %{buildroot}%{_bindir}/ocamlobjinfo
36%global __ocaml_provides_opts -f %{buildroot}%{_bindir}/ocamlobjinfo
37
38%description
39Objective Caml is a high-level, strongly-typed, functional and
40object-oriented programming language from the ML family of languages.
41
42This package comprises two batch compilers (a fast bytecode compiler
43and an optimizing native-code compiler), an interactive toplevel system,
44parsing tools (Lex,Yacc,Camlp4), a replay debugger, a documentation generator,
45and a comprehensive library.
46
47%description -l ja
48Object Caml は ML 系言語の方言で、高水準で強い型付けを備えた関数型と
49オブジェクト指向を併せ持ったプログラミング言語です。
50このパッケージには、2 つのバッチコンパイラ (コンパイル速度が高速な
51バイトコードコンパイラと最適化を行なうネイティブコードコンパイラ)、
52トップレベル対話環境、構文解析ツール (Lex, Yac, Camlp4)、リプレイ
53デバッガ、ドキュメント生成ツール、そして広範囲に渡るライブラリが含まれて
54います。
55
56%package labltk
57Summary: Tk bindings for Objective Caml
58Summary(ja): Objective Caml の Tk バインディング
59Group: Development/Languages
60Requires: ocaml = %{version}-%{release}
61Requires: tk tcl
62Obsoletes: labltk <= %{version}
63
64%description labltk
65A library for interfacing Objective Caml with the scripting language
66Tcl/Tk. It include the OCamlBrowser code editor / library browser.
67
68%package camlp4
69Summary: Pre-Processor-Pretty-Printer for OCaml
70Group: Development/Languages
71Requires: ocaml = %{version}-%{release}
72Obsoletes: camlp4 <= %{version}
73
74%description camlp4
75Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
76file and printing some result on standard output.
77
78%package mode
79Summary: Emacs mode for Objective Caml
80Summary(ja): Objective Caml の Emacs mode
81Group: Applications/Editors/Emacs
82Requires: ocaml = %{version}-%{release}
83Requires(post): emacs, emacsen-common
84Requires(preun): emacs, emacsen-common
85Obsoletes: ocaml-emacs <= %{version}
86
87%description mode
88Emacs mode for Objective Caml.
89
90%description -l ja mode
91Objective Caml 用の Emacs mode です.
92
93
94%prep
95%setup -q -T -b 0
96%setup -q -T -D -a 1
97%setup -q -T -D -a 3
98cp %{SOURCE2} refman.ps.gz
99cp %{SOURCE4} infoman/ocaml-info-entry
100
101%build
102./configure -cc "%{__cc} %{optflags}" -with-pthread \
103    -bindir %{_bindir} \
104    -libdir %{_libdir}/ocaml \
105    -mandir %{_mandir} \
106    -prefix %{_prefix}
107make world opt opt.opt
108(cd infoman; gzip -cd ocaml.info.gz >> ocaml-info-entry; mv ocaml-info-entry  ocaml.info; gzip -f ocaml.info)
109# for dumpobj, objinfo
110(cd tools; make dumpobj; make objinfo; cd ..)
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115make install BINDIR=$RPM_BUILD_ROOT%{_bindir} LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml MANDIR=$RPM_BUILD_ROOT%{_mandir}
116
117mv $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig
118sed -e "s|^%{buildroot}||" $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig > $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf
119rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig
120(mkdir -p $RPM_BUILD_ROOT%{_infodir}; cd infoman; cp ocaml*.gz $RPM_BUILD_ROOT%{_infodir})
121# for dumpobj, objinfo
122(cd tools; install dumpobj objinfo $RPM_BUILD_ROOT%{_bindir})
123
124# for Emacs Lisp
125make -C emacs install install-ocamltags BINDIR=$RPM_BUILD_ROOT%{_bindir} \
126    EMACSDIR=$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/caml-mode
127
128# emacsen-common-ize
129mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/emacsen-common/packages/install
130mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/emacsen-common/packages/remove
131%_installemacsenscript caml-mode %{SOURCE10}
132
133%_removeemacsenscript  caml-mode %{SOURCE11}
134
135
136# Disable build root strip policy:
137# executables generated by ocamlc -custom MUST NOT BE STRIPPED
138# But now that we have dynamic loading of C code, none of the executables
139# in the distribution is generated by ocamlc -custom, so leave default.
140# %define __spec_install_post /usr/lib/rpm/brp-compress
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post
146/sbin/install-info %{_infodir}/ocaml.info %{_infodir}/dir
147
148%post mode
149if [ "$1" = 2 ]; then
150    %_emacsenPackageRemove caml-mode
151
152fi
153
154%_addemacsenlist caml-mode
155
156%_emacsenPackageInstall caml-mode
157
158%preun
159if [ $1 = 0 ]; then
160    /sbin/install-info --delete %{_infodir}/ocaml.info %{_infodir}/dir
161fi
162
163%preun mode
164if [ "$1" = 0 ]; then
165    %_emacsenPackageRemove caml-mode
166   
167    %_removeemacsenlist caml-mode
168
169fi
170
171
172%files
173%defattr(-, root, root)
174%doc README LICENSE refman.ps.gz htmlman
175%{_bindir}/*
176%{_mandir}/man1/*
177%{_mandir}/man3/*
178%{_libdir}/ocaml
179%{_infodir}/*
180### in ocaml-camlp4
181%exclude %{_bindir}/camlp4*
182%exclude %{_bindir}/mkcamlp4
183%exclude %{_libdir}/ocaml/camlp4/
184### in ocaml-labltk
185%exclude %{_bindir}/labltk
186%exclude %{_bindir}/ocamlbrowser
187%exclude %{_libdir}/ocaml/labltk/
188%exclude %{_libdir}/ocaml/stublibs/dlllabltk.so
189### in ocaml-mode
190%exclude %{_bindir}/ocamltags
191
192%files camlp4
193%defattr(-, root, root, 0755)
194%{_bindir}/camlp4*
195%{_bindir}/mkcamlp4
196%dir %{_libdir}/ocaml/
197%{_libdir}/ocaml/camlp4/
198
199%files labltk
200%defattr(-, root, root, 0755)
201%doc otherlibs/labltk/examples_*tk
202%{_bindir}/labltk
203%{_bindir}/ocamlbrowser
204%dir %{_libdir}/ocaml/
205%dir %{_libdir}/ocaml/stublibs/
206%{_libdir}/ocaml/labltk/
207%{_libdir}/ocaml/stublibs/dlllabltk.so
208
209%files mode
210%defattr(-, root, root, 0755)
211%doc emacs/README
212%{_bindir}/ocamltags
213%dir %{_datadir}/emacs/
214%dir %{_datadir}/emacs/site-lisp/caml-mode
215%{_datadir}/emacs/site-lisp/caml-mode/*.el
216#{_datadir}/emacs/site-lisp/caml-mode/*.elc
217%{_prefix}/lib/emacsen-common/packages/install/caml-mode
218%{_prefix}/lib/emacsen-common/packages/remove/caml-mode
219
220
221%changelog
222* Tue May 15 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.12.1-2
223- fixed SOURCEs URL typo
224- updated SOURCE1
225
226* Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> 3.12.1-1
227- new upstream version 3.12.1
228- rebuild with rpm-4.9.1.2
229
230* Wed Apr 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.12.0-1
231- new upstream release
232
233* Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.0-2
234- rebuilt with new tool chain
235
236* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.0-1
237- new upstream release
238- spec in UTF-8
239
240* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl5
241- new upstream release for VineSeed
242
243* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl4
244- new upstream release
245
246* Wed Feb  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.1-0vl1
247- new upstream release
248
249* Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl2
250- rebuilt with VineSeed
251
252* Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl1
253- new upstream release
254
255* Tue Nov 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl2
256- rebuilt for VinePlus/4.0
257
258* Mon Nov 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl1
259- new upstream release
260
261* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.2-0vl4
262- changed ocaml-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
263
264* Wed Aug 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> - 3.09.2-0vl3
265- add BuildRequires: XOrg-devel, ncurses-devel, gdbm-devel, emacsen
266- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
267
268* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl2
269- rebuilt for VineSeed Plus
270
271* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl1
272- new upstream release
273
274* Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl3
275- rebuilt for VineSeed Plus
276
277* Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl2
278- rebuilt for VinePlus/3.0
279- added BuildRequires: expect, thread
280
281* Sat Jan 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl1
282- new upstream release
283
284* Sat Nov  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl2
285- rebuild for VineSeed Plus
286
287* Thu Nov  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl1
288- new upstream release
289
290* Tue Oct 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl3
291- rebuild with VineSeed Plus
292
293* Mon Oct 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl2
294- rebuild with VinePlus/3.0
295- added dumpobj, objinfo
296
297* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl1
298- new upstream release
299- split to caml4p, labltk, mode packages
300
301* Thu Mar 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.3-0vl1
302- new upstream release
303
304* Sat Dec  4 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.2-0vl1
305- new upstream release
306
307* Fri Oct 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.1-0vl1
308- new upstream release
309
310* Fri Aug 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl4
311- fixed typo based on 3.08.0-0vl3
312  * Thu Aug 12 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl3
313  - Modified typo: %%descriptin -l ja into %description -l ja
314
315* Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl3
316- rebuild for VinePlus/3.0 and VineSeedPlus
317- updated Japanese description
318- merged VinePlus/2.6 spec file
319  * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl2
320  - Modified the character code of this file into euc-jp.
321  * Tue Jul 21 2004 by IKEDA Katsumi <ikeda@rg8.so-net.ne.jp> 3.08.0-0vl1
322  - new upstream release.
323  - Modified Copyright.
324  - Added Summary(ja), %%descriptin -l ja, Prereq and %%clean.
325  - Added %%post and %%preun for running /sbin/install-info.
326
327* Wed Apr  7 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.07-2vl2
328- rebuild for VineSeed
329- s/Copyright/License/
330
331* Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
332- 3.07-2vl1
333- Modified %Vendor and %BuildRoot.
334- Add %Distribution.
Note: See TracBrowser for help on using the repository browser.