source: projects/specs/branches/6/o/obexftp/obexftp-vl.spec @ 7739

Revision 7739, 10.6 KB checked in by Takemikaduchi, 11 years ago (diff)

rebuild packages & security fix

Line 
1%define python_sitelib %(%{__python} -c "from distutils import sysconfig; print sysconfig.get_python_lib()")
2%define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
3%define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
4
5Name: obexftp
6Summary: Tool to access devices via the OBEX protocol
7Summary(ja): OBEX プロトコルを使用する機器のためのツールです
8Group: Applications/System
9Version: 0.23
10Release: 2%{?_dist_release}
11License: GPLv2+
12URL: http://openobex.triq.net/
13Source: http://triq.net/obexftp/%{name}-%{version}.tar.bz2
14Patch0: obexftp-norpath.patch
15Patch1: obexftp-perl.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires: bluez-libs-devel
20BuildRequires: gettext
21BuildRequires: libtool
22BuildRequires: openobex-devel >= 1.2
23## BuildRequires: perl-ExtUtils-CBuilder
24BuildRequires: perl(ExtUtils::MakeMaker)
25BuildRequires: python-devel
26BuildRequires: ruby
27BuildRequires: ruby-devel
28BuildRequires: tcl
29
30
31#----------------------------------------------------------------------------
32%description
33The overall goal of this project is to make mobile devices featuring
34 the OBEX protocol and adhering to the OBEX FTP standard accessible
35 by an open source implementation.
36The common usage for ObexFTP is to access your mobile phones memory to
37 store and retrieve e.g. your phonebook, logos, ringtones, music,
38 pictures and alike.
39
40%description -l ja
41このプロジェクトは OBEXプロトコルおよび、標準的で便利なOBEX-FTPを
42フィーチャーしたモバイルデバイスを、オープンソースで実装する事を
43全体的な目標としています。
44ObexFTPの共通の使い方
45 お使いの携帯電話にアクセスし、メモリへ保存したり取り外したりする、
46 例えば、お客様の電話帳、ロゴ、着メロ、音楽、写真等も同様に扱えます。
47
48#----------------------------------------------------------------------------
49%package -n python-%{name}
50Summary: Python library to access devices via the OBEX protocol
51Summary(ja): OBEX プロトコルを使って機器を扱うPythonライブラリです
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description -n python-%{name}
56The overall goal of this project is to make mobile devices featuring
57 the OBEX protocol and adhering to the OBEX FTP standard accessible
58 by an open source implementation.
59The common usage for ObexFTP is to access your mobile phones memory to
60 store and retrieve e.g. your phonebook, logos, ringtones, music,
61 pictures and alike.
62
63%description -n python-%{name} -l ja
64このプロジェクトは OBEXプロトコルおよび、標準的で便利なOBEX-FTPを
65フィーチャーしたモバイルデバイスを、オープンソースで実装する事を
66全体的な目標としています。
67ObexFTPの共通の使い方
68 お使いの携帯電話にアクセスし、メモリへ保存したり取り外したりする、
69 例えば、お客様の電話帳、ロゴ、着メロ、音楽、写真等も同様に扱えます。
70(このパッケージはpython向けライブラリです)
71
72#----------------------------------------------------------------------------
73%package -n perl-%{name}
74Summary: Perl library to access devices via the OBEX protocol
75Summary(ja): OBEX プロトコルを使って機器を扱うPerlライブラリです
76Group: Development/Libraries
77Requires: %{name} = %{version}-%{release}
78Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
79
80%description -n perl-%{name}
81The overall goal of this project is to make mobile devices featuring
82 the OBEX protocol and adhering to the OBEX FTP standard accessible
83 by an open source implementation.
84The common usage for ObexFTP is to access your mobile phones memory to
85 store and retrieve e.g. your phonebook, logos, ringtones, music,
86 pictures and alike.
87
88%description -n perl-%{name} -l ja
89このプロジェクトは OBEXプロトコルおよび、標準的で便利なOBEX-FTPを
90フィーチャーしたモバイルデバイスを、オープンソースで実装する事を
91全体的な目標としています。
92ObexFTPの共通の使い方
93 お使いの携帯電話にアクセスし、メモリへ保存したり取り外したりする、
94 例えば、お客様の電話帳、ロゴ、着メロ、音楽、写真等も同様に扱えます。
95(このパッケージはperl向けライブラリです)
96
97#----------------------------------------------------------------------------
98%package -n ruby-%{name}
99Summary: Ruby library to access devices via the OBEX protocol
100Summary(ja): OBEX プロトコルを使って機器を扱うRubyライブラリです
101Group: Development/Libraries
102BuildRequires: ruby
103BuildRequires: ruby-devel
104Requires: %{name} = %{version}-%{release}
105
106%description -n ruby-%{name}
107The overall goal of this project is to make mobile devices featuring
108 the OBEX protocol and adhering to the OBEX FTP standard accessible
109 by an open source implementation.
110The common usage for ObexFTP is to access your mobile phones memory to
111 store and retrieve e.g. your phonebook, logos, ringtones, music,
112 pictures and alike.
113
114%description -n ruby-%{name} -l ja
115このプロジェクトは OBEXプロトコルおよび、標準的で便利なOBEX-FTPを
116フィーチャーしたモバイルデバイスを、オープンソースで実装する事を
117全体的な目標としています。
118ObexFTPの共通の使い方
119 お使いの携帯電話にアクセスし、メモリへ保存したり取り外したりする、
120 例えば、お客様の電話帳、ロゴ、着メロ、音楽、写真等も同様に扱えます。
121(このパッケージはruby向けライブラリです)
122
123#----------------------------------------------------------------------------
124%package devel
125Summary: Header files and libraries for %{name}
126Summary(ja): OBEX-FTP の開発用ヘッダーファイル等のパッケージです
127Group: Development/Libraries
128Requires: %{name} = %{version}-%{release}
129Requires: openobex-devel >= 1.2
130Requires: pkgconfig
131
132%description devel
133This package contains the header files, static libraries and development
134documentation for %{name}. If you like to develop programs using %{name},
135you will need to install %{name}-devel.
136
137%description devel -l ja
138このパッケージには OBEX-FTPのヘッダファイル、静的ライブラリおよび開発者用の
139ドキュメントが含まれています。
140あなたがOBEX-FTPを使用してプログラムを開発する場合は、この obexftp-develを
141インストールする必要があります。
142
143#----------------------------------------------------------------------------
144%prep
145%setup -q
146%patch0 -p1 -b .norpath
147%patch1 -p1 -b .p
148
149%build
150autoreconf -f -i
151%configure --disable-static --disable-dependency-tracking --disable-rpath
152%{__make} %{?_smp_mflags}
153
154%install
155rm -rf $RPM_BUILD_ROOT
156make DESTDIR=$RPM_BUILD_ROOT RUBYARCHDIR=$RPM_BUILD_ROOT%{rarchdir} install
157chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/*/OBEXFTP/OBEXFTP.so
158# chmod 755 %{buildroot}%{perl_sitearch}/*/OBEXFTP/OBEXFTP.so
159
160rm $RPM_BUILD_ROOT%{_libdir}/*.la
161rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
162rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/*/OBEXFTP/{.packlist,OBEXFTP.bs}
163# %{__rm} -f %{buildroot}%{perl_sitearch}/*/OBEXFTP/{.packlist,OBEXFTP.bs}
164
165
166%clean
167rm -rf $RPM_BUILD_ROOT
168
169%post -p /sbin/ldconfig
170%postun -p /sbin/ldconfig
171
172%files
173%defattr(-, root, root, -)
174%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
175%{_mandir}/man1/obexftp.1*
176%{_mandir}/man1/obexftpd.1*
177%{_bindir}/obexftp
178%{_bindir}/obexftpd
179%{_libdir}/*.so.*
180
181%files devel
182%defattr(-, root, root, -)
183%{_includedir}/bfb/
184%{_includedir}/multicobex/
185%{_includedir}/obexftp/
186%{_libdir}/*.so
187%{_libdir}/pkgconfig/obexftp.pc
188
189%files -n python-%{name}
190%defattr(-, root, root, -)
191# %dir %{python_vendorarch}/obexftp
192# %{python_vendorarch}/obexftp/_obexftp.so*
193# %{python_vendorarch}/obexftp/__init__.py*
194%dir %{python_sitearch}/obexftp
195%{python_sitearch}/obexftp/_obexftp.so*
196%{python_sitearch}/obexftp/__init__.py*
197
198%files -n perl-%{name}
199%defattr(-, root, root, -)
200%{perl_vendorarch}/OBEXFTP.pm
201%dir %{perl_vendorarch}/*/OBEXFTP
202%{perl_vendorarch}/*/OBEXFTP/OBEXFTP.so
203# %{perl_sitearch}/OBEXFTP.pm
204# %dir %{perl_sitearch}/*/OBEXFTP
205# %{perl_sitearch}/*/OBEXFTP/OBEXFTP.so
206
207%files -n ruby-%{name}
208%defattr(-, root, root, -)
209%{rarchdir}/obexftp.so
210#{ruby_sitearch}/obexftp.so
211
212
213#----------------------------------------------------------------------------
214# Maintainers: babasaki@mindgear.org
215#
216#----------------------------------------------------------------------------
217%changelog
218* Sat Jul 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.23-2
219- rebuild with perl-5.12.3
220
221* Sat Dec 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.23-1
222- new upstream release
223- removed Requires: ruby(abi) (= 1.8) <BTS:799>
224
225* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.22-4
226- rebuild (ruby-obexftp subpackage not uploaded on i386/x86_64 yet)
227
228* Fri Oct 24 2008 Seiichirou Babasaki 0.22-3
229- change %{perl_sitearch} -> %{perl_vendorarch}
230- added "# Maintainers: " comments.
231- changed UTF-8 encode at obexftp.vs.spec
232- Updated specfile
233
234* Wed Oct 2 2008 Seiichirou Babasaki 0.22-2
235- change %{perl_vendorarch} -> %{perl_sitearch}
236- Updated specfile
237
238* Wed Jan 16 2008 Seiichirou Babasaki 0.20-0.5_2-1
239- Import obexftp - Packager: Babasaki
240- Updated specfile
241
242#----------------------------------------------------------------------------
243* Thu Sep 06 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.5.rc7
244- updated to 0.22-rc7
245- added pkgconfig file
246- make perl BR more specific
247
248* Mon Aug 27 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.4.rc6
249- rebuilt for BuildID
250- updated license tag
251
252* Mon Aug 06 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.3.rc6
253- updated to 0.22-rc6
254- added ruby bindings (patch by Andy Shevchenko)
255- dropped upstreamed patch
256- added missing BRs for F7+
257
258* Mon Mar 26 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.2.pre4
259- fix segfault in obexftpd (patch by Jan Kratochvil), closes (#230991)
260
261* Fri Mar 23 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.1.pre4
262- updated to 0.22-pre4
263- updated patches
264
265* Fri Jan 26 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-3
266- add missing disttag
267
268* Thu Jan 25 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-2
269- added missing defattr
270- require openobex-devel > 1.2
271- added missing MODULE_COMPAT Requires: to perl subpackage
272- renamed subpackages to perl/python-obexftp
273- fixed rpaths
274
275* Mon Jan 01 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-1
276- updated to 0.20
277
278* Sun Jan 29 2006 Dag Wieers <dag@wieers.com> - 0.18-1
279- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.