source: projects/specs/branches/6/nonfree/self-build-x264/self-build-x264-vl.spec @ 3126

Revision 3126, 7.2 KB checked in by munepi, 13 years ago (diff)

updated self-build-ffmpeg-vl.spec, self-build-gpac-vl.spec self-build-libquicktime-vl.spec self-build-mplayer-vl.spec self-build-vlc-vl.spec self-build-x264-vl.spec; added rtmpdump-vl.spec

Line 
1%define pkgname x264
2%define name    self-build-%{pkgname}
3%define version 0.0.0
4%define date    20110322
5%define time    2245
6%define release 15.%{date}%{?_dist_release}
7
8#define sourceurl0      ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
9%define sourceurl0      http://www.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
10
11Summary:        Package to automatically build %{pkgname} rpm package
12Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
13Name:           %{name}
14Version:        %{version}
15Release:        %{release}
16Source0:        %{pkgname}-vl.spec
17Source1:        %{pkgname}.desktop
18Source111:      %{pkgname}-shared.patch
19Source112:      %{pkgname}-nostrip.patch
20
21License:        GPLv2+
22Group:          Restricted Software
23
24Obsoletes:      x264 < %{version}-%{release}
25Obsoletes:      self-build-x264 < %{version}-%{release}
26
27Requires(post):         self-build-setup >= 0.9.9
28
29# (build)requies of target package.
30%ifarch x86_64 %{ix86}
31Requires(post): yasm
32%endif
33Requires(post): self-build-gpac
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36
37Packager:       munepi
38
39%description
40x264 is a free library for encoding H264/AVC video streams, written from
41scratch.
42
43If you install this package, it automaticaly downloads source
44code ,compile it, and create rpm packages of %{pkgname}-%{version}.
45And the created rpm packages are automatically installed
46if installation is executed by apt-get command or synaptic
47package manager.
48
49[Note]
50This package requires many other packages to compile
51targetsoftware. So it consume more disk space than usual.
52Also installation takes logner time because of compilation.
53(This will take a few minutes to quarter or half of an hour,
54depends on building environment)
55
56[About self-build package]
57For some kind of software, distributing of binary package
58may viorate the patent or law. Therefore we chose self-build
59packge, create binary package on your machine, for such kind
60of softwares instead of distributing binary package.
61
62Please obey the national law when you use the created binary
63packages. And if you want to use the softwares using patented
64thechnology, it may be required to get a permission, make an
65agreement or purchas a license. Please consider it with your
66purpose or way of use and take appropriate action.
67
68%description -l ja
69x264 はスクラッチから書かれた H264/AVC ビデオストリームをエン
70コードするためのフリーなライブラリです.
71
72このパッケージをインストールすると、自動的にソースコードを
73ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
74パッケージを作成します。
75また apt-get コマンドや synaptic パッケージマネージャから実行
76した場合は、作成された rpm パッケージのインストールも自動的に
77行います。
78
79[注意]
80コンパイルに必要な多くの関連パッケージを要求するので通常より
81ディスクの領域を多く消費します。
82またインストール時にコンパイルを行うため、通常より時間がかか
83る場合があります。(環境にもよりますが数分から数十分程度)
84
85[self-build パッケージについて]
86ソフトウェアによってはバイナリパッケージの配布が特許や法律に
87違反する可能性があるものがあります。その為、このような問題が
88懸念されるソフトウェアについてはバイナリパッケージを直接配布
89せずに、ユーザの環境でバイナリを作成する self-build パッケー
90ジという方法を採っています。
91
92作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
93アのライセンス、および利用する国の各種法令に従ってください。
94また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
95センスの購入などが必要となる場合がありますので、利用する目的
96や形態に応じて各自で判断し適切な対応を取ってください。
97
98%prep
99[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
100
101
102%install
103%{__rm} -rf ${RPM_BUILD_ROOT}
104%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
105%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
106%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
107%{__install} -m 644 %{SOURCE111} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
108%{__install} -m 644 %{SOURCE112} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
109
110%clean
111%{__rm} -rf ${RPM_BUILD_ROOT}
112
113%posttrans
114/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 19000
115/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
116                                 %{pkgname}-devel-%{version}-%{release}
117
118%files
119%defattr(-,root,root)
120%{_datadir}/%{name}
121
122%changelog
123* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
124- updated source snapshot 20110322
125
126* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
127- updated source snapshot 20100625
128
129* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
130- renamed %%{Source0} to x264-vl.spec
131
132* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
133- updated source snapshot 20100216
134- applied to link x264 binary to the shared library from RPM Fusion development
135
136* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
137- changed to download from http://www.videolan.org/pub/videolan/x264/snapshots in %%sourceurl0
138- check version between original spec and self-build spec in %%prep
139
140* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
141- dropped BuildArch: noarch
142
143* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
144- 20090522 snapshot
145  - updated x264-vine.patch
146- added BuildArch: noarch
147- avoided to execute self-build-rpm.sh on RPM transaction
148  - moved %%post actions to %%posttrans
149
150* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
151- corrected release number in x264.spec
152
153* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.0-7.20090110
154- enable asm on x86/x86_64 arch. (fix typo?)
155
156* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
157- added PreReq: self-build-gpac
158
159* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
160- dropped PreReq: nasm for x86
161- added PreReq: yasm for x86
162
163* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
164- 20090110 snapshot
165
166* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
167- fixed License: GPLv2+
168- added BuildRequires: gettext
169- source updated
170- fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
171  and added x264-vine.patch
172#- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
173
174* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
175- spec in utf8
176
177* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
178- run pre-allocate-rpm.sh in %%post
179- set PreReq: self-build-setup >= 0.8
180- apply new versioning policy
181
182* Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
183- initial build for Vine Linux 4.2
184
185### end of file
Note: See TracBrowser for help on using the repository browser.