source: projects/specs/branches/6/nonfree/self-build-mplayer/self-build-mplayer-vl.spec @ 7875

Revision 7875, 16.5 KB checked in by munepi, 11 years ago (diff)

updated to 1.1.1 based on 1.1.1-1vl7

Line 
1%global with_faac 1
2#% global with_vaapi 1
3#% global with_libvpx 1
4
5# define with_ffmpeg 1
6%global ffmpegver 0.11.4
7
8%global pkgname mplayer
9%global name    self-build-%{pkgname}
10%global version 1.1.1
11#% global svndate  20120525
12%global release 1%{?svndate:.%svndate}%{?_dist_release}
13
14%global source0path     MPlayer/releases/MPlayer-%{version}.tar.xz
15%global source1url      http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22Source0:        %{pkgname}-vl.spec
23Source10:       mplayer-snapshot-vine.sh
24
25Source11:       http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
26Source12:       http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.5.tar.bz2
27Source13:       http://www.mplayerhq.hu/MPlayer/skins/standard-1.9.tar.bz2
28Source14:       http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
29
30Source102:        %{pkgname}-1.1.1-config-vine.patch
31Source108:        %{pkgname}-1.1.1-manlinks.patch
32Source114:        %{pkgname}-1.1.1-nodvdcss.patch
33Source118:        %{pkgname}-1.1.1-ffmpeg.patch
34
35License:        GPLv2+
36Group:          Restricted Software
37
38Obsoletes:      mplayer < %{version}-%{release}
39Obsoletes:      self-build-mplayer < %{version}-%{release}
40
41Requires(post):         self-build-setup >= 0.9.9
42%{?svndate:Requires(post):              subversion}
43
44# (build)requies of target package.
45Requires(post): xz
46Requires(post): SDL-devel
47Requires(post):  aalib-devel
48Requires(post): alsa-lib-devel
49Requires(post): cdparanoia-devel
50Requires(post):  desktop-file-utils
51Requires(post): libdvdnav-devel
52Requires(post):  enca-devel
53Requires(post): freetype2-devel >= 2.0.9
54Requires(post):  fribidi-devel
55Requires(post):  fontconfig-devel
56Requires(post): giflib-devel
57Requires(post): gtk2-devel
58Requires(post): mesa-libGL-devel
59Requires(post):  libXinerama-devel
60Requires(post):  libXScrnSaver-devel
61Requires(post):  libXv-devel
62Requires(post):  libXvMC-devel
63Requires(post):  libXxf86dga-devel
64Requires(post):  libXxf86vm-devel
65Requires(post):  libass-devel
66Requires(post): libpng-devel
67Requires(post): libjpeg-devel
68Requires(post): libdvdread
69Requires(post):  libmpcdec-devel >= 1.2.1
70Requires(post):  librtmp-devel >= 2.3
71Requires(post):  speex-devel >= 1.1
72%{?with_vaapi:Requires(post):libva-devel}
73Requires(post):  libvdpau-devel
74Requires(post): libvorbis-devel
75%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
76Requires(post):  lzo-devel >= 2
77Requires(post):  pulseaudio-lib-devel
78Requires(post):  speex-devel >= 1.1
79Requires(post):  twolame-devel
80Requires(post): xorg-x11-devel
81Requires(post):  yasm
82Requires(post): zlib-devel
83
84Requires(post):         self-build-mplayer-codecs
85##!!Requires(post):             self-build-libdvdcss
86Requires(post):         self-build-faac
87Requires(post):         self-build-faad2 >= 2.6.1
88Requires(post):         self-build-lame
89Requires(post):         self-build-libdca
90Requires(post):         self-build-libmad
91Requires(post): self-build-x264
92Requires(post):         self-build-xvidcore >= 0.9.2
93Requires(post):         self-build-libmpeg2
94Requires:       TrueType-vlgothic
95Requires:       mesa-libGL
96
97BuildArch:      noarch
98BuildRoot:      %{_tmppath}/%{name}-%{version}-root
99
100Packager:       munepi
101
102%description
103MPlayer can play most standard video formats out of the box and almost
104all others with the help of external codecs.
105MPlayer currently works best from the command line, but visual feedback
106for many functions is available from its onscreen status display (OSD),
107which is also used for displaying subtitles.
108MPlayer also has a GUI with skin support and several unofficial alternative
109graphical frontends are available.
110
111MEncoder is a command line video encoder for advanced users that can
112be built from the MPlayer source tree. Unofficial graphical frontends
113exist but arenot included.
114
115MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
116support for some newer codecs are not yet inpmlemented.
117You should install mplayer-codecs package if you want to play videos
118using those new codecs.
119
120
121Additional function is automatically included if following
122packages are installed in advance.
123
124samba-libsmbclient-devel: SMB file system support
125
126
127[Note]
128This package requires many other packages to compile
129targetsoftware. So it consume more disk space than usual.
130Also installation takes logner time because of compilation.
131(This will take a few minutes to quarter or half of an hour,
132depends on building environment)
133
134[About self-build package]
135For some kind of software, distributing of binary package
136may viorate the patent or law. Therefore we chose self-build
137packge, create binary package on your machine, for such kind
138of softwares instead of distributing binary package.
139
140Please obey the national law when you use the created binary
141packages. And if you want to use the softwares using patented
142thechnology, it may be required to get a permission, make an
143agreement or purchas a license. Please consider it with your
144purpose or way of use and take appropriate action.
145
146%description -l ja
147MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
148またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
149で再生できます。
150現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
151は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
152面上で確認できます。
153MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
154非公式なフロントエンドも利用できます。
155
156MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
157非公式な GUI フロントエンドもありますが、このパッケージには含まれて
158いません。
159
160MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
161を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
162いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
163をインストールする必要があります。
164
165
166このパッケージより前に以下の関連パッケージをインストールして
167おくと、%{pkgname} が対応できる機能が自動的に追加されます。
168
169samba-libsmbclient-devel: SMB ファイルシステムのサポート
170
171
172[注意]
173コンパイルに必要な多くの関連パッケージを要求するので通常より
174ディスクの領域を多く消費します。
175またインストール時にコンパイルを行うため、通常より時間がかか
176る場合があります。(環境にもよりますが数分から数十分程度)
177
178[self-build パッケージについて]
179ソフトウェアによってはバイナリパッケージの配布が特許や法律に
180違反する可能性があるものがあります。その為、このような問題が
181懸念されるソフトウェアについてはバイナリパッケージを直接配布
182せずに、ユーザの環境でバイナリを作成する self-build パッケー
183ジという方法を採っています。
184
185作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
186アのライセンス、および利用する国の各種法令に従ってください。
187また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
188センスの購入などが必要となる場合がありますので、利用する目的
189や形態に応じて各自で判断し適切な対応を取ってください。
190
191
192%prep
193[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
194
195%install
196%{__rm} -rf ${RPM_BUILD_ROOT}
197%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
198%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
199%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
200%{__install} -m 644 \
201    %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} \
202    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
203%{__install} -m 644 \
204    %{SOURCE102} %{SOURCE108} %{SOURCE114} %{SOURCE118} \
205    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
206
207
208%clean
209%{__rm} -rf ${RPM_BUILD_ROOT}
210
211%posttrans
212## official tarball
213/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
214    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
215    %{source1url} \
216    1429000
217exit 0
218
219## svn checkout
220# set locale
221case $LANG in
222    ja*)LOCALE=ja ;;
223    *) LOCALE=C ;;
224esac
225
226GetSrc_C(){
227    echo -n "     "
228    echo "Download source file with Subversion..."
229}
230
231GetSrc_ja(){
232    echo -n "     "
233    echo "Subversion を用いてソースファイルをダウンロードしています..."
234}
235
236GetSrc_$LOCALE
237
238# svn checkout
239. /etc/self-build.conf
240(cd $TEMP_DIR
241su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
242%__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
243)
244
245/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
246    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} 1368000
247   
248
249%files
250%defattr(-,root,root)
251%{_datadir}/%{name}
252
253%changelog
254* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
255- updated to 1.1.1 based on 1.1.1-1vl7
256
257* Tue Jul  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.rc4
258- dropped BuildRequires: self-build-libdvdcss
259
260* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
261- s/self-build-libdvdnav/libdvdnav/
262
263* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
264- updated %%source1path
265  - update to 1.8
266
267* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
268- dropped Requires(post): esound-devel
269
270* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
271- new upstream release
272  - ready for Vine Linux 6
273  - revived support for Vine Linux 5
274- added Requires(post):
275  - libass-devel
276  - librtmp-devel >= 2.3
277  - speex-devel >= 1.1
278
279* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
280- added BuildRequires:
281  - aalib-devel
282  - enca-devel
283  - lzo-devel
284  - speex-devel
285
286* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
287- updated fixed %{name}-config.patch
288  - applied %{name}-config-20100709-vine.patch
289
290* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
291- unpacked source archives
292
293* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
294- updated source snapshot 20100709
295- renamed %%Source10 to mplayer-snapshot-vine.sh
296- added Requires(post): libva-devel, libvpx-devel >= 0.9.1
297- dropped vl4 support
298- updated %%description
299
300* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
301- updated source snapshot 20100621
302- added Requires(post): libXinerama-devel
303- dropped vl4 support
304
305* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
306- updated source snapshot 20100401
307
308* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
309- updated source snapshot 20100317
310- renamed %%{Source0} to mplayer-vl.spec
311
312* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
313- updated source snapshot 20100216
314- dropped obsolete patches
315- added Requires(post): libvdpau-devel libXScrnSaver-devel
316
317* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
318- update mplayer-config-20091215-vine.patch
319- update mplayer-20091215-x86_32-compile.patch
320
321* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
322- source snapshot 20091031
323  - updated mplayer-20091031-x86_32-compile.patch
324
325* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
326- source snapshot 20091003
327
328* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
329- added some if conditions for "vl6"
330
331* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
332- source snapshot 20090905
333- added settings for vl6
334
335* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
336- source snapshot 20090821
337- replaced BR: libungif-devel with BR: giflib-devel
338- mentioned VDPAU support in %%description
339
340* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
341- source snapshot 20090722
342
343* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
344- source snapshot 20090702
345- check version between original spec and self-build spec in %%prep
346
347* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
348- source snapshot 20090611
349
350* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
351- added Requires: TrueType-vlgothic
352
353* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
354- source snapshot 20090522
355  - build with x264 >= 0.0.0-9.20090522
356  - updated mplayer-20090502-nodvdcss.patch
357- avoided to execute self-build-rpm.sh on RPM transaction
358  - moved %%post actions to %%posttrans
359
360* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
361- added PreReq: self-build-mplayer-codecs
362
363* Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
364- added BuildArch: noarch
365- source snapshot 20090502
366- updated mplayer-20090503-x86_32-compile.patch
367- updated mplayer-20090502-nodvdcss.patch
368
369* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
370- included source archives:
371  - mplayer-export-20090327.tar.bz2
372  - Blue-1.7.tar.bz2
373- applied mplayer-config-vine.patch
374
375* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
376- source snapshot 20090327
377- updated mplayer-20090327-x86_32-compile.patch
378- updated mplayer-20090325-nodvdcss.patch
379- dropped gmplayer-about-vine.patch
380
381* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
382- source snapshot 20090206
383- dropped mplayer-man-zh_CN.patch
384- updated mplayer-20090206-nodvdcss.patch
385- changed to PreReq:  self-build-faad2 from faad2-devel
386- added PreReq:  self-build-libmad
387
388* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
389- source snapshot 20090131
390- fixed %%files section
391
392* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
393- fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
394
395* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
396- source snapshot
397- update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
398- added PreReq:
399  - faad2-devel
400  - libmpcdec-devel
401  - twolame-devel
402  - yasm
403  - self-build-libdvdcss
404  - self-build-libdvdnav
405  - self-build-faac
406  - self-build-lame
407  - self-build-libdca
408  - self-build-x264 >= 0.0.0-4.20090110
409  - self-build-xvidcore >= 0.9.2
410- move %%define source0Exists() from %%post section to header
411- fixed %%post section: clean up source archive
412
413* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
414- source snapshot
415- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
416  --disable-faad-internal in configure options
417- dropped gmplayer-add-flv-extension.patch
418
419* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
420- source snapshot
421- fixed License
422- added some patches from RPM Fusion
423- updated gmplayer-about-vine.patch for 20081001 snapshot
424- added BuildRequires:  libdvdread
425- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
426- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
427  in configure options
428#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
429- added PreReq: subversion
430
431* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
432- fixed License
433- added some devel packages to support OpenGL
434
435* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
436- spec in utf8
437- fix sybolic link of subfont for vl5
438
439* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
440- add "Source105: CVE-2008-1558.patch".
441
442* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
443- build with new versioning policy.
444- add "Source200: gmplayer-about-vine.patch".
445- add "Source201: gmplayer-add-flv-extension.patch".
446- fix <BTS:VineLinux:603>.
447  - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
448  - add mirror URLs to self-build-rpm.sh.
449
450* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
451- add four official security patches (CVE-2008-0485, CVE-2008-0486,
452  CVE-2008-0629, CVE-2008-0630)
453- add mplayer-1.0rc2-20080211-stream_cddb.patch
454
455* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
456- change source download URL. <BTS:VineLinux:603>
457
458* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
459- fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
460
461* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
462- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.