source: projects/specs/branches/6/nonfree/self-build-libquicktime/self-build-libquicktime-vl.spec @ 3126

Revision 3126, 6.5 KB checked in by munepi, 13 years ago (diff)

updated self-build-ffmpeg-vl.spec, self-build-gpac-vl.spec self-build-libquicktime-vl.spec self-build-mplayer-vl.spec self-build-vlc-vl.spec self-build-x264-vl.spec; added rtmpdump-vl.spec

Line 
1%define pkgname libquicktime
2%define name    self-build-%{pkgname}
3%define version 1.2.2
4%define release 2%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/libquicktime/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        LGPLv2+
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20Requires(post):         libvorbis-devel
21Requires(post):         libpng-devel
22Requires(post):         libjpeg-devel
23Requires(post):         gtk2-devel
24Requires(post):         libdv-devel
25Requires(post):         libraw1394-devel
26Requires(post):         libavc1394-devel
27
28Requires(post):         alsa-lib-devel
29Requires(post):         zlib-devel
30Requires(post):         gettext-devel
31Requires(post):         mesa-libGL-devel
32Requires(post):         libX11-devel
33Requires(post):         libICE-devel
34Requires(post):         libSM-devel
35Requires(post):         libXext-devel
36Requires(post):         libXmu-devel
37Requires(post):         libXpm-devel
38Requires(post):         libXt-devel
39Requires(post):         libXaw-devel >= 1.0.5
40Requires(post):         libXv-devel
41
42Requires(post):         self-build-ffmpeg
43Requires(post):         self-build-lame
44Requires(post):         self-build-faad2
45Requires(post):         self-build-faac
46Requires(post):         self-build-x264
47
48BuildArch:      noarch
49BuildRoot:      %{_tmppath}/%{name}-%{version}-root
50
51Packager:       munepi
52
53%description
54Libquicktime is based on the quicktime4linux library with several
55enhancements. All 3rd-party libraries were removed from the
56sourcetree. Instead, the systemwide installed libraries are detected
57by the configure script. All original codecs were moved into
58dynamically loadable modules, and new codecs are in
59development. Libquicktime is source-compatible with
60quicktime4linux. Special API extensions allow access to the codec
61registry and more convenient processing of Audio and Video
62data.
63
64
65If you install this package, it automaticaly downloads source
66code ,compile it, and create rpm packages of %{pkgname}-%{version}.
67And the created rpm packages are automatically installed
68if installation is executed by apt-get command or synaptic
69package manager.
70
71[Note]
72This package requires many other packages to compile
73targetsoftware. So it consume more disk space than usual.
74Also installation takes logner time because of compilation.
75(This will take a few minutes to quarter or half of an hour,
76depends on building environment)
77
78[About self-build package]
79For some kind of software, distributing of binary package
80may viorate the patent or law. Therefore we chose self-build
81packge, create binary package on your machine, for such kind
82of softwares instead of distributing binary package.
83
84Please obey the national law when you use the created binary
85packages. And if you want to use the softwares using patented
86thechnology, it may be required to get a permission, make an
87agreement or purchas a license. Please consider it with your
88purpose or way of use and take appropriate action.
89
90%description -l ja
91libquicktime は、quicktime4linux ライブラリを元に拡張しています。
92サードパーティライブラリは、一次元ソースツリーからすべて消えてしまいました。
93その代わりに、システムワイドにインストールされるライブラリは、
94configure スクリプトにより検出されます。
95オリジナルコーデックは、すべて動的読み込み可能なモジュールに
96移行してしまいました。また、新しいコーデックは開発途中です。
97libquicktime は quicktime4linux と互換性を持ったソースです。
98特別な API 拡張は、コーデックレジストリや
99音声や動画のより便利な処理にアクセスができます。
100
101
102このパッケージをインストールすると、自動的にソースコードを
103ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
104パッケージを作成します。
105また apt-get コマンドや synaptic パッケージマネージャから実行
106した場合は、作成された rpm パッケージのインストールも自動的に
107行います。
108
109[注意]
110コンパイルに必要な多くの関連パッケージを要求するので通常より
111ディスクの領域を多く消費します。
112またインストール時にコンパイルを行うため、通常より時間がかか
113る場合があります。(環境にもよりますが数分から数十分程度)
114
115[self-build パッケージについて]
116ソフトウェアによってはバイナリパッケージの配布が特許や法律に
117違反する可能性があるものがあります。その為、このような問題が
118懸念されるソフトウェアについてはバイナリパッケージを直接配布
119せずに、ユーザの環境でバイナリを作成する self-build パッケー
120ジという方法を採っています。
121
122作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
123アのライセンス、および利用する国の各種法令に従ってください。
124また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
125センスの購入などが必要となる場合がありますので、利用する目的
126や形態に応じて各自で判断し適切な対応を取ってください。
127
128%prep
129[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
130
131%install
132%{__rm} -rf ${RPM_BUILD_ROOT}
133%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
134%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
135
136%clean
137%{__rm} -rf ${RPM_BUILD_ROOT}
138
139%posttrans
140/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 188000
141/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
142                                 %{pkgname}-utils-%{version}-%{release} \
143                                 %{pkgname}-devel-%{version}-%{release}
144
145%files
146%defattr(-,root,root)
147%{_datadir}/%{name}
148
149%changelog
150* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-2
151- rebuilt
152
153* Mon Jan 31 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-1
154- new upstream release
155- added the subpackage utils
156- updated %%description
157
158* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
159- new upstream release
160
161* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-2
162- renamed %%{Source0} to libquicktime-vl.spec
163
164* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
165- new upstream release
166
167* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.2-1
168- initial bulid
Note: See TracBrowser for help on using the repository browser.