source: projects/specs/branches/6/nonfree/self-build-lame/self-build-lame-vl.spec @ 692

Revision 692, 6.1 KB checked in by munepi, 14 years ago (diff)

self-build-lameを更新。

Line 
1%define pkgname lame
2%define name    self-build-%{pkgname}
3%define version 3.98.4
4%define release 1%{?_dist_release}
5
6#% define sourceurl http://prdownloads.sourceforge.net/lame/lame-%{version}.tar.gz
7%define sourceurl http://prdownloads.sourceforge.net/lame/lame-%{version}.tar.gz
8
9Summary:        Package to automatically build %{pkgname} rpm package
10Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
11Name:           %{name}
12Version:        %{version}
13Release:        %{release}
14Source0:        %{pkgname}-vl.spec
15Source1:        %{pkgname}-noexecstack.patch
16Source2:        %{pkgname}-pmake.patch
17
18License:        GPL
19Group:          Restricted Software
20
21Requires(post):         self-build-setup >= 0.8
22
23# (build)requies of target package.
24Requires(post):         ncurses
25Requires(post):         ncurses-devel
26Requires(post):         gtk+
27Requires(post):         gtk+-devel
28%ifarch %{ix86} x86_64
29Requires(post):         nasm
30%endif
31
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33
34Packager:       munepi
35
36%description
37Lame is an open source developing mp3 encoder.
38
39If you install this package, it automaticaly downloads source
40code ,compile it, and create rpm packages of %{pkgname}-%{version}.
41And the created rpm packages are automatically installed
42if installation is executed by apt-get command or synaptic
43package manager.
44
45[Note]
46This package requires many other packages to compile
47targetsoftware. So it consume more disk space than usual.
48Also installation takes logner time because of compilation.
49(This will take a few minutes to quarter or half of an hour,
50depends on building environment)
51
52[About self-build package]
53For some kind of software, distributing of binary package
54may viorate the patent or law. Therefore we chose self-build
55packge, create binary package on your machine, for such kind
56of softwares instead of distributing binary package.
57
58Please obey the national law when you use the created binary
59packages. And if you want to use the softwares using patented
60thechnology, it may be required to get a permission, make an
61agreement or purchas a license. Please consider it with your
62purpose or way of use and take appropriate action.
63
64%description -l ja
65lame はオープンソースで開発されている mp3 エンコーダです。
66
67このパッケージをインストールすると、自動的にソースコードを
68ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
69パッケージを作成します。
70また apt-get コマンドや synaptic パッケージマネージャから実行
71した場合は、作成された rpm パッケージのインストールも自動的に
72行います。
73
74[注意]
75コンパイルに必要な多くの関連パッケージを要求するので通常より
76ディスクの領域を多く消費します。
77またインストール時にコンパイルを行うため、通常より時間がかか
78る場合があります。(環境にもよりますが数分から数十分程度)
79
80[self-build パッケージについて]
81ソフトウェアによってはバイナリパッケージの配布が特許や法律に
82違反する可能性があるものがあります。その為、このような問題が
83懸念されるソフトウェアについてはバイナリパッケージを直接配布
84せずに、ユーザの環境でバイナリを作成する self-build パッケー
85ジという方法を採っています。
86
87作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
88アのライセンス、および利用する国の各種法令に従ってください。
89また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
90センスの購入などが必要となる場合がありますので、利用する目的
91や形態に応じて各自で判断し適切な対応を取ってください。
92
93%prep
94[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
95
96%install
97%{__rm} -rf ${RPM_BUILD_ROOT}
98%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
99%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
100%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
101%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
102
103
104%clean
105%{__rm} -rf ${RPM_BUILD_ROOT}
106
107%posttrans
108/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 65000
109/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
110                                 %{pkgname}-mp3x-%{version}-%{release} \
111                                 %{pkgname}-devel-%{version}-%{release}
112
113
114%files
115%defattr(-,root,root)
116%{_datadir}/%{name}
117
118%changelog
119* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.4-1
120- new upstream release
121
122* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.3-1
123- new upstream release
124- renamed %%{Source0} to lame-vl.spec
125
126* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.2-2
127- rebuilt to add signature
128
129* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.2-1
130- new upstream release
131
132* Fri Jun 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-5
133- dropped BuildArch: noarch
134  (because if BuildArch: noarch, %%ifarch is invalid)
135
136* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-4
137- added BuildArch: noarch
138- avoided to execute self-build-rpm.sh on RPM transaction
139  - moved %%post actions to %%posttrans
140
141* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-3
142- spec in utf8
143- remove *.la
144
145* Wed May 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-2
146- change %%{__make} option to -j1 in Source0 <BTS:VineLinux:611>
147- remove trailing /* in %%files <BTS:VineLinux:622>
148
149* Sat May 03 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-1
150- run pre-allocate-rpm.sh in %%post
151- set PreReq: self-build-setup >= 0.8
152- apply new versioning policy
153
154* Thu Nov 01 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl3
155- update description about self-build package
156
157* Mon Oct 22 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl2
158- unset BuildArch: noarch
159
160* Thu Oct 18 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl1
161- initial build for Vine Linux
162  (using same version number of target software)
Note: See TracBrowser for help on using the repository browser.