source: projects/specs/branches/6/nonfree/self-build-k3b-extra/self-build-k3b-extra-vl.spec @ 2857

Revision 2857, 5.0 KB checked in by inagaki, 13 years ago (diff)

update: k3b, self-build-k3b-extra, shared-desktop-ontologies

Line 
1%define pkgname k3b-extra
2%define name    self-build-%{pkgname}
3%define version 2.0.2
4%define release 2%{?_dist_release}
5
6%define sourceurl0      http://downloads.sourceforge.net/project/k3b/k3b/%{version}/k3b-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPLv2
16Group:          Restricted Software
17
18Requires(post): self-build-setup >= 0.8
19Requires(post): self-build-ffmpeg
20Requires(post): self-build-lame
21Requires(post): self-build-libmad
22
23Requires(post): desktop-file-utils
24Requires(post): gettext
25Requires(post): kdelibs4-devel
26Requires(post): kdemultimedia4-devel
27Requires(post): libdvdread-devel
28Requires(post): libmusicbrainz-devel
29Requires(post): libsamplerate-devel
30Requires(post): libXpm-devel
31Requires(post): taglib-devel
32
33Requires:       k3b >= %{version}
34
35BuildArch:      noarch
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37
38Packager:       inagaki
39
40%description
41This package contains additional plugins for K3b.
42
43- FFMpeg decoder for decoding WMA file(s)
44- MAD decoder for decoding MP3 file(s)
45- Lame MP3 encoder for encoding MP3 file(s)
46
47If you install this package, it automaticaly downloads source
48code ,compile it, and create rpm packages of k3b-extra.
49And the created rpm packages are automatically installed
50if installation is executed by apt-get command or synaptic
51package manager.
52
53[Note]
54This package requires many other packages to compile
55targetsoftware. So it consume more disk space than usual.
56Also installation takes logner time because of compilation.
57(This will take a few minutes to quarter or half of an hour,
58depends on building environment)
59
60[About self-build package]
61For some kind of software, distributing of binary package
62may viorate the patent or law. Therefore we chose self-build
63packge, create binary package on your machine, for such kind
64of softwares instead of distributing binary package.
65
66Please obey the national law when you use the created binary
67packages. And if you want to use the softwares using patented
68thechnology, it may be required to get a permission, make an
69agreement or purchas a license. Please consider it with your
70purpose or way of use and take appropriate action.
71
72%description -l ja
73K3b 向けに以下の追加プラグインを提供します.
74
75- WMA ファイルをデコードするための FFMpeg デコーダ
76- MP3 ファイルをデコードするための MAD デコーダ
77- MP3 ファイルをエンコードするための Lame MP3 エンコーダ
78
79このパッケージをインストールすると、自動的にソースコードを
80ダウンロードしてコンパイルし、k3b-extra の rpm パッケージを作成します。
81また apt-get コマンドや synaptic パッケージマネージャから実行
82した場合は、作成された rpm パッケージのインストールも自動的に
83行います。
84
85[注意]
86コンパイルに必要な多くの関連パッケージを要求するので通常より
87ディスクの領域を多く消費します。
88またインストール時にコンパイルを行うため、通常より時間がかか
89る場合があります。(環境にもよりますが数分から数十分程度)
90
91[self-build パッケージについて]
92ソフトウェアによってはバイナリパッケージの配布が特許や法律に
93違反する可能性があるものがあります。その為、このような問題が
94懸念されるソフトウェアについてはバイナリパッケージを直接配布
95せずに、ユーザの環境でバイナリを作成する self-build パッケー
96ジという方法を採っています。
97
98作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
99アのライセンス、および利用する国の各種法令に従ってください。
100また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
101センスの購入などが必要となる場合がありますので、利用する目的
102や形態に応じて各自で判断し適切な対応を取ってください。
103
104%prep
105[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
106
107%install
108%{__rm} -rf ${RPM_BUILD_ROOT}
109%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
110%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
111
112%clean
113%{__rm} -rf ${RPM_BUILD_ROOT}
114
115%posttrans
116/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}"
117
118%files
119%defattr(-,root,root)
120%{_datadir}/%{name}
121
122%changelog
123* Fri Mar  4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-2
124- added BR: libXpm-devel
125
126* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
127- new upstream release
128
129* Sun Sep 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-2
130- fixed %%build section to remove qt-devel dependency
131
132* Wed Sep  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
133- new upstream release
134
135* Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
136- initial bulid for Vine Linux
Note: See TracBrowser for help on using the repository browser.