source: projects/specs/branches/6/nonfree/self-build-gstreamer-plugins-bad/gstreamer-plugins-bad-vl.spec @ 5086

Revision 5086, 17.4 KB checked in by munepi, 13 years ago (diff)

libdvdnav, libmp4v2: changed to plus category; updated libdvdnav, libdvdread: new upstream release

Line 
1%define majorminor   0.10
2%define gstreamer    gstreamer
3
4%define gst_minver   0.10.22.1
5%define gstpb_minver 0.10.22.1
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Name: gstreamer-plugins-bad
9Version: 0.10.21
10Release: 2%{?_dist_release}
11# The freeze and nfs plugins are LGPLv2 (only)
12License: LGPLv2+
13Group: Applications/Multimedia
14URL: http://gstreamer.freedesktop.org/
15Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.bz2
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires: %{gstreamer} >= %{gst_minver}
18BuildRequires: %{gstreamer}-devel >= %{gst_minver}
19BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
20
21BuildRequires: check
22BuildRequires: gettext
23BuildRequires: PyXML
24BuildRequires: libXt-devel
25
26BuildRequires: liboil-devel
27BuildRequires: libdirectfb-devel
28# BuildRequires: self-build-libdca-devel
29# BuildRequires: self-build-faac-devel
30# BuildRequires: self-build-faad2
31BuildRequires: gsm-devel
32BuildRequires: libmpcdec-devel
33BuildRequires: SDL-devel
34#BuildRequires: soundtouch-devel
35#BuildRequires: swfdec-devel
36#Buildrequires: wavpack-devel
37# BuildRequires: self-build-xvidcore-devel
38BuildRequires: bzip2-devel
39BuildRequires: mesa-libGLU-devel
40BuildRequires: neon-devel
41BuildRequires: libmms-devel
42BuildRequires: libmusicbrainz-devel
43#BuildRequires: libcdaudio-devel
44BuildRequires: jack-audio-connection-kit-devel
45#BuildRequires: mjpegtools-devel
46#BuildRequires: nas-devel
47# BuildRequires: self-build-x264-devel
48#BuildRequires: wildmidi-devel
49BuildRequires: libsndfile-devel
50#BuildRequires: libmodplug-devel
51#BuildRequires: libtimidity-devel
52#BuildRequires: gmyth-devel >= 0.4
53BuildRequires: libdc1394-devel
54BuildRequires: libexif-devel
55#BuildRequires: libiptcdata-devel
56#BuildRequires: exempi-devel
57#BuildRequires: dirac-devel
58#BuildRequires: libofa-devel
59BuildRequires: libdvdnav-devel
60BuildRequires: jasper-devel
61BuildRequires: openssl-devel
62BuildRequires: twolame-devel
63BuildRequires: libvdpau-devel
64BuildRequires: librtmp-devel
65
66%description
67GStreamer is a streaming media framework, based on graphs of elements which
68operate on media data.
69
70This package contains plug-ins that have licensing issues, aren't tested
71well enough, or the code is not of good enough quality.
72
73
74# %package extras
75# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
76# Group: Applications/Multimedia
77# Requires: %{name} = %{version}-%{release}
78
79# %description extras
80# GStreamer is a streaming media framework, based on graphs of elements which
81# operate on media data.
82
83# gstreamer-plugins-bad contains plug-ins that have licensing issues, aren't
84# tested well enough, or the code is not of good enough quality.
85
86# This package (gstreamer-plugins-bad-extras) contains extra "bad" plugins for
87# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
88# very much and require additional libraries to be installed.
89
90
91%package devel
92Summary: Development files for the GStreamer media framework "bad" plug-ins
93Group: Development/Libraries
94Requires: %{name} = %{version}-%{release}
95Requires: gstreamer-plugins-base-devel
96
97%description devel
98GStreamer is a streaming media framework, based on graphs of elements which
99operate on media data.
100
101This package contains the development files for the plug-ins that have
102licensing issues, aren't tested well enough, or the code is not of good
103enough quality.
104
105# '
106
107%prep
108%setup -q -n gst-plugins-bad-%{version}
109
110
111%build
112%configure \
113    --enable-debug --disable-static --disable-gtk-doc \
114    --disable-ladspa --enable-experimental \
115    --disable-siren --disable-valve --disable-dtmf --disable-autoconvert \
116    --disable-liveadder \
117    ;
118
119# Don't use rpath!
120%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
121%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
122%{__make} %{?_smp_mflags}
123
124
125%install
126%{__rm} -rf %{buildroot}
127%{__make} install DESTDIR="%{buildroot}"
128%find_lang gst-plugins-bad-%{majorminor}
129
130# Clean out files that should not be part of the rpm.
131%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
132%{__rm} -f %{buildroot}%{_libdir}/*.la
133
134
135%clean
136%{__rm} -rf %{buildroot}
137
138
139%post -p /sbin/ldconfig
140
141%postun -p /sbin/ldconfig
142
143
144%files -f gst-plugins-bad-%{majorminor}.lang
145%defattr(-,root,root,-)
146%doc AUTHORS COPYING README REQUIREMENTS
147# %{_bindir}/gst-camera
148# %{_bindir}/gst-camera-perf
149%{_libdir}/*.so.*
150%{_libdir}/gstreamer-%{majorminor}/*.so
151#%{_datadir}/gstreamer-0.10/presets/GstX264Enc.prs
152#%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.glade
153#%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.ui
154
155# # Plugins without external dependencies
156# %{_libdir}/gstreamer-%{majorminor}/libgstaacparse.so
157# %{_libdir}/gstreamer-%{majorminor}/libgstaiffparse.so
158# %{_libdir}/gstreamer-%{majorminor}/libgstamrparse.so
159# %{_libdir}/gstreamer-%{majorminor}/libgstbayer.so
160# %{_libdir}/gstreamer-%{majorminor}/libgstcdxaparse.so
161# %{_libdir}/gstreamer-%{majorminor}/libgstdccp.so
162# %{_libdir}/gstreamer-%{majorminor}/libgstdeinterlace.so
163# %{_libdir}/gstreamer-%{majorminor}/libgstdeinterlace2.so
164# %{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
165# %{_libdir}/gstreamer-%{majorminor}/libgstfestival.so
166# %{_libdir}/gstreamer-%{majorminor}/libgstfilter.so
167# %{_libdir}/gstreamer-%{majorminor}/libgstflv.so
168# %{_libdir}/gstreamer-%{majorminor}/libgstfreeze.so
169# %{_libdir}/gstreamer-%{majorminor}/libgsth264parse.so
170# %{_libdir}/gstreamer-%{majorminor}/libgstlegacyresample.so
171# %{_libdir}/gstreamer-%{majorminor}/libgstrfbsrc.so
172# %{_libdir}/gstreamer-%{majorminor}/libgstmpeg4videoparse.so
173# %{_libdir}/gstreamer-%{majorminor}/libgstmpegdemux.so
174# %{_libdir}/gstreamer-%{majorminor}/libgstmpegtsmux.so
175# %{_libdir}/gstreamer-%{majorminor}/libgstmpegvideoparse.so
176# %{_libdir}/gstreamer-%{majorminor}/libgstmve.so
177# %{_libdir}/gstreamer-%{majorminor}/libgstmxf.so
178# %{_libdir}/gstreamer-%{majorminor}/libgstnsf.so
179# %{_libdir}/gstreamer-%{majorminor}/libgstnuvdemux.so
180# %{_libdir}/gstreamer-%{majorminor}/libgstpcapparse.so
181# %{_libdir}/gstreamer-%{majorminor}/libgstqtmux.so
182# %{_libdir}/gstreamer-%{majorminor}/libgstrawparse.so
183# %ifarch %{ix86} x86_64
184# %{_libdir}/gstreamer-%{majorminor}/libgstreal.so
185# %endif
186# %{_libdir}/gstreamer-%{majorminor}/libgstrtpmanager.so
187# %{_libdir}/gstreamer-%{majorminor}/libgstscaletempoplugin.so
188# %{_libdir}/gstreamer-%{majorminor}/libgstsdpelem.so
189# %{_libdir}/gstreamer-%{majorminor}/libgstselector.so
190# %{_libdir}/gstreamer-%{majorminor}/libgstspeed.so
191# %{_libdir}/gstreamer-%{majorminor}/libgststereo.so
192# %{_libdir}/gstreamer-%{majorminor}/libgstsubenc.so
193# %{_libdir}/gstreamer-%{majorminor}/libgsttta.so
194# %{_libdir}/gstreamer-%{majorminor}/libgstvideosignal.so
195# %{_libdir}/gstreamer-%{majorminor}/libgstvmnc.so
196# %{_libdir}/gstreamer-%{majorminor}/libgsty4menc.so
197
198# # System (Linux) specific plugins
199# %{_libdir}/gstreamer-%{majorminor}/libgstdvb.so
200# %{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
201# %{_libdir}/gstreamer-%{majorminor}/libgstoss4audio.so
202# %{_libdir}/gstreamer-%{majorminor}/libgstvcdsrc.so
203
204# # Plugins with external dependencies
205# %{_libdir}/gstreamer-%{majorminor}/libgstalsaspdif.so
206# %{_libdir}/gstreamer-%{majorminor}/libgstapexsink.so
207# %{_libdir}/gstreamer-%{majorminor}/libgstbz2.so
208# #%{_libdir}/gstreamer-%{majorminor}/libgstcdaudio.so
209# #%{_libdir}/gstreamer-%{majorminor}/libgstdc1394.so
210# %{_libdir}/gstreamer-%{majorminor}/libgstdfbvideosink.so
211# #%{_libdir}/gstreamer-%{majorminor}/libgstdirac.so
212# %{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
213# %{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
214# %{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
215# %{_libdir}/gstreamer-%{majorminor}/libgstgsm.so
216# %{_libdir}/gstreamer-%{majorminor}/libgstjp2k.so
217# #%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
218# %{_libdir}/gstreamer-%{majorminor}/libgstmetadata.so
219# #%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
220# %{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
221# %{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
222# %{_libdir}/gstreamer-%{majorminor}/libgstmusepack.so
223# %{_libdir}/gstreamer-%{majorminor}/libgsttrm.so
224# %{_libdir}/gstreamer-%{majorminor}/libgstneonhttpsrc.so
225# #%{_libdir}/gstreamer-%{majorminor}/libgstofa.so
226# %{_libdir}/gstreamer-%{majorminor}/libresindvd.so
227# %{_libdir}/gstreamer-%{majorminor}/libgstsdl.so
228# %{_libdir}/gstreamer-%{majorminor}/libgstsndfile.so
229# #%{_libdir}/gstreamer-%{majorminor}/libgstswfdec.so
230# #%{_libdir}/gstreamer-%{majorminor}/libgsttimidity.so
231# %{_libdir}/gstreamer-%{majorminor}/libgsttwolame.so
232# #%{_libdir}/gstreamer-%{majorminor}/libgstwildmidi.so
233# %{_libdir}/gstreamer-%{majorminor}/libgstx264.so
234# %{_libdir}/gstreamer-%{majorminor}/libgstxvid.so
235
236# %files extras
237# %defattr(-,root,root,-)
238# # Plugins with external dependencies
239# %{_libdir}/gstreamer-%{majorminor}/libgstjack.so
240# #%{_libdir}/gstreamer-%{majorminor}/libgstmythtvsrc.so
241# #%{_libdir}/gstreamer-%{majorminor}/libgstnassink.so
242# #%{_libdir}/gstreamer-%{majorminor}/libgstsoundtouch.so
243
244%files devel
245%defattr(-,root,root,-)
246%{_libdir}/*.so
247%{_includedir}/gstreamer-%{majorminor}/gst/basecamerabinsrc/*.h
248%{_includedir}/gstreamer-%{majorminor}/gst/signalprocessor/gstsignalprocessor.h
249%{_includedir}/gstreamer-%{majorminor}/gst/video/*
250%{_includedir}/gstreamer-%{majorminor}/gst/interfaces/photography*
251%{_includedir}/gstreamer-%{majorminor}/gst/vdpau/*
252%{_libdir}/pkgconfig/*
253%{_datadir}/glib-2.0/schemas/org.freedesktop.gstreamer-0.10.default-elements.gschema.xml
254#%doc %{_datadir}/gtk-doc/html/gst-plugins-bad-plugins-0.10
255
256
257
258%changelog
259* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
260- s/self-build-libdvdnav/libdvdnav/
261
262* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
263- new upstream release
264- added BuildRequires:
265  - libmms-devel
266  - librtmp-devel
267
268* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
269- new upstream release
270
271* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
272- new upstream release
273
274* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
275- new upstream release
276- added BuildRequires: libvdpau-devel
277
278* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
279- new upstream release
280
281* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
282- new upstream release
283- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
284  gst-plugins-bad-0.10.5-mms-seek.patch
285
286* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
287- new upstream release
288- dropped devel and devel-docs subpackages
289
290* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
291- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
292- changed to BuildRequires:  self-build-faad2 from faad2-devel
293
294* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
295- initial build based on RPM Fusion package
296
297* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
298- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
299
300* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
301- Rebuild for new x264 (using patch from Rathann)
302
303* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
304- New upstream release 0.10.9
305- Rebuild for new directfb
306
307* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
308- Rebuild for new x264 and to generate new magic gstreamer provides
309
310* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
311- Enable DVD navigation plugin
312
313* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
314- Release bump to keep rpmfusion version higher then livna
315
316* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
317- New upstream release 0.10.8
318- Merge changes from latest freshrpms package: enable ofa and dirac plugins
319
320* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
321- Rebuild for new x264
322
323* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
324- New upstream release 0.10.7
325- Drop many upstreamed patches
326
327* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
328- Rebuild for new x264
329
330* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
331- Enable dc1394 plugin
332
333* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
334- New upstream release 0.10.6-1
335- Drop many upstreamed patches
336- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
337
338* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
339- Fix compilation with gcc 4.3
340
341* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
342- Add flv demuxer from CVS (livna bug 1846)
343
344* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
345- Add patch fixing compilation with mjpegtools 1.9.0rc3
346
347* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
348- Add patch from upstream vcs which makes mms honor your connection speed
349  settings
350- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
351
352* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
353- Rebuild for new faad2
354
355* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
356- Rebuild for new libdca
357
358* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
359- Rebuild for new (old) faad2 (livna bug 1679)
360
361* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
362- Update mythtvsrc code to CVS version (livna bug 1660)
363
364* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
365- No libgstreal.so on ppc / ppc64
366
367* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
368- Fix detection of libdts with current livna libtds, this might need to be
369  changed back again for rpmfusion, depending on how libdts will look there
370
371* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
372- Add mythtvsrc plugin (livna 1646)
373- Put some less often used plugins, which bring in also usually not installed
374  deps in a -extras package
375
376* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
377- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
378- Set release to 4 to be higher as both livna and freshrpms latest release
379- Set package name and origin to rpmfusion
380- Make mpeg2enc plugin compile with current mjpegtools
381- Make the real plugins search for the RealPlayer .so files in various
382  known possible locations instead of using only one hardcoded path to them
383- Make the wildmidi plugin work with the default Fedora timidity patch set
384- Add a couple of missing modtracker mimetypes to the modplug plugin
385- Use the system version of libmodplug
386- Fix building of the neonsrc plugin with the latest (rawhide) neon
387- Disable the ladspa plugin as this has been added to Fedora's rawhide
388  gstreamer-plugins-good
389- Don't put an rpath in the .so's on x86_64
390- Re-enable gtk-doc now that we have a -devel package again
391- Enable libtimidity plugin
392- Fix detection of (and linking with) libdca for the dtsdec plugin
393
394* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
395- Update to 0.10.5.
396- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
397- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
398- Enable new nas, x264, wildmidi and libsndfile plugins.
399- Re-add devel package now that we have a main shared lib and header files.
400- Add check build requirement.
401
402* Wed Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
403- Update to 0.10.4 for F7.
404- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
405  somewhat more, maybe then it'll be worth re-enabling.
406- Re-enable wavpack, it works again now.
407- Enable libcdaudio support.
408- Enable jack support.
409- Enable ladspa support.
410- Enable mpeg2enc (mjpegtools) support.
411- Remove no longer present libgstvideo4linux2.so and add all new plugins.
412- Remove all gtk-doc references (all gone...?) and devel package too.
413
414* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
415- Update faad2 patch to also update the plugin sources, not just configure.
416
417* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
418- Try to rebuild against new wavpack 4.40 from Extras : Fails.
419- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
420- Try to include patch to update wavpack plugin source from 0.10.3.2
421  pre-release : Fails to find wavpack/md5.h.
422- Give up and disable wavpack support for now, sorry! Patches welcome.
423- Include patch to fix faad2 2.5 detection.
424- Add soundtouch support.
425
426* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
427- Update to 0.10.3.
428- Add new translations.
429- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
430- Add new libmusicbrainz support.
431
432* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
433- Add libmms support, thanks to Daniel S. Rogers.
434
435* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
436- Update to 0.10.1.
437- Add libgstcdxaparse.so and libgstfreeze.so.
438- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
439
440* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
441- Update to 0.10.0.1, add new plugins.
442- Spec file cleanup and rebuild for FC5.
443
444* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
445- 0.10.0-0.gst.1
446- new release
447
448* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
449- 0.9.7-0.gst.1
450- new release with 0.10 major/minor
451
452* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
453- new release
454- remove tta patch
455- don't check for languages, no translations yet
456- added gtk-doc
457
458* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
459- 0.9.4-0.gst.1
460- new release
461- added speed plugin
462
463* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
464- 0.9.3-0.gst.1
465- new release
466
Note: See TracBrowser for help on using the repository browser.