source: projects/specs/branches/6/nonfree/self-build-ffmpeg/ffmpeg-vl6.spec @ 7904

Revision 7904, 10.4 KB checked in by munepi, 11 years ago (diff)

added ffmpeg-0.6.7-gcc-check-cflags.patch

Line 
1#TODO: Build with openjpeg, opencore-amr
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5## available for v0.6 or lower
6%define with_libfaad 1
7
8%define with_faac 1
9
10%define with_vaapi 1
11%define with_libvpx 1
12
13Summary:        Digital VCR and streaming server
14Name:           ffmpeg
15Version:        0.6.7
16Release:        2%{?svndate:.%svndate}%{?_dist_release}
17Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
18Source1:        %{name}-snapshot.sh
19
20# pre-built man files
21Source90:       ffmpeg.1.gz
22Source91:       ffplay.1.gz
23Source92:       ffserver.1.gz
24Source93:       ffprobe.1.gz
25
26Patch100:       ffmpeg-0.6.7-gcc-check-cflags.patch
27
28License:        GPLv2+
29Group:          Applications/Multimedia
30URL:            http://ffmpeg.org/
31
32BuildRequires:  bzip2-devel
33##BuildRequires:  dirac-devel
34BuildRequires:  gsm-devel
35BuildRequires:  imlib2-devel
36BuildRequires:  libdc1394-devel
37BuildRequires:  libraw1394-devel
38BuildRequires:  librtmp-devel >= 2.3
39BuildRequires:  libtheora-devel
40%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
41BuildRequires:  libvdpau-devel
42BuildRequires:  libvorbis-devel
43%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
44%{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
45##BuildRequires:  openjpeg-devel
46##BuildRequires:  schroedinger-devel
47BuildRequires:  SDL-devel
48BuildRequires:  speex-devel
49##BuildRequires:        texi2html
50BuildRequires:  zlib-devel
51BuildRequires:  libogg-devel
52BuildRequires:  yasm
53# *-devel packages provided by other self-build-* should only be listed
54# in self-build-%{name}.spec as PreReq.
55#BuildRequires: a52dec-devel
56#BuildRequires: faac-devel
57#BuildRequires: lame-devel
58#BuildRequires: libdca-devel
59#BuildRequires: faad2-devel
60#BuildRequires: x264-devel >= 0.0.0-15.20110322
61#BuildRequires: xvidcore-devel
62
63Requires:       %{name}-libs = %{version}-%{release}
64
65BuildRoot:      %{_tmppath}/%{name}-%{version}-root
66
67%description
68FFMpeg is a complete and free Internet live audio and video
69broadcasting solution for Linux/Unix. It also includes a digital
70VCR. It can encode in real time in many formats including MPEG1 audio
71and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
72
73%package libs
74Summary: Libraries for %{name}
75Group: System Environment/Libraries
76
77%description libs
78FFMpeg is a complete and free Internet live audio and video
79broadcasting solution for Linux/Unix. It also includes a digital
80VCR. It can encode in real time in many formats including MPEG1 audio
81and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
82
83This package contains the libraries for %{name}.
84
85%package devel
86Summary: Development package for %{name}
87Group: Development/Libraries
88Requires: %{name}-libs = %{version}-%{release}
89Requires: pkgconfig
90
91%description devel
92FFMpeg is a complete and free Internet live audio and video
93broadcasting solution for Linux/Unix. It also includes a digital
94VCR. It can encode in real time in many formats including MPEG1 audio
95and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
96
97This package contains development files for %{name}.
98
99
100%prep
101%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
102#% setup -q
103#%patch0 -p1 -b .textrel
104
105%patch100 -p1 -b .vine
106
107%build
108%ifarch ppc
109# compile with -mlongcall on ppc/ppc64 (rf804)
110export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
111%endif
112
113./configure \
114    --prefix=%{_prefix} \
115    --incdir=%{_includedir}/%{name} \
116    --shlibdir=%{_libdir} \
117    --libdir=%{_libdir} \
118    --mandir=%{_mandir} \
119    --arch=%{_target_cpu} \
120%ifarch %{ix86}
121    --cpu=%{_target_cpu} \
122%endif
123%ifarch ppc
124    --cpu=g3 \
125    --enable-pic \
126%endif
127    --enable-runtime-cpudetect \
128    --extra-cflags="$RPM_OPT_FLAGS" \
129    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
130    --enable-bzlib \
131    --enable-zlib \
132    --enable-libdc1394 \
133    %{?_with_libdirac:--enable-libdirac} \
134    %{?with_faac:--enable-libfaac --enable-nonfree} \
135    %{?with_libfaad:--enable-libfaad} \
136    --enable-libgsm \
137    --enable-libmp3lame \
138    %{?_with_openjpeg:--enable-libopenjpeg} \
139    --enable-librtmp \
140    --enable-libspeex \
141    --enable-libtheora \
142    --enable-libvorbis \
143    %{?with_libvpx:--enable-libvpx} \
144    --enable-libx264 \
145    --enable-libxvid \
146    \
147    --enable-x11grab \
148    --enable-avfilter \
149    --enable-postproc \
150    --enable-pthreads \
151    --disable-static \
152    --enable-shared \
153    --enable-gpl \
154    --disable-doc \
155    --disable-debug \
156    --disable-stripping \
157    ;
158
159%{__make} %{?_smp_mflags}
160#% {__make}
161#%{__make} documentation
162
163
164%install
165%__make install DESTDIR=$RPM_BUILD_ROOT
166
167# ## install tool/qt-faststart
168# %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
169
170## install man
171%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
172%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
173    $RPM_BUILD_ROOT%{_mandir}/man1/
174
175
176%clean
177%{__rm} -rf $RPM_BUILD_ROOT
178
179%post libs -p /sbin/ldconfig
180
181%postun libs -p /sbin/ldconfig
182
183%files
184%defattr(-,root,root,-)
185%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
186%{_bindir}/ffmpeg
187%{_bindir}/ffplay
188%{_bindir}/ffprobe
189%{_bindir}/ffserver
190#%{_bindir}/qt-faststart
191%{_mandir}/man1/ffmpeg.1*
192%{_mandir}/man1/ffplay.1*
193%{_mandir}/man1/ffprobe.1*
194%{_mandir}/man1/ffserver.1*
195%{_datadir}/ffmpeg
196
197
198%files libs
199%defattr(-,root,root,-)
200%{_libdir}/lib*.so.*
201
202%files devel
203%defattr(-,root,root,-)
204%doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
205%{_includedir}/ffmpeg
206%{_libdir}/pkgconfig/lib*.pc
207%{_libdir}/lib*.so
208
209
210%changelog
211* Thu Oct 17 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.7-2
212- added ffmpeg-0.6.7-gcc-check-cflags.patch
213
214* Sun Oct  6 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.7-1
215- new upstream release
216
217* Tue Jul  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.6-1
218- new upstream release
219
220* Tue Dec 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.4-1
221- new upstream release
222
223* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-3
224- applied two patches for CVE-2011-3973, CVE-2011-3974, CVE-2011-3362
225  from git.videolan.org
226
227* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
228- change release to sync with self-build-ffmpeg-vl.spec
229
230* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
231- new upstream release
232
233* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
234- new upstream release
235
236* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
237- required latest x264 build
238- added BuildRequires: librtmp-devel >= 2.3
239- build PIC objects on PPC
240#- add qt-faststart tool
241
242* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
243- new upstream release
244
245* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
246- change release to sync with self-build-ffmpeg-vl.spec
247
248* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
249- added BuildRequires: libvpx-devel >= 0.9.1
250
251* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
252- new upstream release
253
254* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
255- bumped version to pre-0.6
256
257* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
258- updated source snapshot 20100410
259
260* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
261- change release to sync with self-build-ffmpeg-vl.spec
262
263* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
264- change release to sync with self-build-ffmpeg-vl.spec
265
266* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
267- updated source snapshot 20100401
268
269* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
270- updated source snapshot 20100326
271
272* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
273- change release to sync with self-build-ffmpeg
274
275* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
276- updated source snapshot 20100216
277  - rebuild with recent x264-devel
278- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
279- added BuildRequires:  libvdpau-devel
280
281* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
282- change release to sync with self-build-ffmpeg
283
284* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
285- change release to sync with self-build-ffmpeg
286
287* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
288- applied ffmpeg-0.5-disable-texi2html.patch
289  - dropped BuildRequires: texi2html
290
291* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
292- change release to sync with self-build-ffmpeg
293
294* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
295- corrected release number
296
297* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
298- new upstream release
299- added BuildRequires:
300  - speex-devel
301  - bzip2-devel
302
303* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
304- 20090227 snapshot
305
306* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
307- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
308
309* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
310- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
311- dropped Requires: a52dec, faad2 in ffmpeg-libs
312
313* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
314- 20090202 snapshot
315
316* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
317- 20090110 snapshot
318- dropped some patches
319
320* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
321- source updated (r15488)
322- fixed License: GPLv2+
323- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
324- added BuildRequires: yasm (only %%ix86)
325- applied ffmpeg-cpu.patch (merged from RPM Fusion)
326
327* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
328- spec in utf8
329
330* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
331- change release to sync with self-build-ffmpeg
332
333* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
334- drop "Patch100: ffmpeg-vine.patch".
335
336* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
337- build with new versioning policy
338- change to use svn export from svn checkout on post install
339- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
340
341* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
342- [self-build-ffmpeg.spec]
343  For all pre-required package that is provied by self-build, 
344  changed to its self-build package
345
346* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
347- initial build for Vine Linux 4.2
348- snapshot 2008/01/28 + some Rev.11662 2008/01/29
349
350### end of file
Note: See TracBrowser for help on using the repository browser.