source: projects/specs/branches/6/nonfree/self-build-audacious-plugins-extra/self-build-audacious-plugins-extra-vl.spec @ 1158

Revision 1158, 5.1 KB checked in by inagaki, 14 years ago (diff)

updated: alien, audacious, audacious-plugins
NEW: libcddb, self-build-audacious-plugins-extra

Line 
1%define pkgname audacious-plugins-extra
2%define name    self-build-%{pkgname}
3%define version 2.3
4%define release 2%{?_dist_release}
5
6%define sourceurl0      http://distfiles.atheme.org/audacious-plugins-%{version}.tgz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPLv2
16Group:          Restricted Software
17
18Requires(post): self-build-setup >= 0.8
19Requires(post): self-build-faad2
20Requires(post): self-build-ffmpeg
21Requires(post): self-build-lame
22Requires(post): self-build-libmad
23
24Requires(post): audacious-devel >= 2.3-1
25Requires(post): glib2-devel >= 2.8.0
26Requires(post): gtk2-devel >= 2.10.0
27Requires(post): pango-devel >= 1.8.0
28Requires(post): mcs-devel
29Requires(post): dbus-devel
30Requires(post): dbus-glib-devel
31Requires(post): libogg-devel >= 1.0
32Requires(post): libvorbis-devel >= 1.0
33Requires(post): flac-devel >= 1.2.0
34
35Requires:       audacious-libs >= 2.3-1
36Requires:       glib2 >= 2.8.0
37Requires:       gtk2 >= 2.10.0
38Requires:       pango >= 1.8.0
39
40BuildArch:      noarch
41BuildRoot:      %{_tmppath}/%{name}-%{version}-root
42
43Obsoletes:      self-build-audacious-mad < %{version}-%{release}
44
45Packager:       inagaki
46
47%description
48This package contains input plugins that enable playback of MP3/TTA/WMA
49files and a output plugins tha enable encode MP3 files in Audacious.
50
51If you install this package, it automaticaly downloads source
52code ,compile it, and create rpm packages of audacious-aac, audacious-ffmpeg,
53audacious-mad and audacious-lame.
54And the created rpm packages are automatically installed
55if installation is executed by apt-get command or synaptic
56package manager.
57
58[Note]
59This package requires many other packages to compile
60targetsoftware. So it consume more disk space than usual.
61Also installation takes logner time because of compilation.
62(This will take a few minutes to quarter or half of an hour,
63depends on building environment)
64
65[About self-build package]
66For some kind of software, distributing of binary package
67may viorate the patent or law. Therefore we chose self-build
68packge, create binary package on your machine, for such kind
69of softwares instead of distributing binary package.
70
71Please obey the national law when you use the created binary
72packages. And if you want to use the softwares using patented
73thechnology, it may be required to get a permission, make an
74agreement or purchas a license. Please consider it with your
75purpose or way of use and take appropriate action.
76
77%description -l ja
78Audacious で MP3 ファイルの再生を可能にするプラグインです。
79
80このパッケージをインストールすると、自動的にソースコードを
81ダウンロードしてコンパイルし、audacious-aac, audacious-ffmpeg,
82audacious-mad および audacious-lame の rpm パッケージを作成します。
83また apt-get コマンドや synaptic パッケージマネージャから実行
84した場合は、作成された rpm パッケージのインストールも自動的に
85行います。
86
87[注意]
88コンパイルに必要な多くの関連パッケージを要求するので通常より
89ディスクの領域を多く消費します。
90またインストール時にコンパイルを行うため、通常より時間がかか
91る場合があります。(環境にもよりますが数分から数十分程度)
92
93[self-build パッケージについて]
94ソフトウェアによってはバイナリパッケージの配布が特許や法律に
95違反する可能性があるものがあります。その為、このような問題が
96懸念されるソフトウェアについてはバイナリパッケージを直接配布
97せずに、ユーザの環境でバイナリを作成する self-build パッケー
98ジという方法を採っています。
99
100作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
101アのライセンス、および利用する国の各種法令に従ってください。
102また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
103センスの購入などが必要となる場合がありますので、利用する目的
104や形態に応じて各自で判断し適切な対応を取ってください。
105
106%prep
107[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
108
109%install
110%{__rm} -rf ${RPM_BUILD_ROOT}
111%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
112%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
113
114%clean
115%{__rm} -rf ${RPM_BUILD_ROOT}
116
117%posttrans
118/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}"
119
120%files
121%defattr(-,root,root)
122%{_datadir}/%{name}
123
124%changelog
125* Sat Jun  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-2
126- added aac, ffaudio, filewriter_mp3 plugins
127- Obsoletes: self-build-audacious-mad < 2.3-1
128
129* Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-1
130- new upstream release
131
132* Thu Aug 13 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-2
133- fixed Requires(post)
134
135* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-1
136- initial bulid
Note: See TracBrowser for help on using the repository browser.