source: projects/specs/branches/6/n/numpy/numpy-vl.spec @ 6364

Revision 6364, 10.2 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild or update packages

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2# eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
3%{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
4
5Name:           numpy
6Summary:        A fast multidimensional array facility for Python
7Version:        1.4.1
8Release:        9%{?_dist_release}
9
10Group:          Development/Languages
11License:        BSD
12URL:            http://numeric.scipy.org/
13
14Source0:        http://downloads.sourceforge.net/numpy/%{name}-%{version}.tar.gz
15Patch0:         numpy-1.0.1-f2py.patch
16Patch1:         numpy_doublefree.patch
17
18# PyOS_ascii_strtod is deprecated in python 2.7, and the deprecation warning
19# outside of the GIL causes python to segfault (rhbz#617384)
20# Patch is a combination of upstream changeset 7926 followed by 8387
21Patch2:         numpy-1.4.1-remove-PyOS_ascii_strtod.patch
22
23## patches from debian
24Patch3:         changeset_r8510.diff
25Patch4:         changeset_r8511.diff
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29#BuildRequires:  python-devel lapack-devel python-setuptools gcc-gfortran atlas-devel python-nose
30BuildRequires:  python-devel lapack-devel python-setuptools gcc-gfortran python-nose
31Requires:       python-nose
32
33%description
34NumPy is a general-purpose array-processing package designed to
35efficiently manipulate large multi-dimensional arrays of arbitrary
36records without sacrificing too much speed for small multi-dimensional
37arrays.  NumPy is built on the Numeric code base and adds features
38introduced by numarray as well as an extended C-API and the ability to
39create arrays of arbitrary type.
40
41There are also basic facilities for discrete fourier transform,
42basic linear algebra and random number generation. Also included in
43this package is a version of f2py that works properly with NumPy.
44
45%package f2py
46Summary:        f2py for numpy
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49Requires:       python-devel
50Provides:       f2py
51Obsoletes:      f2py <= 2.45.241_1927
52
53%description f2py
54This package includes a version of f2py that works properly with NumPy.
55
56%prep
57%setup -q -n %{name}-%{version}
58%patch0 -p1 -b .f2py
59%patch1 -p0
60%patch2 -p1 -b .remove-PyOS_ascii_strtod
61%patch3 -p1 -b .r8510
62%patch4 -p1 -b .r8511
63
64%build
65env FFTW=%{_libdir} BLAS=%{_libdir} \
66    LAPACK=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" \
67    %{__python} setup.py build --fcompiler=gnu95
68
69%install
70rm -rf $RPM_BUILD_ROOT
71#%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
72# skip-build currently broken, this works around it for now
73env ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
74    LAPACK=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" \
75    %{__python} setup.py install --root $RPM_BUILD_ROOT
76rm -rf docs-f2py ; mv $RPM_BUILD_ROOT%{python_sitearch}/%{name}/f2py/docs docs-f2py
77mv -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/f2py/f2py.1 f2py.1
78rm -rf doc ; mv -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/doc .
79install -D -p -m 0644 f2py.1 $RPM_BUILD_ROOT%{_mandir}/man1/f2py.1
80pushd $RPM_BUILD_ROOT%{_bindir} &> /dev/null
81# symlink for anyone who was using f2py.numpy
82ln -s f2py f2py.numpy
83popd &> /dev/null
84
85#symlink for includes, BZ 185079
86mkdir -p $RPM_BUILD_ROOT/usr/include
87ln -s %{python_sitearch}/%{name}/core/include/numpy/ $RPM_BUILD_ROOT/usr/include/numpy
88
89# Remove doc files. They should in in %doc
90rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/COMPATIBILITY
91rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/DEV_README.txt
92rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/INSTALL.txt
93rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/LICENSE.txt
94rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/README.txt
95rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/THANKS.txt
96rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/site.cfg.example
97
98%check
99pushd doc &> /dev/null
100PYTHONPATH="%{buildroot}%{python_sitearch}" %{__python} -c "import pkg_resources, numpy ; numpy.test()" \
101%ifarch s390 s390x
102|| :
103%endif
104# don't remove this comment
105popd &> /dev/null
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files
111%defattr(-,root,root,-)
112%doc docs-f2py doc/* LICENSE.txt README.txt THANKS.txt DEV_README.txt COMPATIBILITY site.cfg.example
113%dir %{python_sitearch}/%{name}
114%{python_sitearch}/%{name}/*.py*
115%{python_sitearch}/%{name}/core
116%{python_sitearch}/%{name}/distutils
117%{python_sitearch}/%{name}/fft
118%{python_sitearch}/%{name}/lib
119%{python_sitearch}/%{name}/linalg
120%{python_sitearch}/%{name}/ma
121%{python_sitearch}/%{name}/numarray
122%{python_sitearch}/%{name}/oldnumeric
123%{python_sitearch}/%{name}/random
124%{python_sitearch}/%{name}/testing
125%{python_sitearch}/%{name}/tests
126%{python_sitearch}/%{name}/compat
127%{python_sitearch}/%{name}/matrixlib
128%{python_sitearch}/%{name}/polynomial
129%{python_sitearch}/%{name}-*.egg-info
130%{_includedir}/numpy
131
132%files f2py
133%defattr(-,root,root,-)
134%{_mandir}/man*/*
135%{_bindir}/f2py
136%{_bindir}/f2py.numpy
137%{python_sitearch}/%{name}/f2py
138
139
140%changelog
141* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-9
142- rebuild with Vine6 environment
143
144* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-8
145- add Patch3(changeset_r8510.diff) and Patch4(changeset_r8511.diff) from debian
146
147* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.1-7
148- Initial build for Vine Linux
149
150* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-6
151- actually add the patch this time
152
153* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-5
154- fix segfault within %check on 2.7 (patch 2)
155
156* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-4
157- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
158
159* Sun Jul 18 2010 Dan Horák <dan[at]danny.cz> 1.4.1-3
160- ignore the "Ticket #1299 second test" failure on s390(x)
161
162* Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-2
163- source commit fix
164
165* Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-1
166- New upstream release. Include backported doublefree patch
167
168* Mon Apr 26 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-8
169- Moved distutils back to the main package, BZ 572820.
170
171* Thu Apr 08 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-7
172- Reverted to 1.3.0 after upstream pulled 1.4.0, BZ 579065.
173
174* Tue Mar 02 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-5
175- Linking /usr/include/numpy to .h files, BZ 185079.
176
177* Tue Feb 16 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-4
178- Re-enabling atlas BR, dropping lapack Requires.
179
180* Wed Feb 10 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-3
181- Since the previous didn't work, Requiring lapack.
182
183* Tue Feb 09 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-2
184- Temporarily dropping atlas BR to work around 562577.
185
186* Fri Jan 22 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-1
187- 1.4.0.
188- Dropped ARM patch, ARM support added upstream.
189
190* Tue Nov 17 2009 Jitesh Shah <jiteshs@marvell.com> - 1.3.0-6.fa1
191- Add ARM support
192
193* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-6
194- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
195
196* Thu Jun 11 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-5
197- Fixed atlas BR, BZ 505376.
198
199* Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-4
200- EVR bump for pygame chainbuild.
201
202* Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-3
203- Moved linalg, fft back to main package.
204
205* Tue Apr 14 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-2
206- Split out f2py into subpackage, thanks Peter Robinson pbrobinson@gmail.com.
207
208* Tue Apr 07 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-1
209- Update to latest upstream.
210- Fixed Source0 URL.
211
212* Thu Apr 02 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-0.rc1
213- Update to latest upstream.
214
215* Thu Mar 05 2009 Jon Ciesla <limb@jcomserv.net> 1.2.1-3
216- Require python-devel, BZ 488464.
217
218* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
220
221* Fri Dec 19 2008 Jon Ciesla <limb@jcomserv.net> 1.2.1-1
222- Update to 1.2.1.
223
224* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-2
225- Rebuild for Python 2.6
226
227* Tue Oct 07 2008 Jon Ciesla <limb@jcomserv.net> 1.2.0-1
228- New upstream release, added python-nose BR. BZ 465999.
229- Using atlas blas, not blas-devel. BZ 461472.
230
231* Wed Aug 06 2008 Jon Ciesla <limb@jcomserv.net> 1.1.1-1
232- New upstream release
233
234* Thu May 29 2008 Jarod Wilson <jwilson@redhat.com> 1.1.0-1
235- New upstream release
236
237* Tue May 06 2008 Jarod Wilson <jwilson@redhat.com> 1.0.4-1
238- New upstream release
239
240* Mon Feb 11 2008 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-2
241- Add python egg to %%files on f9+
242
243* Wed Aug 22 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-1
244- New upstream release
245
246* Wed Jun 06 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3-1
247- New upstream release
248
249* Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-2
250- Drop BR: atlas-devel, since it just provides binary-compat
251  blas and lapack libs. Atlas can still be optionally used
252  at runtime. (Note: this is all per the atlas maintainer).
253
254* Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-1
255- New upstream release
256
257* Tue Apr 17 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-4
258- Update gfortran patch to recognize latest gfortran f95 support
259- Resolves rhbz#236444
260
261* Fri Feb 23 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-3
262- Fix up cpuinfo bug (#229753). Upstream bug/change:
263  http://projects.scipy.org/scipy/scipy/ticket/349
264
265* Thu Jan 04 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-2
266- Per discussion w/Jose Matos, Obsolete/Provide f2py, as the
267  stand-alone one is no longer supported/maintained upstream
268
269* Wed Dec 13 2006 Jarod Wilson <jwilson@redhat.com> 1.0.1-1
270- New upstream release
271
272* Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.0-2
273- Rebuild for python 2.5
274
275* Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.0-1
276- New upstream release
277
278* Tue Sep 06 2006 Jarod Wilson <jwilson@redhat.com> 0.9.8-1
279- New upstream release
280
281* Wed Apr 26 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.6-1
282- Upstream update
283
284* Thu Feb 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.5-1
285- Upstream update
286
287* Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-2
288- Rebuild for Fedora Extras 5
289
290* Thu Feb  2 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-1
291- Initial RPM release
292- Added gfortran patch from Neal Becker
Note: See TracBrowser for help on using the repository browser.