source: projects/specs/branches/6/n/ntp/ntp-vl.spec @ 9352

Revision 9352, 12.6 KB checked in by iwamoto, 9 years ago (diff)

ntp: CVE-2014-9297,98

Line 
1%define _bindir %{_prefix}/sbin
2
3Summary: Synchronizes system time using the Network Time Protocol (NTP).
4Name: ntp
5Version: 4.2.6p3
6Release: 5%{?_dist_release}
7License: distributable
8Group: System Environment/Daemons
9URL: http://www.ntp.org/
10Source0: ftp://ftp.udel.edu/pub/ntp/ntp4/ntp-%{version}.tar.gz
11Source1: ntp.conf
12Source2: ntp.keys
13Source3: ntpd.init
14Source4: ntpd.sysconfig
15Source5: ntpstat-0.2.tgz
16
17Source100: ntpd-NM-dispatch
18Source999: filter-requires-ntp.sh
19
20# ntpbz #802
21Patch1: ntp-4.2.6p1-sleep.patch
22# add support for dropping root to ntpdate
23Patch2: ntp-4.2.6p1-droproot.patch
24# ntpbz #779
25Patch3: ntp-4.2.6p3-bcast.patch
26# align buffer for control messages
27Patch4: ntp-4.2.6p1-cmsgalign.patch
28# link ntpd with -ffast-math on ia64
29# Patch5: ntp-4.2.6p1-linkfastmath.patch
30# ntpbz #1134
31Patch6: ntp-4.2.6p3-tentative.patch
32# ntpbz #759
33Patch7: ntp-4.2.6p1-retcode.patch
34# ntpbz #992
35Patch8: ntp-4.2.6p3-rtnetlink.patch
36# fix script used to generate man pages
37Patch9: ntp-4.2.6p2-html2man.patch
38# ntpbz #898
39Patch10: ntp-4.2.6p2-htmldoc.patch
40# fix precision calculation on fast CPUs
41Patch12: ntp-4.2.4p7-getprecision.patch
42# ntpbz #1408
43Patch13: ntp-4.2.6p1-logdefault.patch
44# add option -m to lock memory
45Patch14: ntp-4.2.6p3-mlock.patch
46# allow -u and -p options to be used twice (#639101)
47Patch15: ntp-4.2.6p2-multiopts.patch
48# ntpbz #1554
49Patch16: ntp-4.2.6p3-nosyspeer.patch
50# ntpbz #1670
51Patch17: ntp-4.2.6p3-broadcastdelay.patch
52# ntpbz #1671
53Patch18: ntp-4.2.6p3-delaycalib.patch
54# ntpbz #1695
55Patch19: ntp-4.2.6p3-ntpdaterecv.patch
56
57# handle unknown clock types
58Patch50: ntpstat-0.2-clksrc.patch
59# process first packet in multipacket response
60Patch51: ntpstat-0.2-multipacket.patch
61# use current system variable names
62Patch52: ntpstat-0.2-sysvars.patch
63# print synchronization distance instead of dispersion
64Patch53: ntpstat-0.2-maxerror.patch
65
66# workaround fix for glibc headers
67Patch60: ntp-4.2.x_MOD_NANO.patch
68
69# security
70# Patch100: ntp-4.2.4_CVE-2009-0159.patch
71Patch100: ntp-4.2.6p5-cve-2014-9293.patch
72Patch110: ntp-4.2.6p5-cve-2014-9294.patch
73Patch120: ntp-4.2.6p3_CVE-2014-9295.patch
74Patch130: ntp-4.2.6p3_CVE-2014-9296.patch
75Patch140: ntp-4.2.6p3-CVE-2014-9297.patch
76Patch150: ntp-4.2.6p5-CVE-2014-9298.patch
77
78Requires(pre): /sbin/chkconfig
79# PreReq: /sbin/chkconfig
80BuildRequires: openssl-devel, readline-devel
81BuildRequires: libcap-devel
82BuildRequires: autoconf
83# ntpstat
84BuildRequires: perl-HTML-Parser
85#Conflicts: xntp3
86Obsoletes: xntp3
87BuildRoot: %{_tmppath}/%{name}-%{version}-root
88
89Packager: iwamoto
90Vendor: Project Vine
91Distribution: Vine Linux
92
93# Working around perl dependency problem
94%define __find_requires %{SOURCE999}
95
96%description
97The Network Time Protocol (NTP) is used to synchronize a computer's
98time with another reference time source.  The ntp package contains
99utilities and daemons which will synchronize your computer's time to
100Coordinated Universal Time (UTC) via the NTP protocol and NTP servers.
101The ntp package includes ntpdate (a program for retrieving the date
102and time from remote machines via a network) and ntpd (a daemon which
103continuously adjusts system time).
104
105Install the ntp package if you need tools for keeping your system's
106time synchronized via the NTP protocol.
107#'
108
109%package perl
110Summary: NTP utilities written in perl
111Group: Applications/System
112Requires: %{name} = %{version}-%{release}
113
114%description perl
115This package contains perl scripts ntp-wait and ntptrace.
116
117%prep
118%setup -q -a 5
119
120%patch1 -p1 -b .sleep
121%patch2 -p1 -b .droproot
122%patch3 -p1 -b .bcast
123%patch4 -p1 -b .cmsgalign
124%ifarch ia64
125# %patch5 -p1 -b .linkfastmath
126%endif
127%patch6 -p1 -b .tentative
128%patch7 -p1 -b .retcode
129%patch8 -p1 -b .rtnetlink
130%patch9 -p1 -b .html2man
131%patch10 -p1 -b .htmldoc
132%patch12 -p1 -b .getprecision
133%patch13 -p1 -b .logdefault
134%patch14 -p1 -b .mlock
135%patch15 -p1 -b .multiopts
136%patch16 -p1 -b .nosyspeer
137%patch17 -p1 -b .broadcastdelay
138%patch18 -p1 -b .delaycalib
139%patch19 -p1 -b .ntpdaterecv
140
141# set default path to sntp KoD database
142sed -i 's|/var/db/ntp-kod|%{_localstatedir}/lib/ntp/sntp-kod|' sntp/{sntp.1,main.c}
143
144# ntpstat patches
145%patch50 -p1 -b .clksrc
146%patch51 -p1 -b .multipacket
147%patch52 -p1 -b .sysvars
148%patch53 -p1 -b .maxerror
149
150%patch60 -p0 -b .NANO
151
152# security
153# %patch100 -p1 -b .CVE-2009-0159
154%patch100 -p1 -b .cve-2014-9293
155%patch110 -p1 -b .cve-2014-9294
156%patch120 -p1 -b .CVE-2014-9295
157%patch130 -p1 -b .CVE-2014-9296
158%patch140 -p1 -b .CVE-2014-9297
159%patch150 -p1 -b .CVE-2014-9298
160
161%build
162# autoconf
163autoreconf -vfi
164
165# XXX work around for anal ntp configure
166# %define       _target_platform        %{nil}
167# %configure
168# CFLAGS="-g -DDEBUG" ./configure --prefix=/usr
169
170CFLAGS="-g" ./configure         \
171             --prefix=/usr      \
172             --with-openssl-libdir=%{_libdir} \
173             --with-lineeditlibs=readline
174
175%undefine       _target_platform
176
177%__make %{?_smp_mflags}
178%__make %{?_smp_mflags} -C ntpstat-0.2 CFLAGS="$CFLAGS"
179
180pushd html
181../scripts/html2man
182# remove adjacent blank lines
183sed -i 's/^[\t\ ]*$//;/./,/^$/!d' man/man*/*.[58]
184popd
185
186%install
187rm -rf $RPM_BUILD_ROOT
188
189%makeinstall
190
191{ pushd $RPM_BUILD_ROOT
192
193  mkdir -p .%{_sysconfdir}/{ntp,rc.d/init.d,sysconfig}
194  mkdir -p .%{_sysconfdir}/NetworkManager/dispatcher.d
195  install -m644 $RPM_SOURCE_DIR/ntp.conf .%{_sysconfdir}/ntp.conf
196  touch .%{_sysconfdir}/ntp/drift
197  install -m600 $RPM_SOURCE_DIR/ntp.keys .%{_sysconfdir}/ntp/keys
198  touch .%{_sysconfdir}/ntp/step-tickers
199  install -m755 $RPM_SOURCE_DIR/ntpd.init .%{_sysconfdir}/rc.d/init.d/ntpd
200  install -m644 %{SOURCE4} .%{_sysconfdir}/sysconfig/ntpd
201  install -m755 %{SOURCE100} .%{_sysconfdir}/NetworkManager/dispatcher.d/06-ntpd
202
203  strip .%{_bindir}/* || :
204  popd
205}
206
207mkdir -p $RPM_BUILD_ROOT%{_mandir}/man8
208pushd html/man/man8
209install -m 644 ntp-wait.8 $RPM_BUILD_ROOT%{_mandir}/man8/
210install -m 644 ntptrace.8 $RPM_BUILD_ROOT%{_mandir}/man8/
211popd
212
213pushd ntpstat-0.2
214mkdir -p $RPM_BUILD_ROOT%{_bindir}
215install -m 755 ntpstat $RPM_BUILD_ROOT%{_bindir}
216install -m 644 ntpstat.1 $RPM_BUILD_ROOT%{_mandir}/man8/ntpstat.8
217popd
218
219%clean
220rm -rf $RPM_BUILD_ROOT
221
222%post
223/sbin/chkconfig --add ntpd
224
225%preun
226if [ $1 = 0 ]; then
227    service ntpd stop > /dev/null 2>&1
228    /sbin/chkconfig --del ntpd
229fi
230
231%postun
232if [ "$1" -ge "1" ]; then
233# service ntpd condrestart > /dev/null 2>&1
234  service ntpd condrestart
235fi
236
237%files
238%defattr(-,root,root)
239%doc html/* NEWS TODO
240
241%{_sbindir}/ntp-keygen
242%{_sbindir}/ntpd
243%{_sbindir}/ntpdate
244%{_sbindir}/ntpdc
245%{_sbindir}/ntpq
246%{_sbindir}/ntpstat
247%{_sbindir}/ntptime
248%{_sbindir}/sntp
249%{_sbindir}/tickadj
250
251%config                         %{_sysconfdir}/rc.d/init.d/ntpd
252# %config(noreplace)            %{_sysconfdir}/ntp.conf
253%config                         %{_sysconfdir}/ntp.conf
254%dir                            %{_sysconfdir}/ntp/
255%ghost %config(missingok)       %{_sysconfdir}/ntp/drift
256%config(noreplace)              %{_sysconfdir}/ntp/keys
257%ghost %config(missingok)       %{_sysconfdir}/ntp/step-tickers
258%config(noreplace)              %{_sysconfdir}/sysconfig/ntpd
259%{_sysconfdir}/NetworkManager/dispatcher.d/*
260%{_mandir}/man1/*
261%{_mandir}/man8/ntpstat*
262
263%files perl
264%defattr(-,root,root)
265%{_sbindir}/ntp-wait
266%{_sbindir}/ntptrace
267%{_mandir}/man8/ntp-wait.8*
268%{_mandir}/man8/ntptrace.8*
269
270%changelog
271* Mon Feb  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.6p3-5
272- add patch140 for fix CVE-2014-9297 (length value in extension fields)
273- add patch150 for fix CVE-2014-9298 (bypass ACLs based on IPv6)
274  these patches based from debian wheezy, thanks.
275
276* Sun Dec 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.6p3-4
277- add Patch100-130 for fix CVE-2014-9293,4,5,6
278  these patches are from rhel6, thanks.
279
280* Sat Dec 13 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.6p3-3
281- update default ntp.conf
282- remove "noreplace" of ntp.conf in files section
283- fix Vendor/Distri tags...
284
285* Sun Jan 16 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.6p3-2
286- add config options to use openssl libs, readline libs
287- add BR: libcap-devel, perl-HTML-Parser (Thanks to Take-san)
288
289* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.6p3-1
290- new upstream release
291- built with openssl 1.0.0c
292- perl scripts are saparated to -perl package
293
294* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p8-1
295- new upstream release with security fix (CVE-2009-3563)
296
297* Fri Aug 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p7-3
298- add NetworkManager/dispatcher.d/06-ntpd for NM
299- fix changelog typo...
300
301* Wed May 20 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p7-2
302- turn on daemon restart message
303
304* Wed May 20 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p7-1
305- new upstream release with security fix (CVE-2009-0159,1252)
306- drop pacth100 (included in new release)
307- update patch5 to fit p7 release
308
309* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p6-2
310- add patch100 for fix CVE-2009-0159 (ntpq)
311- run autoreconf instead of autoconf
312
313* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p6-1
314- new upstream release with security fix (CVE-2009-0021)
315
316* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4p4-1
317- new upstream release
318
319* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4p3-0vl2
320- rebuilt
321
322* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4p3-0vl1
323- new upstream release
324- updated Patch5
325
326* Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.0-0vl7
327- rebuild for Vine Seed
328
329* Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.0-0vl6
330- add Patch5 to skip checking md5.h
331
332* Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.0-0vl5
333- rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
334
335* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.2.0-0vl4
336- rebuild with readline-5.1
337- add BuildRequires: openssl-devel, readline-devel
338
339* Fri Apr 09 2004 Tomoya TAKA <taka@vinelinux.org> 4.2.0-0vl3
340- rebuild with openssl-0.9.7d
341- add config_crypto.patch for alpha (Patch4)
342
343* Wed Mar  3 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 4.2.0-0vl2
344- ntp.conf (Source1): authenticate command has been disappeared.
345- ntpd.init (Source3): remove RedHat's firewall-related codes.
346- remove obsolete patches (Patch0, Patch1)
347
348* Mon Feb 16 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
349- update to 4.2.0
350- update ntpd.init (Source3): from Fedora ntp-4.2.0-5
351- add ntpd.sysconfig (Source4)
352- stop patching vsnprintf patch (Patch1)
353
354* Mon Sep  1 2003 IWAI, Masaharu <iwai@alib.jp> 4.1.2-0vl1
355- update to 4.1.2
356- update URL tag
357- update vsnprintf.patch (Patch1)
358
359* Tue May 06 2003 Tomoya TAKA <taka@vinelinux.org> 4.1.1-0vl2
360- rebuild with new toolchain
361
362* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 4.1.1-0vl1
363- update to 4.1.1
364
365* Tue Sep 04 2001 Jiro Yamada <jiro@fd.catv.ne.jp>
366- update to 4.1.0
367
368* Mon Apr 09 2001 akira yamada <akira@vinelinux.org>
369- new upstream version 4.0.99k23.
370
371* Thu Apr 05 2001 akira yamada <akira@vinelinux.org>
372- fixed buffer overrun (imported from debian).
373- imported from rawhide.
374
375* Mon Mar  5 2001 Preston Brown <pbrown@redhat.com>
376- allow comments in /etc/ntp/step-tickers file (#28786).
377- need patch0 (glibc patch) on ia64 too
378
379* Tue Feb 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
380- also set prog=ntpd in initscript
381
382* Tue Feb 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
383- use "$prog" instead of "$0" for the init script
384
385* Thu Feb  8 2001 Preston Brown <pbrown@redhat.com>
386- i18n-neutral .init script (#26525)
387
388* Tue Feb  6 2001 Preston Brown <pbrown@redhat.com>
389- use gethostbyname on addresses in /etc/ntp.conf for ntptime command (#26250)
390
391* Mon Feb  5 2001 Preston Brown <pbrown@redhat.com>
392- start earlier and stop later (#23530)
393
394* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
395- i18nize init script (#26078)
396
397* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
398- typo in ntp.conf (#23173).
399
400* Mon Dec 11 2000 Karsten Hopp <karsten@redhat.de>
401- rebuilt to fix permissions of /usr/share/doc/ntp-xxx
402
403* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
404- correct mis-spellings in ntpq.htm (#20007).
405
406* Thu Oct 19 2000 Jeff Johnson <jbj@redhat.com>
407- add %ghost /etc/ntp/drift (#15222).
408
409* Wed Oct 18 2000 Jeff Johnson <jbj@redhat.com>
410- comment out default values for keys, warn about starting with -A (#19316).
411- take out -A from ntpd startup as well.
412- update to 4.0.99k.
413
414* Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
415- use vsnprintf rather than vsprintf (#16676).
416
417* Mon Aug 14 2000 Jeff Johnson <jbj@redhat.com>
418- remove Conflicts: so that the installer is happy.
419
420* Tue Jul 25 2000 Jeff Johnson <jbj@redhat.com>
421- workaround glibc-2.1.90 lossage for now.
422
423* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
424- move initscript back
425
426* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
427- automatic rebuild
428
429* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
430- move and update init script, update post/preun/postun scripts
431
432* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
433- noreplace ntp.conf,keys files
434
435* Mon Jun 12 2000 Jeff Johnson <jbj@redhat.com>
436- Create 4.0.99j package.
437- FHS packaging.
Note: See TracBrowser for help on using the repository browser.