source: projects/specs/branches/6/n/ntfs-3g/ntfs-3g-vl.spec @ 10691

Revision 10691, 8.7 KB checked in by tomop, 8 years ago (diff)

ntfs-3g-2016.2.22-1

Line 
1%bcond_with externalfuse
2
3Summary:        Linux NTFS userspace driver
4Summary(ja):    Linux NTFS ユーザ空間ドライバ
5Name:           ntfs-3g
6
7Version:        2016.2.22
8Release:        1%{?_dist_release}
9
10License:        GPLv2+
11Group:          System Environment/Base
12URL:            http://www.ntfs-3g.org/
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        http://tuxera.com/opensource/%{name}_ntfsprogs-%{version}.tgz
18Source1:        20-ntfs-config-write-policy.fdi
19Patch0:         ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
22
23BuildRequires:  libtool
24BuildRequires:  libattr-devel
25%if %{?_dist_release} != "vl6"
26BuildRequires:  libconfig-devel
27%endif
28BuildRequires:  libgcrypt-devel
29BuildRequires:  gnutls-devel
30BuildRequires:  libuuid-devel
31%if %{with externalfuse}
32BuildRequires:  fuse-devel
33Requires:       fuse
34%endif
35
36%description
37NTFS-3G is a stable, open source, GPL licensed, POSIX, read/write NTFS
38driver for Linux and many other operating systems. It provides safe
39handling of the Windows XP, Windows Server 2003, Windows 2000, Windows
40Vista, Windows Server 2008 and Windows 7 NTFS file systems. NTFS-3G can
41create, remove, rename, move files, directories, hard links, and streams;
42it can read and write normal and transparently compressed files, including
43streams and sparse files; it can handle special files like symbolic links,
44devices, and FIFOs, ACL, extended attributes; moreover it provides full
45file access right and ownership support.
46
47%package devel
48Summary:        Development files and libraries for ntfs-3g
49Summary(ja):    ntfs-3g の開発ファイルとライブラリ
50Group:          Development/Libraries
51Requires:       %{name} = %{version}-%{release}
52Requires:       pkgconfig
53Provides:       ntfsprogs-devel = %{version}-%{release}
54Obsoletes:      ntfsprogs-devel < 2.0.0-3
55
56%description devel
57Headers and libraries for developing applications that use ntfs-3g
58functionality.
59
60%package -n ntfsprogs
61Summary:        NTFS filesystem libraries and utilities
62Summary(ja):    NTFS ファイルシステム用ライブラリおよびユーティリティ
63Group:          System Environment/Base
64Provides:       ntfsprogs-gnomevfs = %{version}-%{release}
65Obsoletes:      ntfsprogs-gnomevfs < 2.0.0-3
66
67%description -n ntfsprogs
68The ntfsprogs package currently consists of a library and utilities
69such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
70(for a full list of included utilities see man 8 ntfsprogs after
71installation).
72
73
74%prep
75%setup -q -n %{name}_ntfsprogs-%{version}
76%patch0 -p1 -b .unsupported
77
78%build
79%configure --disable-static \
80           --disable-ldconfig \
81%{?with_ externalfuse:--with-fuse=external} \
82           --exec-prefix=/ \
83           --bindir=/bin \
84           --sbindir=/sbin \
85           --libdir=/%{_lib} \
86           --enable-crypto \
87           --enable-extras \
88           --enable-quarantined
89
90make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
91
92%install
93rm -rf $RPM_BUILD_ROOT
94make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
95
96rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
97rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.{la,a}
98
99mkdir -p $RPM_BUILD_ROOT/sbin
100
101# make the symlink an actual copy to avoid confusion
102rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
103cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
104
105# make compatibility symlinks
106ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
107ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
108ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
109ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
110mkdir -p $RPM_BUILD_ROOT%{_bindir}
111ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
112ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
113
114# Put the .pc file in the right place.
115mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
116mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
117
118%if %{?_dist_release} == "vl6"
119mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
120cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
121%endif
122
123# We get this on our own, thanks.
124rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%files
134%defattr(-,root,root,-)
135%doc AUTHORS ChangeLog COPYING CREDITS NEWS README
136/sbin/mount.ntfs
137%attr(4754,root,root) /sbin/mount.ntfs-3g
138/sbin/mount.ntfs-fuse
139/sbin/mount.lowntfs-3g
140/bin/lowntfs-3g
141/bin/ntfs-3g
142/bin/ntfs-3g.probe
143/bin/ntfs-3g.secaudit
144/bin/ntfs-3g.usermap
145/bin/ntfsmount
146%{_bindir}/ntfs-3g
147%{_bindir}/ntfsmount
148/%{_lib}/libntfs-3g.so.*
149%{_mandir}/man8/mount.lowntfs-3g.*
150%{_mandir}/man8/mount.ntfs-3g.*
151%{_mandir}/man8/ntfs-3g*
152%if %{?_dist_release} == "vl6"
153%{_datadir}/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi
154%endif
155
156%files devel
157%defattr(-,root,root,-)
158%{_includedir}/ntfs-3g/
159/%{_lib}/libntfs-3g.so
160%{_libdir}/pkgconfig/*.pc
161
162%files -n ntfsprogs
163%doc AUTHORS COPYING CREDITS ChangeLog NEWS README
164/bin/ntfscat
165/bin/ntfscluster
166/bin/ntfscmp
167/bin/ntfsfix
168/bin/ntfsinfo
169/bin/ntfsls
170# extras
171/bin/ntfsck
172/bin/ntfsdecrypt
173/bin/ntfsdump_logfile
174/bin/ntfsfallocate
175/bin/ntfsmftalloc
176/bin/ntfsmove
177/bin/ntfsrecover
178/bin/ntfstruncate
179/bin/ntfswipe
180/sbin/fsck.ntfs
181/sbin/mkfs.ntfs
182/sbin/mkntfs
183/sbin/ntfsclone
184/sbin/ntfscp
185/sbin/ntfslabel
186/sbin/ntfsresize
187/sbin/ntfsundelete
188%{_mandir}/man8/mkntfs.8*
189%{_mandir}/man8/mkfs.ntfs.8*
190%{_mandir}/man8/ntfs[^m][^o]*.8*
191%exclude %{_mandir}/man8/ntfs-3g*
192
193%changelog
194* Mon Jul 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016.2.22-1
195- new upstream release.
196
197* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015.3.14-3
198- rebuilt with gnutls-3.4.x.
199
200* Fri May  8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-2
201- reverted file location <Vine Linux:2914>
202
203* Fri Apr 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-1
204- new upstream release
205- dropt hal files, since hal is very old
206
207* Sun Mar 02 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2014.2.15-1
208- new upstream release
209
210* Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2013.1.13-2
211- rebuilt with gnutls-3.2 and libgcrypt-1.6
212
213* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
214- new upstream release
215
216* Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
217- new upstream release
218- merge ntfsprogs
219  - add Obsoletes and Provides ntfsprogs*
220  - add BR: for ntfsprogs
221
222* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
223- new upstream release
224- fix %%files (add lowntfs-3g)
225
226* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
227- new upstream release
228- use internal fuse-lite, remove BR: fuse-devel and R: fuse
229- move binaries to /bin
230- move libraries to /%%{_lib}
231- add fdi file to enable hal automounting
232
233* Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
234- new upstream release
235
236* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
237- new upstream release
238
239* Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
240- new upstream release
241
242* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
243- new upstream release
244
245* Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
246- initial build for Vine Linux
247
248* Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
249- bump to 1.516
250- fix bugzilla 232031
251
252* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
253- bump to 1.417
254
255* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
256- bump to 1.416
257- drop patch0, upstreamed
258
259* Wed Apr  4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
260- allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
261
262* Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
263- bump to 1.328
264- drop patch, use --disable-ldconfig instead
265
266* Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
267- 1.0 release!
268
269* Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
270- symlink to mount.ntfs
271
272* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
273- bump to 20070118
274
275* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
276- bump to latest version for all active dists
277
278* Wed Jan  3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
279- bump to latest version (note that upstream fixed their date mistake)
280
281* Wed Nov  1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
282- add an obsoletes for ntfsprogs-fuse
283- make some convenience symlinks
284
285* Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
286- add some extra Provides
287
288* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
289- add explicit Requires on fuse
290
291* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
292- fixed versioning (bumped epoch, since it now shows as older)
293- change sbin symlink to actual copy to be safe
294
295* Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
296- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.