source: projects/specs/branches/6/n/nss/nss-vl.spec @ 10686

Revision 10686, 27.6 KB checked in by tomop, 8 years ago (diff)

nss-3.21.1-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define _unpackaged_files_terminate_build 1
4
5%define nspr_version 4.11
6%define unsupported_tools_directory %{_libdir}/nss/unsupported-tools
7
8# Produce .chk files for the final stripped binaries
9#
10# NOTE: The LD_LIBRARY_PATH line guarantees shlibsign links
11# against the freebl that we just built. This is necessary
12# because the signing algorithm changed on 3.14 to DSA2 with SHA256
13# whereas we previously signed with DSA and SHA1. We must Keep this line
14# until all mock platforms have been updated.
15# After %%{__os_install_post} we would add
16# export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%%{_libdir}
17%define __spec_install_post \
18    %{?__debug_package:%{__debug_install_post}} \
19    %{__arch_install_post} \
20    %{__os_install_post} \
21    $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libsoftokn3.so \
22    $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libfreebl3.so \
23    $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libnssdbm3.so \
24%{nil}
25
26
27Summary:          Network Security Services
28Name:             nss
29Version:          3.21.1
30Release:          3%{?_dist_release}
31License:          MPLv1.1 or GPLv2+ or LGPLv2+
32URL:              http://www.mozilla.org/projects/security/pki/nss/
33Group:            System Environment/Libraries
34Vendor:           Project Vine
35Distribution:     Vine Linux
36
37Source0:          %{name}-%{version}.tar.gz
38Source1:          nss.pc.in
39Source2:          nss-config.in
40Source3:          blank-cert8.db
41Source4:          blank-key3.db
42Source5:          blank-secmod.db
43Source6:          blank-cert9.db
44Source7:          blank-key4.db
45Source8:          system-pkcs11.txt
46Source12:         %{name}-pem-20140125.tar.bz2
47Source101:        nss-util.pc.in
48Source102:        nss-util-config.in
49Source103:        nss-softokn.pc.in
50Source104:        nss-softokn-config.in
51
52Patch2:           add-relro-linker-option.patch
53Patch3:           renegotiate-transitional.patch
54Patch6:           nss-enable-pem.patch
55Patch16:          nss-539183.patch
56Patch18:          nss-646045.patch
57# TODO: Remove this patch when the ocsp test are fixed
58Patch40:          nss-3.14.0.0-disble-ocsp-test.patch
59Patch50:          iquote.patch
60# As of nss-3.21 we compile NSS with -Werror.
61# see https://bugzilla.mozilla.org/show_bug.cgi?id=1182667
62# This requires a cleanup of the PEM module as we have it here.
63# TODO: submit a patch to the interim nss-pem upstream project
64# The submission will be very different from this patch as
65# cleanup there is already in progress there.
66Patch51:          pem-compile-with-Werror.patch
67Patch52:          Bug-1001841-disable-sslv2-libssl.patch
68Patch53:          Bug-1001841-disable-sslv2-tests.patch
69Patch54:          sslauth-no-v2.patch
70Patch55:          enable-fips-when-system-is-in-fips-mode.patch
71# rhbz: https://bugzilla.redhat.com/show_bug.cgi?id=1026677
72Patch56:          p-ignore-setpolicy.patch
73# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=943144
74Patch62: nss-fix-deadlock-squash.patch
75# Two patches from from rhel6.8 that are also needed for rhel-7
76# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1054373
77Patch74: race.patch
78Patch94: nss-3.16-token-init-race.patch
79Patch99: ssl-server-min-key-sizes.patch
80Patch100: fix-min-library-version-in-SSLVersionRange.patch
81# Add support for sha384 tls cipher suites, dss cipher suites, and
82# server-side dhe key exchange
83# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=102794
84# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
85# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
86Patch101: dhe-sha384-dss-support.patch
87# TODO: From upstream review: For the client authentication case, should
88# probably drop our hack of swapping between sha256 and sha384 and plan
89# on implementing the fix we already have a patch for. What is that fix?
90Patch102: client_auth_for_sha384_prf_support.patch
91Patch103: nss-fix-client-auth-init-hashes.patch
92Patch104: nss-map-oid-to-hashalg.patch
93Patch105: nss-remove-bogus-assert.patch
94Patch106: nss-old-pkcs11-num.patch
95Patch107: nss-enable-384-cipher-tests.patch
96Patch108: nss-sni-c-v-fix.patch
97Patch109: nss-fix-signature-and-hash.patch
98Patch110: nss-sslstress-txt-ssl3-lower-value-in-range.patch
99
100# Enable by default two additional ciphers and fix order of two tables
101# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
102# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
103# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1211403
104Patch112: rh1238290.patch
105# Local: keep as long nss-softokn lacks support
106Patch113: disable-extended-master-secret-with-old-softoken.patch
107# extra tests needed
108Patch114: tests-extra.patch
109Patch115: nss-prevent-abi-issue.patch
110Patch116: nss-tests-prevent-abi-issue.patch
111Patch117: fix-nss-test-filtering.patch
112Patch118: fix-allowed-sig-alg.patch
113Patch119: nss-ssl-ssl3con-delete-duplicates.patch
114
115# Local patches
116Patch1002: hasht-dont-include-prtypes.patch
117Patch1007: pkcs1sig-include-prtypes.patch
118# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
119# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
120Patch1008: nss-util-3.19.1-tls12-mechanisms.patch
121
122
123
124BuildRoot:        %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
125BuildRequires:    nspr-devel >= %{nspr_version}
126BuildRequires:    sqlite3-devel
127BuildRequires:    zlib-devel
128BuildRequires:    pkgconfig
129BuildRequires:    gawk
130BuildRequires:    psmisc
131BuildRequires:    perl
132Provides:         mozilla-nss
133Obsoletes:        mozilla-nss
134Requires:         nspr >= %{nspr_version}
135
136%description
137Network Security Services (NSS) is a set of libraries designed to
138support cross-platform development of security-enabled client and
139server applications. Applications built with NSS can support SSL v2
140and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
141v3 certificates, and other security standards.
142
143
144%package tools
145Summary:          Tools for the Network Security Services
146Group:            System Environment/Base
147Requires:         nss = %{version}-%{release}
148
149%description tools
150Network Security Services (NSS) is a set of libraries designed to
151support cross-platform development of security-enabled client and
152server applications. Applications built with NSS can support SSL v2
153and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
154v3 certificates, and other security standards.
155
156Install the nss-tools package if you need command-line tools to
157manipulate the NSS certificate and key database.
158
159
160%package devel
161Summary:          Development libraries for Network Security Services
162Group:            Development/Libraries
163Requires:         nss = %{version}-%{release}
164Requires:         nspr-devel >= %{nspr_version}
165Provides:         mozilla-nss-devel
166Obsoletes:        mozilla-nss-devel
167
168%description devel
169Header and Library files for doing development with Network Security Services.
170
171
172%package pkcs11-devel
173Summary:          Development libraries for PKCS #11 (Cryptoki) using NSS
174Group:            Development/Libraries
175Requires:         nss-devel = %{version}-%{release}
176
177%description pkcs11-devel
178Library files for developing PKCS #11 modules using basic NSS
179low level services.
180
181
182## to build compat32 for x86_64 architecture support
183%package -n compat32-%{name}
184Summary:          Network Security Services
185Group: System Environment/Libraries
186
187%description -n compat32-%{name}
188Network Security Services (NSS) is a set of libraries designed to
189support cross-platform development of security-enabled client and
190server applications. Applications built with NSS can support SSL v2
191and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
192v3 certificates, and other security standards.
193
194
195%prep
196%setup -q
197%setup -q -T -D -n %{name}-%{version} -a 12
198
199%patch2 -p0 -b .relro
200%patch3 -p0 -b .transitional
201%patch6 -p0 -b .libpem
202%patch16 -p0 -b .539183
203pushd nss
204%patch18 -p1 -b .646045
205popd
206%patch40 -p0 -b .noocsptest
207%patch50 -p0 -b .iquote
208%patch51 -p1 -b -Werror
209pushd nss
210%patch52 -p1 -b .disableSSL2libssl
211%patch53 -p1 -b .disableSSL2tests
212%patch54 -p1 -b .sslauth-no-v2
213%patch55 -p1 -b .852023_enable_fips_when_in_fips_mode
214%patch56 -p1 -b .1026677_ignore_set_policy
215%patch62 -p1 -b .fix_deadlock
216%patch99 -p1 -b .min_key_sizes
217%patch100 -p0 -b .1171318
218%patch101 -p1 -b .dhe_and_sha384
219%patch102 -p1 -b .client_auth_prf
220%patch112 -p1 -b .1238290
221%patch113 -p1 -b .disable-ems
222%patch114 -p1 -b .extra
223%patch115 -p1 -b .abi_lib
224%patch116 -p1 -b .abi_tests
225%patch117 -p1 -b .test-filtering
226%patch74 -p1 -b .race
227popd
228%patch94 -p0 -b .init-token-race
229%patch103 -p0 -b .fix_client_auth_crash
230%patch104 -p0 -b .use_oids
231%patch105 -p0 -b .remove_bogus_assert
232%patch106 -p0 -b .old_pkcs11_num
233%patch107 -p0 -b .enable_384_cipher_tests
234%patch108 -p0 -b .sni_c_v_fix
235%patch109 -p0 -b .fix_signature_and_hash
236%patch110 -p0 -b .no_ssl2
237pushd nss
238%patch118 -p1 -b .allowed-sig-alg
239popd
240%patch119 -p0 -b .delete_duplicates
241
242%patch1002 -p0 -b .prtypes
243%patch1007 -p0 -b .include_prtypes
244%patch1008 -p1 -b .tls12_mechs
245
246
247pemNeedsFromSoftoken="lowkeyi lowkeyti softoken softoknt"
248for file in ${pemNeedsFromSoftoken}; do
249    %{__cp} ./nss/lib/softoken/${file}.h ./nss/lib/ckfw/pem/
250done
251%{__cp} ./nss/lib/softoken/lowkeyi.h ./nss/cmd/rsaperf
252%{__cp} ./nss/lib/softoken/lowkeyti.h ./nss/cmd/rsaperf
253
254pushd nss/tests/ssl
255# Create versions of sslcov.txt and sslstress.txt that disable tests
256# for SSL2 and EXPORT ciphers.
257cat sslcov.txt| sed -r "s/^([^#].*EXPORT|^[^#].*SSL2)/#disabled \1/" > sslcov.noSSL2orExport.txt
258cat sslstress.txt| sed -r "s/^([^#].*EXPORT|^[^#].*SSL2)/#disabled \1/" > sslstress.noSSL2orExport.txt
259popd
260
261%build
262
263export NSS_NO_SSL2=1
264
265NSS_NO_PKCS11_BYPASS=1
266export NSS_NO_PKCS11_BYPASS
267
268# partial RELRO support as a security enhancement
269#LDFLAGS+=-Wl,-z,relro
270#export LDFLAGS
271
272FREEBL_NO_DEPEND=1
273export FREEBL_NO_DEPEND
274
275# Must export FREEBL_LOWHASH=1 for nsslowhash.h so that it gets
276# copied to dist and the rpm install phase can find it
277# This due of the upstream changes to fix
278# https://bugzilla.mozilla.org/show_bug.cgi?id=717906
279FREEBL_LOWHASH=1
280export FREEBL_LOWHASH
281
282# Enable compiler optimizations and disable debugging code
283BUILD_OPT=1
284export BUILD_OPT
285
286# Generate symbolic info for debuggers
287XCFLAGS=$RPM_OPT_FLAGS
288export XCFLAGS
289
290PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
291PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1
292
293export PKG_CONFIG_ALLOW_SYSTEM_LIBS
294export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS
295
296NSPR_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nspr | sed 's/-I//'`
297NSPR_LIB_DIR=`/usr/bin/pkg-config --libs-only-L nspr | sed 's/-L//'`
298
299export NSPR_INCLUDE_DIR
300export NSPR_LIB_DIR
301
302#export FREEBL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-softokn | sed 's/-I//'`
303#export FREEBL_LIB_DIR=%{_libdir}
304export USE_SYSTEM_FREEBL=0
305
306NSS_USE_SYSTEM_SQLITE=1
307export NSS_USE_SYSTEM_SQLITE
308
309export USE_SYSTEM_ZLIB=1
310export ZLIB_LIBS=%{_libdir}
311
312%ifarch x86_64 ppc64 ia64 s390x
313USE_64=1
314export USE_64
315%endif
316
317# uncomment if the iquote patch is activated
318export IN_TREE_FREEBL_HEADERS_FIRST=1
319
320#export NSS_BLTEST_NOT_AVAILABLE=1
321#
322#%{__make} -C ./nss/coreconf
323#%{__make} -C ./nss/lib/dbm
324%{__make} -C ./nss
325
326
327%install
328
329# There is no make install target so we'll do it ourselves.
330
331%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3
332%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3/templates
333%{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
334%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}
335%{__mkdir_p} $RPM_BUILD_ROOT/%{unsupported_tools_directory}
336%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
337
338# Copy the binary libraries we want
339for file in libsoftokn3.so libfreebl3.so libnss3.so libnssutil3.so \
340            libssl3.so libsmime3.so libnssckbi.so libnsspem.so libnssdbm3.so
341do
342  %{__install} -m 755 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
343done
344
345# Install the empty NSS db files
346# Legacy db
347%{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb
348%{__install} -m 644 %{SOURCE3} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert8.db
349%{__install} -m 644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key3.db
350%{__install} -m 644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/secmod.db
351# Shared db
352%{__install} -p -m 644 %{SOURCE6} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert9.db
353%{__install} -p -m 644 %{SOURCE7} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key4.db
354%{__install} -p -m 644 %{SOURCE8} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/pkcs11.txt
355
356
357# Copy the development libraries we want
358for file in libcrmf.a libnssb.a libnssckfw.a
359do
360  %{__install} -m 644 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
361done
362
363# Copy the binaries we want
364for file in certutil cmsutil crlutil modutil pk12util signtool signver ssltap
365do
366  %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{_bindir}
367done
368
369# Copy the binaries we ship as unsupported
370for file in atob btoa derdump ocspclnt pp selfserv shlibsign strsclnt symkeyutil tstclnt vfyserv vfychain
371do
372  %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{unsupported_tools_directory}
373done
374
375# Copy the include files
376for file in dist/public/nss/*.h
377do
378  %{__install} -m 644 $file $RPM_BUILD_ROOT/%{_includedir}/nss3
379done
380
381# Copy some freebl include files we also want
382for file in blapi.h alghmac.h
383do
384  %{__install} -p -m 644 dist/private/nss/$file $RPM_BUILD_ROOT/%{_includedir}/nss3
385done
386
387# Copy the static freebl library
388for file in libfreebl.a
389do
390%{__install} -p -m 644 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
391done
392
393# Set up our package file
394%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
395%{__cat} %{SOURCE1} | sed -e "s,%%libdir%%,%{_libdir},g" \
396                          -e "s,%%prefix%%,%{_prefix},g" \
397                          -e "s,%%exec_prefix%%,%{_prefix},g" \
398                          -e "s,%%includedir%%,%{_includedir}/nss3,g" \
399                          -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
400                          -e "s,%%NSS_VERSION%%,%{version},g" \
401                          -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
402                          $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss.pc
403
404NSS_VMAJOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
405NSS_VMINOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
406NSS_VPATCH=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
407
408export NSS_VMAJOR
409export NSS_VMINOR
410export NSS_VPATCH
411
412%{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
413%{__cat} %{SOURCE2} | sed -e "s,@libdir@,%{_libdir},g" \
414                          -e "s,@prefix@,%{_prefix},g" \
415                          -e "s,@exec_prefix@,%{_prefix},g" \
416                          -e "s,@includedir@,%{_includedir}/nss3,g" \
417                          -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
418                          -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
419                          -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
420                          > $RPM_BUILD_ROOT/%{_bindir}/nss-config
421
422chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-config
423
424%{__cat} %{SOURCE101} | sed -e "s,%%libdir%%,%{_libdir},g" \
425                          -e "s,%%prefix%%,%{_prefix},g" \
426                          -e "s,%%exec_prefix%%,%{_prefix},g" \
427                          -e "s,%%includedir%%,%{_includedir}/nss3,g" \
428                          -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
429                          -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
430                          $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-util.pc
431
432NSSUTIL_VMAJOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMAJOR" | awk '{print $3}'`
433NSSUTIL_VMINOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMINOR" | awk '{print $3}'`
434NSSUTIL_VPATCH=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VPATCH" | awk '{print $3}'`
435
436export NSSUTIL_VMAJOR
437export NSSUTIL_VMINOR
438export NSSUTIL_VPATCH
439
440%{__cat} %{SOURCE102} | sed -e "s,@libdir@,%{_libdir},g" \
441                          -e "s,@prefix@,%{_prefix},g" \
442                          -e "s,@exec_prefix@,%{_prefix},g" \
443                          -e "s,@includedir@,%{_includedir}/nss3,g" \
444                          -e "s,@MOD_MAJOR_VERSION@,$NSSUTIL_VMAJOR,g" \
445                          -e "s,@MOD_MINOR_VERSION@,$NSSUTIL_VMINOR,g" \
446                          -e "s,@MOD_PATCH_VERSION@,$NSSUTIL_VPATCH,g" \
447                          > $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
448
449chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
450
451%{__cat} %{SOURCE103} | sed -e "s,%%libdir%%,%{_libdir},g" \
452                          -e "s,%%prefix%%,%{_prefix},g" \
453                          -e "s,%%exec_prefix%%,%{_prefix},g" \
454                          -e "s,%%includedir%%,%{_includedir}/nss3,g" \
455                          -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
456                          -e "s,%%NSSUTIL_VERSION%%,%{version},g" \
457                          -e "s,%%SOFTOKEN_VERSION%%,%{version},g" > \
458                          $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-softokn.pc
459
460SOFTOKEN_VMAJOR=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VMAJOR" | awk '{print $3}'`
461SOFTOKEN_VMINOR=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VMINOR" | awk '{print $3}'`
462SOFTOKEN_VPATCH=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VPATCH" | awk '{print $3}'`
463
464export SOFTOKEN_VMAJOR
465export SOFTOKEN_VMINOR
466export SOFTOKEN_VPATCH
467
468%{__cat} %{SOURCE104} | sed -e "s,@libdir@,%{_libdir},g" \
469                          -e "s,@prefix@,%{_prefix},g" \
470                          -e "s,@exec_prefix@,%{_prefix},g" \
471                          -e "s,@includedir@,%{_includedir}/nss3,g" \
472                          -e "s,@MOD_MAJOR_VERSION@,$SOFTOKEN_VMAJOR,g" \
473                          -e "s,@MOD_MINOR_VERSION@,$SOFTOKEN_VMINOR,g" \
474                          -e "s,@MOD_PATCH_VERSION@,$SOFTOKEN_VPATCH,g" \
475                          > $RPM_BUILD_ROOT/%{_bindir}/nss-softokn-config
476
477chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-softokn-config
478
479
480%clean
481%{__rm} -rf $RPM_BUILD_ROOT
482
483
484%post
485/sbin/ldconfig >/dev/null 2>/dev/null
486
487%postun
488/sbin/ldconfig >/dev/null 2>/dev/null
489
490
491%files
492%defattr(-,root,root)
493%{_libdir}/libnss3.so
494%{_libdir}/libnssutil3.so
495%{_libdir}/libnssdbm3.so
496%{_libdir}/libssl3.so
497%{_libdir}/libsmime3.so
498%{_libdir}/libsoftokn3.so
499%{_libdir}/libnssckbi.so
500%{_libdir}/libnsspem.so
501%{_libdir}/libfreebl3.so
502%{unsupported_tools_directory}/shlibsign
503%{_libdir}/libfreebl3.chk
504%{_libdir}/libnssdbm3.chk
505%{_libdir}/libsoftokn3.chk
506%dir %{_sysconfdir}/pki/nssdb
507%config(noreplace) %{_sysconfdir}/pki/nssdb/cert8.db
508%config(noreplace) %{_sysconfdir}/pki/nssdb/key3.db
509%config(noreplace) %{_sysconfdir}/pki/nssdb/secmod.db
510%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/cert9.db
511%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/key4.db
512%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/pkcs11.txt
513
514%files tools
515%defattr(-,root,root)
516%{_bindir}/certutil
517%{_bindir}/cmsutil
518%{_bindir}/crlutil
519%{_bindir}/modutil
520%{_bindir}/pk12util
521%{_bindir}/signtool
522%{_bindir}/signver
523%{_bindir}/ssltap
524%{unsupported_tools_directory}/atob
525%{unsupported_tools_directory}/btoa
526%{unsupported_tools_directory}/derdump
527%{unsupported_tools_directory}/ocspclnt
528%{unsupported_tools_directory}/pp
529%{unsupported_tools_directory}/selfserv
530%{unsupported_tools_directory}/strsclnt
531%{unsupported_tools_directory}/symkeyutil
532%{unsupported_tools_directory}/tstclnt
533%{unsupported_tools_directory}/vfyserv
534%{unsupported_tools_directory}/vfychain
535
536
537%files devel
538%defattr(-,root,root)
539%{_libdir}/libcrmf.a
540%{_libdir}/libfreebl.a
541%{_libdir}/pkgconfig/nss.pc
542%{_libdir}/pkgconfig/nss-softokn.pc
543%{_libdir}/pkgconfig/nss-util.pc
544%{_bindir}/nss-config
545%{_bindir}/nss-softokn-config
546%{_bindir}/nss-util-config
547
548%dir %{_includedir}/nss3
549%{_includedir}/nss3/alghmac.h
550%{_includedir}/nss3/base64.h
551%{_includedir}/nss3/blapi.h
552%{_includedir}/nss3/blapit.h
553%{_includedir}/nss3/cert.h
554%{_includedir}/nss3/certdb.h
555%{_includedir}/nss3/certt.h
556%{_includedir}/nss3/ciferfam.h
557%{_includedir}/nss3/cmmf.h
558%{_includedir}/nss3/cmmft.h
559%{_includedir}/nss3/cms.h
560%{_includedir}/nss3/cmsreclist.h
561%{_includedir}/nss3/cmst.h
562%{_includedir}/nss3/crmf.h
563%{_includedir}/nss3/crmft.h
564%{_includedir}/nss3/cryptohi.h
565%{_includedir}/nss3/cryptoht.h
566%{_includedir}/nss3/ecl-exp.h
567%{_includedir}/nss3/hasht.h
568%{_includedir}/nss3/jar-ds.h
569%{_includedir}/nss3/jar.h
570%{_includedir}/nss3/jarfile.h
571%{_includedir}/nss3/key.h
572%{_includedir}/nss3/keyhi.h
573%{_includedir}/nss3/keyt.h
574%{_includedir}/nss3/keythi.h
575%{_includedir}/nss3/nss.h
576%{_includedir}/nss3/nssb64.h
577%{_includedir}/nss3/nssb64t.h
578%{_includedir}/nss3/nssckbi.h
579%{_includedir}/nss3/nssilckt.h
580%{_includedir}/nss3/nssilock.h
581%{_includedir}/nss3/nsslocks.h
582%{_includedir}/nss3/nsslowhash.h
583%{_includedir}/nss3/nsspem.h
584%{_includedir}/nss3/nssrwlk.h
585%{_includedir}/nss3/nssrwlkt.h
586%{_includedir}/nss3/nssutil.h
587%{_includedir}/nss3/ocsp.h
588%{_includedir}/nss3/ocspt.h
589%{_includedir}/nss3/p12.h
590%{_includedir}/nss3/p12plcy.h
591%{_includedir}/nss3/p12t.h
592%{_includedir}/nss3/pk11func.h
593%{_includedir}/nss3/pk11pqg.h
594%{_includedir}/nss3/pk11priv.h
595%{_includedir}/nss3/pk11pub.h
596%{_includedir}/nss3/pk11sdr.h
597%{_includedir}/nss3/pkcs11.h
598%{_includedir}/nss3/pkcs11f.h
599%{_includedir}/nss3/pkcs11n.h
600%{_includedir}/nss3/pkcs11p.h
601%{_includedir}/nss3/pkcs11t.h
602%{_includedir}/nss3/pkcs11u.h
603%{_includedir}/nss3/pkcs12.h
604%{_includedir}/nss3/pkcs12t.h
605%{_includedir}/nss3/pkcs7t.h
606%{_includedir}/nss3/pkcs1sig.h
607%{_includedir}/nss3/portreg.h
608%{_includedir}/nss3/preenc.h
609%{_includedir}/nss3/secasn1.h
610%{_includedir}/nss3/secasn1t.h
611%{_includedir}/nss3/seccomon.h
612%{_includedir}/nss3/secder.h
613%{_includedir}/nss3/secdert.h
614%{_includedir}/nss3/secdig.h
615%{_includedir}/nss3/secdigt.h
616%{_includedir}/nss3/secerr.h
617%{_includedir}/nss3/sechash.h
618%{_includedir}/nss3/secitem.h
619%{_includedir}/nss3/secmime.h
620%{_includedir}/nss3/secmod.h
621%{_includedir}/nss3/secmodt.h
622%{_includedir}/nss3/secoid.h
623%{_includedir}/nss3/secoidt.h
624%{_includedir}/nss3/secpkcs5.h
625%{_includedir}/nss3/secpkcs7.h
626%{_includedir}/nss3/secport.h
627%{_includedir}/nss3/shsign.h
628%{_includedir}/nss3/smime.h
629%{_includedir}/nss3/ssl.h
630%{_includedir}/nss3/sslerr.h
631%{_includedir}/nss3/sslproto.h
632%{_includedir}/nss3/sslt.h
633%{_includedir}/nss3/utilrename.h
634%{_includedir}/nss3/utilmodt.h
635%{_includedir}/nss3/utilpars.h
636%{_includedir}/nss3/utilparst.h
637         
638
639%files pkcs11-devel
640%defattr(-, root, root)
641%{_includedir}/nss3/nssbase.h
642%{_includedir}/nss3/nssbaset.h
643%{_includedir}/nss3/nssckepv.h
644%{_includedir}/nss3/nssckft.h
645%{_includedir}/nss3/nssckfw.h
646%{_includedir}/nss3/nssckfwc.h
647%{_includedir}/nss3/nssckfwt.h
648%{_includedir}/nss3/nssckg.h
649%{_includedir}/nss3/nssckmdt.h
650%{_includedir}/nss3/nssckt.h
651%{_libdir}/libnssb.a
652%{_libdir}/libnssckfw.a
653
654
655## to build compat32 for x86_64 architecture support
656%if %{build_compat32}
657%files -n compat32-%{name}
658%defattr(-,root,root)
659%{_libdir}/*.so
660%ghost %{_libdir}/libsoftokn3.chk
661%ghost %{_libdir}/libfreebl3.chk
662%{unsupported_tools_directory}/shlibsign
663%endif
664
665
666%changelog
667* Mon Jun 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.21.1-3
668- added libfreebl.a.
669
670* Mon Jun 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.21.1-2
671- enabled softokn and freebl.
672- dropped Patch47 and Patch49.
673
674* Tue May 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.21.1-1
675- update to 3.21.1
676- import patches from centos package
677
678* Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.16.1-1
679- update to 3.16.1
680
681* Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.3-1
682- update to 3.14.3
683- import patches from fedora package
684
685* Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.1-1
686- update to 3.14.1
687
688* Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.6-2
689- add Source101 (nss-util.pc.in)
690- add Source102 (nss-util-config.in)
691
692* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.6-1
693- new upstream release
694
695* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.3-1
696- new upstream release
697
698* Thu Dec 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-2
699- fix nss.pc
700
701* Wed Dec 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-1
702- new upstream release
703
704* Fri Sep 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.11-1
705- new upstram release
706
707* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.10-1
708- update to 3.12.10
709
710* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.9-1
711- update to 3.12.9.with.ckbi.1.82
712- update nss-pem source
713- define NSS_USE_SYSTEM_SQLITE, remove unneeded Patch2
714
715* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-2
716- rebuild with rpm-4.8.1 for pkg-config file
717
718* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12.6-1
719- new upstream release
720- update nss-pem Source12 to 20091210 (from 3.12.6-2.fc14)
721
722* Sat Jan 23 2010 NAKAMURA Kenta <kenta@vinelinux.org> 3.12.5-2
723- built with FREEBL_NO_DEPEND environmental variable to include nsslowhash.h
724
725* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.5-1
726- new upstream release
727
728* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-4
729- rebuild to fix the package built with broken environment.
730
731* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-3
732- fixed %%files for compat32
733
734* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-2
735- added compat32 subpackages
736
737* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-1
738- new upstream release
739
740* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-1
741- new upstream release
742
743* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.11.4-0vl1
744- initial build for Vine Linux
745
746* Fri Mar 02 2007 Kai Engert <kengert@redhat.com> - 3.11.5-2
747- Fix rhbz#230545, failure to enable FIPS mode
748- Fix rhbz#220542, make NSS more tolerant of resets when in the
749  middle of prompting for a user password.
750
751* Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 3.11.5-1
752- Update to 3.11.5
753- This update fixes two security vulnerabilities with SSL 2
754- Do not use -rpath link option
755- Added several unsupported tools to tools package
756
757* Tue Jan  9 2007 Bob Relyea <rrelyea@redhat.com> - 3.11.4-4
758- disable ECC, cleanout dead code
759
760* Tue Nov 28 2006 Kai Engert <kengert@redhat.com> - 3.11.4-1
761- Update to 3.11.4
762
763* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-2
764- Revert the attempt to require latest NSPR, as it is not yet available
765  in the build infrastructure.
766
767* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-1
768- Update to 3.11.3
769
770* Thu Aug 03 2006 Kai Engert <kengert@redhat.com> - 3.11.2-2
771- Add /etc/pki/nssdb
772
773* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.11.2-1.1
774- rebuild
775
776* Fri Jun 30 2006 Kai Engert <kengert@redhat.com> - 3.11.2-1
777- Update to 3.11.2
778- Enable executable bit on shared libs, also fixes debug info.
779
780* Wed Jun 14 2006 Kai Engert <kengert@redhat.com> - 3.11.1-2
781- Enable Elliptic Curve Cryptography (ECC)
782
783* Fri May 26 2006 Kai Engert <kengert@redhat.com> - 3.11.1-1
784- Update to 3.11.1
785- Include upstream patch to limit curves
786
787* Wed Feb 15 2006 Kai Engert <kengert@redhat.com> - 3.11-4
788- add --noexecstack when compiling assembler on x86_64
789
790* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.2
791- bump again for double-long bug on ppc(64)
792
793* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.1
794- rebuilt for new gcc4.1 snapshot and glibc changes
795
796* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 3.11-3
797- rebuild
798
799* Fri Dec 16 2005 Christopher Aillon <caillon@redhat.com> 3.11-2
800- Update file list for the devel packages
801
802* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-1
803- Update to 3.11
804
805* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs.2
806- Add patch to allow building on ppc*
807- Update the pkgconfig file to Require nspr
808
809* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs
810- Initial import into Fedora Core, based on a CVS snapshot of
811  the NSS_3_11_RTM tag
812- Fix up the pkcs11-devel subpackage to contain the proper headers
813- Build with RPM_OPT_FLAGS
814- No need to have rpath of /usr/lib in the pc file
815
816* Thu Dec 15 2005 Kai Engert <kengert@redhat.com>
817- Adressed review comments by Wan-Teh Chang, Bob Relyea,
818  Christopher Aillon.
819
820* Sat Jul  9 2005 Rob Crittenden <rcritten@redhat.com> 3.10-1
821- Initial build
Note: See TracBrowser for help on using the repository browser.