source: projects/specs/branches/6/n/nsd/nsd-vl.spec @ 3097

Revision 3097, 9.8 KB checked in by daisuke, 13 years ago (diff)

nsd: new package, 3.2.8-1

Line 
1Summary: Fast and lean authoritative DNS Name Server
2Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
3Name: nsd
4Version: 3.2.8
5Release: 1%{?_dist_release}
6License: BSD
7Url: http://www.nlnetlabs.nl/%{name}/
8Source: http://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
9Source1: nsd.init
10Source2: nsd.cron
11Source3: nsd.sysconfig
12Patch0: nsd-install.patch
13Group: System Environment/Daemons
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: flex, openssl-devel
16Requires(pre): shadow-utils
17
18%description
19NSD is a complete implementation of an authoritative DNS name server.
20For further information about what NSD is and what NSD is not please
21consult the REQUIREMENTS document which is a part of this distribution
22
23%description -l ja
24NSD は Authoritative DNSネームサーバの完全な実装です。
25NDS に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
26
27%prep
28%setup -q
29%patch0 -p1
30
31%build
32%configure --enable-bind8-stats --enable-checking --enable-nsec3 \
33           --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid --with-ssl \
34           --with-user=nsd --with-difffile=%{_localstatedir}/lib/%{name}/ixfr.db \
35           --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
36           --with-dbfile=%{_localstatedir}/lib/%{name}/nsd.db
37
38%{__make} %{?_smp_mflags}
39#convert to utf8
40iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
41iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
42mv -f doc/RELNOTES.utf8 doc/RELNOTES
43mv -f doc/CREDITS.utf8 doc/CREDITS
44
45
46%install
47rm -rf %{buildroot}
48%{__make} DESTDIR=%{buildroot} install
49install -d -m 0755 %{buildroot}%{_initrddir}
50install -d -m 0755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
51install -c -m 0755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/nsd
52install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
53install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
54install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
55install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
56install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
57
58# change .sample to normal config files
59head -76 %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample > %{buildroot}%{_sysconfdir}/nsd/nsd.conf
60rm %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample
61echo "database: /var/lib/nsd/nsd.db" >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
62echo "# include: \"/some/path/file\"" >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
63
64%clean
65rm -rf ${RPM_BUILD_ROOT}
66
67%files
68%defattr(-,root,root,-)
69%doc doc/*
70%doc contrib/nsd.zones2nsd.conf
71%dir %{_sysconfdir}/nsd/
72%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
73#%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
74%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
75%attr(0755,root,root) %{_initrddir}/%{name}
76%{_sysconfdir}/cron.hourly/nsd
77%ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
78%attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
79%{_sbindir}/*
80%{_mandir}/*/*
81
82%pre
83getent group nsd >/dev/null || groupadd -r nsd
84getent passwd nsd >/dev/null || \
85useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
86-c "nsd daemon account" nsd
87exit 0
88
89%post
90/sbin/chkconfig --add %{name}
91
92%preun
93if [ $1 -eq 0 ]; then
94        /sbin/service %{name} stop
95        /sbin/chkconfig --del %{name}
96fi
97
98%postun
99if [ "$1" -ge "1" ]; then
100  /sbin/service %{name} condrestart
101fi
102
103%changelog
104* Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-1
105- new upstream release
106
107* Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
108- initial build for Vine Linux
109
110* Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
111- Updated to nsd 3.2.4
112
113* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
114- Incorporated Ville Mattila's fixes  to nsd.cron
115- Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
116
117* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
118- rebuilt with new openssl
119
120* Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
121- The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
122
123* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
124-Updated to version 3.2.3
125
126* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
128
129* Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
130- Fixed /dev/nul which cause a file \%%1 to be written by cron
131- Bump for EVR.
132
133* Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
134- Upgraded to 3.2.2 security release
135  http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
136
137* Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
138- Make various file paths used by the nsd.init script configurable
139  from /etc/sysconfig/nsd.
140- Add template /etc/sysconfig/nsd.
141
142* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
143- nsd used the 'named' subsystem in one call in the init script
144
145* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
147
148* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
149- Fix init script 'unary operator' error.
150
151* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
152- Updated to new version 3.2.1
153
154* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
155- rebuild with new openssl
156
157* Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
158- Updates summary as per Richard Hughes guidelines
159
160* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
161- Bump version after pre-release version correction.
162
163* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
164- 3.2.0-1
165
166* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
167- updated to 3.1.1
168
169* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
170- fix license tag
171- fix static user creation
172
173* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
174- Updated to 3.1.0
175
176* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
177- Fix /dev/null redirection [Venkatesh Krishnamurthi]
178
179* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
180- Updated to 3.0.8
181
182* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
183- Autorebuild for GCC 4.3
184
185* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
186- Rebuild for new libcrypto
187
188* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
189- Updated to new version
190- fix RELNOTES/README to be utf8
191- Fix path to nsd.db in cron job.
192
193* Thu Nov  8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
194- Modified cron to only rebuild/reload when zone updates
195  have been received
196
197* Wed Nov  7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
198- Added hourly cron job to do various maintenance tasks
199- Added nsd rebuild to create the proper nsd.db file on startup
200- Added nsd patch on shutdown to ensure zonefiles are up to date
201
202* Tue Oct  2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
203- nsdc update and nsdc notify are no longer needed in initscript.
204
205* Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
206- Bump release for upgrade path.
207
208* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
209- Do not include examples from nsd.conf.sample that causes
210  bogus network traffic.
211
212* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
213- Change locations of ixfr.db and xfrd.state to /var/lib/nsd
214- Enable NSEC3
215- Delay running nsdc update until after nsd has started
216- Delete xfrd.state on nsd stop
217- Run nsdc notify in the background, since it can take
218  a very long time when remote servers are unavailable.
219
220* Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
221- Upgraded to 3.0.6
222- Do not include bind2nsd, since it didn't compile for me
223
224* Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
225- Fix init script, bug #245546
226
227* Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
228- Upgraded to 3.0.5
229
230* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
231- Upgraded to 3.0.3
232
233* Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
234- Upgraded to 3.0.2.
235- Use new configuration file nsd.conf. Still needs migration script.
236  patch from Farkas Levente <lfarkas@bppiac.hu>
237
238* Mon Oct 16 2006  Paul Wouters <paul@xelerance.com> 2.3.6-2
239- Bump version for upgrade path
240
241* Thu Oct 12 2006  Paul Wouters <paul@xelerance.com> 2.3.6-1
242- Upgraded to 2.3.6
243- Removed obsolete workaround in nsd.init
244- Fixed spec file so daemon gets properly restarted on upgrade
245
246* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
247- Rebuild requested for PT_GNU_HASH support from gcc
248- Removed dbaccess.c from doc section
249
250* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
251- Bump version for FC-x upgrade path
252
253* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
254- Upgraded to nsd-2.3.5
255
256* Sun May  7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
257- Upgraded to nsd-2.3.4.
258- Removed manual install targets because DESTDIR is now supported
259- Re-enabled --checking, checking patch no longer needed and removed.
260- Work around in nsd.init for nsd failing to start when there is no ipv6
261
262* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
263- chkconfig and attribute  changes as proposed by Dmitry Butskoy
264
265* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
266- Moved pid file to /var/run/nsd/nsd.pid.
267- Use _localstatedir instead of "/var"
268
269* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
270- Added BuildRequires for openssl-devel, removed Requires for openssl.
271
272* Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
273- upgraded to nsd-2.3.3
274
275* Wed Dec  7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
276- minor cleanups
277
278* Mon Dec  5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
279- Upgraded to 2.3.2. Changed post scripts to comply to Fedora
280  Extras policies (eg do not start daemon on fresh install)
281
282* Tue Oct  4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
283- Initial version
Note: See TracBrowser for help on using the repository browser.