source: projects/specs/branches/6/n/nqxml/nqxml-vl.spec @ 521

Revision 521, 2.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define rblibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
2
3Summary: pure Ruby implementation of a non-validating XML processor
4Summary(ja): Ruby で実装された non-validating XML プロセッサ
5Name: nqxml
6Version: 1.1.3p1
7Release: 1%{?_dist_release}
8License: distributable
9Group: Development/Libraries
10Source: http://downloads.sourceforge.net/nqxml/%{name}-%{version}.tar.gz
11URL: http://nqxml.sourceforge.net/
12BuildArch: noarch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: ruby
15BuildRequires: ruby-devel >= 1.6.4-0vl3
16Requires: libruby >= 1.6
17
18%description
19NQXML is a pure Ruby implementation of a non-validating XML processor. It
20includes an XML tokenizer, a SAX-style streaming XML parser, a DOM-style
21tree parser, and an XML writer. ``NQ'' stands for ``Not Quite''. There is
22some limitations.
23
24%description -l ja
25NQXMLは完全にRubyだけで実装されたnon-validating XMLプロセッサです.
26XMLトークン化,SAXスタイルでのパーズ,DOMスタイルでのパーズ,XML出
27力が可能です.「NQ」は「Not Quite」を意味しており,いくつかの制限
28事項があります.
29
30%prep
31%setup -q -c
32
33%build
34
35%install
36rm -rf ${RPM_BUILD_ROOT}
37mkdir -p ${RPM_BUILD_ROOT}%{rblibdir}
38
39cd %{name}-%{version}
40ruby install.rb --install-dir=${RPM_BUILD_ROOT}%{rblibdir}
41cd ..
42
43(find \
44  $RPM_BUILD_ROOT%{rblibdir} \
45      -type f -o -type l) |
46 sort | sed -e "s,^$RPM_BUILD_ROOT,," > nqxml.files
47
48%clean
49rm -f nqxml.files
50rm -rf ${RPM_BUILD_ROOT}
51
52%pre
53
54%post
55
56%files -f nqxml.files
57%defattr(-, root, root)
58%doc %{name}-%{version}/ChangeLog
59%doc %{name}-%{version}/Credits
60%doc %{name}-%{version}/INSTALL
61%doc %{name}-%{version}/README
62%doc %{name}-%{version}/TODO
63%doc %{name}-%{version}/contrib/
64%doc %{name}-%{version}/examples/
65%doc %{name}-%{version}/tests/
66
67%changelog
68* Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.3p1-1
69- updated to 1.1.3p1
70- changed Group to Development/Libraries
71
72* Wed Oct 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
73- applied new versioning policy, spec in utf-8
74- s/Copyright/License/
75
76* Sun Oct 14 2001 akira yamada <akira@vinelinux.org> 1.1.1-0vl1
77- Initial packaging.
Note: See TracBrowser for help on using the repository browser.