source: projects/specs/branches/6/n/notify-python/notify-python-vl.spec @ 1979

Revision 1979, 2.8 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary:        Python bindings for libnotify
4Summary(ja):    libnotify の Python バインディング
5
6Name:           notify-python
7Version:        0.1.1
8Release:        3%{?_dist_release}
9
10Group:          Development/Languages
11# No version specified, just COPYING.
12License:        LGPLv2+
13URL:            http://www.galago-project.org/specs/notification
14Source0:        http://www.galago-project.org/files/releases/source/notify-python/notify-python-%{version}.tar.gz
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  python-devel, pkgconfig, libnotify-devel, pygtk2-devel
18BuildRequires:  gtk2-devel, dbus-devel, dbus-glib-devel
19
20Requires:   libnotify
21Requires:   notification-daemon
22
23%define pypkgname pynotify
24
25%description
26Python bindings for libnotify
27
28%prep
29%setup -q
30
31# WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
32# from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
33
34%build
35CFLAGS="$RPM_OPT_FLAGS"
36PYTHON=%{__python}
37%configure
38touch src/pynotify.override
39make
40
41%install
42rm -rf $RPM_BUILD_ROOT
43make DESTDIR=$RPM_BUILD_ROOT install
44# remove unnecessary la file
45rm $RPM_BUILD_ROOT/%{python_sitearch}/gtk-2.0/%{pypkgname}/_%{pypkgname}.la
46
47 
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(-,root,root,-)
53%doc
54%{python_sitearch}/gtk-2.0/%{pypkgname}
55%{_datadir}/pygtk/2.0/defs/%{pypkgname}.defs
56%{_libdir}/pkgconfig/%{name}.pc
57
58%changelog
59* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.1-3
60- rebuilt with rpm-4.8.1 for pkg-config
61
62* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.1-2
63- rebuild with python-2.6
64
65* Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.1-1
66- initial build for Vine Linux
67
68* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.1.1-4
69- fix license tag
70
71* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.1-3
72- Autorebuild for GCC 4.3
73
74* Fri Jan  4 2008  <jdennis@redhat.com> - 0.1.1-2
75- Resolves bug# 427499: attach_to_status_icon not created
76  force regeneration of pynotify.c
77
78* Wed Jan  2 2008 John Dennis <jdennis@redhat.com> - 0.1.1-1
79- upgrade to current upstream
80- no longer remove package config file (notify-python.pc), resolves bug #427001
81
82* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.1.0-4
83- rebuild for python 2.5
84
85* Tue Aug 15 2006 Luke Macken <lmacken@redhat.com> - 0.1.0-3
86- Add notify-python-0.1.0-attach_to_status_icon.patch to allow the attaching
87  notifications to status icons.
88
89* Thu Jul 20 2006 John Dennis <jdennis@redhat.com> - 0.1.0-2
90- change use of python_sitelib to python_sitearch, add BuildRequires
91
92* Wed Jul 19 2006 John Dennis <jdennis@redhat.com> - 0.1.0-1
93- Initial build
94
Note: See TracBrowser for help on using the repository browser.