source: projects/specs/branches/6/n/nmap/nmap-vl.spec @ 2691

Revision 2691, 8.2 KB checked in by Takemikaduchi, 13 years ago (diff)

pygtk2: add R:gtk2-devel others: new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 5.51
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/System
10URL: http://www.insecure.org/nmap/
11Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
12#Source1: zenmap.desktop
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libpcap-devel
16BuildRequires: pcre-devel
17BuildRequires: python-devel
18BuildRequires: pygtk2-devel
19BuildRequires: openssl-devel
20BuildRequires: lua-devel
21
22%description
23Nmap is a utility for network exploration or security auditing. It
24supports ping scanning (determine which hosts are up), many port
25scanning techniques (determine what services the hosts are offering),
26and TCP/IP fingerprinting (remote host operating system
27identification). Nmap also offers flexible target and port
28specification, decoy scanning, determination of TCP sequence
29predictability characteristics, sunRPC scanning, reverse-identd
30scanning, and more.
31
32%description -l ja
33Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
34ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
35技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
36の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
37ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
38予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
39機能も提供します。
40
41%package frontend
42Summary: Gtk+ frontend for nmap
43Summary(ja): Nmap の GTK+ フロントエンド
44Group: Applications/System
45Requires: nmap = %{version}-%{release}
46Requires: python pygtk2 pysqlite
47Provides: zenmap = %{version}-%{release}
48
49%description frontend
50This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
51be installed before installing nmap-frontend.
52
53%description frontend -l ja
54Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
55する前に、nmap パッケージをインストールする必要があります。
56
57%prep
58%setup -q
59
60%build
61export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
62%configure
63make
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
70cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
71gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
72pushd $RPM_BUILD_ROOT%{_mandir}/man1
73ln -s zenmap.1.gz nmapfe.1.gz
74ln -s zenmap.1.gz xnmap.1.gz
75popd
76
77#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
78#mkdir zenmap
79#mv *.svg zenmap
80#mv *.png zenmap
81#popd
82
83#desktop-file-install --vendor= \
84#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
85#       %{SOURCE1};
86rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
87
88%find_lang %{name} --with-man
89
90%clean
91rm -rf %{buildroot}
92
93%files -f %{name}.lang
94%defattr(-,root,root)
95%doc COPYING COPYING.OpenSSL CHANGELOG
96%doc docs/README docs/nmap.usage.txt docs/nmap.dtd
97%{_bindir}/nmap
98%{_bindir}/ncat
99%{_bindir}/ndiff
100%{_bindir}/nping
101%{_datadir}/nmap
102%{_datadir}/ncat
103#%{_libexecdir}/nmap
104%{_mandir}/man1/nmap.1*
105%{_mandir}/man1/ncat.1*
106%{_mandir}/man1/ndiff.1*
107%{_mandir}/man1/nping.1*
108
109%files frontend
110%defattr(-,root,root)
111%{_bindir}/nmapfe
112%{_bindir}/xnmap
113%{_bindir}/zenmap
114%{python_sitelib}/*
115%{_datadir}/applications/*.desktop
116#%{_datadir}/icons/*
117#%{_datadir}/pixmaps/zenmap
118%{_datadir}/zenmap
119%{_mandir}/man1/zenmap.1*
120%{_mandir}/man1/nmapfe.1*
121%{_mandir}/man1/xnmap.1*
122
123%changelog
124* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
125- new upstream release
126
127* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
128- new upstream release
129- fix %files to add nping
130
131* Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
132- new upstream release
133- add BuildRequires: openssl-devel, lua-devel
134- fix %files to add ncat and ndiff
135
136* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
137- new upstream release
138- spec in UTF-8
139- added BuildRequires: libpcap-devel instead of libpcap
140- removed BuildRequires: desktop-file-utils
141
142* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
143- rebuilt with libpcap 1.0.0
144
145* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
146- rebuilt with python-2.5.2
147
148* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
149- updated python sitelib files path
150
151* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
152- new upstream release
153
154* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
155- new upstream release
156- rebuild with new environment/toolchain
157
158* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
159- new upstream release
160- added BuildRequires: desktop-file-utils
161
162* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
163- new upstream release
164
165* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
166- rebuild for VineSeed Plus
167
168* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
169- new upstream release
170
171* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
172- new upstream release
173
174* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
175- new upstream release
176- added Japanese summary to nmap-frontend
177
178* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
179- new upstream release
180
181* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
182- rebuild with new openssl
183
184* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
185- new upstream release
186
187* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
188- new upstream release
189
190* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
191- new upstream release
192
193* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
194- new upstream release
195
196* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
197- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
198
199* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
200- new upstream release
201- rebuild with new toolchains
202
203* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
204- new upstream release
205- delete Version Tag from nmap-frontend package
206- fix BuildRoot
207
208* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
209- new upstream release
210- 2.54BETA is developpment release, but it is more stable than 2.53.
211
212* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
213- unfortunately increase release: 1vl2 from 0vl2
214  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
215- patch to build on current glibc22 system
216
217* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
218- 2.53-0vl2: use better macros
219
220* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
221- rebuild for VineSeed based on the original site's srpm
222- add Japanese summary and description
223
224* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
225- Updated description
226- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
227- Fixed nmap distribution URL (source0)
228- Added this .rpm to base Nmap distribution
229
230* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
231- based on origional spec file from
232        http://www.insecure.org/nmap/index.html#download
233- general cleanups, removed lots of commenrts since it made the spec hard to
234        read
235- changed group to Applications/System
236- quiet setup
237- no need to create dirs in the install section, "make
238        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
239- using defined %{prefix}, %{version} etc. for easier/quicker maint.
240- added docs
241- gzip man pages
242- strip after files have been installed into buildroot
243- created separate package for the frontend so that Gtk+ isn't needed for the
244        CLI nmap
245- not using -f in files section anymore, no need for it since there aren't that
246        many files/dirs
247- added desktop entry for gnome
248
249* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
250- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
251
252* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
253- Made some changes, and merged in another .spec file sent in
254  by Oren Tirosh <oren@hishome.net>
255
256* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
257- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.