source: projects/specs/branches/6/n/netcat/netcat-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Networking utility that manages TCP and UDP connections
2Name: netcat
3Version: 0.7.1
4Release: 2%{?_dist_release}
5License: GPL
6Group: Applications/Internet
7URL: http://netcat.sourceforge.net/
8Source: http://prdownloads.sourceforge.net/netcat/netcat-%{version}.tar.bz2
9Packager: Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11
12%description
13Netcat is a featured networking utility which reads and writes data across
14network connections, using the TCP/IP protocol.
15It is designed to be a reliable "back-end" tool that can be used directly or
16easily driven by other programs and scripts. At the same time, it is a
17feature-rich network debugging and exploration tool, since it can create
18almost any kind of connection you would need and has several interesting
19built-in capabilities.
20
21%prep
22%setup -q
23
24%build
25%configure
26
27%install
28rm -rf $RPM_BUILD_ROOT
29make install DESTDIR="$RPM_BUILD_ROOT"
30
31# ugly hack in order to include the structured directory in the rpm
32rm -f doc/drafts/Makefile*
33
34%find_lang %name
35
36%clean
37rm -rf $RPM_BUILD_ROOT
38
39%files -f %{name}.lang
40%defattr(-,root,root)
41%doc AUTHORS COPYING ChangeLog NEWS README TODO doc/migration doc/drafts
42
43%{_bindir}/netcat
44%{_bindir}/nc
45
46%{_infodir}/*
47%{_mandir}/*/*
48
49%post
50/sbin/install-info %{_infodir}/netcat.info.gz %{_infodir}/dir
51
52%preun
53if [ "$1" = 0 ]; then
54    /sbin/install-info --delete %{_infodir}/netcat.info.gz %{_infodir}/dir
55fi
56
57%changelog
58* Wed Oct 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.7.1-2vl5
59- applied new versioning policy
60
61* Sat Sep 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.1-1vl2
62- Plus package for Vine 4.0/Seed
63
64* Sat Sep 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.1-1vl1
65- Plus package for Vine 3.2
66
67* Sun Jan 11 2004 Giovanni Giacobbi <giovanni@giacobbi.net> 0.7.1-1
68- Minor spec file cleanup
69- Updated to version 0.7.1.
70
71* Thu Aug 21 2003 Giovanni Giacobbi <giovanni@giacobbi.net> 0.7.0-1
72- Updated to version 0.7.0.
73
74* Tue Oct 15 2002 Giovanni Giacobbi <giovanni@giacobbi.net> 0.6.1-1
75- Updated author's email address.
76- Now adds info entries in the global info directory on install.
77- Updated to version 0.6.1.
78
79* Thu Aug 22 2002 Giovanni Giacobbi <giovanni@giacobbi.net> 0.6.0-1
80- Final updates for the public release.
81
82* Tue Aug 20 2002 Giovanni Giacobbi <giovanni@giacobbi.net> 0.6.0-0.5
83- Some updates, still testing for first public release.
84
85* Sat Jun 15 2002 Giovanni Giacobbi <giovanni@giacobbi.net> 0.5.1-1
86- First testing package v0.5.1.
Note: See TracBrowser for help on using the repository browser.