source: projects/specs/branches/6/n/netatalk/netatalk-vl.spec @ 4426

Revision 4426, 10.3 KB checked in by shaolin, 13 years ago (diff)
  • netatalk: this is the official 2.2.0 release, hopefully
Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AppleTalk and AppleShare/IP services for Linux
5Summary(ja):   Linux 用 AppleTalk, AppleShare/IP サービス
6Name:          netatalk
7Version:       2.2.0
8Release:       3%{_dist_release}
9License:       GPLv2+
10Group:         System Environment/Daemons
11Source0:       %{name}-%{version}.tar.bz2
12URL:           http://netatalk.sourceforge.net/
13Obsoletes:     netatalk-1.4b2+asun
14
15# patch for default config file
16Patch10:       netatalk-2.2.0-config-utf8.patch
17
18
19############################################################## REQUIREMENTS
20Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
21Requires:      cracklib, openssl, tcp_wrappers, pam, perl
22BuildRequires: openssl-devel, avahi-devel, pam-devel, db4-devel, quota
23
24BuildRoot:     %{_tmppath}/%{name}-%{version}-root
25
26Vendor:        Project Vine
27Distribution:  Vine Linux
28Packager:      shaolin
29
30
31%description
32Netatalk is a freely-available Open Source AFP fileserver. It also provides a
33kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
34running Netatalk is capable of serving many Macintosh clients simultaneously
35as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
36and for accessing AppleTalk printers via Printer Access Protocol (PAP).
37Included are a number of minor printing and debugging utilities.
38
39%description -l ja
40このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
41扱うことができ, Macintosh と通信が可能になります.
42Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
43稼働させることができるデーモンプログラムが収められています.
44
45
46%package devel
47Group:         Development/Libraries
48Summary:       Headers for AppleTalk development
49Summary(ja):   AppleTalk 開発用ヘッダファイル
50
51%description devel
52This package contains the header files for building AppleTalk networking
53programs.
54
55
56%prep
57%setup -q
58
59%patch10 -p1 -b .cjk-config
60
61
62%build
63touch AUTHORS
64ln -s NEWS ChangeLog
65rm -f README.cjk4.cjk
66
67libtoolize --force
68aclocal -I macros
69automake --add-missing
70autoconf
71autoheader
72CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
73./configure \
74        --prefix=%{_prefix} \
75        --libdir=%{_libdir} \
76        --libexecdir=%{_libdir}/netatalk \
77        --sysconfdir=%{_sysconfdir} \
78        --mandir=%{_mandir} \
79        --localstatedir=%{_var} \
80        --enable-shared \
81        --enable-zeroconf \
82        --disable-srvloc \
83        --enable-afp3 --disable-ddp \
84        --with-cnid-dbd-backend \
85        --with-cnid-cdb-backend \
86        --with-cnid-default-backend=dbd \
87        --with-uams-path=%{_libdir}/netatalk \
88        --enable-redhat \
89        --with-cracklib \
90        --with-pam \
91        --with-shadow \
92        --with-tcp-wrappers \
93        --with-ssl \
94        --enable-pgp-uam
95
96make all
97
98
99%install
100### INSTALL (USING "make install") ###
101rm -rf ${RPM_BUILD_ROOT}
102mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
103make DESTDIR=$RPM_BUILD_ROOT install
104
105## netatalk/at.h is now provided by glibc
106rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
107
108## for Bonjour (requires nss-mdns)
109#install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
110#install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
111
112
113%pre
114### COPY OLD PREFERENCE FILES ###
115
116if [ -d /etc/atalk ] ; then
117    mkdir -p /etc/netatalk/
118    cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
119fi
120exit 0
121
122
123%post
124
125### RUN CHKCONFIG ###
126/sbin/chkconfig --add netatalk
127
128/sbin/ldconfig
129
130if test -r /var/lock/atalkd ; then
131        /etc/rc.d/init.d/netatalk restart >&2
132fi
133
134
135%preun
136
137### RUN CHKCONFIG ###
138/sbin/chkconfig --del netatalk
139
140
141%triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
142/sbin/chkconfig --add netatalk
143
144
145%clean
146rm -rf ${RPM_BUILD_ROOT}
147
148
149%files
150%defattr(-,root,root)
151%doc AUTHORS CONTRIBUTORS COPYING COPYRIGHT
152%doc ChangeLog NEWS README* TODO
153%doc doc/[A-L,N-Z]*
154%config(noreplace) /etc/netatalk/Apple*
155%config(noreplace) /etc/netatalk/*.conf
156%config /etc/pam.d/netatalk
157%config /etc/rc.d/init.d/netatalk
158%dir %{_sysconfdir}/netatalk
159%dir %{_sysconfdir}/netatalk/msg
160#%{_sysconfdir}/avahi/services/afpd.service
161%{_bindir}/*
162%{_sbindir}/*
163%{_libdir}/netatalk/*
164%exclude %{_libdir}/netatalk/*.a
165%exclude %{_libdir}/netatalk/*.la
166%{_mandir}/*/*
167
168
169%files devel
170%defattr(-,root,root)
171%{_libdir}/*.a
172%{_libdir}/*.la
173%{_libdir}/netatalk/*.a
174%{_libdir}/netatalk/*.la
175%dir %{_includedir}/atalk
176%{_includedir}/atalk/*.h
177%dir %{_includedir}/netatalk
178%{_includedir}/netatalk/*.h
179%{_datadir}/aclocal/netatalk.m4
180
181
182%changelog
183* Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
184- now back from the upstream confusion (and one more or two...)
185  new upstream release 2.2.0 at the official site
186
187* Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
188- fix Patch10 to follow HAT-san's strong and confident objection
189  (no need to set ATALK_NAME explicitly in netatalk.conf)
190
191* Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
192- new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
193- add Source100 to add one missing header file in the tarball
194- revise Patch10
195- explicitly specify --disable-ddp for the first time
196
197* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
198- new upstream release
199
200* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
201- rebuild with openssl-1.0.0c
202
203* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
204- fix Patch10 & update description - upon HAT-san's suggestions
205
206* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
207- new upstream release
208- update Vine patch
209
210* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
211- new upstream release
212
213* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
214- new upstream release
215
216* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
217- rebuilt both for VineSeed / VinePlus-4.0
218
219* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
220- updated to the cjk-6 patch
221- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
222- Patch14 updated for db46
223
224* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
225- remove openslp dependency
226
227* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
228- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
229- TODO: remember to revise this fix after VineSeed changes default locale
230        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
231
232* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
233- revise description (thanks HAT-san for pointing this out)
234- run libtoolize/aclocal/auto{make,conf,header} before doing configure
235  (without this, uams_* modules won't get .so suffix)
236
237* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
238- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
239  (Patch10 now includes all the modifications and more fixes)
240
241* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
242- add patch13 and patch14 for db-4.3.
243- move files in %%_libexecdir to %%libdir.
244
245* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
246- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
247
248* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
249- security fix: added Patch10 (CAN-2004-0974)
250
251* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
252- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
253
254* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
255- updated to 2.0 with cjk patch
256  (see the above Patch section for details)
257
258* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
259- merge the patch repairing bug for System 7.5.5
260- (patch6 netatalk-1.5.3.oldsys.patch)
261- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
262- patch6 addupted no matter noeuc is, license GPL, URL in comment
263
264* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
265- euc and kana patch originally by
266- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
267- applied to netatalk-1.5.2 by me
268- README.vine
269- omit VERSION from doc, omit perl from require
270
271* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
272- this package is removed because the release number duplicated
273
274* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
275- move acleandir.rc to the doc directory, remove executable flag.
276
277* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
278- updated to new upstream release
279
280* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
281- added Japanese Summary for devel and corrected Group
282
283* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
284- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
285  (say atd.pid doesn't have anything to do with netatalk!!)
286
287* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
288- updated to new upstream release
289
290* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
291- install man pages into %%{_mandir}
292- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
293- let pre script exit 0
294
295* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
296- spec cleanup
297- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
298- restart atalk daemons in the %%post section
299
300* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
301 - v1.5.1.1-0vl1
302
303* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
304  - v1.5.0-0vl1
305  - release 1.5.0 for sourceforge
306
307* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
308  - v1.5pre6-1rh7
309  - pre-release 6 for sourceforge
310
311* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
312  - v1.5pre5-1
313  - pre-release 5 for sourceforge
314
315* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
316  - v1.5pre5-0
317  - pre-release 5 for sourceforge (prebuild)
318
319* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
320  - v1.5pre4-1
321  - pre-release 4 for sourceforge
322  - modified/split mandrake spec for redhat 7 build
323
324* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
325  - v1.5pre3-1mdk
326  - pre-release 3 for sourceforge
327  - moved away from 1.4.99 ...
328
329* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
330  - v1.4.99-0.20001108mdk
331  - pre-release 2 for sourceforge
332
333* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
334  - v1.4.99-0.20000927mdk
335  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.