source: projects/specs/branches/6/n/nemiver/nemiver-vl.spec @ 2143

Revision 2143, 5.0 KB checked in by kazutaka, 14 years ago (diff)

nemiver を新規追加

Line 
1%define build_vine5 0
2
3%if "%{?_dist_release}" == "vl5"
4%define build_vine5 1
5%endif
6
7Summary:        Standalone graphical debugger for GNOME
8Summary(ja):    GNOME 向けの GUI デバッガ
9Name:           nemiver
10Version:        0.8.0
11Release:        1%{?_dist_release}
12Source0:        %{name}-%{version}.tar.bz2
13Patch0:         nemiver-0.8.0-below-gtkmm2.18.0.patch
14License:        GPLv2
15Group:          Applications/Development
16URL:            http://projects.gnome.org/nemiver/
17
18Requires:       gdb
19Requires:       ghex > 2.21.4
20Requires(pre):  GConf2
21Requires(post): GConf2, desktop-file-utils, scrollkeeper
22Requires(postun):GConf2, desktop-file-utils, scrollkeeper
23BuildRequires:  ghex > 2.21.4
24BuildRequires:  gdb
25BuildRequires:  gnome-doc-utils >= 0.3.2
26BuildRequires:  gtkmm2-devel >= 2.14.0
27BuildRequires:  gtksourceviewmm-devel >= 1.9.4
28BuildRequires:  libgtop2-devel >= 2.14
29BuildRequires:  vte-devel >= 0.12.0
30BuildRequires:  GConf2-devel >= 2.14.0
31BuildRequires:  sqlite3-devel >= 3.0
32BuildRequires:  libboost-devel >= 1.33.1
33
34BuildRoot:      %{_tmppath}/%{name}-%{version}-root
35
36Packager:       kazutaka
37
38%description
39Nemiver is a standalone graphical debugger that integrates well in the
40GNOME desktop environment.  It currently features a backend which uses
41the GNU debugger GDB for debugging C/C++ programs.
42
43%description -l ja
44Nemiver は GNOME デスクトップ向けのスタンドアローンな GUI デバッガです。
45C/C++ プログラムのデバッグのバックエンドには GDB (GNU デバッガ)を利用
46しています。
47
48%package devel
49Summary:        Libraries and headers for %{name}
50Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
51Group:          Development/Libraries
52Requires:       %{name} = %{version}
53
54%description devel
55This package includes the files needed for developing and compiling
56applications which use the %{name} library.
57
58You should install the %{name}-devel package if you would like to
59develop applications using %{name}.
60
61%description devel -l ja
62このパッケージは %{name} ライブラリを使用するアプリケーションを開発
63するのに必要なライブラリやヘッダファイルを含んでいます。
64
65%{name} を使用したアプリケーションを開発するなら、このパッケージ
66をインストールしてください。
67
68%prep
69%setup -q
70%if %{build_vine5}
71%patch0 -p1 -b .below-gtkmm218
72%endif
73
74%build
75%configure --disable-static \
76           --disable-scrollkeeper \
77           --disable-schemas-install
78
79%{__make} %{?_smp_mflags}
80
81
82%install
83%{__rm} -rf $RPM_BUILD_ROOT
84%{__make} install DESTDIR=$RPM_BUILD_ROOT
85%find_lang %{name}
86
87# remove unnecessary files
88find $RPM_BUILD_ROOT/%{_libdir} -name "*.la" -exec %{__rm} -f "{}" \;
89
90
91%clean
92%{__rm} -rf $RPM_BUILD_ROOT
93
94
95%pre
96# uninstall old schemas before update
97if [ "$1" -gt 1 ]; then
98  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
99  SCHEMAS="nemiver-dbgperspective.schemas nemiver-workbench.schemas"
100  for S in $SCHEMAS; do
101    echo %{_sysconfdir}/gconf/schemas/$S ; done \
102    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
103fi
104
105%post
106update-desktop-database %{_datadir}/applications >& /dev/null ||:
107scrollkeeper-update > /dev/null 2>&1 || :
108touch --no-create %{_datadir}/icons/hicolor
109if [ -x /usr/bin/gtk-update-icon-cache ]; then
110  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
111fi
112
113# install schemas after install/update
114export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
115SCHEMAS="nemiver-dbgperspective.schemas nemiver-workbench.schemas"
116for S in $SCHEMAS; do
117  echo %{_sysconfdir}/gconf/schemas/$S ; done \
118  | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
119
120%preun
121# uninstall schemas before clean remove
122if [ "$1" -eq 0 ]; then
123  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
124  SCHEMAS="nemiver-dbgperspective.schemas nemiver-workbench.schemas"
125  for S in $SCHEMAS; do
126    echo %{_sysconfdir}/gconf/schemas/$S ; done \
127    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
128fi
129
130%postun
131update-desktop-database %{_datadir}/applications >& /dev/null ||:
132scrollkeeper-update > /dev/null 2>&1 || :
133touch --no-create %{_datadir}/icons/hicolor
134if [ -x /usr/bin/gtk-update-icon-cache ]; then
135  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
136fi
137
138
139%files -f %{name}.lang
140%defattr(-,root,root)
141%doc AUTHORS COPYING COPYRIGHT ChangeLog INSTALL NEWS
142%doc README TODO
143%{_bindir}/%{name}
144%{_libdir}/%{name}
145%{_datadir}/%{name}
146%{_datadir}/applications/%{name}.desktop
147%{_datadir}/icons/hicolor/16x16/apps/%{name}.png
148%{_datadir}/icons/hicolor/22x22/apps/%{name}.png
149%{_datadir}/icons/hicolor/24x24/apps/%{name}.png
150%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
151%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
152%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
153%{_datadir}/gnome/help/%{name}
154%{_datadir}/omf/%{name}
155%{_mandir}/man1/nemiver.1*
156%{_sysconfdir}/gconf/schemas/nemiver-dbgperspective.schemas
157%{_sysconfdir}/gconf/schemas/nemiver-workbench.schemas
158
159%files devel
160%{_includedir}/%{name}
161
162
163%changelog
164* Sun Oct 24 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.0-1
165- initial build for Vine Linux
166- add patch0 to fix compile error with gtkmm-2.14 (for Vine Linux 5)
Note: See TracBrowser for help on using the repository browser.