source: projects/specs/branches/6/n/neXtaw/neXtaw-vl.spec @ 521

Revision 521, 4.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define For_Vine 1
2%define sversion 0.15.1
3%define srelease 1
4Name: neXtaw
5Version: %{sversion}
6Source0: http://siag.nu/pub/neXtaw/neXtaw-%{sversion}.tar.gz
7# Patch0: neXtaw-0.11.glibc22x.time.h
8License: distributable
9Packager: Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
10Group: System Environment/Libraries
11Summary: N*XTStep-ish replacement library for Xaw
12Summary(ja): N*XTライクなAthenaウィジェット
13URL: http://www.siag.nu/neXtaw/
14Icon: AFstep.gif
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16Prefix: %{_prefix}
17
18%if %{For_Vine}
19Release: %{srelease}%{?_dist_release}
20Vendor: Project Vine
21Distribution: Vine Linux
22%else
23Release: %{srelease}
24%endif
25
26# NoSource: 0
27
28%description
29neXtaw is a modified version of the Athena Widgets with a N*XTStep look. Goes
30great with a nice tall glass of Afterstep!
31This RPM contains the shared libraries.
32
33%description -l ja
34Athenaウィジェットを使ったアプリケーションの外観をN*XTSTEPのように変えます。
35利用するには、プログラムを修正してneXtawのライブラリを明示的にリンクし、
36/usr/doc/neXtaw-*/Xdefaults を各自の ~/.Xdefaults あるいは ~/.Xresources に
37追加する必要があります。
38このパッケージには、shared library が納められています。
39
40%package devel
41Summary: Files for developing programs that use neXtaw
42Group: Development/Libraries
43Requires: %name = %{PACKAGE_VERSION}
44
45%description devel
46neXtaw is a modified version of the Athena Widgets with a N*XTStep look.
47This RPM contains all of the fun things that you'll need to compile things
48with neXtaw.
49
50%description devel -l ja
51Athenaウィジェットを使ったアプリケーションの外観をN*XTSTEPのように変えます。
52このパッケージには、neXtaw を用いたプログラムのコンパイルに必要なファイル
53群が納められています。
54
55%prep
56%setup -q
57# %patch0 -p1
58
59%build
60if [ -x /usr/bin/getconf ] ; then
61    NRPROC=$(/usr/bin/getconf _NPROCESSORS_ONLN)
62    if [ $NRPROC -eq 0 ] ; then
63        NRPROC=1
64    fi
65    if [ $NRPROC -gt 1 ] ; then
66        NRPROC=2
67    fi
68else
69    NRPROC=1
70fi
71
72CFLAGS=${RPM_OPT_FLAGS} ./configure \
73        --prefix=%{prefix} \
74        --libdir=%{_libdir} \
75        --sysconfdir=%{_sysconfdir} \
76        --mandir=%{_mandir}
77
78make -j $NRPROC MAKE="make -j $NRPROC"
79
80%install
81rm -rf $RPM_BUILD_ROOT
82make DESTDIR="$RPM_BUILD_ROOT" install
83ln -s ./X11/neXtaw $RPM_BUILD_ROOT%{prefix}/include/neXtaw
84
85%post
86/sbin/ldconfig
87
88%postun
89/sbin/ldconfig
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(-,root,root)
96%doc README doc/README.XAW3D doc/CHANGES doc/FAQ  doc/TODO doc/app-defaults
97%{prefix}/%{_lib}/libneXtaw.so*
98
99%files devel
100%defattr(-,root,root)
101%{prefix}/%{_lib}/libneXtaw.a
102#%{prefix}/lib/libneXtaw.la
103%{prefix}/include/neXtaw
104%{prefix}/include/X11/neXtaw/
105
106%changelog
107* Wed Oct 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.15.1-1vl5
108- applied new versioning policy, spec in utf-8
109- removed *.la
110- modified library-path
111
112* Sun Nov 19 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
113- 0.15.1-0vl1
114- build for VinePlus 4.0
115
116* Sat Nov 11 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
117- 0.15.1-0vl0.32
118- new upstream release
119- build for VinePlus 3.2
120
121* Sun Aug 03 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
122- 0.14-0vl4
123- rebuild for VineSeed Plus
124
125* Sun Jun 22 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
126- 0.14-0vl3
127- fix typo in changelog
128
129* Sun Jun 22 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
130- 0.14-0vl2
131- fix typo in changelog
132- remove rpm macros (distribution, vender) from build env
133- add Vendor, Distribution tags for VinePlus
134
135* Fri Apr 12 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
136- 0.14-0vl1
137- update source
138* Fri May 03 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
139- 0.12-0vl1 / 0.12-1
140- update source
141- remove patch (neXtaw-0.11.glibc22x.time.h)
142* Mon Feb 11 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
143- 0.11-0vl1 / 0.11-1
144- update source
145- update patch (neXtaw-0.11.glibc22x.time.h)
146- update URL
147- remove neXtaw-neXtclock package
148* Tue Jan 01 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
149- 0.9-0vl4 / 0.9-4
150- enable neXtaw.glibc22x.time.h patch for glibc 2.2.x
151* Sun Nov 25 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
152- 0.9-0vl3 / 0.9-3
153- add switch For VineLinux
154* Wed Nov 14 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
155- 0.9-0vl2
156- fix files list
157* Wed Nov 14 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
158- 0.9-0vl1
159- This package based neXtaw-0.9-8k.nosrc.rpm (Kondara)
160
Note: See TracBrowser for help on using the repository browser.