source: projects/specs/branches/6/n/ncurses/ncurses-vl.spec @ 521

Revision 521, 18.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A CRT screen handling and optimization package.
2Summary(ja): CRT スクリーンの操作と最適化を行うパッケージ
3Name: ncurses
4Version: 5.6
5%define includedirw %{_includedir}/ncursesw
6%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
7Release: 4%{?_dist_release}
8License: distributable
9Group: System Environment/Libraries
10URL: http://dickey.his.com/ncurses/ncurses.html
11Source0: ftp://dickey.his.com/ncurses/ncurses-%{version}.tar.gz
12Source2: ncurses-linux
13Source3: ncurses-linux-m
14Source4: ncurses-resetall.sh
15Patch1: ncurses-5.6-20080621-patch.sh.bz2
16Patch2: ncurses-5.6-20080628.patch.gz
17Patch3: ncurses-5.6-20080705.patch.gz
18Patch4: ncurses-5.6-20080712.patch.gz
19Patch5: ncurses-5.6-20080713.patch.gz
20Patch6: ncurses-5.6-20080726.patch.gz
21
22Patch10: ncurses-5.5-20061209-config.patch
23Patch11: ncurses-5.6-20070612-libs.patch
24Patch12: ncurses-5.6-20080112-xterm.patch
25Patch13: ncurses-5.6-20080112-urxvt.patch
26Patch14: ncurses-5.6-20080628-kbs.patch
27
28Requires(post): /sbin/ldconfig
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35The curses library routines are a terminal-independent method of
36updating character screens with reasonable optimization.  The ncurses
37(new curses) library is a freely distributable replacement for the
38discontinued 4.4 BSD classic curses library.
39
40
41%package devel
42Summary: The development files for applications which use ncurses.
43Summary(ja): ncurses を用いるアプリケーション開発用のファイル
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Obsoletes: libtermcap-devel <= 2.0.8-46vl1
47Provides: libtermcap-devel = 2.0.8-47
48
49%description devel
50The header files and libraries for developing applications that use
51the ncurses CRT screen handling and optimization package.
52
53Install the ncurses-devel package if you want to develop applications
54which will use ncurses.
55
56Use the following compiler flags to build against the ncurses library:
57                                                                               
58-lncurses
59(compile and link against the regular ncurses library)
60                                                                               
61-I %{includedirw} -lncursesw
62(compile and link against the wide-character, UTF-8, library)
63
64
65%package c++-devel
66Summary: C++ bindings to ncurses
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69Requires: %{name}-devel = %{version}-%{release}
70 
71%description c++-devel
72C++ bindings to ncurses
73
74
75%package -n compat32-%{name}
76Summary: A CRT screen handling and optimization package.
77Summary(ja): CRT スクリーンの操作と最適化を行うパッケージ
78Group: System Environment/Libraries
79Requires: %{name} = %{version}-%{release}
80
81%description -n compat32-%{name}
82The curses library routines are a terminal-independent method of
83updating character screens with reasonable optimization.  The ncurses
84(new curses) library is a freely distributable replacement for the
85discontinued 4.4 BSD classic curses library.
86
87
88%package -n compat32-%{name}-devel
89Summary: The development files for applications which use ncurses.
90Summary(ja): ncurses を用いるアプリケーション開発用のファイル
91Group: Development/Libraries
92Requires: compat32-%{name} = %{version}-%{release}
93Requires: %{name}-devel = %{version}-%{release}
94Obsoletes: compat32-libtermcap-devel <= 2.0.8-46vl1
95Provides: compat32-libtermcap-devel = 2.0.8-47
96
97%description -n compat32-%{name}-devel
98The header files and libraries for developing applications that use
99the ncurses CRT screen handling and optimization package.
100
101Install the ncurses-devel package if you want to develop applications
102which will use ncurses.
103
104Use the following compiler flags to build against the ncurses library:
105                                                                               
106-lncurses
107(compile and link against the regular ncurses library)
108                                                                               
109-I %{includedirw} -lncursesw
110(compile and link against the wide-character, UTF-8, library)
111
112
113%package -n compat32-%{name}-c++-devel
114Summary: C++ bindings to ncurses
115Group: System Environment/Libraries
116Requires: compat32-%{name} = %{version}-%{release}
117Requires: compat32-%{name}-devel = %{version}-%{release}
118Requires: %{name}-c++-devel = %{version}-%{release}
119 
120%description -n compat32-%{name}-c++-devel
121C++ bindings to ncurses
122
123
124%prep
125%setup -q
126%patch1 -p1
127%patch2 -p1
128%patch3 -p1
129%patch4 -p1
130%patch5 -p1
131%patch6 -p1
132
133%patch10 -p1
134%patch11 -p1
135%patch12 -p1
136%patch13 -p1
137%patch14 -p1
138
139find . -name "*.orig" -exec rm -f {} \;
140
141
142%build
143CFLAGS="%{optflags} -DPURE_TERMINFO -DSVR4_CURSES"
144%define optflags $CFLAGS
145                                                                               
146%define rootdatadir /lib
147%define ncurses_options \\\
148    --with-shared --without-ada --with-ospeed=unsigned \\\
149    --enable-hard-tabs --enable-xmc-glitch --enable-colorfgbg \\\
150    --with-terminfo-dirs=%{_sysconfdir}/terminfo:%{_datadir}/terminfo:%{rootdatadir}/terminfo \\\
151    --enable-overwrite \\\
152    --with-termlib=tinfo \\\
153    --with-chtype=long
154
155mkdir narrowc widec
156cd narrowc
157ln -s ../configure .
158%configure %{ncurses_options} --with-ticlib
159make %{?_smp_mflags} libs
160make %{?_smp_mflags} -C progs
161
162cd ../widec
163ln -s ../configure .
164%configure %{ncurses_options} --enable-widec --without-progs
165make %{?_smp_mflags} libs
166cd ..
167
168
169%install
170rm -rf ${RPM_BUILD_ROOT}
171
172make -C narrowc DESTDIR=$RPM_BUILD_ROOT install.{libs,progs,data}
173rm -f $RPM_BUILD_ROOT%{_libdir}/libtinfo.*
174make -C widec DESTDIR=$RPM_BUILD_ROOT install.{libs,includes,man}
175
176chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*.*
177chmod 644 ${RPM_BUILD_ROOT}%{_libdir}/lib*.a
178
179# move lib{ncurses{,w},tinfo}.so.* to /lib*
180mkdir $RPM_BUILD_ROOT/%{_lib}
181mv $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so.* $RPM_BUILD_ROOT/%{_lib}
182for l in $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so; do
183    ln -sf $(echo %{_libdir} | \
184        sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
185done
186
187mkdir -p $RPM_BUILD_ROOT{%{rootdatadir},%{_sysconfdir}}/terminfo
188
189# move few basic terminfo entries to /lib
190baseterms=
191for termname in \
192        ansi dumb linux vt100 vt100-nav vt102 vt220 vt52
193do
194    for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo \
195        -samefile $RPM_BUILD_ROOT%{_datadir}/terminfo/${termname::1}/$termname)
196    do
197        baseterms="$baseterms $(basename $t)"
198    done
199done
200for termname in $baseterms; do
201    termpath=terminfo/${termname::1}/$termname
202    mkdir $RPM_BUILD_ROOT%{rootdatadir}/terminfo/${termname::1} &> /dev/null || :
203    mv $RPM_BUILD_ROOT%{_datadir}/$termpath $RPM_BUILD_ROOT%{rootdatadir}/$termpath
204    ln -s $(dirname %{_datadir}/$termpath | \
205        sed 's,\(^/\|\)[^/][^/]*,..,g')%{rootdatadir}/$termpath \
206        $RPM_BUILD_ROOT%{_datadir}/$termpath
207done
208
209# prepare -base and -term file lists
210for termname in \
211    Eterm cons25 cygwin gnome* hurd jfbterm mach* mlterm mrxvt \
212    nsterm putty* pcansi rxvt rxvt-\* screen screen-\* screen.* \
213    sun teraterm wsvt25* xfce xterm xterm-\*
214do
215    for i in $RPM_BUILD_ROOT%{_datadir}/terminfo/?/$termname; do
216        for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo -samefile $i); do
217            baseterms="$baseterms $(basename $t)"
218        done
219    done
220done 2> /dev/null
221for t in $baseterms; do
222    echo "%dir %{_datadir}/terminfo/${t::1}"
223    echo %{_datadir}/terminfo/${t::1}/$t
224done 2> /dev/null | sort -u > terms.base
225find $RPM_BUILD_ROOT%{_datadir}/terminfo \! -type d | \
226    sed "s|^$RPM_BUILD_ROOT||" | while read t
227do
228    echo "%dir $(dirname $t)"
229    echo $t
230done 2> /dev/null | sort -u | comm -2 -3 - terms.base > terms.term
231
232cat terms.base terms.term |sort -u > terms.all
233
234# can't replace directory with symlink (rpm bug), symlink all headers
235mkdir $RPM_BUILD_ROOT%{_includedir}/ncurses{,w}
236for l in $RPM_BUILD_ROOT%{_includedir}/*.h; do
237    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncurses
238    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncursesw
239done
240
241rm -f $RPM_BUILD_ROOT%{_libdir}/libcurses{,w}.so
242echo "INPUT(-lncurses)" > $RPM_BUILD_ROOT%{_libdir}/libcurses.so
243echo "INPUT(-lncursesw)" > $RPM_BUILD_ROOT%{_libdir}/libcursesw.so
244
245echo "INPUT(-ltinfo)" > $RPM_BUILD_ROOT%{_libdir}/libtermcap.so
246
247rm -f ${RPM_BUILD_ROOT}%{_libdir}/terminfo
248
249
250%post -p /sbin/ldconfig
251
252%postun -p /sbin/ldconfig
253
254%post -n compat32-%{name} -p /sbin/ldconfig
255
256%postun -n compat32-%{name} -p /sbin/ldconfig
257
258
259%files -f terms.all
260%defattr(-,root,root)
261%doc ANNOUNCE AUTHORS README TO-DO
262%{_bindir}/[cirt]*
263%{_mandir}/man1/*
264%{_mandir}/man5/*
265%{_mandir}/man7/*
266/%{_lib}/lib*.so.*
267%{_libdir}/lib*.so.*
268%dir %{_sysconfdir}/terminfo
269%{rootdatadir}/terminfo
270%{_datadir}/tabset
271%dir %{_datadir}/terminfo
272
273%files devel
274%defattr(-,root,root)
275%doc test
276%doc doc/html/hackguide.html
277%doc doc/html/ncurses-intro.html
278%doc c++/README*
279%{_bindir}/ncurses*-config
280%{_libdir}/lib*.so
281%{_libdir}/lib*.a
282 %dir %{_includedir}/ncurses
283%dir %{_includedir}/ncursesw
284%{_includedir}/ncurses/*.h
285%{_includedir}/ncursesw/*.h
286%{_includedir}/*.h
287%{_mandir}/man3/*
288 
289
290%files c++-devel
291%defattr(-,root,root)
292%doc c++/NEWS c++/PROBLEMS c++/README*
293%{_includedir}/ncurses/cursesapp.h
294%{_includedir}/ncurses/curses?.h
295%{_includedir}/ncurses/etip.h
296%{_libdir}/libncurses++.a
297 
298%{_libdir}/libncurses++w.a
299
300
301%if %{build_compat32}
302%files -n compat32-%{name}
303%defattr(-,root,root)
304%attr(755,root,root) %{_libdir}/lib*.so.*
305/%{_lib}/lib*.so.*
306%{_libdir}/lib*.so.*
307
308
309%files -n compat32-%{name}-devel
310%defattr(-,root,root)
311%{_libdir}/lib*.so
312%{_libdir}/lib*.a
313 
314
315%files -n compat32-%{name}-c++-devel
316%defattr(-,root,root)
317%{_libdir}/libncurses++.a
318%{_libdir}/libncurses++w.a
319%endif
320
321
322%clean
323rm -rf $RPM_BUILD_ROOT
324
325
326%changelog
327* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.6-4
328- rebuilt with new toolchain
329- add Requires(post,pre): /sbin/ldconfig
330
331* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.6-3
332- updated %%files section on compat32-* packages
333
334* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.6-2
335- changed c++-devel Group to Development/Libraries
336- changelog of 5.6-1 is missing... seemed to be updated on Aug 10 2008
337
338* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 5.4-0vl3
339- added compat32- packages for x86_64 architecture support
340
341* Mon May 17 2004 Tomoya TAKA <taka@vinelinux.org> 5.4-0vl2
342- add patch10 taken from fedora's 5.4-4
343
344* Sun May  9 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4-0vl1
345- new upstream release
346- remove obsolete patches
347
348* Mon Mar 22 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.3-9vl1
349- synced up with Fedora 5.3-9
350  - Thu Sep 11 2003 Adrian Havill <havill@redhat.com> 5.3-9
351  - remove not-so safe-sprintf configure option because the code does
352    not appear to be stable enough for some apps. (#103790)
353 
354  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8.1
355  - RHEL bump
356 
357  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8
358  - multilib patch (#91211)
359 
360  - Mon Aug 11 2003 Adrian Havill <havill@redhat.com> 5.3-7
361  - fixed the safe sprintf code that was enabled in the previous release
362    by the configure parameter. (#101486)
363 
364  - Mon Jun 16 2003 Elliot Lee <sopwith@redhat.com> 5.3-6.1
365  - Fix ac25 patch, make it easy to turn off GPM support
366 
367  - Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
368  - rebuilt
369 
370  - Thu May 22 2003 Adrian Havill <havill@redhat.com> 5.3-5
371  - added latest rollup patch with widec/UTF8 centric weekly (20030517)
372  - added --enable-widec to configure (#86311)
373    original work done by Mr. Sam <sam@email-scan.com>
374  - require sharutils (#86605)
375  - add gpm, xmc support
376  - add debug syms back into package
377  - updated autoconf/configure patch
378
379* Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.3-4vl1
380- synced Rawhide 5.3-4
381
382* Fri Feb 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl2
383- revert to patch13 from 14 for XF86-4
384
385* Wed Feb 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl1
386- synced Rawhide 5.2-16
387
388* Tue Aug 28 2001 Shoji Matsumoto <shom@vinelinux.org> 5.2-12vl2
389- patch 3 (xterm) disabled. this patch is for XF86-4???
390
391* Wed Aug 22 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-12vl1
392- added kon patch for Vine
393
394* Fri Jul 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-12
395- Sync terminfo with termcap 11.0.1-10
396
397* Sun Jun 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-11
398- Update to patchlevel 20010623, fixes some lynx issues
399 
400* Mon Jun 18 2001 Helge Deller <hdeller@redhat.de>
401- fixed tput -S segfaulting bug (#44669)
402- use _tmppath for BuildRoot:
403- Copyright -> License
404
405* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
406- Update to patchlevel 20010407
407
408* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
409- Fix up some terminfo entries containing includes to
410  "/var/tmp/ncurses-root/something" (#30771)
411
412* Wed Feb 22 2001 Harald Hoyer <harald@redhat.de>
413- fixed rxvt backspace setting
414
415* Fri Feb  9 2001 Yukihiro Nakai <ynakai@redhat.com>
416- Update Japanese kterm patch
417
418* Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
419- Update
420- Add japanese patch from termcap
421- Fix ospeed handling
422
423* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
424- Add libcurses.a -> libncurses.a symlink (RFE #23023)
425
426* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
427- Use --with-ospeed='unsigned int'
428
429* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
430- Fix alpha and ia64
431- Rebuild with gcc 2.96-64
432
433* Thu Nov  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
434- 5.2
435- Fix typo in man page (Bug #20205)
436- update the "screen" terminfo entries to the version supplied with
437  screen 3.9.8
438
439* Mon Oct  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
440- Update (fixes the "make menuconfig" bug introduced by the security fix)
441
442* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
443- Fix security problem (possible buffer overrun)
444
445* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
446- Add the bugfix patches from the ncurses maintainer
447
448* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
449- 5.1
450
451* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
452- automatic rebuild
453
454* Mon Jun  5 2000 Matt Wilson <msw@redhat.com>
455- *don't ship symlinks from lib*.so.5 to lib*.so.4!
456- use FHS macros
457
458* Fri Jun  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
459- rebuild for 7.0
460- /usr/share/man
461- update URL for patches
462- misc. fixes to spec file
463
464* Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
465- use the real library version number
466- update to 20000319
467
468* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
469- rebuild for sparc baud rates > 38400.
470
471* Fri Feb 18 2000 Preston Brown <pbrown@redhat.com>
472- xterm terminfo entries from XFree86 3.3.6
473- final round of xterm fixes, follow debian policy.
474
475* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
476- strip libraries
477
478* Thu Feb  3 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
479- More xterm fixes (Bug #9087)
480
481* Thu Jan 27 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
482- More xterm fixes from Hans de Goede (Bug #8633)
483
484* Sat Jan 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
485- remove some broken symlinks (leftovers from libncurses.so.5)
486- Use %configure (Bug #8484)
487
488* Tue Jan 11 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
489- Add xterm patch from Hans de Goede <hans@highrise.nl>
490- Patch 20000108, this fixes a problem with a header file.
491
492* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
493- Add 20000101 patch, hopefully finally fixing the xterm description
494
495* Wed Dec 22 1999 Cristian Gafton <gafton@redhat.com>
496- revert to the old major number - because the ABI is not changed (and we
497  should be handling the changes via symbol versioning anyway)
498
499* Fri Nov 12 1999 Bernhard Rosenkraenzer <bero@redhat.com>
500- Fix a typo in spec
501- Add the 19991006 patch, fixing some C++ STL compatibility problems.
502- get rid of profiling and debugging versions - we need to save space...
503
504* Thu Nov  4 1999 Bernhard Rosenkraenzer <bero@redhat.com>
505- 5.0
506- some spec cleanups to make updating easier
507- add links *.so.5 to *.so.4 - they are fully binary compatible.
508  (Why did they change the invocation number???)
509
510* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
511- make clean in the test dir - don't ship any binaries at all.
512
513* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
514- fixed stripping of test programs.
515
516* Sun Aug 29 1999 Preston Brown <pbrown@redhat.com>
517- removed 'flash' capability for xterm; see bug #2820 for details.
518
519* Fri Aug 27 1999 Cristian Gafton <gafton@redhat.com>
520- add the resetall script from Marc Merlin <marc@merlins.org>
521
522* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
523- added iris-ansi-net as alias for iris-ansi (bug #2561)
524
525* Fri Jul 30 1999 Michael K. Johnson <johnsonm@redhat.com>
526- added ncurses-intro.hmtl and hackguide.html to -devel package [bug #3929]
527
528* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
529- make sure ALL binaries are stripped (incl. test binaries)
530
531* Thu Mar 25 1999 Preston Brown <pbrown@redhat.com>
532- made xterm terminfo stuff MUCH better.
533
534* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
535- auto rebuild in the new build environment (release 16)
536
537* Sat Mar 13 1999 Cristian Gafton <gafton@redhat.com>
538- fixed header for C++ compiles
539
540* Fri Mar 12 1999 Jeff Johnson <jbj@redhat.com>
541- add terminfo entries for linux/linux-m on sparc (obsolete termfile_sparc).
542
543* Thu Feb 18 1999 Cristian Gafton <gafton@redhat.com>
544- updated patchset from original site
545
546* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
547- don't build the C++ demo code
548- update patch set to the current as of today (redid all the individual
549  patches in a single one)
550
551* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
552- make sure to strip the binaries
553
554* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
555- added another zillion of patches. The spec file *is* ugly
556- defattr
557
558* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
559- added lots of patches. This spec file is starting to look ugly
560
561* Wed Jul 01 1998 Alan Cox <alan@redhat.com>
562- Fix setuid trusting. Open termcap/info files as the real user.
563
564* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
565- added terminfo entry for the poor guys using lat1 and/or lat-2 on their
566  consoles... Enjoy linux-lat ! Thanks, Erik !
567
568* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
569- new patch to get xterm-color and nxterm terminfo entries
570- aliased them to rxvt, as that seems to satisfy everybody
571
572* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
573- added %clean section
574
575* Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
576- removed /usr/lib/terminfo symlink - we shouldn't need that
577
578* Mon Apr 06 1998 Cristian Gafton <gafton@redhat.com>
579- updated to 4.2 + patches
580- added BuildRoot
581
582* Sat Apr 04 1998 Cristian Gafton <gafton@redhat.com>
583- rebuilt with egcs on alpha
584
585* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
586- version 7 didn't rebuild properly on the Alpha somehow -- no real changes
587  are in this version
588
589* Tue Dec 09 1997 Erik Troan <ewt@redhat.com>
590- TIOCGWINSZ wasn't used properly
591
592* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
593- built against glibc, linked shared libs against -lc
594
Note: See TracBrowser for help on using the repository browser.