source: projects/specs/branches/6/n/ncompress/ncompress-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Fast compression and decompression utilities.
2Summary(ja): 高速なファイル圧縮/展開ユーティリティ
3Name: ncompress
4Version: 4.2.4
5Release: 45%{?_dist_release}
6License: Public Domain
7Group: Applications/Archiving
8Source: ftp://metalab.unc.edu/pub/Linux/utils/compress/ncompress-%{version}.tar.Z
9Patch0: ncompress-4.2.4-make.patch
10Patch1: ncompress-4.2.4-lfs2.patch
11Patch2: ncompress-4.2.4-filenamelen.patch
12Patch3: ncompress-2GB.patch
13Patch4: ncompress-4.2.4-zerobyteforce.patch
14Patch5: ncompress-4.2.4-bssUnderflow.patch
15Patch6: ncompress-4.2.4-endians.patch
16BuildRequires: gcc glibc-devel fileutils
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19
20%description
21The ncompress package contains the compress and uncompress file
22compression and decompression utilities, which are compatible with the
23original UNIX compress utility (.Z file extensions).  These utilities
24can't handle gzipped (.gz file extensions) files, but gzip can handle
25compressed files.
26
27Install ncompress if you need compression/decompression utilities
28which are compatible with the original UNIX compress utility.
29
30%description -l ja
31ncompress パッケージには compress と uncompress という
32ファイル圧縮/展開ユーティリティが含まれています.
33このユーティリティはオリジナルの UNIX で使われる
34compress ユーティリティ (ファイル拡張子 .Z) と互換性があります.
35gzip で圧縮されたファイル (ファイル拡張子 .gz) は扱うことが
36出来ませんが,逆に gzip は compress で圧縮されたファイルを
37扱うことが出来ます.
38
39オリジナルの UNIX の compress ユーティリティと互換性のある
40ファイル圧縮/展開ユーティリティが必要ならこの ncompress を
41インストールして下さい.
42
43
44%prep
45%setup -q
46%patch0 -p1
47%patch1 -p1 -b .lfs
48%patch2 -p1 -b .filenamelen
49%patch3 -p1 -b .2GB
50%patch4 -p1 -b .zerobyteforce
51%patch5 -p1 -b .bssUnderflow
52%patch6 -p1 -b .endians
53
54%build
55
56export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
57ENDIAN=4321
58
59%ifarch sparc m68k armv4l ppc s390 s390x ppc64 sparc64
60ENDIAN=1234
61%endif
62
63%ifarch alpha ia64
64export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -DNOALLIGN=0"
65%endif
66
67make RPM_OPT_FLAGS="$RPM_OPT_FLAGS" ENDIAN="$ENDIAN"
68
69%install
70rm -rf $RPM_BUILD_ROOT
71mkdir -p $RPM_BUILD_ROOT%{_bindir}
72mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
73
74
75install -m755 compress $RPM_BUILD_ROOT%{_bindir}
76ln -sf compress $RPM_BUILD_ROOT%{_bindir}/uncompress
77install -m644 compress.1 $RPM_BUILD_ROOT%{_mandir}/man1
78ln -sf compress.1 $RPM_BUILD_ROOT%{_mandir}/man1/uncompress.1
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(-,root,root)
85/usr/bin/compress
86/usr/bin/uncompress
87%{_mandir}/man1/*
88%doc LZW.INFO README
89
90%changelog
91* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4-45
92- applied new versioning policy
93- added Patch5 and 6 from Fedora 4.2.4-50
94  * Tue Sep 19 2006 Peter Vrabec <pvrabec@redhat.com> 4.2.4-46
95  - fix endian problem (#207001)
96  * Thu Aug 10 2006 Peter Vrabec <pvrabec@redhat.com> 4.2.4-45
97  - fix bss buffer underflow CVE-2006-1168 (#201919)
98- spec in UTF-8
99
100* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4-44vl2
101- changed Group to Applications/Archiving
102
103* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4-44vl1
104- added Patch3 and 4 from Fedora development
105  * Fri Apr 21 2006 Peter Vrabec <pvrabec@redhat.com> 4.2.4-44
106  - fix problems with compressing zero-sized files (#189215, #189216)
107  * Thu Sep 22 2005 Peter Vrabec <pvrabec@redhat.com> 4.2.4-43
108  - compress zero-sized files when -f is used(#167615)
109  * Tue Oct 05 2004 Than Ngo <than@redhat.com> 4.2.4-40
110  - permit files > 2GB to be compressed (#126775).
111
112* Tue Apr  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.2.4-31vl2
113- rebuild
114
115* Fri Dec 06 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.4-31vl1
116- based on 4.2.4-31 from Rawhide and built for Vine Linux
117- added Japanese summary and description
118
119* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
120- automated rebuild
121
122* Wed Jun 19 2002 Trond Eivind Glomsr <teg@redhat.com> 4.2.4-30
123- Don't strip when installing
124
125* Thu May 23 2002 Tim Powers <timp@redhat.com>
126- automated rebuild
127
128* Wed Feb 27 2002 Trond Eivind Glomsr <teg@redhat.com> 4.2.4-28
129- Rebuild
130
131* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
132- automated rebuild
133
134* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 4.2.4-26
135- Rebuild, to fix problem with broken man page (#56654)
136
137* Wed Nov 21 2001 Trond Eivind Glomsr <teg@redhat.com> 4.2.4-25
138- Exit, don't segfault, when given too long filenames
139
140* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
141- s390x change
142
143* Tue May  8 2001 Trond Eivind Glomsr <teg@redhat.com>
144- Make it support large files (structs, stats, opens and of course:
145  _don't use signed longs for file size before and after compression_.)
146  This should fix #39470
147
148* Thu Apr 26 2001 Florian La Roche <Florian.LaRoche@redhat.de>
149- add s390x, patch from Oliver Paukstadt <oliver.paukstadt@millenux.com>
150
151* Mon Nov 13 2000 Oliver Paukstadt <oliver.paukstadt@millenux.com>
152- add s390 to the bigendian arch list
153
154* Thu Aug 17 2000 Trond Eivind Glomsr <teg@redhat.com>
155- change category to Applications/File, to match
156  gzip and bzip2
157- rename the spec file to ncompress.spec
158- add ppc to the bigendian arch list
159
160* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
161- rebuild
162
163* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
164- automatic rebuild
165
166* Tue Jun 13 2000 Trond Eivind Glomsr <teg@redhat.com>
167- update URL
168- use %%{_mandir}
169
170* Wed May  5 2000 Bill Nottingham <notting@redhat.com>
171- fix %build for ia64
172
173* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
174- handle compressed manpages
175
176* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
177- auto rebuild in the new build environment (release 14)
178
179* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
180- build on armv4l too
181- build for 6.0
182
183* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
184- build root
185
186* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
187- translations modified for de, fr, tr
188
189* Wed Oct 21 1997 Cristian Gafton <gafton@redhat.com>
190- fixed the spec file
191
192* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
193- built against glibc
Note: See TracBrowser for help on using the repository browser.