source: projects/specs/branches/6/n/nas/nas-vl.spec @ 6246

Revision 6246, 8.7 KB checked in by inagaki, 12 years ago (diff)

update: espeak, kdepim3, nas, xplanet

Line 
1Name:           nas     
2Summary:        The Network Audio System (NAS)
3Summary(ja):    ネットワークオーディオシステム (NAS)
4Version:        1.9.3
5Release:        3%{?_dist_release}
6
7URL:            http://radscan.com/nas.html
8
9License:        Public Domain
10Group:          Development/Libraries
11Source0:        http://nas.codebrilliance.com/nas/nas-%{version}.src.tar.gz
12Source1:        http://apt.kde-redhat.org/apt/kde-redhat/SOURCES/nas/nasd.init
13Source2:        http://apt.kde-redhat.org/apt/kde-redhat/SOURCES/nas/nasd.sysconfig
14Patch0:         %{name}-1.9.3-Move-AuErrorDB-to-SHAREDIR.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  bison flex
18BuildRequires:  imake
19BuildRequires:  libX11-devel libXau-devel libXaw-devel libXext-devel
20BuildRequires:  libXpm-devel libXp-devel libXt-devel
21%define libdir_x11 %{_libdir}/X11
22
23Requires(preun): chkconfig /sbin/service
24Requires(post): chkconfig
25
26Requires:       %{name}-libs = %{version}-%{release}
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30
31
32%package devel
33Summary:        Development and doc files for the NAS
34Summary(ja):    NAS 用開発ファイルとドキュメント
35Group:          Development/Libraries
36Requires:       %{name}-libs = %{version}-%{release}
37
38%description devel
39Development files and the documentation
40
41%description devel -l ja
42NAS 用開発ファイルとドキュメント
43
44
45%package libs
46Summary: Runtime libraries for NAS
47Summary(ja): NAS のランタイムライブラリ
48Group:   System Environment/Libraries
49
50%description libs
51%{summary}.
52
53
54%description
55In a nutshell, NAS is the audio equivalent of an X display server.
56The Network Audio System (NAS) was developed by NCD for playing,
57recording, and manipulating audio data over a network.  Like the
58X Window System, it uses the client/server model to separate
59applications from the specific drivers that control audio input
60and output devices.
61
62Key features of the Network Audio System include:
63        o  Device-independent audio over the network
64        o  Lots of audio file and data formats
65        o  Can store sounds in server for rapid replay
66        o  Extensive mixing, separating, and manipulation of audio data
67        o  Simultaneous use of audio devices by multiple applications
68        o  Use by a growing number of ISVs
69        o  Small size
70        o  Free!  No obnoxious licensing terms
71
72%description -l ja
73簡単にいうと、NAS は X ディスプレイサーバのオーディオ版です。
74NCD (Network Computing Devices) 社で開発されたネットワークオーディオシステム
75(NAS) は、ネットワーク越しにオーディオデータを再生・録音・操作するための
76ものです。X Window System と同様にクライアント/サーバモデルを採用し、
77アプリケーションをオーディオ入出力デバイスおよび特定のドライバから切り離す
78設計になっています。
79
80NAS の特徴は以下の通りです:
81        o  デバイスに依存しない、ネットワーク越しのオーディオ
82        o  多数のオーディオファイルやデータフォーマットに対応
83        o  サーバ上にサウンドを保持、すばやくリプレイが可能
84        o  オーディオデータのミキシング、セパレーション、操作が可能
85        o  複数のアプリケーションからのオーディオデバイス同時利用が可能
86        o  多数のソフトウェアメーカーによる利用実績
87        o  コンパクトで小さなサイズ
88        o  フリーです!面倒なライセンス条件はありません
89
90
91%prep
92%setup -q
93%patch0 -p1 -b .move_AuErrorDB
94iconv --from-code=ISO_8859-15 --to-code=UTF-8 HISTORY >HISTORY.tmp
95mv HISTORY.tmp HISTORY
96
97
98%build
99xmkmf
100find . -name Makefile \
101| xargs sed -i -e 's/^\(\s*CDEBUGFLAGS\s*=.*\)/\1 $(RPM_OPT_FLAGS)/'
102make %{?_smp_mflags} World MFLAGS="IRULESRC=%{_datadir}/X11/config"
103
104
105%install
106rm -rf %{buildroot}
107
108make MFLAGS="IRULESRC=%{_datadir}/X11/config" \
109  DESTDIR=%{buildroot} BINDIR=%{_bindir} INCROOT=%{_includedir} \
110  LIBDIR=%{libdir_x11}  SHLIBDIR=%{_libdir} USRLIBDIR=%{_libdir} MANPATH=%{_mandir} \
111  INSTALLFLAGS='-p' \
112  install install.man
113
114install -p -m755 -D %{SOURCE1} %{buildroot}%{_initrddir}/nasd
115install -p -m644 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/nasd
116
117# remove static lib
118rm -f %{buildroot}%{_libdir}/*.a
119# rename cofigfile
120mv %{buildroot}/etc/nas/nasd.conf.eg %{buildroot}/etc/nas/nasd.conf
121
122
123%post
124/sbin/chkconfig --add nasd
125
126
127%preun
128if [ $1 = 0 ] ; then
129  /sbin/chkconfig --del nasd
130  /sbin/service nasd stop >/dev/null 2>&1 ||:
131fi
132
133
134%post libs -p /sbin/ldconfig
135
136%postun libs -p /sbin/ldconfig
137
138
139%clean
140rm -rf %{buildroot}
141
142
143%files
144%defattr(-,root,root,-)
145%dir %{_sysconfdir}/nas
146%config(noreplace) %{_sysconfdir}/nas/nasd.conf
147%config(noreplace) %{_sysconfdir}/sysconfig/nasd
148%{_initrddir}/nasd
149%{_bindir}/*
150%{_mandir}/man1/*
151%{_mandir}/man5/*
152
153%files libs
154%defattr(-,root,root,-)
155%doc README FAQ HISTORY TODO
156%{_libdir}/libaudio.so.*
157%{_datadir}/X11/AuErrorDB
158
159%files devel
160%defattr(-,root,root,-)
161%{_includedir}/audio/
162%{_libdir}/libaudio.so
163%{_mandir}/man3/*
164
165
166%changelog
167* Sun May 27 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.9.3-3
168- add Japanese summary and description to libs subpackage
169
170* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.3-2
171- add Japanese summary and description
172
173* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.3-1
174- new upstream release
175- add Patch0 (move AuErrorDB to sharedir)
176
177* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.9.1-7
178- Initial build for Vine Linux
179
180* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-6
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
182
183* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-5
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
185
186* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.9.1-4
187- -libs subpkg (f9+, #438547)
188- %%install: INSTALLFLAGS='-p' (preserve timestamps)
189- fixup %%changelog whitespace
190
191* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.9.1-3
192- Autorebuild for GCC 4.3
193
194* Sun Nov 11 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9.1-2
195- fix spec file
196
197* Sun Nov 11 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9.1-1
198- update to 1.9.1
199- remove unneeded patches
200
201* Fri Nov 02 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9a-3
202- add better patch for #247468
203
204* Fri Nov 02 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9a-2
205- add patch to fix #247468
206
207* Sun Oct 28 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9a-1
208- update to 1.9a to fix #245712
209
210* Sat Aug 18 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9-4
211- fix for bug #245712
212
213* Sat Aug 11  2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9-3
214- fix for bug #250453
215
216* Fri May 04 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9-2%{?dist}
217- rebuild for the new ppc64 arch
218
219* Sun Apr 08 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9-1%{?dist}
220- update to 1.9
221- remove old patch file
222
223* Mon Mar 26 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8b-1%{?dist}
224- update to 1.8b
225
226* Thu Mar 22 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8a-2%{?dist}
227- use the SVN version of 1.8a
228
229* Wed Mar 21 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8a-1%{?dist}
230- fix bug 233353
231
232* Thu Feb 09 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8-13%{?dist}
233- use the corrected patch
234
235* Thu Feb 08 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8-11%{?dist}
236- fix bug 227759
237
238* Tue Sep 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 1.8-10
239- don't rely-on/use potentially broken %%_libdir/X11 symlink (#207180)
240
241* Mon Sep 11 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-9%{?dist}
242- second rebuild for FC6
243
244* Mon Jul 24 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-8%{?dist}
245- fix ugly output when starting the daemon
246
247* Fri Jul 21 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-7%{?dist}
248- disable build for EMT64 on FC4
249
250* Thu Jul 13 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-6%{?dist}
251- fix build on EMT64
252
253* Wed Jul 12 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-5%{?dist}
254- fix include dir
255
256* Fri Jul 7 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-4%{?dist}
257- add Requires(preun): chkconfig /sbin/service
258- add Requires(post):  chkconfig
259- add remarks for FC4
260
261* Fri Jul 7 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-3%{?dist}
262- move man3 to devel
263- rename nasd.conf.eg to .conf
264- add build depend for libXext-devel libXt-devel
265- change license to Public Domain
266- add path to make intall
267- add rc.d/sysconfig  files
268
269* Fri Jul 7 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-2%{?dist}
270- move libaudio.so.2 to main package
271- switch package name from NAS to nas
272- fix depend for devel package
273- fix version
274- add nas subdir in etc to main package
275- set license to Distributable
276- add readme file
277
278* Fri Jul 7 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-1%{?dist}
279- start
Note: See TracBrowser for help on using the repository browser.