source: projects/specs/branches/6/m/mutter/mutter-vl.spec @ 1886

Revision 1886, 3.6 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define pkg_version 2.29.1
2%define pkg_release 2%{?_dist_release}
3
4Summary:     Window and compositing manager based on Clutter
5Name:        mutter
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.bz2
9License:     GPLv2+
10Group:       User Interface/Desktops
11URL:         http://git.gnome.org/browse/mutter
12
13Requires(post,postun): scrollkeeper >= 0.1.4
14Requires(post,pre,preun): GConf2 >= 2.14
15BuildRequires: pkgconfig
16BuildRequires: gtk2-devel
17BuildRequires: clutter-devel
18BuildRequires: libSM-devel
19BuildRequires: GConf2-devel
20BuildRequires: gir-repository-devel
21BuildRequires: python-devel
22BuildRequires: startup-notification-devel
23BuildRequires: libcanberra-devel
24BuildRequires: gnome-doc-utils
25BuildRequires: desktop-file-utils
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: Takemikaduchi
31
32
33%description
34Mutter is a minimal X window manager aimed at nontechnical users and is designed to integrate well with the GNOME desktop. Mutter lacks some features that may be expected by traditional UNIX or other technical users; these users may want to investigate other available window managers for use with GNOME or standalone.
35
36
37%package devel
38Summary:     Development files of the mutter library.
39Group:       Development/Libraries
40
41Requires: %{name} = %{version}-%{release}
42Requires: pkgconfig
43Requires: gtk-doc
44Requires: clutter-devel
45
46%description devel
47Development files of the mutter library.
48
49
50%prep
51%setup -q
52
53
54%build
55%configure --disable-static
56%{__make} %{?_smp_mflags}
57
58
59%install
60%{__rm} -rf ${RPM_BUILD_ROOT}
61%{__make} install DESTDIR=${RPM_BUILD_ROOT}
62
63%find_lang %{name}
64
65%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/*.la
66
67
68%clean
69%{__rm} -rf ${RPM_BUILD_ROOT}
70
71
72%post
73/sbin/ldconfig
74export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
75gconftool-2 --makefile-install-rule \
76    %{_sysconfdir}/gconf/schemas/mutter.schemas \
77  > /dev/null || :
78/sbin/ldconfig
79touch --no-create %{_datadir}/icons/hicolor
80if [ -x /usr/bin/gtk-update-icon-cache ]; then
81  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
82fi
83
84%pre
85if [ "$1" -gt 1 ]; then
86  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
87  gconftool-2 --makefile-uninstall-rule \
88    %{_sysconfdir}/gconf/schemas/mutter.schemas \
89    > /dev/null || :
90fi
91
92%preun
93if [ "$1" -eq 0 ]; then
94  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
95  gconftool-2 --makefile-uninstall-rule \
96    %{_sysconfdir}/gconf/schemas/mutter.schemas \
97    > /dev/null || :
98fi
99
100%postun
101scrollkeeper-update -q || :
102/sbin/ldconfig
103touch --no-create %{_datadir}/icons/hicolor
104if [ -x /usr/bin/gtk-update-icon-cache ]; then
105  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
106fi
107
108
109%files -f %{name}.lang
110%defattr(-,root,root)
111%doc COPYING ChangeLog NEWS README
112%{_bindir}/mutter
113%{_bindir}/mutter-message
114%{_libdir}/lib*.so.*
115%{_libdir}/mutter/*
116%{_datadir}/applications/*
117%{_datadir}/gnome/wm-properties/*
118%{_datadir}/mutter/*
119%{_sysconfdir}/gconf/schemas/*
120%{_mandir}/man1/mutter.1.gz
121%{_mandir}/man1/mutter-message.1.gz
122
123%files devel
124%defattr(-,root,root,-)
125%{_bindir}/mutter-theme-viewer
126%{_bindir}/mutter-window-demo
127%{_includedir}/mutter/*
128%{_libdir}/lib*.so
129%{_libdir}/pkgconfig/*
130%{_mandir}/man1/mutter-theme-viewer.1.gz
131%{_mandir}/man1/mutter-window-demo.1.gz
132
133%changelog
134* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
135- rebuild with rpm-4.8.1 for pkg-config file
136
137* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
138- new upstream release
139- add BuildRequires: libcanberra-devel
140- Requires: clutter-devel (devel package)
141
142* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
143- initial build for Vine Linux
144
Note: See TracBrowser for help on using the repository browser.