source: projects/specs/branches/6/m/moonlight/moonlight-vl.spec @ 2025

Revision 2025, 10.2 KB checked in by owa, 13 years ago (diff)

rebuilt with mono-2.8

Line 
1%define mono_dir %{_prefix}/lib/mono
2%define monodoc_dir %{_prefix}/lib/monodoc
3%define moonlight_dir %{_prefix}/lib/moonlight
4%define pkgconfigdir %{_datadir}/pkgconfig
5%define included_mono 2.6.1
6%define included_basic 2.6
7Summary:  An open source implementation of Silverlight
8Summary(ja): Silverlight のオープンソースによる実装
9Name: moonlight
10Version: 2.3
11Release: 2%{?_dist_release}
12Group: Applications/Multimedia
13License: LGPL v2.0 only ; MIT License (or similar) ; Ms-Pl
14URL: http://go-mono.com/moonlight/
15Source0: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/moonlight-%{version}.tar.bz2
16Source1: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/mono-%{included_mono}.tar.bz2
17Source2: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/mono-basic-%{included_basic}.tar.bz2
18Patch0: bad-register.patch
19Patch1: r159607.patch
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: mono-devel >= 2.6
22BuildRequires: gtk-sharp2
23BuildRequires: rsvg2-sharp
24BuildRequires: wnck-sharp
25BuildRequires: gcc-c++
26BuildRequires: gtk2-devel
27BuildRequires: alsa-lib-devel
28BuildRequires: xulrunner-devel
29BuildRequires: bison
30BuildRequires: autoconf
31ExclusiveArch: %ix86 x86_64
32
33%description
34Moonlight is an open source implementation of Microsoft Silverlight for
35Unix systems.
36
37%description -l ja
38Moonlight は Unix 系システムのための,Microsoft Silverlight のオープン
39ソースな実装です.
40
41
42%package libs
43Summary: Moonlight libmoon
44Group: System Environment/Libraries
45License: LGPL v2.0 only
46Requires: mono-core >= 2.6
47
48%description libs
49Moonlight libmoon
50
51%package devel
52Summary: Moonlight libmoon C/C++ development files
53Group: Development/Libraries
54License: LGPL v2.0 only
55Requires: %{name}-libs == %{version}
56
57%description devel
58Development files for libmoon
59
60%package tools
61Summary: Moonlight tools
62Group: Development/Tools
63Requires: %{name}-libs == %{version}
64
65%description tools
66Moonlight tools (mopen, xamlg, xaml2html, mxap, respack, svg2xaml)
67
68%package plugin
69Summary: Moonlight browser plugin
70Group: Applications/Internet
71Requires: %{name}-libs == %{version}
72Requires: mono-core >= 2.6
73
74%description plugin
75Browser plugin for Novell Moonlight
76
77%package web-devel
78Summary: Development files for Moonlight Web
79Group: Development/Libraries
80License: MIT License (or similar) ; Ms-Pl
81Requires: %{name}-plugin == %{version}
82
83%description web-devel
84Development files for creating Moonlight web applications.
85
86%package desktop
87Summary: Mono bindings for Moonlight Desktop
88Group: Development/Libraries
89License: MIT License (or similar) ; Ms-Pl
90Requires: %{name}-libs == %{version}
91
92%description desktop
93Mono bindings for Novell Moonlight.
94
95%package desktop-devel
96Summary: Development files for Moonlight Desktop
97Group: Development/Libraries
98License: MIT License (or similar) ; Ms-Pl
99Requires: %{name}-libs == %{version}
100Requires: glib2-devel
101Requires: gtk-sharp2
102Requires: %{name}-desktop == %{version}
103Requires: %{name}-tools == %{version}
104
105%description desktop-devel
106Development files for Moonlight Desktop.
107
108%package sharp
109Summary: Moonlight sharp
110Group: Development/Libraries
111Requires: %{name}-libs == %{version}
112
113%description sharp
114Provides a gtk-sharp object that can be used to embed a moonlight surface in a desktop application.
115
116
117%prep
118%setup -q
119%setup -q -T -D -b 1 -n %{name}-%{version}
120%setup -q -T -D -b 2 -n %{name}-%{version}
121pushd ../mono-%{included_mono}
122%patch0
123popd
124%patch1
125
126
127%build
128# The plugin requires a complete build of it's own mono
129pushd ../mono-%{included_mono}
130./configure \
131        --prefix=%{_builddir}/install \
132        --with-mcs-docs=no \
133        --with-ikvm-native=no \
134        ;
135# mono is not strictly -j safe
136%{__make} EXTERNAL_MCS=false EXTERNAL_RUNTIME=false
137%{__make} install
138find %{_builddir}/install -name \*.la -delete
139popd
140
141# Configure against the junk install of mono
142export PATH=%{_builddir}/install/bin:${PATH}
143export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
144export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
145# Only needed when there are Makefile.am or configure.ac patches
146autoreconf -f -i -Wnone
147%configure \
148        --with-ffmpeg=no \
149        --with-cairo=system \
150        --with-curl=system \
151        --with-mcspath=%{_builddir}/mono-%{included_mono}/mcs \
152        --with-mono-basic-path=%{_builddir}/mono-basic-%{included_basic} \
153        --with-ff3=yes \
154        --with-testing=no \
155        --with-performance=no \
156        --with-examples=no \
157        --with-debug=no \
158        --with-sanity-checks=no \
159        --without-testing \
160        --without-performance \
161        --without-examples \
162        --disable-debug \
163        --disable-sanity \
164        ;
165
166export MONO_GAC_PREFIX=%{_builddir}/install:%{_prefix}
167%{__make} %{?_smp_mflags}
168
169
170%install
171rm -rf %{buildroot}
172export PATH=%{_builddir}/install/bin:${PATH}
173export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
174export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
175make install DESTDIR=%{buildroot} pkgconfigdir=%{pkgconfigdir}
176
177install -m 644 %{_builddir}/install/lib/libmono.so.0 %{buildroot}%{_libdir}/moonlight/
178chrpath -r %{_libdir}/moonlight %{buildroot}%{_libdir}/moonlight/plugin/libmoonplugin.so
179chrpath -r  %{_libdir}/moonlight %{buildroot}%{_libdir}/moonlight/plugin/libmoonplugin.so
180
181mkdir -p %{buildroot}%{_libdir}/mozilla/plugins
182ln -s %{_libdir}/moonlight/plugin/libmoonloader.so \
183        %{buildroot}%{_libdir}/mozilla/plugins/libmoonloader.so
184
185# remove unuse files
186rm -f %{buildroot}%{_libdir}/libshocker.so
187find %{buildroot} -name \*.la -delete
188
189
190%post libs -p /sbin/ldconfig
191%postun libs -p /sbin/ldconfig
192%clean
193rm -rf %{buildroot}
194
195
196%files libs
197%defattr(-, root, root)
198%doc AUTHORS COPYING ChangeLog README TODO NEWS
199%{_libdir}/libmoon.so.*
200%dir %{_libdir}/moonlight
201%{_libdir}/moonlight/libmono.so.0
202
203%files devel
204%defattr(-, root, root)
205%{_libdir}/libmoon.so
206
207%files tools
208%defattr(-, root, root)
209%{_bindir}/mopen
210%{_bindir}/munxap
211%{_bindir}/mxap
212%{_bindir}/respack
213%{_bindir}/sockpol
214%{_bindir}/unrespack
215%{_bindir}/xaml2html
216%{_bindir}/xamlg
217%{_libdir}/moonlight/mopen.exe*
218%{_libdir}/moonlight/munxap.exe
219%{_libdir}/moonlight/mxap.exe
220%{_libdir}/moonlight/respack.exe
221%{_libdir}/moonlight/xaml2html.exe
222%{_libdir}/moonlight/xamlg.exe
223%{_libdir}/moonlight/sockpol.exe
224%{_mandir}/man1/mopen.1.gz
225%{_mandir}/man1/mxap.1.gz
226%{_mandir}/man1/respack.1.gz
227%{_mandir}/man1/svg2xaml.1.gz
228%{_mandir}/man1/xamlg.1.gz
229%{_mandir}/man1/sockpol.1.gz
230
231%files plugin
232%defattr(-, root, root)
233%dir %{_libdir}/moonlight/plugin
234%{_libdir}/moonlight/plugin/Microsoft.VisualBasic.dll
235%{_libdir}/moonlight/plugin/System.Core.dll*
236%{_libdir}/moonlight/plugin/System.Net.dll*
237%{_libdir}/moonlight/plugin/System.Runtime.Serialization.dll*
238%{_libdir}/moonlight/plugin/System.ServiceModel.Web.dll*
239%{_libdir}/moonlight/plugin/System.ServiceModel.dll*
240%{_libdir}/moonlight/plugin/System.Windows.Browser.dll*
241%{_libdir}/moonlight/plugin/System.Windows.dll*
242%{_libdir}/moonlight/plugin/System.Xml.dll*
243%{_libdir}/moonlight/plugin/System.dll*
244%{_libdir}/moonlight/plugin/libmoonloader.so
245%{_libdir}/moonlight/plugin/libmoonplugin-curlbridge.so
246%{_libdir}/moonlight/plugin/libmoonplugin-ff3bridge.so
247%{_libdir}/moonlight/plugin/libmoonplugin.so
248%{_libdir}/moonlight/plugin/mscorlib.dll*
249%{_libdir}/mozilla/plugins/libmoonloader.so
250
251%files web-devel
252%defattr(-, root, root)
253%{_bindir}/smcs
254%dir %{moonlight_dir}/2.0-redist
255%{moonlight_dir}/2.0-redist/System.Windows.Controls.Data.dll*
256%{moonlight_dir}/2.0-redist/System.Windows.Controls.dll*
257%{moonlight_dir}/2.0-redist/System.Xml.Linq.dll*
258%dir %{moonlight_dir}/2.0
259%{moonlight_dir}/2.0/Microsoft.VisualBasic.dll*
260%{moonlight_dir}/2.0/Mono.CompilerServices.SymbolWriter.dll*
261%{moonlight_dir}/2.0/System.Core.dll*
262%{moonlight_dir}/2.0/System.Net.dll*
263%{moonlight_dir}/2.0/System.Runtime.Serialization.dll*
264%{moonlight_dir}/2.0/System.ServiceModel.Web.dll*
265%{moonlight_dir}/2.0/System.ServiceModel.dll*
266%{moonlight_dir}/2.0/System.Windows.Browser.dll*
267%{moonlight_dir}/2.0/System.Windows.dll*
268%{moonlight_dir}/2.0/System.Xml.dll*
269%{moonlight_dir}/2.0/System.dll*
270%{moonlight_dir}/2.0/mscorlib.dll*
271%{moonlight_dir}/2.0/respack.exe*
272%{moonlight_dir}/2.0/smcs
273%{moonlight_dir}/2.0/smcs.exe*
274%{moonlight_dir}/2.0/buildversion
275%{pkgconfigdir}/moonlight-web-2.0.pc
276
277%files desktop
278%defattr(-, root, root)
279%{mono_dir}/gac/Moon.Windows.Desktop
280%{mono_dir}/gac/Moonlight.Gtk
281%{mono_dir}/gac/System.Windows
282%{mono_dir}/gac/System.Windows.Browser
283%{mono_dir}/gac/System.Windows.Controls
284%{mono_dir}/gac/System.Windows.Controls.Data
285
286%files desktop-devel
287%defattr(-, root, root)
288%dir %{mono_dir}/moonlight
289%{mono_dir}/moonlight/Moon.Windows.Desktop.dll*
290%{mono_dir}/moonlight/System.Windows.Browser.dll*
291%{mono_dir}/moonlight/System.Windows.Controls.Data.dll*
292%{mono_dir}/moonlight/System.Windows.Controls.dll*
293%{mono_dir}/moonlight/System.Windows.dll*
294%{pkgconfigdir}/moonlight-desktop-2.0.pc
295# It may make sense in the future to have a moonlight-gtk package
296%{mono_dir}/moonlight/Moonlight.Gtk.dll*
297%{monodoc_dir}/sources/moonlight-gtk.source
298%{monodoc_dir}/sources/moonlight-gtk.tree
299%{monodoc_dir}/sources/moonlight-gtk.zip
300%{pkgconfigdir}/moonlight-gtk-2.0.pc
301
302
303%changelog
304* Sun Oct 10 2010 Shu KONNO <owa@bg.wakwak.com> 2.3-2
305- rebuilt with mono-2.8
306- added bad-register.patch, r159607.patch (from suse)
307- added BR: autoconf (use autoreconf in %%build)
308- installed %%{_libdir}/moonlight/libmono.so.0 (obsoleted in mono-2.8)
309
310* Tue Oct 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.3-1
311- updated moonlightautoconf to 2.3
312- updated mono to 2.6.1
313- updated mono-basic to 2.6
314- added BR: bison
315
316* Wed Sep 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.0-3
317- export PATH, LD_LIBRARY_PATH, PKG_CONFIG_PATH, MONO_GAC_PREFIX
318
319* Sat Sep  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-2
320- fixed Group
321- added BR: wnck-sharp
322
323* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
324- updated moonlight to 2.0
325
326* Thu Jul 09 2009 Shu KONNO <owa@bg.wakwak.com> 1.0.1-1
327- updated moon to 1.0.1
328- dropt missing-files.patch (included in source)
329- built with latest rpm to update mono-dependencies
330
331* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.1-2
332- changed plugin Group to Applications/Internet
333- changed other sub packages Group to Development/Libraries
334- added %%pkgconfigdir macro
335
336* Sat Sep 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
337- new upstream release
338- added missing-files.patch from suse
339- added --with-managed=desktop
340
341* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 0.8-1
342- initial build for VineSeed
343    - moonlight 0.8
344    - vine versioning policy
345    - spec in utf-8
346
Note: See TracBrowser for help on using the repository browser.