source: projects/specs/branches/6/m/mod_perl2/mod_perl2-vl.spec @ 521

Revision 521, 2.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An embedded Perl interpreter for the Apache Web server Version 2
2Summary(ja): Apache2 Web サーバ用 組み込み Perl インタプリタ
3Name: mod_perl2
4Version: 2.0.4
5Release: 2%{?_dist_release}
6URL: http://perl.apache.org/
7Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
8Source1: perl.conf
9Source2: filter-requires.sh
10Source3: filter-provides.sh
11License:  The Apache Software License, Version 2.0
12Group: System Environment/Daemons
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: apache2-devel >= 2.0.51
15BuildRequires: perl >= 5.6.0
16
17%define __find_requires %{SOURCE2}
18%define __find_provides %{SOURCE3}
19
20%description
21Mod_perl incorporates a Perl interpreter into the Apache web server,
22so that the Apache web server can directly execute Perl code.
23Mod_perl links the Perl runtime library into the Apache web server and
24provides an object-oriented Perl interface for Apache's C language
25API.  The end result is a quicker CGI script turnaround process, since
26no external Perl interpreter has to be started.
27
28Install mod_perl if you're installing the Apache web server and you'd
29like for it to directly incorporate a Perl interpreter.
30
31
32%prep
33%setup -q -n mod_perl-%{version}
34
35
36%build
37perl Makefile.PL PREFIX=%{buildroot}/usr \
38  MP_APXS=%{_bindir}/apxs \
39  INSTALLDIRS=vendor
40make
41
42
43%install
44rm -rf %{buildroot}
45%makeinstall \
46  MODPERL_AP_INCLUDEDIR=%{buildroot}%{_includedir}/apache2 \
47  MODPERL_AP_LIBEXECDIR=%{buildroot}%{_libdir}/apache2/modules
48
49install -d -m 755 %{buildroot}%{_sysconfdir}/apache2/conf.d
50install -p -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/apache2/conf.d/
51
52find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
53find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
54
55chmod -R u+w %{buildroot}/*
56
57
58%clean
59rm -rf %{buildroot}
60
61
62%files
63%defattr(-,root,root)
64%doc Changes INSTALL LICENSE README* STATUS SVN-MOVE docs
65%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
66%{_bindir}/*
67%{_mandir}/man3/*
68%{_includedir}/apache2/mod_perl*
69%{_includedir}/apache2/modperl*
70%{_libdir}/apache2/modules/mod_perl.so
71%{perl_vendorarch}/*.pm
72%{perl_vendorarch}/APR
73%{perl_vendorarch}/Apache
74%{perl_vendorarch}/Apache2
75%{perl_vendorarch}/Bundle
76%{perl_vendorarch}/ModPerl
77%{perl_vendorarch}/auto
78
79
80%changelog
81* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.4-2
82- rebuilt with openldap-2.4.16
83
84* Fri Jan 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
85- new upstream release
86- new versioning policy
87- add default config file (SOURCE1) and prov/req filters (SOURCE2/3)
88- install under vendor_perl dir instead of site_perl
89
90* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 1.99_09-0vl1
91- Initial build.
Note: See TracBrowser for help on using the repository browser.