source: projects/specs/branches/6/m/mod_perl/mod_perl-vl.spec @ 521

Revision 521, 7.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define defperlver 5.8.2
2%define perlver %(rpm -q perl --queryformat '%%{version}' 2> /dev/null || echo %{defperlver})
3%define perlmajor %(echo %{perlver} | cut -f1 -d.)
4%define contentdir /home/httpd
5
6Summary: An embedded Perl interpreter for the Apache Web server.
7Name: mod_perl
8Version: 1.29
9Release: 0vl1
10Group: System Environment/Daemons
11Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
12License: GPL
13URL: http://perl.apache.org/
14BuildRoot: %{_tmppath}/%{name}-root
15Requires: webserver, perl = %{perlver}, perl-libwww-perl, perl-HTML-Parser
16BuildPrereq: apache-devel, perl, perl-libwww-perl, perl-HTML-Parser
17Prereq: perl
18
19%description
20Mod_perl incorporates a Perl interpreter into the Apache web server,
21so that the Apache web server can directly execute Perl code.
22Mod_perl links the Perl runtime library into the Apache web server and
23provides an object-oriented Perl interface for Apache's C language
24API.  The end result is a quicker CGI script turnaround process, since
25no external Perl interpreter has to be started.
26
27Install mod_perl if you're installing the Apache web server and you'd
28like for it to directly incorporate a Perl interpreter.
29
30%prep
31%setup -q
32
33%build
34# Compile the module.
35perl Makefile.PL \
36        USE_APXS=1 WITH_APXS=%{_sbindir}/apxs PERL_USELARGEFILES=0 \
37        EVERYTHING=1 CCFLAGS="$RPM_OPT_FLAGS -fPIC"
38make
39
40# Run the test suite.
41make test
42
43%install
44[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
45#make pure_install INSTALLDIRS=vendor PREFIX=$RPM_BUILD_ROOT%{_prefix}
46make pure_install DESTDIR=$RPM_BUILD_ROOT
47
48# Install the module itself.
49mkdir -p $RPM_BUILD_ROOT%{_libdir}/apache
50install -c -m 755 apaci/libperl.so $RPM_BUILD_ROOT%{_libdir}/apache/
51
52# Install its manual.
53mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/manual/mod/mod_perl
54install -c -m 644 htdocs/manual/mod/mod_perl.html \
55        $RPM_BUILD_ROOT%{contentdir}/html/manual/mod
56
57make -C faq
58rm faq/pod2htm*
59install -m644 faq/*.html $RPM_BUILD_ROOT%{contentdir}/html/manual/mod/mod_perl/
60
61# Remove the temporary files.
62find $RPM_BUILD_ROOT%{perl_sitearch}/auto -name "*.bs" | xargs rm
63rm   $RPM_BUILD_ROOT%{perl_sitearch}/auto/%{name}/.packlist
64
65%clean
66[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(-,root,root)
70%doc CREDITS Changes README SUPPORT cgi_to_mod_perl.pod mod_perl.pod
71%doc mod_perl_method_handlers.pod mod_perl_traps.pod mod_perl_tuning.pod
72%doc INSTALL faq/*.html eg faq
73%doc apache-modlist.html
74%{contentdir}/html/manual/mod/*
75%{_libdir}/apache/libperl.so
76%{perl_sitearch}/auto/*
77%{perl_sitearch}/Apache*
78%{perl_sitearch}/Bundle
79%{perl_sitearch}/cgi*
80%{perl_sitearch}/mod_perl*
81%{_mandir}/man3/*.3*
82
83%changelog
84* Tue Jul  6 2004 IWAI, Masaharu <iwai@alib.jp> 1.29-0vl1
85- new upstream release
86- build with Perl 5.8.2 ( perl-5.8.2-0vl2 )
87- update %%install section
88- update %%files section
89
90* Sun Nov  3 2002 IWAI Masaharu <iwai@alib.jp> 1.27-6vl0
91- upstream release
92- add perl-libwww-perl and perl-HTML-Parser in Requires
93- add perl-libwww-perl and perl-HTML-Parser in BuildPrereq
94- drop ToDo in %%doc
95
96* Sun Jun  2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.26-6vl0
97- first build for Vine
98- changed INSTALLDIRS (no use vender)
99- use rpm macros
100- moved contentdir for Vine Linux
101
102* Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-6
103- rebuild in new environment
104
105* Wed Mar 27 2002 Chip Turner <cturner@redhat.com> 1.26-5
106- move to vendor_perl
107
108* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-4
109- rebuild
110
111* Fri Feb  8 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-3
112- rebuild
113
114* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-2
115- turn off large file support, which makes mod_perl think that server request
116  structures are the wrong size (heads-up from Doug MacEachern and Chip Turner)
117
118* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-1
119- update to 1.26
120
121* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.24_01-4
122- automated rebuild
123
124* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com> 1.24_01-3
125- Bump release + rebuild.
126
127* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com> 1.24_01-2
128- don't include .bs files
129
130* Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 1.24_01-1
131- update to 1.24_01
132- add URL
133
134* Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
135- rebuild in new environment
136
137* Fri Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
138- patch to fix bug in Apache::ExtUtils (#17147)
139
140* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
141- remove backup files from docs (#14174)
142
143* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
144- automatic rebuild
145
146* Sat Jun 17 2000 Nalin Dahyabhai <nalin@redhat.com>
147- remove workarounds for broken Perl
148
149* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
150- get rid of multiple prefixes
151
152* Wed May 31 2000 Nalin Dahyabhai <nalin@redhat.com>
153- update to 1.24
154- remove pre- and post-install scripts and triggers
155
156* Thu May 11 2000 Nalin Dahyabhai <nalin@redhat.com>
157- work around weird Perl version reporting problems with a suitably weird check
158
159* Fri Apr 28 2000 Nalin Dahyabhai <nalin@redhat.com>
160- modify to be able to rebuild on both 5.003 and 5.6.0
161- update to 1.23
162
163* Thu Mar 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
164- rebuild with perl 5.6.0
165- add perlver macro to spec file to make handling of other perl versions easier
166
167* Thu Mar 23 2000 Nalin Dahyabhai <nalin@redhat.com>
168- update to 1.22
169
170* Fri Mar 03 2000 Cristian Gafton <gafton@redhat.com>
171- fixed the postun script to check for upgrades. doh
172- add triggerpostun to fix older versions of the package
173
174* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
175- make perl a prereq because it's used in %post
176
177* Fri Feb 25 2000 Nalin Dahyabhai <nalin@redhat.com>
178- rebuild against Apache 1.3.12 and EAPI (release 8)
179
180* Mon Feb 21 2000 Preston Brown <pbrown@redhat.com>
181- incorporate fixes from Markus Pilzecker <mp@rhein-neckar.netsurf.de>:
182- Prefix: /usr
183- find apxs binary and package directories automatically
184
185* Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
186- automatically enable/disable in httpd.conf in post/postun.
187
188* Thu Feb 10 2000 Preston Brown <pbrown@redhat.com>
189- fix up some strange permissions
190
191* Sun Feb 06 2000 Preston Brown <pbrown@redhat.com>
192- rebuild to pick up gzipped man pages, new descr.
193
194* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
195- changed paths for perl 5.00503 (RHL 6.1 version)
196
197* Fri Jul 09 1999 Preston Brown <pbrown@redhat.com>
198- added -fPIC to correct functionality on SPARC
199- upgrade to 1.21, removed build cruft from old buggy mod_perl days
200- added extra documentation that was missing
201
202* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
203- bump ver. # so SWS mod_perl gets auto-upgraded
204
205* Wed Apr 07 1999 Preston Brown <pbrown@redhat.com>
206- bugfix 1.19 release from Doug
207
208* Wed Mar 24 1999 Preston Brown <pbrown@redhat.com>
209- experimental patch from Doug MacEachern <dougm@pobox.com> to fix segfault
210- rebuilt against apache 1.3.6
211
212* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
213- auto rebuild in the new build environment (release 3)
214
215* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
216- Injected new description and group.
217
218* Sun Feb 07 1999 Preston Brown <pbrown@redhat.com>
219- upgraded to mod_perl 1.18.
220
221* Mon Dec 21 1998 Preston Brown <pbrown@redhat.com>
222- Upgraded to mod_perl 1.16.
223
224* Thu Sep 03 1998 Preston Brown <pbrown@redhat.com>
225- disabled stacked_handlers.  They still seem busted!
226- minor updates so no conflicts with either apache / secureweb
227- fixed bug building on multiple architectures
228
229* Wed Sep 02 1998 Preston Brown <pbrown@redhat.com>
230- Updates for apache 1.3.x, and mod_perl 1.15
231
232* Fri Feb 27 1998 Cristian Gafton <gafton@redhat.com>
233- added a patch to compile it as a shared object for the apache/ssl (and
234  future revisions of apache)
235
Note: See TracBrowser for help on using the repository browser.