source: projects/specs/branches/6/m/ming/ming-vl.spec @ 1919

Revision 1919, 5.3 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1Name:    ming
2Summary: Ming - an SWF output library
3Summary(ja): SWF 出力ライブラリ
4Version: 0.4.3
5Release: 2%{?_dist_release}
6License: LGPL
7Group:   System Environment/Libraries
8URL:     http://sourceforge.net/projects/ming/
9Source:  %{name}-%{version}.tar.bz2
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11Requires: freetype2 zlib libungif libpng
12BuildRequires: freetype2-devel zlib-devel libungif-devel libpng-devel
13BuildRequires: swig
14
15%description
16Ming is a library for generating Macromedia Flash files (.swf), written in C,
17and includes useful utilities for working with .swf files.
18It has wrappers that allow it to be used in C++, PHP, Python, Ruby, and Perl.
19See http://www.libming.net/FrontPage
20
21%package devel
22Summary:    A SWF output library
23Group:      Development/Libraries
24Requires:   %{name} = %{version}
25Requires:   freetype2-devel zlib-devel libungif-devel libpng-devel
26
27%description devel
28The ming-devel package includes the static libraries,
29header files, and developer docs for the ming package.
30
31Install ming-devel if you want to develop programs which
32will use ming.
33
34%package python
35Summary:    Ming Python wrapper
36Group:      Development/Libraries
37Requires:   %{name} = %{version}
38BuildRequires: python-devel
39%description python
40%{summary}
41
42%package tcl
43Summary:    Ming Tcl wrapper
44Group:      Development/Libraries
45Requires:   %{name} = %{version}
46%description tcl
47%{summary}
48
49%package perl
50Summary:    Ming Perl wrapper
51Group:      Development/Libraries
52Requires:   %{name} = %{version}
53%description perl
54%{summary}
55
56%package php
57Summary:    Ming PHP wrapper
58Group:      Development/Libraries
59Requires:   %{name} = %{version}
60BuildRequires: php5-devel
61%description php
62%{summary}
63
64%prep
65%setup -q
66
67%build
68%configure \
69        --enable-python \
70        --enable-tcl \
71        --enable-php \
72        --enable-perl \
73        --with-pic \
74        ;
75make %{?_smp_mflags}
76
77%install
78[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
79make install \
80        DESTDIR=$RPM_BUILD_ROOT \
81        pkgconfigdir=%{_libdir}/pkgconfig \
82        docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
83        ;
84chmod 755 $RPM_BUILD_ROOT%{perl_sitearch}/auto/SWF/*.so
85make -C ./docs/man mandir=$RPM_BUILD_ROOT%{_mandir} install-man1
86make -C ./docs/man mandir=$RPM_BUILD_ROOT%{_mandir} install-man3
87
88%post -p /sbin/ldconfig
89%post python -p /sbin/ldconfig
90%post tcl -p /sbin/ldconfig
91%post perl -p /sbin/ldconfig
92%post php -p /sbin/ldconfig
93%postun -p /sbin/ldconfig
94%postun python -p /sbin/ldconfig
95%postun tcl -p /sbin/ldconfig
96%postun perl -p /sbin/ldconfig
97%postun php -p /sbin/ldconfig
98%clean
99[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(-,root,root)
103%doc README AUTHORS COPYING ChangeLog
104%{_libdir}/libming*.so.*
105%{_bindir}/*
106%{_mandir}/man1/*
107
108%files devel
109%defattr(-, root, root)
110%{_includedir}/*
111%{_libdir}/libming.so
112%{_libdir}/pkgconfig
113%{_mandir}/man3/*
114%exclude %{_libdir}/*.a
115%exclude %{_libdir}/*.la
116
117%files python
118%defattr(-, root, root)
119%{python_sitearch}/*.so
120%{python_sitearch}/*.py*
121%{python_sitearch}/mingc-%{version}-py%{pyver}.egg-info
122
123%files tcl
124%defattr(-, root, root)
125%{_libdir}/%{name}/tcl/*.so
126%exclude %{_libdir}/%{name}/tcl/*.a
127%exclude %{_libdir}/%{name}/tcl/*.la
128
129%files perl
130%defattr(-, root, root)
131%{_libdir}/perl5/*
132
133%files php
134%defattr(-, root, root)
135%{_libdir}/php5/*
136
137%changelog
138* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.3-2
139- rebuilt with rpm-4.8.1 for pkg-config
140
141* Tue Feb 16 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.3-1
142- updated ming to 0.4.3
143- added %{name}-python, -tcl, -perl, -php sub packages
144- added BR: swig python-devel php-devel
145
146* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.2-1vl5
147- updated ming to 0.4.2
148- added tags: BuildRequires Requires
149- added sub package: ming-devel
150- added script at %%clean
151- applied new versioning policy, spec in utf-8
152
153* Wed Sep 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl3
154- fixed args type of addString function (Patch1)
155- added Japanese Summary
156
157* Sat May 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl2
158- removed Vendor: tag
159- fixed post and postun section
160
161* Sat May 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl1
162- rebuild for Vine Linux
163- based on TLD 10, but removed Serial:
164
165* Thu Apr 24 2003 Noriyuki Suzuki <noriyuki@turbolinux.co.jp>
166- modified spec file for x86_64.
167
168* Thu Feb 28 2002 Kiichiro NAKA <knaka@turbolinux.co.jp>
169- I have gotten SRPM from http://rpms.arvin.dk/ming/source/
170
171* Tue Aug 21 2001 Troels Arvin <troels@arvin.dk>
172  [0.2a-2.arvin]
173- Add Hansuck Jo's listmp3.c patch.
174- Build and include some of the utils.
175
176* Mon Aug 20 2001 Troels Arvin <troels@arvin.dk>
177  [0.2a-1.arvin]
178- Uses new source version.
179
180* Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
181  [0.1.1-3.arvin]
182- Added distribution to release-tag.
183
184* Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
185  [0.1.1-2.arvin]
186- Fixed a permission problem for the documentation
187  area.
188* Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
189  [0.1.1-1.arvin]
190- Rebuilt with new source version.
191* Mon Mar 19 2001 Troels Arvin <troels@arvin.dk>
192  [0.1.0-1.arvin]
193- Rebuilt with new source version. Patches shouldn't be need
194  any more.
195* Mon Jan 29 2001 Troels Arvin <troels@arvin.dk>
196  [0.0.9c-1.arvin]
197- First Ming RPM package. Currently, the RPM doesn't include
198  anyting but the shared library and the C-oriented include
199  file. None of the wrappers for other languages are handled by this
200  RPM, currently. Also, none of the utilities are included in the
201  package yet.
Note: See TracBrowser for help on using the repository browser.