source: projects/specs/branches/6/m/mikmod/mikmod-vl.spec @ 5648

Revision 5648, 7.7 KB checked in by Takemikaduchi, 12 years ago (diff)

arpscan, aslookup, audacity, black-box, bookview, bumprace, gimp-help, js: new upstream release
libsrtp, gstreamer-filters: new package
others: rebuild

Line 
1# libmikmod rpm specification file
2%define lversion 3.1.11
3
4Summary: A MOD music file player.
5Summary(ja): MOD ファイル再生プログラム
6Name: mikmod
7Version: 3.1.6
8Release: 35%{?_dist_release}
9License: GPL/LGPL
10Group: Applications/Multimedia
11Requires(pre): /sbin/ldconfig
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13URL: http://mikmod.raphnet.net/
14Source0: http://mikmod.raphnet.net/files/mikmod-%{version}.tar.gz
15Source1: http://mikmod.raphnet.net/files/libmikmod-%{lversion}.tar.gz
16Patch0:  http://mikmod.raphnet.net/files/libmikmod-3.1.11-a.diff
17Patch1:  mikmod-strip.patch
18Patch2:  libmikmod-esd.patch
19Patch3:  libmikmod-64bit.patch
20Patch4:  patch-mikmod-3.1.6-a
21Patch5:  mikmod-3.1.6-varargs.patch
22Patch6:  libmikmod-strip-lib.patch
23Provides: libmikmod = %{lversion}-%{release}
24#Obsoletes: tracker
25
26Requires: gpm ncurses
27#BuildRequires: gpm ncurses
28BuildRequires: ncurses-devel texinfo
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: OOI Keita <ooi.keita@gmail.com>
33
34%description
35MikMod is one of the best and most well known MOD music file players
36for UNIX-like systems.  This particular distribution is intended to
37compile fairly painlessly in a Linux environment. MikMod uses the OSS
38/dev/dsp driver including all recent kernels for output, and will also
39write .wav files. Supported file formats include MOD, STM, S3M, MTM,
40XM, ULT, and IT.  The player uses ncurses for console output and
41supports transparent loading from gzip/pkzip/zoo archives and the
42loading/saving of playlists.
43
44Install the mikmod package if you need a MOD music file player.
45
46%description -l ja
47mikmod はとても手軽な音楽トラック再生プログラムです。
48幅広い種類のモジュール形式に対応しており、
49その中には Impulse Tracker の圧縮サンプルも含まれます。
50その他にも、多くのアーカイブ形式にも対応しています。
51
52%package devel
53Group: Development/Libraries
54Summary: Header files and documentation for compiling mikmod applications.
55Requires: %{name} = %{version}-%{release}
56Requires(pre): /sbin/install-info
57Provides: libmikmod-devel = %{lversion}-%{release}
58
59%description devel
60This package includes the header files you will need to compile
61applications for mikmod.
62
63%prep
64%setup -q -a 1
65%patch0 -p0
66%patch1 -p1 -b .strip
67%patch2 -p1 -b .esd
68%patch3 -p1
69%patch4 -p1 -b .orig
70%patch5 -p1
71%patch6 -p1 -b .lib-strip
72
73%build
74rm -rf $RPM_BUILD_ROOT
75cd libmikmod-%{lversion}
76cp /usr/share/libtool/config/config.{sub,guess} .
77%configure
78make
79make install DESTDIR=$RPM_BUILD_ROOT
80cd ..
81
82# Trick it into compiling while libmikmod is not installed...
83export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_prefix}/lib:$LD_LIBRARY_PATH
84perl -pi -e "s,-lmikmod,-I$RPM_BUILD_ROOT%{_prefix}/include -L$RPM_BUILD_ROOT%{_libdir} -lmikmod,g" libmikmod-%{lversion}/libmikmod-config
85export LIBMIKMOD_CONFIG=`pwd`/libmikmod-%{lversion}/libmikmod-config
86cp /usr/share/libtool/config/config.{sub,guess} .
87%configure \
88        --with-libmikmod-prefix=$RPM_BUILD_ROOT%{_prefix} \
89        --with-libmikmod-exec-prefix=$RPM_BUILD_ROOT%{_prefix}/bin \
90        --disable-libmikmodtest
91make CFLAGS="$RPM_OPT_FLAGS `libmikmod-%{lversion}/libmikmod-config --cflags` -I."
92
93%install
94make install DESTDIR=$RPM_BUILD_ROOT
95rm -f $RPM_BUILD_ROOT%{_infodir}/dir
96
97## remove unuse files
98rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
99
100%clean
101rm -fr $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104
105%post devel
106/sbin/install-info %{_infodir}/mikmod.info.gz %{_infodir}/dir
107
108%postun -p /sbin/ldconfig
109
110%postun devel
111if [ $1 = 0 ] ; then
112        /sbin/install-info  --delete %{_infodir}/mikmod.info.gz %{_infodir}/dir
113fi
114
115%files
116%defattr(-, root, root)
117%doc AUTHORS COPYING NEWS README
118%doc libmikmod-%{lversion}/TODO
119%{_bindir}/mikmod
120%{_mandir}/man1/mikmod*
121%{_libdir}/*.so.*
122
123%files devel
124%defattr(-, root, root)
125%{_bindir}/*-config
126%{_libdir}/*.so
127%{_libdir}/*.a
128#%{_libdir}/*.la
129%{_datadir}/aclocal/*
130%{_includedir}/*
131%{_infodir}/mikmod*
132%{_mandir}/man1/libmikmod-config*
133
134%changelog
135* Tue Feb 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.6-35
136- rebuild with Vine6 environment
137
138* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.6-34vl5
139- applied new versioning policy, spec in utf-8
140- removed *.la
141
142* Thu Mar 10 2005 OOI Keita <ooi.keita@gmail.com> 3.1.6-33vl2
143- build for vine
144- add ja summary and description from deb
145
146* Tue Dec 21 2004 Martin Stransky <stransky@redhat.com> 3.1.6-33
147- strip library (#143258)
148
149* Mon Dec 13 2004 Bill Nottingham <notting@redhat.com> 3.1.6-31
150- move mikmod binary back to main package (#142668)
151
152* Fri Oct  8 2004 Bill Nottingham <notting@redhat.com> 3.1.6-30
153- add texinfo buildreqs (#135088)
154
155* Wed Oct  6 2004 Bill Nottingham <notting@redhat.com> 3.1.6-29
156- install-info scripts go with -devel (#134882)
157
158* Wed Sep 22 2004 Than Ngo <than@redhat.com> 3.1.6-28
159- increase release number
160
161* Wed Sep 22 2004 Than Ngo <than@redhat.com> 3.1.6-27
162- new devel sub package, multiarch problem
163- add /sbin/ldconfig in Prereq
164- cleanup specfile
165
166* Wed Aug  4 2004 Miloslav Trmac <mitr@redhat.com> - 3.1.6-26
167- Update to libmikmod-3.1.11-a, fixes #116182
168
169* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
170- rebuilt
171
172* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
173- rebuilt
174
175* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
176- rebuilt
177
178* Wed Jul 23 2003 Bill Nottingham <notting@redhat.com> 3.1.6-23
179- remove URL (#77375)
180
181* Mon Jul 14 2003 Bill Nottingham <notting@redhat.com> 3.1.6-22
182- fix build with gcc-3.3 some more
183
184* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
185- rebuilt
186
187* Thu May 22 2003 Bill Nottingham <notting@redhat.com> 3.1.6-21
188- fix build with gcc-3.3
189
190* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
191- rebuilt
192
193* Tue Jan  7 2003 Jeff Johnson <jbj@redhat.com> 3.1.6-19
194- don't include -debuginfo files in package.
195
196* Sat Nov 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
197- add further lib64 support, clean up spec file
198
199* Sat Oct 12 2002 Florian La Roche <Florian.LaRoche@redhat.de>
200- add 64bit patch
201
202* Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
203- don't strip binaries
204- fix buffering with esd output (#57154, <stssppnn@yahoo.com>)
205
206* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
207- automated rebuild
208
209* Thu May 23 2002 Tim Powers <timp@redhat.com>
210- automated rebuild
211
212* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
213- automated rebuild
214
215* Fri Jul 20 2001 Bill Nottingham <notting@redhat.com>
216- add buildprereq for ncurses-devel (#49524)
217
218* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
219- Bump release + rebuild.
220
221* Thu Dec  7 2000 Bill Nottingham <notting@redhat.com>
222- fix %doc generation
223
224* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
225- automatic rebuild
226
227* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
228- FHS fixes, etc.
229
230* Mon Apr  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
231- rebuild with current ncurses
232- library 3.1.9
233- fix build when libmikmod is not already installed
234
235* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
236- gzip info page (Bug #9035)
237- Update URL and Source fields to present location
238
239* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
240- fix description
241- get rid of useless defines
242
243* Tue Jan 11 2000 Bill Nottingham <notting@redhat.com>
244- update lib to 3.1.8
245
246* Mon Aug  2 1999 Bill Nottingham <notting@redhat.com>
247- add more patches
248
249* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
250- update to 3.1.6/3.1.7
251
252* Mon Mar 22 1999 Cristian Gafton <gafton@redhat.com>
253- fixed spec file description and group according to sepcspo
254
255* Mon Mar 22 1999 Michael Maher <mike@redhat.com>
256- changed spec file, updated package
257- added libmikmod to the package
258
259* Mon Feb 15 1999 Miodrag Vallat <miodrag@multimania.com>
260- Created for 3.1.5
261
262* Tue Jan 24 1999 Michael Maher <mike@redhat.com>
263- changed group
264- fixed bug #145
265
266* Fri Sep 04 1998 Michael Maher <mike@redhat.com>
267- added patch for alpha
268
269* Wed Sep 02 1998 Michael Maher <mike@redhat.com>
270- built package; obsoletes the ancient tracker program.
271
Note: See TracBrowser for help on using the repository browser.