source: projects/specs/branches/6/m/mew/mew-vl.spec @ 3735

Revision 3735, 11.2 KB checked in by Takemikaduchi, 13 years ago (diff)

clutter,gthumb,babl,gegl:new upstream release, others: rebuild

Line 
1%define _docdir %{_defaultdocdir}
2%define _noVersionedDependencies        1
3# %define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4
5%define _libdir %{_prefix}/lib
6
7%define       origver       6.3
8%define       pkgver        %{origver}
9%define       origname      mew       
10
11
12Summary:       Mew - Messaging in the Emacs World
13Summary(ja):   Emacs でメールを読むためのインターフェース
14Name:          %{origname}
15Version:       %{origver}
16Release:       2%{?_dist_release}
17License:       distributable
18Group:         Applications/Editors/Emacs
19URL:           http://www.mew.org/
20Source0:       http://www.mew.org/Release/mew-%{pkgver}.tar.gz
21Source1:       %{origname}-install.sh
22Source2:       %{origname}-remove.sh
23Source3:       vine.dot.mew
24
25Source4:       %{name}-init.el
26Source5:       vine-default-%{name}.el
27
28Patch11:       mew-6.3-icondir.diff
29
30Requires:      emacsen
31Requires:      perl >= 5.004_jp-4
32Provides:      %{origname} = %{origver}
33#Conflicts:     %{origname}-el
34Obsoletes:     mew-mule, mew-el
35Obsoletes:     mew-xemacs, mew-xemacs-extra
36Requires:      mew-common = %{version}
37# PreReq:        /sbin/install-info
38
39BuildRequires: emacsen
40BuildRoot:     %{_tmppath}/%{name}-%{origver}-root
41
42Vendor:        Project Vine
43Distribution:  Vine Linux
44
45
46%description
47Messaging in the Emacs World.  It provides a very easy user interface
48to e-mail, MIME and PGP (Pretty Good Privacy) on Emacsen.
49
50Please install Perl5 to use mew.
51
52Don't forget to copy %{_docdir}/mew-%{version}/vine.dot.mew
53to your ~/.mew.el file, and modify the site configurations, e.g.
54
55    (setq mew-mail-domain-list '("your mail domain"))
56
57%description -l ja
58電子メールを Emacs / XEmacs 上で簡単に読み書きすることができるインター
59フェース mew です。MIME や PGP にも対応しています。mewを使うためには、
60perlが必要です。
61
62%{_docdir}/mew-common-%{version}/vine.dot.mew を ~/.mew.el としてコピー
63し、適切に設定してください。
64
65    (setq mew-mail-domain-list '("your mail domain"))
66
67また、%{_docdir}/mew-common-%{version}/contrib/以下にもいくつかのMewを便利に使う
68為のelispを収録しています。
69
70
71%package -n mew-common
72Summary:     Common files/programs for Mew Emacs/XEmacs
73Summary(ja): Emacs/XEmacs 用 Mew 両方で利用するファイル/プログラム
74Group:       Applications/Internet
75Obsoletes:   mew-xemacs-extra
76
77
78%description -n mew-common
79This package contains common files/programs for Mew Emacs/XEmacs.
80
81%description -n mew-common -l ja
82Emacs/XEmacs 用 Mew に共通するファイル/プログラムです.
83
84
85%prep
86%setup -q -n mew-%{pkgver}
87%patch11 -p1
88
89cp %{SOURCE3} .
90
91%build
92%configure
93make PREFIX="/usr" CFLAGS="$RPM_OPT_FLAGS" bin
94
95
96%install
97[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
98
99mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
100mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/install
101mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/remove
102mkdir -p %{buildroot}/usr/info
103mkdir -p %{buildroot}%{_datadir}/pixmaps/%{origname}
104# install el files
105
106
107        # Add here commands to install the package into debian/mew.
108        cp *.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
109        cp %{SOURCE4} %{SOURCE5} \
110            %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
111        make install-bin prefix=%{buildroot}%{_prefix} \
112                mandir=%{buildroot}%{_mandir}/man1 \
113                bindir=%{buildroot}%{_bindir}
114
115        # contrib
116        #install -m 755 contrib/mewinc contrib/incdir contrib/incmbox \
117        #         $RPM_BUILD_ROOT/%{_docdir}/%{origname}/contrib/
118
119        ## install icons
120        cp etc/*.xpm %{buildroot}/usr/share/pixmaps/%{origname}
121        cp etc/*.png %{buildroot}/usr/share/pixmaps/%{origname}
122        cp etc/*.img %{buildroot}/usr/share/pixmaps/%{origname}
123
124        ## install contrib
125        #cp -a contrib $(CURDIR)/debian/mew/usr/share/doc/mew
126
127
128
129
130# install {info,jinfo} for mew-emacs
131make infodir="%{buildroot}%{_infodir}" \
132    INSTALLINFO="/sbin/install-info" install-info install-jinfo
133rm -f %{buildroot}%{_infodir}/dir
134
135gzip -9nf %{buildroot}%{_infodir}/*
136
137%_installemacsenscript %{origname} %{SOURCE1}
138
139%_removeemacsenscript  %{origname} %{SOURCE2}
140
141%post
142
143if [ "$1" = 2 ]; then
144
145%_emacsenPackageRemove %{origname}
146
147fi
148
149%_addemacsenlist %{origname}
150
151%_emacsenPackageInstall %{origname}
152
153
154/sbin/install-info %{_infodir}/mew.info.gz %{_infodir}/dir \
155  --section="Message User Agent"
156/sbin/install-info %{_infodir}/mew.jis.info.gz %{_infodir}/dir \
157  --section="Message User Agent"
158
159
160%preun
161if [ "$1" = 0 ]; then
162
163  %_emacsenPackageRemove %{origname}
164
165  %_removeemacsenlist %{origname}
166
167
168  /sbin/install-info --delete %{_infodir}/mew.info.gz %{_infodir}/dir \
169  --section="Message User Agent"
170  /sbin/install-info --delete %{_infodir}/mew.jis.info.gz %{_infodir}/dir \
171  --section="Message User Agent"
172fi
173
174
175%clean
176[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
177
178
179%files
180%defattr(-,root,root)
181%{_infodir}/mew.info*
182%{_infodir}/mew.jis.info*
183%{_datadir}/emacs/site-lisp/%{origname}/
184%{_libdir}/emacsen-common/packages/install/%{origname}
185%{_libdir}/emacsen-common/packages/remove/%{origname}
186%{_datadir}/pixmaps/%{origname}
187
188
189%files -n mew-common
190%defattr(-,root,root)
191%doc 00changes 00copyright 00copyright.jis 00diff 00readme
192%doc mew.dot.emacs vine.dot.mew
193%doc contrib/
194%{_bindir}/*
195%{_mandir}/man1/*
196
197%changelog
198* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.3-2
199- rebuild with rpm-4.8.1
200- change pixmap directory
201- fix Patch11
202
203* Mon Dec 21 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.3-1
204- new upstream release
205
206* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-3
207- fixed mew-init.el
208
209* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-2
210- added mew-init.el, vine-default-mew.el
211- updated mew-install.sh, mew-remove.sh for vine-default-mew.el
212
213* Fri Jan 16 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.2-1
214- new upstream release
215
216* Sun Jun 15 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-1
217- applied new versioning policy
218
219* Tue Jun 10 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-0vl1
220- new upstream release
221
222* Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 5.2-0vl3
223- added %%define _lib lib (for x86_64 support)
224
225* Mon Mar 05 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl2
226- added support X-Spam-Flag header in vine.dot.mew
227
228* Tue Jan 23 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl1
229- new upstream release
230
231* Mon Nov 26 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.1-0vl1
232- new upstream release
233- modified vine.dot.mew for Mew-5.1 feature support
234
235* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl3
236- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
237
238* Tue Jul 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl2
239- changed Group to Applications/Editors/EmacsLisp
240- changed common package's Group to Applications/Internet
241
242* Mon Feb 14 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.2-0vl1
243- source update
244
245* Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1-0vl1
246- source update
247
248* Mon Jul 28 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.3-0vl1
249- source update
250
251* Thu Mar 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2-0vl1
252- source update
253- update vine.dot.mew
254  Obsoleting the following variables:
255        mew-noreplyto-to-list
256        mew-noreplyto-cc-list
257        mew-replyto-to-list
258        mew-replyto-cc-list
259        mew-fromme-to-list
260        mew-fromme-cc-list
261  And defining the following variables:
262        mew-reply-all-alist
263        mew-reply-sender-alist
264        mew-reply-fromme-alist
265
266* Sat Jan 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl3
267- added vine.dot.mew(Source3)
268
269* Wed Dec 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl2
270- source update
271
272* Tue Dec 03 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl1
273- update to mew-3.1
274
275* Thu Nov 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.2
276- test package: update to mew-3.1rc2
277
278* Fri Nov 01 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.1
279- test package: update to mew-3.1rc1
280
281* Mon Mar 18 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-0vl4
282- changed License to distributable (not GPL2)
283
284* Mon Mar 18 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 2.2-0vl3
285- incm and man pages are included in common subpackage
286
287* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.2-0vl2
288- corrected Group for common subpackage
289
290* Mon Feb 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2-0vl1
291- update to mew-2.2
292
293* Thu Feb 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.99.4-0vl1
294- update to mew-2.2rc4
295
296* Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2..99.2-0vl1
297- update to mew-2.2rc2
298
299* Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl3
300- mew-el -> mew
301- added Patch11 to set default icon directory for Vine
302
303* Wed Dec 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl2
304- added Obsoletes: mew-xemacs, mew-xemacs-extra
305- install-info gzipped info files :)
306
307* Thu Nov 01 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-0vl1
308- update 2.1
309
310* Sat Oct  6 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0-0vl5
311- change package name ( mew -> mew-el)
312-  apply  emacsenc-oomon
313
314* Thu Sep 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
315- Oops, forgot to add %%defattr for mew-common. Fixed.
316
317* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
318- split mew-common, obsoletes mew-xemacs-extra
319
320* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
321- 2.0-0vl2: eliminate executable bit in %%doc and bin files install 755
322- install info files into %%{_infodir}
323
324* Sun Aug 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
325- 2.0-0vl1
326- update
327
328* Tue Oct 24 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
329- 1.94.2-3
330- fixed %files section to handle compressed info pages
331
332* Wed Jun  7 2000 Toru Sagami <czs14350@nifty.ne.jp>
333- fix description: mess up with mule/emacs/xemacs...
334- added BuildRequires and Conflicts
335
336* Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
337- updated 1.94.2
338
339* Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
340- added PreReq: /sbin/install-info
341- attrib +x for /usr/bin/uumerge
342- CFLAGS="$RPM_OPT_FLAGS"
343
344* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
345 - 1.94.1-2
346 - changed destination to /usr/share/emacs/site-lisp/mew
347
348* Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
349 - 1.94.1-1
350 - updated in sync with 1.94.1 release
351 - fixed %post and %preun section
352 - Obsoletes: mew now changed to Obsoletes: mew-mule
353
354* Fri Oct  8 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
355 - fixed info path & install info
356 - fixed '%description'
357
358* Sat Oct  2 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
359 - removed extra packages
360 - fixed char-set "euc" of the spec file.
361 - slight modifications for Vine-1.9
362
363* Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
364  - 1.94-3
365  - package name changed from mew-emacs to mew
366  - make info, make jinfo now processed even under emacs
367
368* Thu Sep 16 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
369- Released as version "1.94-2".
370
371Changed from "mew-emacs 1.94-1".
372- Deleted "NoSource: 0", the definition part of data.
373- Revised some, the definition part of data.
374- Revised some, part of "%post, %postun".
375- Changerd "%postun" => "%preun".
376
377* Mon Sep  6 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
378- First release.
Note: See TracBrowser for help on using the repository browser.