source: projects/specs/branches/6/m/metamail/metamail-vl.spec @ 521

Revision 521, 7.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A program for handling multimedia mail using the mailcap file.
2Summary(ja): mailcap ファイルを使ってマルチメディアメールを扱うプログラム
3Name: metamail
4Version: 2.7
5Release: 29%{?_dist_release}
6License: Distributable
7Group: Applications/Internet
8Source: ftp://ftp.research.telcordia.com/pub/nsb/mm2.7.tar.Z
9Patch0: mm-2.7-make.patch
10Patch1: mm-2.7-fonts.patch
11Patch2: mm-2.7-glibc.patch
12Patch3: mm-2.7-csh.patch
13Patch4: mm-2.7-uudecode.patch
14Patch5: mm-2.7-sunquote.patch
15Patch6: mm-2.7-tmpfile.patch
16Patch7: mm-2.7-ohnonotagain.patch
17Patch8: mm-2.7-arghhh.patch
18Patch9: mm-2.7-sml.patch
19Patch10: metamail-2.7-nl.patch
20Patch11: mm-2.7-linux.patch
21Patch12: metamail-2.7-fixpartial.patch
22Patch13: metamail-2.7-fixawk.patch
23Patch14: metamail-2.7-usesox.patch
24Patch15: metamail-2.7-ulf.patch
25Patch16: mm2.7-shared.patch
26Patch17: mm2.7-richtext.patch
27Patch18: mm2.7-Makefile.patch
28
29Requires: mktemp sharutils csh
30BuildRequires: libtermcap-devel
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
33
34%description
35Metamail is a system for handling multimedia mail, using the mailcap
36file.  Metamail reads the mailcap file, which tells Metamail what
37helper program to call in order to handle a particular type of
38non-text mail.  Note that metamail can also add multimedia support to
39certain non-mail programs.
40
41Metamail should be installed if you need to add multimedia support to
42mail programs and some other programs, using the mailcap file.
43
44%description -l ja
45metamail は mailcap ファイルを使ってマルチメディアメールを扱うための
46システムです.metamail は,テキストではないメールの各部分を,mailcap
47ファイルを読んでそれぞれどのヘルパーアプリケーションを使って読むかを
48決定します.metamail はメール以外のデータを扱うプログラムに
49マルチメディアサポートを追加することも出来ます.
50
51mailcap ファイルを使ってメールプログラムやその他のプログラムに
52マルチメディアサポートを追加したい場合は,metamail をインストールして
53下さい.
54
55
56%prep
57%setup -q -n mm2.7
58%patch0 -p1 -b .make
59%patch1 -p1 -b .font
60%patch2 -p1 -b .glibc
61%patch3 -p1 -b .csh
62%patch4 -p1 -b .tmpfiles
63%patch5 -p1 -b .quote
64#%patch6 -p1 -b .tmpagain
65%patch7 -p1 -b .sigh
66%patch8 -p1 -b .arghhh
67%patch9 -p1 -b .sml
68%patch10 -p1
69%patch11 -p1 -b .linux
70%patch12 -p1 -b .fixpartial
71%patch13 -p1 -b .fixawk
72%patch14 -p1 -b .usesox
73pushd src/metamail
74%patch15 -p0 -b .ulf
75popd
76%patch16 -p1 -b .shared
77%patch17 -p1 -b .richtext
78%patch18 -p1 -b .Makefile
79
80
81%build
82cd src
83make RPM_OPT_FLAGS="$RPM_OPT_FLAGS" basics
84
85%install
86rm -rf $RPM_BUILD_ROOT
87#mkdir -p $RPM_BUILD_ROOT/{usr/bin,usr/lib/metamail/fonts,%{_mandir}/man{1,4}}
88mkdir -p $RPM_BUILD_ROOT/{%{_bindir},%{_mandir}/man{1,4}}
89
90cd src
91make INSTROOT=$RPM_BUILD_ROOT%{_prefix} \
92     MAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
93     MAN4DIR=$RPM_BUILD_ROOT%{_mandir}/man4 \
94     install-all || :
95
96# These fonts are now included in XFree86 4.0.2...
97#install -m644 fonts/*.pcf %{buildroot}/usr/lib/metamail/fonts
98#install -m644 fonts/fonts.alias %{buildroot}/usr/lib/metamail/fonts
99#mkfontdir %{buildroot}/usr/lib/metamail/fonts
100#rm -fr $RPM_BUILD_ROOT/usr/lib/metamail/fonts
101
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106
107%files
108%defattr(755,root,root)
109%{_bindir}/audiocompose
110%{_bindir}/audiosend
111%{_bindir}/extcompose
112%{_bindir}/getfilename
113%{_bindir}/mailserver
114%{_bindir}/mailto
115%{_bindir}/mailto-hebrew
116%{_bindir}/metamail
117%{_bindir}/metasend
118%{_bindir}/mimencode
119%{_bindir}/mmencode
120%{_bindir}/patch-metamail
121%{_bindir}/rcvAppleSingle
122%{_bindir}/richtext
123%{_bindir}/richtoatk
124%{_bindir}/showaudio
125%{_bindir}/showexternal
126%{_bindir}/shownonascii
127%{_bindir}/showpartial
128%{_bindir}/showpicture
129%{_bindir}/sndAppleSingle
130%{_bindir}/splitmail
131%{_bindir}/sun-audio-file
132%{_bindir}/sun-message.csh
133%{_bindir}/sun-to-mime
134%{_bindir}/sun2mime
135%defattr(644,root,root)
136%{_mandir}/man1/audiocompose.1*
137%{_mandir}/man1/audiosend.1*
138%{_mandir}/man1/extcompose.1*
139%{_mandir}/man1/getfilename.1*
140%{_mandir}/man1/mailto-hebrew.1*
141%{_mandir}/man1/mailto.1*
142%{_mandir}/man1/metamail.1*
143%{_mandir}/man1/metasend.1*
144%{_mandir}/man1/mime.1*
145%{_mandir}/man1/mimencode.1*
146%{_mandir}/man1/mmencode.1*
147%{_mandir}/man1/patch-metamail.1*
148%{_mandir}/man1/richtext.1*
149%{_mandir}/man1/showaudio.1*
150%{_mandir}/man1/showexternal.1*
151%{_mandir}/man1/shownonascii.1*
152%{_mandir}/man1/showpartial.1*
153%{_mandir}/man1/showpicture.1*
154%{_mandir}/man1/splitmail.1*
155#%{_libdir}/metamail
156
157
158%changelog
159* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.7-29vl5
160- applied new versioning policy, spec in utf-8
161
162* Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 2.7-29vl3
163- added Patch16: mm2.7-shared.patch
164- added Patch17: mm2.7-richtext.patch
165- added Patch18: mm2.7-Makefile.patch
166
167* Tue Mar  2 2004 IWAI, Masaharu <iwai@alib.jp> 2.7-29vl2
168- add BuildRequires: libtermcap-devel
169- fix changelog: build date in 2.7-29vl1
170
171* Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-29vl1
172- based on 2.7-29 from Redhat AW 2.1 updates
173  * Tue Feb 10 2004 Nalin Dahyabhai <nalin@redhat.com> 2.7-29
174  - update source URL
175  - apply rollup patch from Ulf H辰rnhammar to correct some format-string
176    vulnerabilities and buffer overflows (CAN-2004-0104, CAN-2004-0105)
177  * Tue Feb 13 2001 Preston Brown <pbrown@redhat.com>
178  - remove duplicate fonts (#26862)
179  * Thu Feb  1 2001 Preston Brown <pbrown@redhat.com>
180  - fix showpartial usage (#16029)
181  - use sox to play files with showaudio, if present (#21494)
182  - nawk --> gawk for sun2mime (#17429)
183- rebuild with new toolchains
184- s/Copyright/License/
185
186* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
187- 2.7-25vl1
188- based on 2.7-25 from Rawhide
189- added Japanese summary and description
190
191* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
192- automatic rebuild
193
194* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
195- use %%{_mandir}
196- remove stupid #defines that break building against any sane set of C
197  libraries (patch11)
198
199* Sun Feb 06 2000 Preston Brown <pbrown@redhat.com>
200- rebuild w/gzipped man pages and new description
201
202* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
203- fox the newline parsing for the mailto content-type problem
204
205* Fri Jul 30 1999 Michael K. Johnson <johnsonm@redhat.com>
206- changed all instances of /usr/lib/sendmail to /usr/sbin/sendmail [bug #4010]
207
208* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
209- auto rebuild in the new build environment (release 20)
210
211* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
212- rebuild against glibc 2.1
213
214* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
215- build root
216
217* Tue Jun 23 1998 Alan Cox <alan@redhat.com>
218- Here we go again. One more quoting issue.
219
220* Mon Jun 22 1998 Alan Cox <alan@redhat.com>
221- If you want to know how not to write secure software
222  then metamail is a good worked example. Mind you to
223  be fair the original author wrote it as a prototype
224  MIME tool and it stuck. Anyway it might actually be
225  safe now. More from the Linux Security Audit Project.
226
227* Tue Jun 16 1998 Alan Cox <alan@redhat.com>
228- Round and round the tmp fixes go
229  Where they stop nobody knows
230- More holes in metamail fixed - (Linux Security Audit Project)
231
232* Tue May 19 1998 Prospector System <bugs@redhat.com>
233- translations modified for de
234
235* Tue May 19 1998 Alan Cox <alan@redhat.com>
236- Fixed the quoting bug in sun mail handling noted by Chris Evans and
237  a while back via bugtraq.
238
239* Thu May 07 1998 Prospector System <bugs@redhat.com>
240- translations modified for de, fr, tr
241
242* Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
243- added security fix for uudecode
244- requires mktemp, sharutils
245
246* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
247- built against glibc
248
249* Tue Apr 22 1997 Erik Troan <ewt@redhat.com>
250- Added security patch from Olaf for csh escapes.
Note: See TracBrowser for help on using the repository browser.