source: projects/specs/branches/6/m/medit/medit-vl.spec @ 3737

Revision 3737, 5.6 KB checked in by kudoh, 13 years ago (diff)
Line 
1%define name     medit
2%define version  1.0.3
3
4Name:        %{name}
5Version:     %{version}
6Release:     1%{?_dist_release}
7Summary:     Multiplatform GTK+2 text editor
8Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
9Group:       Applications/Editors
10License:     GPLv2+
11URL:         http://mooedit.sourceforge.net/
12Source0:     http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
13Source1:     medit_ja.po
14
15BuildRoot:   %{_tmppath}/%{name}-%{version}-root
16
17Buildrequires:   cairo-devel
18BuildRequires:   desktop-file-utils
19BuildRequires:   gettext
20BuildRequires:   gtk2-devel glib2-devel
21BuildRequires:   intltool
22BuildRequires:   libxml2-devel
23BuildRequires:   libX11-devel libXext-devel libICE-devel
24BuildRequires:   libSM-devel
25Buildrequires:   perl-XML-Parser pango-devel
26BuildRequires:   pcre-devel
27BuildRequires:   python-devel
28BuildRequires:   pygtk2-devel
29
30%description
31Medit is a multiplatform GTK+2 text editor.
32
33Features:
34 * Configurable syntax highlighting.
35 * Configurable keyboard accelerators.
36 * Multiplatform - works both on unix and windows.
37 * Plugins: can be written in C or Python.
38 * Configurable tools available from the main and context menus.
39   They can be written in Python or Lua, or it can be a shell script.
40 * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
41
42%description -l ja
43Medit はマルチプラットフォームな GTK+2 テキストエディタです。
44
45機能一覧:
46 * 設定可能な構文強調機能。
47 * 設定可能なキーボードアクセラレータ。
48 * マルチプラットフォーム - unix と windows の両者で動作。
49 * プラグイン: C あるいは Python で作成可能。
50 * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
51   Python あるいは lua 、シェルスクリプトで作成可能。
52 * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
53
54
55%prep
56%setup -q
57sed -i 's|fr|fr\nja|g' po/LINGUAS
58
59%__cp -f %{SOURCE1} po/ja.po
60
61%build
62#cmake -D CMAKE_INSTALL_PREFIX=/usr .
63%configure
64make %{?_smp_mflags}
65
66%install
67rm -rf %{buildroot}
68make install DESTDIR=$RPM_BUILD_ROOT
69
70desktop-file-install --vendor=""                          \
71        --dir=${RPM_BUILD_ROOT}%{_datadir}/applications   \
72        --mode 0644                                       \
73        $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
74
75%post
76update-desktop-database %{_datadir}/applications
77touch --no-create %{_datadir}/icons/hicolor
78if [ -x /usr/bin/gtk-update-icon-cache ]; then
79  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
80fi
81
82%postun
83update-desktop-database %{_datadir}/applications
84touch --no-create %{_datadir}/icons/hicolor
85if [ -x /usr/bin/gtk-update-icon-cache ]; then
86  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
87fi
88
89%clean
90rm -rf %{buildroot}
91
92%files
93%defattr(-,root,root)
94%doc COPYING README
95%{_bindir}/*
96%{_datadir}/applications/%{name}.desktop
97%{_datadir}/%{name}-1/*
98%{_datadir}/icons/hicolor/48x48/
99%exclude %{_datadir}/icons/hicolor/icon-theme.cache
100%{_datadir}/locale/*
101%{_docdir}/%{name}-1/*
102%{_mandir}/man?/
103
104%changelog
105* Sat Apr 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.3-1
106- new upstream release
107
108* Mon Feb 28 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1-1
109- new upstream release
110
111* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.0-1
112- new upstream release
113- updated Source1
114- dropt BuildRequires: cmake
115- added BuildRequires: libSM-devel
116- fixed %%files
117
118* Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
119- updated Source1
120
121* Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
122- new upstream release
123- cleaned up spec
124
125* Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
126- updated Source1
127- added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
128- changed BuildRequires: cmake >= 2.6
129
130* Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
131- new upstream release
132- added Japanese language file
133- added man directory in %files
134
135* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
136- new upstream release
137- applied new naming policy to spec
138
139* Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
140- initial build for VineSeed
141
142* Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
143+ Revision: 155675
144- New version 0.9.2
145- rediff patch0
146
147  + Olivier Blin <oblin@mandriva.com>
148    - restore BuildRoot
149
150  + Thierry Vignaud <tvignaud@mandriva.com>
151    - kill re-definition of %%buildroot on Pixel's request
152
153* Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
154+ Revision: 114221
155- New version 0.9.0
156
157* Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
158+ Revision: 109208
159- New release 0.8.11
160
161* Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
162+ Revision: 59667
163- New version 0.8.10
164
165* Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
166+ Revision: 57568
167- New version 0.8.9
168
169* Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
170+ Revision: 51500
171- Fix file list
172- New version
173
174* Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
175+ Revision: 39539
176- SILent renew tarball
177- New version
178- New version
179  add dirty patch that skips update-icon-cache and mime database when building
180
181  + Jérôme Soyer <saispo@mandriva.org>
182    - Import medit
183
184
185
186
187* Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
188- new release
189
190* Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
191- first spec for Mandriva
Note: See TracBrowser for help on using the repository browser.