source: projects/specs/branches/6/m/mcomix/mcomix-vl.spec @ 4311

Revision 4311, 3.2 KB checked in by kudoh, 13 years ago (diff)
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:        customizable image viewer that specifically designed to handle comic books
4Summary(ja):    漫画向けに特化してデザインされたカスタム可能なイメージビューワ
5Name:           mcomix
6Version:        0.92
7Release:        2%{?_dist_release}
8Source0:        mcomix-%{version}.tar.bz2
9Source1:        mcomix_ja.po
10
11License:        GPLv2
12Group:          Applications/Graphics
13URL:            http://mcomix.sourceforge.net/
14
15Requires:       pygtk2 >= 2.12, python-imaging >= 1.1.5, libjpeg-turbo
16Requires:       python >= 2.5
17
18BuildRequires:  python  >= 2.5
19BuildRequires:  python-setuptools
20BuildRequires:  pygtk2-devel python-imaging
21BuildRequires:  gettext
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildArch: noarch
24
25%description
26MComix is a user-friendly, customizable image viewer. It is specifically
27designed to handle comic books, but also serves as a generic viewer. It
28reads images in ZIP, RAR or tar archives as well as plain image files.
29It is written in Python and uses GTK+ through the PyGTK bindings.
30
31%description -l ja
32MComix はユーザーフレンドリでカスタマイズ可能なイメージビューワです。
33このビューワは漫画を読むのに特化してデザインされていますが、一般的な画像
34ビューワとしても利用できます。
35通常のイメージファイルと同様に、ZIP、RAR または tar (gzip 及び bzip2 で圧縮
36されたものも含む) アーカイブ中のイメージも読み込めます。
37Python で書かれており、PyGTK バインディングを通じて GTK+ を使用しています。
38
39%prep
40
41%setup -qn mcomix-%{version}
42%{__cp} -f %{SOURCE1} mcomix/messages/ja/LC_MESSAGES/mcomix.po
43msgfmt -o mcomix/messages/ja/LC_MESSAGES/mcomix.mo mcomix/messages/ja/LC_MESSAGES/mcomix.po
44
45%install
46%{__rm} -rf ${RPM_BUILD_ROOT}
47
48%{__python} setup.py install --single-version-externally-managed --root=$RPM_BUILD_ROOT
49
50%clean
51%{__rm} -rf ${RPM_BUILD_ROOT}
52
53%post
54touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
55
56
57%postun
58if [ $1 -eq 0 ] ; then
59        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
60        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
61fi
62
63%posttrans
64gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
65
66
67%files
68%defattr(-,root,root)
69%doc ChangeLog README
70%{_bindir}/%{name}
71%{_datadir}/applications/%{name}.desktop
72%{_datadir}/icons/hicolor/
73%{_datadir}/mime/packages/%{name}.xml
74%{_mandir}/man1/*.1.gz
75%{python_sitelib}/*
76
77%changelog
78* Sun Jul 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.92-2
79- updated source1
80
81* Sat Jul 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.92-1
82- new upstream release
83- replaced source1
84
85* Sun May 22 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.91-2
86- added BuildRequires:  python-setuptools
87
88* Wed May 11 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.91-1
89- new upstream release
90- changed Lisence tag
91  - applied to GPLv2
92- changed URL
93- changed BuildArch to noarch
94
95* Sun Nov 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.90.2-2
96- updated source1
97- probed %%post and %%postun
98  - added %%posttrans
99
100* Sat Oct 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.90.2-1
101- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.