source: projects/specs/branches/6/m/maxima/maxima-vl.spec @ 6364

Revision 6364, 5.5 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild or update packages

Line 
1# -*- mode: rpm-spec -*-
2
3# By default, this spec file will generate RPMs for Clisp, CMUCL
4# and GCL. This can be changed by modifying the variables below.
5%define enable_clisp 1
6%define clisp_flags --enable-clisp
7%define enable_cmucl 0
8%define cmucl_flags --disable-cmucl
9%define enable_gcl 0
10%define gcl_flags --disable-gcl
11
12# Inhibit automatic compressing of info files. Compressed info
13# files break maxima's internal help.
14%define __spec_install_post /bin/true
15
16Summary: Maxima Symbolic Computation Program
17Summary(ja): 数式処理プログラム Maxima
18Name: maxima
19Version: 5.16.3
20Release: 3%{?_dist_release}
21License: GPL
22Group: Applications/Engineering
23URL: http://maxima.sourceforge.net
24Source0: %{name}-%{version}.tar.gz
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26Requires: maxima_exec = %{version}-%{release}
27Requires(post): /sbin/install-info
28Requires(preun): /sbin/install-info
29
30%description
31Maxima is a full symbolic computation program.  It is full featured
32doing symbolic manipulation of polynomials, matrices, rational
33functions, integration, Todd-coxeter, graphing, bigfloats.  It has a
34symbolic debugger source level debugger for maxima code.  Maxima is
35based on the original Macsyma developed at MIT in the 1970's.  It is
36quite reliable, and has good garbage collection, and no memory leaks.
37It comes with hundreds of self tests.
38
39%description -l ja
40Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
41有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
42も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
43ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
44Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
45ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
46信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
47
48%package xmaxima
49Summary: Tcl/Tk interface to Maxima
50Summary(ja): Maxima 用 Tcl/Tk インターフェース
51Group: Applications/Engineering
52Requires: %{name} = %{version}-%{release}
53Requires: tk > 8.1
54Provides: xmaxima
55
56%description xmaxima
57Tcl/Tk interface to Maxima.
58
59%if %{enable_clisp}
60%package exec-clisp
61Summary: Maxima compiled with clisp
62Group: Applications/Engineering
63Requires: clisp
64BuildRequires: clisp
65Provides: maxima_exec
66%description exec-clisp
67Maxima compiled with clisp.
68%endif
69
70%if %{enable_cmucl}
71%package exec-cmucl
72Summary: Maxima compiled with CMUCL
73Group: Applications/Engineering
74Requires: cmucl
75BuildPreReq: cmucl
76Provides: maxima_exec
77%description exec-cmucl
78Maxima compiled with CMUCL.
79%endif
80
81%if %{enable_gcl}
82%package exec-gcl
83Summary: Maxima compiled with GCL
84Group: Applications/Engineering
85Requires: gcl
86BuildPreReq: gcl
87Provides: maxima_exec
88%description exec-gcl
89Maxima compiled with Gnu Common Lisp.
90%endif
91
92%prep
93%setup -q
94%configure  %{?cmucl_flags:} %{?gcl_flags:} %{?clisp_flags:}
95
96%build
97%__make
98
99%install
100%__rm -rf %{buildroot}
101%makeinstall
102
103rm -f $RPM_BUILD_ROOT%{_infodir}/dir
104
105%post
106/sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
107
108%preun
109if [ "$1" = 0 ]; then
110        /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
111fi
112
113%clean
114%__rm -rf %{buildroot}
115
116%files
117%defattr(-,root,root,-)
118%{_datadir}/maxima/%{version}
119%dir %{_libdir}/maxima/%{version}
120%{_libexecdir}/maxima/%{version}
121%{_infodir}/*
122%{_mandir}/man1/*
123%{_bindir}/*
124%doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
125
126%files xmaxima
127%{_bindir}/xmaxima
128
129%if %{enable_clisp}
130%files exec-clisp
131%{_libdir}/maxima/%{version}/binary-clisp
132%endif
133
134%if %{enable_cmucl}
135%files exec-cmucl
136%{_libdir}/maxima/%{version}/binary-cmucl
137%endif
138
139%if %{enable_gcl}
140%files exec-gcl
141%{_libdir}/maxima/%{version}/binary-gcl
142%endif
143
144%changelog
145* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.16.3-3
146- rebuild with Vine6 environment
147
148* Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
149- rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
150
151* Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
152- new upstream release
153
154* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
155- applied new versioning policy, spec in utf-8
156
157* Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
158- New upstream release
159- Change Group
160
161* Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
162- Japanese Summary and description by rpmSpecTranslate project
163
164* Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
165- New upstream release (for diff() bug fix)
166- Tidy up spec file
167
168* Sun Feb  1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
169- Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
170
171* Sat Aug  2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
172- Add exec-clisp BuildPreReq clisp
173- Add xmaxima Requires tk > 8.1
174- Remove xmaxima-olderTcl patch
175
176* Fri Jun  6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
177- Rebuild for clisp-2.29-0vl1
178
179* Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
180- Enable clisp only, disable cmucl and gcl
181- Add xmaxima-olderTcl patch (for tclversion older than 8.1)
182- Remove %{_infodir}/dir file
183
184* Sat Jan  4 2003 James Amundson <amundson@fnal.gov>
185- Added doc files
186- Added explicit clisp version
187- Added conditional to postun
188- Renamed exec_* packages to exec-*
189- Use rpm macros instead of hard-coded paths
190- Thanks to Rex Dieter for helpful suggestions
191
192* Sun Sep  8 2002 James Amundson <amundson@fnal.gov>
193- Initial build.
Note: See TracBrowser for help on using the repository browser.