source: projects/specs/branches/6/m/mathabx/mathabx-vl.spec @ 521

Revision 521, 3.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define texmf           %{_datadir}/texmf
2%define updmapcfg       %{_datadir}/texmf-config/web2c/updmap.cfg
3%define build_texmf     $RPM_BUILD_ROOT%{texmf}
4%define mapdir          %{texmf}-dist/fonts/map/dvips/misc
5%define mathabxdate     20050518
6
7%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
8%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
9
10Summary: The mathabx font series: extended and extendable series of mathematical symbols for TeX
11Summary(ja): TeX 用の新しい数式フォント
12Name: mathabx
13Version: 2005
14Release: 1%{?_dist_release}
15Source0: mathabx-%{mathabxdate}.tar.bz2
16Source1: abxtype1-%{mathabxdate}.tar.bz2
17Source2: mathabx_docs-%{mathabxdate}.tar.bz2
18URL: http://auemath.aichi-edu.ac.jp/~khotta/ghost/mathabx.html
19License: GPL
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21Group: Applications/Publishing
22BuildArch: noarch
23PreReq: sed, sh-utils
24Requires: task-tetex
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29The mathabx font series is a high quality extended and extendable series of
30mathematical symbols.
31To use this package, you describe \usepackage{mathabx} at preamble in your
32TeX document.
33
34%description -l ja
35mathabx は CM + AMS の拡張であると考えられます。 全体的に色々な工夫が見られ,
36例えば、積分記号 \int が CM より垂直に見え、不等号 ≦ は AMS のものより < と
37 = がくっついているので、日本人が見慣れているものにより近いようです。
38
39TeX 文書の最初の部分へ \usepackage{mathabx} と記述すれば、普通の数式モードに
40て mathabx の利用が可能になります。
41
42%prep
43rm -rf $RPM_BUILD_ROOT
44
45%setup -q -a 1 -a 2 -n %{name}
46
47%build
48
49%install
50rm -rf $RPM_BUILD_ROOT
51mkdir -p            %{build_texmf}/fonts/source/public/mathabx
52cp -p source/*      %{build_texmf}/fonts/source/public/mathabx
53mkdir -p            %{build_texmf}/tex/latex/mathabx
54cp -p texinputs/*   %{build_texmf}/tex/latex/mathabx
55mkdir -p            %{build_texmf}/fonts/type1/mathabx
56cp -p abxtype1/pfb/*.pfb %{build_texmf}/fonts/type1/mathabx
57mkdir -p            %{buildroot}%{mapdir}
58cp -p abxtype1/map/mathabx.map %{buildroot}%{mapdir}/mathabx.map
59
60%post
61MATHABX=`grep "mathabx" %{updmapcfg}`
62if [ "$MATHABX" = "" ]; then
63    echo "# mathabx" >> %{updmapcfg}
64    echo "Map mathabx.map" >> %{updmapcfg}
65fi
66
67%{exec_texhash}
68%{exec_updmap}
69exit 0
70
71%postun
72if [ "$1" = "0" ]; then
73    perl -pi -e 's/^# mathabx.*\n//; s/^Map mathabx.*\n//' \
74    %{updmapcfg}
75fi
76
77%{exec_texhash}
78%{exec_updmap}
79exit 0
80
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%files
86%defattr(-,root,root)
87%{texmf}/fonts/source/public/mathabx/*
88%{texmf}/fonts/type1/mathabx/*
89%{texmf}/tex/latex/mathabx/*
90%{mapdir}/mathabx.map
91%doc mathtest.tex mathtest.dvi mathtest.pdf
92
93
94%changelog
95* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2005-1vl5
96- applied new versioning policy, spec in utf-8
97
98* Tue May 16 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl4
99- fix exec_updmap: added --nostop option
100
101* Fri Dec 02 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl3
102- fix install dir of mathabx.mat
103
104* Thu Nov 17 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl2
105- fix exec_updmap
106
107* Wed Nov 16 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl1
108- source update
109- modified for tetex-3.0
110
111* Tue Feb 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl3
112- fix exec_updmap
113
114* Thu Dec 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl2
115- source update
116
117* Fri Aug 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl1
118- source update
119
120* Wed Jun 12 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl2
121- update Type1 fonts
122
123* Sun Jun 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl1
124- 1st release
Note: See TracBrowser for help on using the repository browser.