source: projects/specs/branches/6/m/man-pages/man-pages-vl.spec @ 521

Revision 521, 12.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define posix_version 2003
2%define posix_release a
3
4Summary: Man (manual) pages from the Linux Documentation Project.
5Summary(ja): Linux ドキュメンテーションプロジェクトの Man (manual) ページ
6Name: man-pages
7Version: 3.23
8Release: 1%{?_dist_release}
9License: GPLv2+ and GPL+ and BSD and MIT and Copyright only and IEEE
10Group:   Applications/Documentation
11
12Source0: http://www.kernel.org/pub/linux/docs/manpages/man-pages-%{version}.tar.bz2
13# POSIX man pages
14Source1: http://www.kernel.org/pub/linux/docs/man-pages/man-pages-posix/man-pages-posix-%{posix_version}-%{posix_release}.tar.bz2
15Source2: man-pages_add-01.tar.bz2
16Source3: man-pages-extralocale.tar.bz2
17Source4: man-pages_syscalls-01.tar.bz2
18# IBM-supplied man pages for suid binaries:
19Source5: man-suid-bins.tar.bz2
20Patch1: man-pages-1.51-iconv.patch
21Patch28: man-pages-2.46-nscd.patch
22Patch36: man-pages-2.63-unimplemented.patch
23Patch41: man-pages-2.43-rt_spm.patch
24Patch44: man-pages-2.43-fadvise.patch
25Patch45: man-pages-2.48-passwd.patch
26Patch46: man-pages-2.51-nscd-conf.patch
27Patch49: man-pages-2.63-getent.patch
28Patch50: man-pages-2.63-iconv.patch
29Patch53: man-pages-2.78-stream.patch
30Patch54: man-pages-2.80-malloc_h.patch
31Patch55: man-pages-3.22-gai.conf.patch
32Patch56: man-pages-3.22-strcpy.patch
33Patch57: man-pages-3.22-nsswitch.conf.patch
34Patch58: man-pages-3.23-proc.patch
35Patch59: man-pages-3.23-ld.so.patch
36
37Buildroot: %{_tmppath}/%{name}-%{version}-root
38Autoreqprov: false
39BuildArchitectures: noarch
40
41%description
42A large collection of man pages (documentation) from the Linux
43Documentation Project (LDP).
44
45%prep
46%setup -q -n %{name}-%{version} -a 1 -a 2 -a 3 -a 4 -a 5
47
48mv  man-pages-posix-%{posix_version}-%{posix_release}/* ./
49rmdir man-pages-posix-%{posix_version}-%{posix_release}
50
51%patch1 -p1
52%patch28 -p1
53%patch36 -p1
54%patch41 -p1
55%patch44 -p1
56%patch45 -p1
57%patch46 -p1
58%patch49 -p1
59%patch50 -p1
60%patch53 -p1
61%patch54 -p1
62%patch55 -p1
63%patch56 -p1
64%patch57 -p1
65%patch58 -p1
66%patch59 -p1
67
68### And now remove those we are not going to use:
69
70# Part of quota
71rm -v man2/quotactl.2
72
73# Only briefly part of a devel version of glibc
74rm -v man3/getipnodeby{name,addr}.3 man3/freehostent.3
75
76# Part of libattr-devel
77rm -v man2/{,f,l}{get,list,remove,set}xattr.2
78
79# Problem with db x db4 (#198597) - man pages are obsolete
80rm -v man3/{btree,dbopen,hash,mpool,recno}.3
81
82# Remove rpcinfo page - obsolete
83rm -v man8/rpcinfo.8
84
85# Deprecated
86rm -v man2/pciconfig_{write,read,iobase}.2
87
88# Part of squid
89rm -v man8/ncsa_auth.8
90
91# Part of numactl package
92rm -v man5/numa_maps.5
93
94# Vine
95# Part of shadow-utils
96rm -v man3/getspnam.3
97
98# part of bind
99rm -v man5/resolv.conf.5
100
101# Part of bind-utils
102rm -v man5/resolver.5
103
104# Compress/Uncompress man pages
105rm -v man1p/uncompress.1p
106rm -v man1p/compress.1p
107
108# Part of util-linux
109rm -v man1p/renice.1p
110
111# Obsolete
112rm -f man3/infnan.3
113
114%build
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119instdir=$RPM_BUILD_ROOT%{_mandir}
120for sec in 0p 1 1p 2 3 3p 4 5 6 7 8 9; do
121  mkdir -p $instdir{,/en}/man$sec
122  for f in man$sec/*.$sec; do
123    case $f in
124      man$sec/'*'.$sec)
125        # this dir is empty
126        continue ;;
127      man7/iso_8859-*.7)
128        enc=${f#man7/}
129        enc=${enc%.7}
130        enc=ISO-${enc#iso_}
131        LANG=en iconv -f $enc -t utf-8 -o $instdir/$f $f ;;
132      man7/koi8-r.7)
133        enc=${f#man7/}
134        enc=${enc%.7}
135        LANG=en iconv -f $enc -t utf-8 -o $instdir/$f $f ;;
136      *)
137        LANG=en iconv -f latin1 -t utf-8 -o $instdir/en/$f $f
138        LANG=en iconv -f utf-8 -t ascii//translit -o $instdir/$f $instdir/en/$f
139        cmp -s $instdir/$f $instdir/en/$f &&
140          rm $instdir/en/$f ;;
141    esac
142  done
143done
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%files
149%defattr(0644,root,root,0755)
150%doc README man-pages-%{version}.Announce POSIX-COPYRIGHT
151%{_mandir}/man*/*
152%lang(en) %{_mandir}/en/man*
153
154%changelog
155* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23-1
156- added Japanese summary
157- updated Sources and Patches based on Fedora 3.23-3
158
159* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.21-1vl5
160- applied new versioning policy, spec in utf-8
161
162* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.21-1vl2
163- change Group to Applications/Documentation. <BTS:VineLinux:163>
164
165* Mon Jan 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.21-1vl1
166- added Japanese summary
167- updated 2.21 based on Fedora 2.21-1
168  * Mon Jan 16 2006 Ivana Varekova <varekova@redhat.com> 2.21-1
169  - add the description of reload-count option (nscd.conf
170    man page - bug 177368)
171  * Tue Dec 13 2005 Ivana Varekova <varekova@redhat.com> 2.16-2
172  - fix bug 174628 - mmap(2) CAN return mappings at location 0
173  * Thu Sep 29 2005 Ivana Varekova <varekova@redhat.com> 2.07-7
174  - fix typo in nsswitch.conf man page (bug 169309)
175  * Mon Sep 12 2005 Ivana Varekova <varekova@redhat.com> 2.07-3
176  - fix socket.7 man page - fix information about SO_RCVLOWAT option
177    (bug 163120)
178  * Tue Aug 23 2005 Ivana Varekova <varekova@redhat.com> 2.07-2
179  - add sln.8 man page (bug 10601)
180  * Mon Jul 04 2005 Jiri Ryska <jryska@redhat.com> 2.05-1
181  - update to 2.05
182  - atanh(3) fix
183  - issue(5) fix
184  - ldd(1) fix
185  - removed man1p/{compress,uncompress,renice}.1p
186
187* Sun Mar 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.66-0vl1
188- updated 1.66
189- added Patch5--15 from Fedora 1.66-2
190
191* Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-0vl1
192- new upstream release 1.60
193- dropped SOURCE3, 4 and 5
194
195* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.53-0vl1
196- new upstream release 1.53
197
198* Wed Aug 14 2002 IWAI Masaharu <iwai@alib.jp> 1.52-2vl1
199- sync Rawhide 1.52-2
200  - upstream release
201  - added Patch1, 2 and 3
202  - removed getipnodebyname.3, getipnodebyname.3, freehostent.3
203    - Fix reference in rpcgen(1) - #69740
204    - Fix #63547
205    - Mentium mem=nopentium in bootparam(7) - #60487
206    - Fix to iconv(1) - #66441
207    - Ret value of iconv(3) was wrong (#65375)
208    - Remove getipnodebyname, getipnodebyname, freehostent - they were
209      only briefly part of a glibc devel version (#62646)
210
211* Wed Mar 06 2002 Toru Sagami <sagami@vinelinux.org> 1.47-1vl1
212- 1.47
213
214* Wed Oct 10 2001 Toru Sagami <sagami@vinelinux.org> 1.40-1vl1
215- remove resolv.conf.5
216
217* Tue Sep 25 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 1.40-1
218- 1.40. Remove now included patches.
219
220* Tue Sep  4 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 1.39-2
221- New strptime.3, from the ftp site. Matches glibc better.
222- Fix missing .br in netdevices.7 (#53091)
223
224* Tue Aug  7 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
225- 1.39
226- Drop obsolete patches
227
228* Tue Jul 24 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
229- s/NSF/NFS/ in initrd.4 - (#48322)
230
231* Mon Jul  2 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
232- regcomp and friends support collating elements now (#46939)
233
234* Thu Jun 21 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
235- 1.38
236
237* Fri Jun  8 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
238- 1.37
239
240* Thu Jun  7 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
241- Remove capset(2) - part of libcap (#43828)
242
243* Fri Jun  1 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
244- Remove diff.1 - let diffutils include it instead
245- Remove capget.2 - it's included in libcap
246- Keep resolv.conf.5 - it's useful on systems without bind packages
247- Fix bootparam.7 (patch from Tim Waugh (twaugh@redhat.com)
248
249* Tue May 22 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
250- 1.36
251- drop some old patches, redo others
252
253* Thu May 17 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
254- Work around bug in groff for latin1.7 (#41118)
255
256* Wed Apr  4 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
257- use MS_SYNCHRONOUS instead of MS_SYNC in mount(2) (#34665)
258
259* Tue Apr  3 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
260- roff fixes to multiple man pages
261
262* Mon Apr  2 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
263- correct the URL for unicode in the charset manpage (#34291)
264- roff fixes
265- redo iconv patch, so we don't get a .orig from patch because of
266  a two line offset
267
268* Fri Mar 30 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
269- remove resolv.conf (bind-utils) and infnan (obsolete - #34171)
270
271* Wed Mar 28 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
272- resurrect getnetent(3)
273
274* Sun Mar 25 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
275- 1.35, obsoletes patch for strsep
276- move rpcinfo to section 8 (#33114)
277
278* Fri Mar  9 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
279- Include man-pages on locales (#29713)
280
281* Tue Feb 13 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
282- fix return value of strsep(3) call (#24789)
283
284* Mon Jan 15 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
285- 1.34
286
287* Fri Dec 15 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
288- 1.33
289- obsolete some old, now included patches
290- remove netman-cvs, it's now older than the mainstream
291
292* Tue Nov 21 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
293- Identify two of the macros in stat(2) as GNU, not POSIX. (#21169)
294
295* Wed Nov 08 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
296- don't delete the man pages for dlopen() and friends,
297  they are no longer part of another package
298- include man pages for ld*
299
300* Thu Oct 24 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
301- remove const from iconv function prototype (#19486)
302
303* Tue Aug 29 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
304- reference wctype(3) instead of non-existing ctype(3)
305  from regex(7) (#17037)
306- 1.31
307
308* Sun Aug 27 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
309- remove lilo man pages (now included in package)
310  (#16984)
311
312* Fri Aug 04 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
313- fixed bad header specification (#15364)
314- removed obsolete patches from package
315- updated the rest
316
317* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
318- automatic rebuild
319
320* Mon Jun 19 2000 Matt Wilson <msw@redhat.com>
321- defattr before docs in filelist
322
323* Sun Jun 17 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
324- updated to 1.30
325
326* Tue Jun 06 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
327- use %%{_tmppath}
328
329* Wed May 31 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
330- remove resolv.conf(5) - part of bind-utils
331
332* Tue May 30 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
333- Remove resolver, dlclose, dlerror, dlopen, dlsym as these
334  are included in other packages.
335
336* Tue May 30 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
337- use %%{_mandir) instead of /usr/man
338- verify and fix bug in mmap man page (#7382)
339- verify and fix missing data in recvfrom man page (#1736)
340- verify and fix missing data in putw man page (#10104)
341- fixed sendfile(2) man page (#5599)
342- fixed tzset man page (#11623)
343
344* Mon May 15 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
345- updated to 1.29
346- split off other languages into separate RPMS
347
348* Thu Mar 16 2000 Florian La Roche <Florian.LaRoche@redhat.com>
349- do not use group "man"
350
351* Fri Mar 03 2000 Cristian Gafton <gafton@redhat.com>
352- don't apply the netman-cvs man pages anymore, as they seem to be really
353  out of date
354
355* Sat Feb 05 2000 Cristian Gafton <gafton@redhat.com>
356- put back man3/resolver.3
357
358* Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
359- remove non-man pages (#7814)
360
361* Fri Feb  4 2000 Matt Wilson <msw@redhat.com>
362- exclude dir.1 and vdir.1 (these are in the fileutils package)
363
364* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
365- version 1.28
366
367* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
368- Fixed SIGILL, SIGQUIT in signals.7
369
370* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
371- fix man page for getcwd
372
373* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
374- added man pages for set/getcontext
375
376* Tue Sep 14 1999 Bill Nottingham <notting@redhat.com>
377- remove some bad man pages
378
379* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
380- czech, german, spanish, russian man pages
381
382* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
383- version 1.26
384- add french man pages
385- add italian man pages
386
387* Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
388- update to 1.25.
389
390* Fri Apr 16 1999 Cristian Gafton <gafton@redhat.com>
391- fiox man page fro ftw
392
393* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
394- spellnig fixse
395
396* Tue Mar 30 1999 Bill Nottingham <notting@redhat.com>
397- updated to 1.23
398
399* Thu Mar 25 1999 Cristian Gafton <gafton@redhat.com>
400- added kernel net manpages
401
402* Mon Mar 22 1999 Erik Troan <ewt@redhat.com>
403- updated printf man page
404- added rpcgen man page
405
406* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
407- auto rebuild in the new build environment (release 6)
408
409* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
410- leave the lilo man pages alone (oops)
411
412* Fri Feb 12 1999 Michael Maher <mike@redhat.com>
413- fixed bug #413
414
415* Mon Jan 18 1999 Cristian Gafton <gafton@redhat.com>
416- remove lilo man pages too
417- got rebuilt for 6.0
418
419* Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
420- version 1.21
421
422* Sat Jun 20 1998 Jeff Johnson <jbj@redhat.com>
423- updated to 1.20
424
425* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
426- get rid of the modutils man pages
427- updated to 1.19
428
429* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
430- translations modified for de, fr, tr
431
432* Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
433- updated to 1.18
434
435* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
436- updated to 1.17
437- moved build root to /var
438
439* Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
440- made a noarch package
Note: See TracBrowser for help on using the repository browser.