source: projects/specs/branches/6/m/make/make-vl.spec @ 10338

Revision 10338, 7.7 KB checked in by Takemikaduchi, 8 years ago (diff)

merge with VineSeed package

Line 
1Summary:     A GNU tool which simplifies the build process for users.
2Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
3Name: make
4Epoch: 1
5Version: 3.82
6Release: 1%{?_dist_release}
7License: GPL
8Group: Development/Tools
9URL: http://www.gnu.org/software/make/
10Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
11Source1: make-3.81-ja.po
12
13Patch1: make-3.82-noclock_gettime.patch
14Patch2: make-3.82-j8k.patch
15Patch3: make-3.82-getcwd.patch
16Patch4: make-3.82-err-reporting.patch
17
18# Upstream: https://savannah.gnu.org/bugs/?30748
19Patch6: make-3.82-weird-shell.patch
20
21Patch7: make-3.82-newlines.patch
22Patch8: make-3.82-jobserver.patch
23Patch9: make-3.82-bugfixes.patch
24Patch10: make-3.82-sort-blank.patch
25Patch11: make-3.82-copy-on-expand.patch
26
27# Upstream: https://savannah.gnu.org/bugs/?33873
28Patch12: make-3.82-parallel-remake.patch
29
30# http://savannah.gnu.org/bugs/?34335
31Patch13: make-3.82-warn_undefined_function.patch
32
33# http://lists.gnu.org/archive/html/bug-make/2011-06/msg00032.html
34Patch14: make-3.82-trace.patch
35
36# http://lists.gnu.org/archive/html/bug-make/2011-04/msg00002.html
37Patch15: make-3.82-expensive_glob.patch
38
39# Upstream: https://savannah.gnu.org/bugs/?30653
40Patch16: make-3.82-dont-prune-intermediate.patch
41
42Buildroot: %{_tmppath}/%{name}-%{version}-root
43Requires(post): /sbin/install-info
44Requires(preun): /sbin/install-info
45BuildRequires: automake >= 1.7.3
46BuildRequires: perl
47BuildRequires: procps
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53A GNU tool for controlling the generation of executables and other
54non-source files of a program from the program's source files.  Make
55allows users to build and install packages without any significant
56knowledge about the details of the build process.  The details about
57how the program should be built are provided for make in the program's
58makefile.
59
60The GNU make tool should be installed on your system because it is
61commonly used to simplify the process of installing programs.
62
63
64%description -l ja
65プログラムのソースファイルから実行ファイル及びその他のファイルを
66生成する GNU ツールです.Make を使うことでユーザは build 時の
67細かいプロセスを気にせず build しインストールすることが出来ます.
68プログラムがどの様に build されるのかは,プログラムの Makefile に
69書かれています.
70
71GNU make ツールは,プログラムのインストールを容易にするのに
72非常によく使われますので,このパッケージは是非インストールして下さい.
73
74
75%prep
76%setup -q
77
78%patch1 -p1
79%patch2 -p1
80%patch3 -p1
81%patch4 -p1
82%patch6 -p1
83%patch7 -p1
84%patch8 -p1
85%patch9 -p1
86%patch10 -p1
87%patch11 -p1
88%patch12 -p0
89%patch13 -p2
90%patch14 -p1
91%patch15 -p0
92%patch16 -p0
93rm -f tests/scripts/features/parallelism.orig
94
95cp %{SOURCE1} po/ja.po
96
97%build
98config/missing --run aclocal -I config
99config/missing --run automake --gnu Makefile
100config/missing --run autoconf
101%configure
102make
103
104%install
105rm -rf $RPM_BUILD_ROOT
106%makeinstall
107
108pushd $RPM_BUILD_ROOT
109  ln -sf make .%{_bindir}/gmake
110#  gzip -9nf .%{_infodir}/make.info*
111  rm -f .%{_infodir}/dir
112popd
113
114%find_lang %name
115
116
117%check
118echo ============TESTING===============
119/usr/bin/env LANG=C make check
120echo ============END TESTING===========
121
122
123%clean
124rm -rf ${RPM_BUILD_ROOT}
125
126%post
127/sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
128
129%preun
130if [ $1 = 0 ]; then
131   /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
132fi
133
134
135%files -f %{name}.lang
136%defattr(-,root,root)
137%doc NEWS README
138%{_bindir}/*
139%{_mandir}/man*/*
140%{_infodir}/*.info*
141#%{_datadir}/locale/*/LC_MESSAGES/make*
142
143%changelog
144* Wed May 25 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.82-1
145- update to 3.82
146- merge with VineSeed package
147
148  * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.82-1
149  - new upstream release
150
151* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.81-8
152- rebuild for Vine6
153
154* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
155- applied new versioning policy
156- added BuildRequires: perl (for %%check)
157- spec in UTF-8
158
159* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
160- updated to 3.81 based on Fedora packages
161  * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
162  - Always run testsuite with C locale.
163  - Resolves: #232607
164  * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
165  - Fix newline handling for quoted SHELL.
166  - Resolves: #219409
167  * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
168  - Upstream 3.81:
169    - Contains several backwards incompatible changes.  See NEWS inside
170      the source package to find out more.
171  - memory patch and error reporting patch were ported to this version.
172- updated ja.po
173
174* Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
175- added URL
176- s/Copyright/License/
177- added some patches from fedora development 3.80-8
178  * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
179  - make sure errno for error reporting is not lost accross _() calls
180  - report EOF on read pipe differently from read returning < 0 reporting
181  * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
182  - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
183  * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
184  - add important bug-fixes from make home-page
185
186* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
187- some patches was included from 3.79.1-17
188
189* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
190- update ja.po
191
192* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
193- new upstream release
194
195* Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
196- 3.79.1-5vl1
197- based on 3.79.1-5 from Rawhide
198- rebuilt for Vine Linux
199- added Japanese summary and description
200
201* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
202- change info-dir entry so that 'info make' works (#15029).
203
204* Tue Aug  1 2000 Jakub Jelinek <jakub@redhat.com>
205- assume we don't have clock_gettime in configure, so that
206  make is not linked against -lpthread (and thus does not
207  limit stack to 2MB).
208
209* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
210- add locale files (#14362).
211
212* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
213- automatic rebuild
214
215* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
216- 3.79.1 bugfix release
217
218* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
219- FHS packaging.
220
221* Sun May  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
222- Fix build for some odd situations, such as
223  - previously installed make != GNU make
224  - /bin/sh != bash
225
226* Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
227- update to 3.79
228
229* Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
230- add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
231  builds)
232
233* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
234- compress man page.
235
236* Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
237- apply patch to fix a /tmp race condition from Thomas Biege
238- simplify %install
239
240* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
241- update to 3.78.1.
242
243* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
244- added a serial tag so it upgrades right
245
246* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
247- auto rebuild in the new build environment (release 5)
248
249* Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
250- added a patch for large file support in glob
251 
252* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
253- update to 3.77
254
255* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
256- translations modified for de, fr, tr
257
258* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
259- udpated from 3.75 to 3.76
260- various spec file cleanups
261- added install-info support
262
263* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
264- built against glibc
Note: See TracBrowser for help on using the repository browser.