source: projects/specs/branches/6/lib/libz/libzen/libzen-vl.spec @ 4335

Revision 4335, 4.0 KB checked in by kudoh, 13 years ago (diff)
Line 
1# Copyright (c) 2008 oc2pus
2# This file and all modifications and additions to the pristine
3# package are under the same license as the package itself.
4#
5# Please submit bugfixes or comments to toni@links2linux.de
6#
7# *** This spec is modified for Vine Linux ***
8
9# norootforbuild
10
11%define _prefix /usr
12# %define _SO_nr        0
13
14Name:                   libzen
15Version:                0.4.20
16Release:                1%{?_dist_release}
17Summary:                Shared library for libmediainfo and medianfo-*
18Summary(ja):            libmediainfo 及び mediainfo-* 用の共有ライブラリ
19Group:                  System Environment/Libraries
20License:                BSD
21URL:                    http://zenlib.sourceforge.net/
22Source:                 libzen_%{version}.tar.bz2
23BuildRoot:              %{_tmppath}/%{name}-%{version}-root
24# BuildRequires:                dos2unix
25BuildRequires:          nkf
26BuildRequires:          doxygen
27## Need GCC3
28BuildRequires:          gcc-c++
29
30Packager:               babasaki
31
32%description
33Shared library for libmediainfo and medianfo-*.
34
35%description -l ja
36libmediainfo 及び mediainfo-* 用の共有ライブラリです。
37
38%package -n libzen-devel
39Summary:        Include files and mandatory libraries for development
40Summary(ja):    libzen の開発用のヘッダとライブラリファイル
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43
44%description -n libzen-devel
45Include files and mandatory libraries for development.
46
47%description -n libzen-devel -l ja
48libzen の開発用のヘッダとライブラリファイルです。
49
50%prep
51%setup -q -n ZenLib
52## dos2unix     *.txt Source/Doc/*.html
53nkf --unix --overwrite *.txt Source/Doc/*.html
54
55%__chmod 644 *.txt Source/Doc/*.html
56
57%build
58export CFLAGS="$RPM_OPT_FLAGS"
59export CPPFLAGS="$RPM_OPT_FLAGS"
60export CXXFLAGS="$RPM_OPT_FLAGS"
61
62pushd Source/Doc/
63        doxygen Doxyfile
64popd
65cp Source/Doc/*.html ./
66
67pushd Project/GNU/Library
68        %__chmod +x autogen
69        ./autogen
70        %configure --enable-shared --disable-static
71
72        %__make clean
73        %__make %{?jobs:-j%{jobs}}
74popd
75
76%install
77pushd Project/GNU/Library
78        %__make install-strip DESTDIR=%{buildroot}
79popd
80
81# Zenlib headers and ZenLib-config
82%__install -dm 755 %{buildroot}%{_includedir}/ZenLib
83%__install -m 644 Source/ZenLib/*.h \
84        %{buildroot}%{_includedir}/ZenLib
85for i in Base64 HTTP_Client Format/Html Format/Http TinyXml; do
86        %__install -dm 755 %{buildroot}%{_includedir}/ZenLib/$i
87        %__install -m 644 Source/ZenLib/$i/*.h \
88                %{buildroot}%{_includedir}/ZenLib/$i
89done
90
91%__sed -i -e 's|Version: |Version: %{version}|g' \
92        Project/GNU/Library/libzen.pc
93%__install -dm 755 %{buildroot}%{_libdir}/pkgconfig
94%__install -m 644 Project/GNU/Library/libzen.pc \
95        %{buildroot}%{_libdir}/pkgconfig
96
97# remove unpackaged files
98rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la
99
100
101%clean
102[ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %__rm -rf "%{buildroot}"
103
104%post -n libzen -p /sbin/ldconfig
105
106%postun -n libzen -p /sbin/ldconfig
107
108%files
109%defattr(-,root,root,-)
110%doc History.txt License.txt ReadMe.txt
111%{_libdir}/libzen.so.*
112
113%files -n libzen-devel
114%defattr(-,root,root,-)
115%doc Documentation.html
116%doc Doc/*
117%dir %{_includedir}/ZenLib
118%{_includedir}/ZenLib/*
119%{_libdir}/libzen.so
120%{_libdir}/pkgconfig/*.pc
121
122%changelog
123* Fri Jul 15 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.20-1
124- new upstream release
125
126* Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.17-1
127- new upstream release
128
129* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.15-4
130- rebuilt with rpm-4.8.1 for pkg-config
131
132* Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.15-3
133- fixed Group to System Environment/Libraries
134
135* Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.15-2
136- fix %install (add install directory)
137
138* Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15-1
139- new upstream release
140
141* Tue Jul 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.3-1
142- new upstream release
143- change spec file name to libzen-vl.spec
144- add japanese summary and description
145- change group for -devel sub package to Development/Libraries
146- add configure option --disable-static
147- remove unpackaged file (.la)
148- add Packager tag
149
150* Tue Jan 01 2009 Jerome Martinez <zen@mediaarea.net> - 0.3.6-0
151- See History.txt for more info and real dates
152- Previous packages made by Toni Graffy <toni@links2linux.de>
Note: See TracBrowser for help on using the repository browser.