source: projects/specs/branches/6/lib/libx/libxkbfile/libxkbfile-vl.spec @ 2203

Revision 2203, 7.1 KB checked in by Takemikaduchi, 13 years ago (diff)

update Xorg libraries and xserver, and rebuild driver

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libxkbfile runtime library
4Summary(ja): X.Org X11 libxkbfile ランタイムライブラリ
5Name: libxkbfile
6Version: 1.0.7
7Release: 1%{?_dist_release}
8License: MIT
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/libxkbfile/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: xorg-x11-proto-devel
16BuildRequires: libX11-devel
17
18%description
19X.Org X11 libxkbfile runtime library
20
21%package devel
22Summary: X.Org X11 libxkbfile development package
23Summary(ja): X.Org X11 libxkbfile 開発パッケージ
24Group: Development/Libraries
25Requires(pre): xorg-x11-filesystem
26Requires: %{name} = %{version}-%{release}
27Requires: pkgconfig
28BuildRequires: xorg-x11-proto-devel
29
30%description devel
31X.Org X11 libxkbfile development package
32
33# compat32
34%package -n compat32-%{name}
35Summary: X.Org X11 libxkbfile runtime library
36Summary(ja): X.Org X11 libxkbfile ランタイムライブラリ
37Group: System Environment/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description -n compat32-%{name}
41X.Org X11 libxkbfile runtime library
42
43%package -n compat32-%{name}-devel
44Summary: X.Org X11 libxkbfile development package
45Summary(ja): X.Org X11 libxkbfile 開発パッケージ
46Group: Development/Libraries
47Requires(pre): xorg-x11-filesystem
48Requires: %{name}-devel = %{version}-%{release}
49Requires: compat32-%{name} = %{version}-%{release}
50
51%description -n compat32-%{name}-devel
52X.Org X11 libxkbfile development package
53
54%prep
55%setup -q
56
57# Disable static library creation by default.
58%define with_static 0
59
60%build
61# FIXME: We use -fno-strict-aliasing, to work around the following bug:
62# maprules.c:1373: warning: dereferencing type-punned pointer will break strict-aliasing rules)
63export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
64%configure \
65%if ! %{with_static}
66        --disable-static
67%endif
68make %{?_smp_mflags}
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73make install DESTDIR=$RPM_BUILD_ROOT
74
75# We intentionally don't ship *.la files
76rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post -p /sbin/ldconfig
82%postun -p /sbin/ldconfig
83
84%post -n compat32-%{name} -p /sbin/ldconfig
85%postun -n compat32-%{name} -p /sbin/ldconfig
86
87%files
88%defattr(-,root,root,-)
89%doc COPYING ChangeLog
90%{_libdir}/libxkbfile.so.1
91%{_libdir}/libxkbfile.so.1.0.2
92
93%files devel
94%defattr(-,root,root,-)
95%dir %{_includedir}/X11
96%dir %{_includedir}/X11/extensions
97%{_includedir}/X11/extensions/XKBbells.h
98%{_includedir}/X11/extensions/XKBconfig.h
99%{_includedir}/X11/extensions/XKBfile.h
100%{_includedir}/X11/extensions/XKBrules.h
101%{_includedir}/X11/extensions/XKM.h
102%{_includedir}/X11/extensions/XKMformat.h
103%if %{with_static}
104%{_libdir}/libxkbfile.a
105%endif
106%{_libdir}/libxkbfile.so
107%{_libdir}/pkgconfig/xkbfile.pc
108
109# compat32
110%if %{build_compat32}
111%files -n compat32-%{name}
112%defattr(-,root,root,-)
113%{_libdir}/libxkbfile.so.1
114%{_libdir}/libxkbfile.so.1.0.2
115
116%files -n compat32-%{name}-devel
117%defattr(-,root,root,-)
118%if %{with_static}
119%{_libdir}/libxkbfile.a
120%endif
121%{_libdir}/libxkbfile.so
122%{_libdir}/pkgconfig/xkbfile.pc
123%endif
124
125%changelog
126* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
127- new upstream release
128
129* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-2
130- rebuild with rpm-4.8.1 for pkg-config file
131
132* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
133- new upstream release
134
135* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
136- added compat32 package for x86_64 arch support
137
138* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
139- new upstream release
140
141* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
142- new versioning policy
143
144* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
145- initial build for Vine Linux
146
147* Tue Jan 15 2008 parag <paragn@fedoraproject.org> - 1.0.4-4
148- Merge-Review #226077
149- Removed XFree86-libs, xorg-x11-libs XFree86-devel, xorg-x11-devel as Obsoletes
150- Removed BR:pkgconfig
151- Removed zero-length AUTHORS README file
152
153* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.4-3
154- Rebuild for build id
155
156* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
157- Don't install INSTALL
158
159* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.4-1.fc7
160- Update to 1.0.4
161
162* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.3-3.1
163- rebuild
164
165* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.3-3
166- Added "Requires: xorg-x11-proto-devel" to devel package for xkbfile.pc
167
168* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.3-2
169- Added "BuildRequires: pkgconfig" for (#193424)
170- Replace "makeinstall" with "make install DESTDIR=..."
171- Remove package ownership of mandir/libdir/etc.
172
173* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
174- Update to 1.0.3
175
176* Tue Feb 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
177- Updated libxkbfile to version 1.0.2
178
179* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
180- bump again for double-long bug on ppc(64)
181
182* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
183- rebuilt for new gcc4.1 snapshot and glibc changes
184
185* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
186- Updated libxkbfile to version 1.0.1 from X11R7.0
187
188* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
189- Updated libxkbfile to version 1.0.0 from X11R7 RC4
190
191* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
192- Updated libxkbfile to version 0.99.2 from X11R7 RC3
193- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
194  that /usr/lib/X11 and /usr/include/X11 pre-exist.
195- Removed 'x' suffix from manpage directories to match RC3 upstream.
196
197* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
198- rebuilt
199
200* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
201- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
202- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
203
204* Thu Oct 27 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
205- Work around pointer aliasing problem with -fno-strict-aliasing
206
207* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
208- Updated libxkbfile to version 0.99.1 from X11R7 RC1
209
210* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
211- Renamed package to remove xorg-x11 from the name due to unanimous decision
212  between developers.
213- Use Fedora Extras style BuildRoot tag.
214- Disable static library creation by default.
215- Add missing defattr to devel subpackage
216- Add missing documentation files to doc macro
217
218* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
219- Renamed package to prepend "xorg-x11" to the name for consistency with
220  the rest of the X11R7 packages.
221- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
222  subpackage to ensure the devel package matches the installed shared libs.
223- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
224  allow applications to use implementation agnostic dependencies.
225- Added post/postun scripts which call ldconfig.
226- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
227  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
228
229* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
230- Initial build.
Note: See TracBrowser for help on using the repository browser.