source: projects/specs/branches/6/lib/libx/libxcb/libxcb-vl.spec @ 7730

Revision 7730, 5.6 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define xpyb_version 1.2
4
5Summary:        A C binding to the X11 protocol
6Summary(ja):    X11 プロトコルの C による実装
7Name:           libxcb
8Version:        1.7
9Release:        2%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        MIT
13URL:            http://xcb.freedesktop.org/
14Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
15
16Source2:        http://xcb.freedesktop.org/dist/xpyb-%{xpyb_version}.tar.bz2
17
18# fix CVE-2013-2064
19Patch0:                 libxcb-CVE-2013-2064.patch
20
21Patch10:        libxcb-1.7-no-pthread-stubs.patch
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires:  autoconf automake libtool pkgconfig
25#BuildRequires:  doxygen
26#BuildRequires:  graphviz
27BuildRequires:  libXau-devel
28BuildRequires:  libxslt
29BuildRequires:  xcb-proto >= 1.6
30BuildRequires:  xorg-x11-proto-devel
31BuildRequires:  xorg-x11-util-macros
32BuildRequires:  python-devel
33
34%description
35The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
36small footprint, latency hiding, direct access to the protocol, improved
37threading support, and extensibility.
38
39%package        devel
40Summary:        Development files for %{name}
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       pkgconfig
44
45%description    devel
46The %{name}-devel package contains libraries and header files for
47developing applications that use %{name}.
48
49%package        doc
50Summary:        Documentation for %{name}
51Group:          Documentation
52
53%description    doc
54The %{name}-doc package contains documentation for the %{name} library.
55
56%package        python
57Summary:        Python bindings for %{name}
58Group:          Development/Libraries
59Provides:       xpyb
60
61%description    python
62Python bindings for %{name}.
63
64%package        -n compat32-%{name}
65Summary:        A C binding to the X11 protocol
66Summary(ja):    X11 プロトコルの C による実装
67Group:          System Environment/Libraries
68
69%description    -n compat32-%{name}
70The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
71small footprint, latency hiding, direct access to the protocol, improved
72threading support, and extensibility.
73
74%package        -n compat32-%{name}-devel
75Summary:        Development files for %{name}
76Group:          Development/Libraries
77Requires:       compat32-%{name} = %{version}-%{release}
78Requires:       %{name}-devel = %{version}-%{release}
79
80%description    -n compat32-%{name}-devel
81The %{name}-devel package contains libraries and header files for
82developing applications that use %{name}.
83
84%prep
85%setup -q -b2
86%patch0 -p1
87%patch10 -p1
88
89pushd ../xpyb-%{xpyb_version}
90# XXX fix me upstream please
91sed -i 's@$(pythondir)@$(pyexecdir)@' src/Makefile.am
92popd
93
94%build
95autoreconf -v --install
96%configure --disable-static --docdir=%{_datadir}/doc/%{name}-%{version} --disable-selinux
97make %{?_smp_mflags}
98
99pushd ../xpyb-%{xpyb_version}
100autoreconf -v --install
101%configure
102make %{?_smp_mflags}
103popd
104
105%install
106rm -rf $RPM_BUILD_ROOT
107make install DESTDIR=$RPM_BUILD_ROOT
108find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
109install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
110
111pushd ../xpyb-%{xpyb_version}
112make install DESTDIR=$RPM_BUILD_ROOT
113popd
114
115find $RPM_BUILD_ROOT -name '*.la' -delete
116
117# remove xml and txt file
118rm -rf $RPM_BUILD_ROOT%{_docdir}/xpyb
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
126%post -n compat32-%{name} -p /sbin/ldconfig
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129%files
130%defattr(-,root,root,-)
131%{_libdir}/*.so.*
132
133%files devel
134%defattr(-,root,root,-)
135%{_includedir}/xcb
136%{_libdir}/*.so
137%{_libdir}/pkgconfig/*.pc
138
139%files doc
140%defattr(-,root,root,-)
141%{_datadir}/doc/%{name}-%{version}
142
143%files python
144%defattr(-,root,root,-)
145%{python_sitearch}/xcb
146
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-,root,root,-)
150%{_libdir}/*.so.*
151
152%files  -n compat32-%{name}-devel
153%defattr(-,root,root,-)
154%{_libdir}/*.so
155%{_libdir}/pkgconfig/*.pc
156%endif
157
158%changelog
159* Wed May 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-2
160- Patch0 (libxcb-CVE-2013-2064.patch)
161
162* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
163- new upstream release
164- update Patch10
165
166* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
167- add BuildRequires: python-devel
168
169* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
170- build with rpm-4.8.1-1 for pkg-config file
171
172* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
173- new upstream release
174
175* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
176- rebuild with python-2.6
177
178* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
179- new upstream release
180- add libxcb python binding (xpyb)
181
182* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
183- added compat32 package for x86_64 arch support
184
185* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
186- new upstream release
187
188* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
189- spec in utf-8
190- added japanese summary
191
192* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
193- new versioning policy
194
195* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
196- initial build for Vine Linux
197
198* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
199- libxcb 1.1
200
201* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
202- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
203  abstract-namespace unix sockets to filesystem-bound sockets.
204
205* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
206- Rebuild for PPC toolchain bug
207
208* Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
209- Initial revision.
Note: See TracBrowser for help on using the repository browser.