source: projects/specs/branches/6/lib/libv/libvorbis/libvorbis-vl.spec @ 1855

Revision 1855, 9.7 KB checked in by inagaki, 14 years ago (diff)

rebuilt with rpm-4.8.1: libcapseo, ilmbase
updated and built with rpm-4.8.1: libogg, libvorbis

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define liboggver 1.2.0
3%define epoch_num 1
4
5Summary:        The Vorbis General Audio Compression Codec.
6Summary(ja):    Vorbis - 汎用オーディオ圧縮コーデック
7Name:           libvorbis
8Version:        1.3.1
9Release:        1%{?_dist_release}
10Epoch:          %{epoch_num}
11
12Group:          System Environment/Libraries
13License:        BSD
14URL:            http://www.xiph.org/
15
16Source:         http://downloads.xiph.org/releases/vorbis/%{name}-%{version}.tar.bz2
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  libogg-devel >= %{liboggver}
20BuildRequires:  perl
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24
25%description
26Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
27general-purpose compressed audio format for audio and music at fixed
28and variable bitrates from 16 to 128 kbps/channel.
29
30The libvorbis package contains runtime libraries for use in programs
31that support Ogg Voribs.
32
33%description -l ja
34Ogg Vorbis は完全にオープンで、知的所有権による制約、特許やロイヤリティ
35と関係ない汎用のオーディオ圧縮フォーマットで、チャンネルあたり 16〜128
36kbps の固定/可変ビットレートのオーディオや音楽用です。
37
38このパッケージには、Ogg Vorbis をサポートするプログラムで使われるランタ
39イムライブラリが含まれています。
40
41%package devel
42Summary:        Development files for Vorbis applications.
43Summary(ja):    Vorbis アプリケーションの開発用ファイル
44Group:          Development/Libraries
45Requires:       %{name} = %{epoch_num}:%{version}-%{release}
46Requires:       libogg-devel >= %{liboggver}
47
48%description devel
49The libvorbis-devel package contains the header files, static libraries
50and documentation needed to develop applications with libvorbis.
51
52%description -l ja devel
53このパッケージには、libvorbis を使ったアプリケーションの開発に必要な
54ヘッダファイル、静的ライブラリ、及びドキュメントが含まれています。
55
56# compat32
57%package -n compat32-%{name}
58Summary:        The Vorbis General Audio Compression Codec.
59Summary(ja):    Vorbis - 汎用オーディオ圧縮コーデック
60Group:          System Environment/Libraries
61
62%description -n compat32-%{name}
63Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
64general-purpose compressed audio format for audio and music at fixed
65and variable bitrates from 16 to 128 kbps/channel.
66
67The libvorbis package contains runtime libraries for use in programs
68that support Ogg Voribs.
69
70%description -n compat32-%{name} -l ja
71Ogg Vorbis は完全にオープンで、知的所有権による制約、特許やロイヤリティ
72と関係ない汎用のオーディオ圧縮フォーマットで、チャンネルあたり 16〜128
73kbps の固定/可変ビットレートのオーディオや音楽用です。
74
75このパッケージには、Ogg Vorbis をサポートするプログラムで使われるランタ
76イムライブラリが含まれています。
77
78%package -n compat32-%{name}-devel
79Summary:        Development files for Vorbis applications.
80Summary(ja):    Vorbis アプリケーションの開発用ファイル
81Group:          Development/Libraries
82Requires:       compat32-%{name} = %{epoch_num}:%{version}-%{release}
83Requires:       compat32-libogg-devel >= %{liboggver}
84
85%description -n compat32-%{name}-devel
86The libvorbis-devel package contains the header files, static libraries
87and documentation needed to develop applications with libvorbis.
88
89%description -n compat32-%{name}-devel -l ja
90このパッケージには、libvorbis を使ったアプリケーションの開発に必要な
91ヘッダファイル、静的ライブラリ、及びドキュメントが含まれています。
92
93%prep
94%setup -q
95
96perl -p -i -e "s/-O20/%{optflags}/" configure
97perl -p -i -e "s/-ffast-math//" configure
98
99%build
100%configure --with-ogg-libraries=%{_libdir} --disable-static
101make %{?_smp_mflags}
102
103%install
104[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
105make DESTDIR=%{buildroot} install
106
107#rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
108rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
109
110%clean
111[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117%post -n compat32-%{name} -p /sbin/ldconfig
118
119%postun -n compat32-%{name} -p /sbin/ldconfig
120
121%files
122%defattr(-,root,root)
123%doc AUTHORS COPYING README todo.txt
124%{_libdir}/*.so.*
125
126%files devel
127%defattr(-,root,root)
128%doc doc/*
129%{_includedir}/vorbis
130#{_libdir}/*.la
131%{_libdir}/*.so
132%{_libdir}/pkgconfig/*.pc
133%{_datadir}/aclocal/vorbis.m4
134
135# compat32
136%if %{build_compat32}
137%files -n compat32-%{name}
138%defattr(-,root,root)
139%{_libdir}/*.so.*
140
141%files -n compat32-%{name}-devel
142%defattr(-,root,root)
143#{_libdir}/*.la
144%{_libdir}/*.so
145%{_libdir}/pkgconfig/*.pc
146%endif
147
148%changelog
149* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-1
150- new upstream release
151- built with rpm-4.8.1
152
153* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
154- new upstream release
155- dropped Patch2-7 (merged into upstream)
156
157* Wed Aug 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-9
158- add patch7 to fix CVE-2009-2663 (OGG Processing) from fc10
159
160* Sun Jun 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-8
161- fix compat32-devel Require tag (adding epoch)
162
163* Sun Jun 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-7
164- rollback to 1.2.0 because of pulseaudio lockup issue
165- add Epoch 1
166- patch2-6 are added again
167
168* Wed Jun 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
169- new upstream release
170- drop old patches
171
172* Fri Jun 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-6
173- used --disable-static option
174
175* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.0-5
176- added compat32 package for x86_64 arch support
177- removed lib*.a from devel package
178
179* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.0-4vl5
180- spec in utf-8
181
182* Sun Jun 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-3vl5
183- added Patches for security fix based on VinePlus 1.2.0-3vl4
184  * Sat Jun 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-3vl4
185  - add patch2,6 for additional hardening/sanity checks
186  - add patch3 for CVE-2008-1420
187  - add patch4 for CVE-2008-1419
188  - add patch5 for CVE-2008-1423
189
190* Mon May 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
191- applied new versioning policy
192- removed lib*.la from devel package
193
194* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl4
195- fixed include file location
196
197* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl3
198- rebuild for VineSeed
199
200* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl2
201- rebuild for Vine Linux 4.1
202
203* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
204- new upstream release (CVE-2007-3106, CVE-2007-4029)
205
206* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
207- rebuild with new toolchain
208
209* Tue Nov 29 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
210- source upgrade
211
212* Fri Jul 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
213- source upgrade
214- add Japanese summary and description
215
216* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
217- source upgrade
218- update source-URL
219
220* Fri Mar 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl3
221- rebuild
222
223* Sat Nov 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl2
224- rebuild for VineSeedPlus
225
226* Fri Nov 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl1
227- source upgrade
228- build for VinePlus/2.6
229- add %%{_libdir}/*.la and %%{_libdir}/pkgconfig/*.pc to devel package
230- disable %%configure script
231
232* Sat Oct  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl3
233- rebuild with new toolchains
234- use License tag
235
236* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl2
237- rebuild with new toolchains
238
239* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl1
240- source upgrade
241- update %description devel
242- add PreReq: ldconfig
243- delete Patch
244
245* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.99.3-1vl1
246- build for VineSeed
247- change version number to 0.99.3 (means 1.0rc3)
248
249* Tue Jan  1 2002 Bill Nottingham <notting@redhat.com>
250- update to 1.0rc3
251
252* Thu Aug 16 2001 Bill Nottingham <notting@redhat.com>
253- fix bug in floor backend (<michael@stroucken.org>)
254
255* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
256- update to 1.0rc2
257
258* Fri Jul 20 2001 Bill Nottingham <notting@redhat.com>
259- split out from the main vorbis package
260
261* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com>
262- own %%{_libdir}/ao
263- I love libtool
264
265* Tue Jun 26 2001 Florian La Roche <Florian.LaRoche@redhat.de>
266- add links from library major version numbers in rpms
267
268* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
269- update to rc1
270
271* Fri May  4 2001 Oliver Paukstadt <oliver.paukstadt@millenux.com>
272- fixed perl line in spec file to set optims correctly
273
274* Tue Mar 20 2001 Bill Nottingham <notting@redhat.com>
275- fix alpha/ia64, again
276- use optflags, not -O20 -ffast-math (especially on alpha...)
277
278* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
279- fix license tag
280
281* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
282- beta4
283
284* Fri Feb  9 2001 Bill Nottingham <notting@redhat.com>
285- fix alpha/ia64
286
287* Thu Feb  8 2001 Bill Nottingham <notting@redhat.com>
288- update CVS in prep for beta4
289
290* Wed Feb 07 2001 Philipp Knirsch <pknirsch@redhat.de>
291- Fixed bugzilla bug #25391. ogg123 now usses the OSS driver by default if
292  none was specified.
293
294* Tue Jan  9 2001 Bill Nottingham <notting@redhat.com>
295- update CVS, grab aRts backend for libao
296
297* Thu Dec 27 2000 Bill Nottingham <notting@redhat.com>
298- update CVS
299
300* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
301- rebuild because of broken fileutils
302
303* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
304- hack up specfile some, merge some packages
305
306* Sat Oct 21 2000 Jack Moffitt <jack@icecast.org>
307- initial spec file created
Note: See TracBrowser for help on using the repository browser.