source: projects/specs/branches/6/lib/libu/libutempter/libutempter-vl.spec @ 3155

Revision 3155, 9.3 KB checked in by inagaki, 13 years ago (diff)

update: libmng, libutempter

Line 
1%define utempter_compat_ver 0.5.5
2
3Name: libutempter
4Summary: A privileged helper for utmp/wtmp updates
5Version: 1.1.5
6Release: 4%{?_dist_release}
7
8Group: System Environment/Libraries
9License: LGPLv2
10URL: ftp://ftp.altlinux.org/pub/people/ldv/utempter
11
12Source0: ftp://ftp.altlinux.org/pub/people/ldv/utempter/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15Requires(pre): shadow-utils
16Requires(post): /sbin/ldconfig
17Requires(postun): /sbin/ldconfig
18
19Provides: utempter = %{utempter_compat_ver}
20Obsoletes: utempter
21
22%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
23
24%description
25This library provides interface for terminal emulators such as
26screen and xterm to record user sessions to utmp and wtmp files.
27
28%package devel
29Summary: Development environment for utempter
30Group: Development/Libraries
31Requires: %{name} = %{version}-%{release}
32
33%description devel
34This package contains development files required to build
35utempter-based software.
36
37
38%package -n compat32-%{name}
39Summary:   A privileged helper for utmp/wtmp updates.
40Group:     System Environment/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description -n compat32-%{name}
44Utempter is a utility which allows some non-privileged programs to
45have required root access without compromising system
46security. Utempter accomplishes this feat by acting as a buffer
47between root and the programs.
48
49%package -n compat32-%{name}-devel
50Summary: Development environment for utempter
51Group: Development/Libraries
52Requires: compat32-%{name} = %{version}
53Requires: %{name}-devel = %{version}
54
55%description -n compat32-%{name}-devel
56This package contains development files required to build
57utempter-based software.
58
59
60%prep
61%setup -q
62
63%build
64make CFLAGS="$RPM_OPT_FLAGS" libdir="%{_libdir}" libexecdir="%{_libexecdir}"
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69make install DESTDIR="$RPM_BUILD_ROOT" libdir="%{_libdir}" libexecdir="%{_libexecdir}"
70
71# FIXME: We might need to enable this part for backward compat with the
72# Red Hat / Fedora 'utempter' package:
73#
74# mkdir -p %{_sbindir}
75# ln -sf %{helperdir}/utempter %{_sbindir}/utempter
76
77
78# NOTE: Static lib intentionally disabled.
79rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%pre
85{
86    %{_sbindir}/groupadd -g 22 -r -f utmp || :
87    %{_sbindir}/groupadd -g 35 -r -f utempter || :
88}
89
90%post
91{
92    /sbin/ldconfig
93    for file in /var/log/wtmp /var/run/utmp ; do
94        if [ -f $file ]; then
95            chown root:utmp $file
96            chmod 664 $file
97        fi
98    done
99}
100
101%postun -p /sbin/ldconfig
102
103%if %{build_compat32}
104%post -n compat32-%{name} -p /sbin/ldconfig
105%postun -n compat32-%{name} -p /sbin/ldconfig
106%endif
107
108%files
109%defattr(-,root,root,-)
110%doc COPYING README
111%{_libdir}/libutempter.so.*
112%dir %attr(755,root,utempter) %{_libexecdir}/utempter
113%attr(2711,root,utmp) %{_libexecdir}/utempter/utempter
114# FIXME: If a symlink is needed for compat here, uncomment the code in the
115# install section and this as well:
116#%{_sbindir}/utempter
117
118%files devel
119%defattr(-,root,root,-)
120%{_includedir}/utempter.h
121%{_libdir}/libutempter.so
122
123%if %{build_compat32}
124%files -n compat32-%{name}
125%defattr(-,root,root)
126%{_libdir}/libutempter.so.*
127
128%files -n compat32-%{name}-devel
129%defattr(-,root,root)
130%{_libdir}/libutempter.so
131%endif
132
133%changelog
134* Sun Mar 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.5-4
135- rebuilt with new toolchain
136
137* Sun Jul 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.5-3
138- initial build for Vine Linux
139- replaced utempter
140  * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 0.5.5-6vl2
141  - added compat32- packages for x86_64 architecture support
142  * Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.5-6vl1
143  - based on Fedora 0.5.5-6
144    * Mon Apr 19 2004 Mike A. Harris <mharris@redhat.com> 0.5.5-1
145    - [SECURITY] Fix CAN-2004-0233 utempter directory traversal symlink attack
146      issue for immediate erratum release.
147    - Build all-arch test package 0.5.5-1 in dist-fc2-scratch
148    * Mon Feb 23 2004 Mike A. Harris <mharris@redhat.com> 0.5.4-1
149    - Rewrote post install script to be a bit cleaner and rebuilt in rawhide to
150      pick up twaugh's chown change
151    - Added 'srpm-x' target to Makefile for package maintainer SRPM building
152    * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
153    - Use ':' instead of '.' as separator for chown.
154  * Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.3-2vl1
155  - based on Redhat Rawhide 0.5.3-2
156    * Fri May 30 2003 Mike A. Harris <mharris@redhat.com> 0.5.3-1
157    - Bump version and release and rebuild to strip debug info into .debuginfo
158      package, as the Red Hat Linux 9 package shipped unstripped (#91664)
159    - Updated license field to reflect dual license MIT style + LGPL
160    - Changed spec file Copyright tag to proper License tag
161    - Removed stupid crackrock "version" macro define
162    * Thu Jun 20 2002 Elliot Lee <sopwith@redhat.com> 0.5.2-9
163    - Don't strip binary
164    - Thu Feb 24 2000 Erik Troan <ewt@redhat.com>
165    - added LGPL notice
166  * Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-4vl2
167  - rebuild to remove rpmlib dependancy
168  * Tue May 29 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
169  - 0.5.2-4vl1
170  - rebuilt for Vine Linux
171
172* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.5-2
173- Autorebuild for GCC 4.3
174
175* Wed Nov 07 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
176- 1.1.5-1
177- version upgrade
178- fix #246063
179
180* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.1.4-4
181- Rebuild for build id
182
183* Thu Jul 27 2006 Mike A. Harris <mharris@redhat.com> 1.1.4-3.fc6
184- Create 'utempter' group with official allocated GID==35 (from setup package).
185
186* Tue Jul 25 2006 Mike A. Harris <mharris@redhat.com> 1.1.4-2.fc6
187- Removed usage of rpm macros inside the spec changelog (#200051)
188- Removed non-UTF-8 chars from changelog.
189
190* Mon Jul 24 2006 Mike A. Harris <mharris@redhat.com> 1.1.4-1.fc6
191- Initial build of Dimitry's libutempter replacement for Fedora Core.
192- Reworked the upstream spec file for Fedora packaging compliance.
193- Removed static lib subpackage as we dont ship those.
194
195* Fri Dec 09 2005 Dmitry V. Levin <ldv@altlinux.org> 1.1.4-alt1
196- Enabled almost all diagnostics supported by gcc and fixed all
197  issues found by gcc-3.4.4-alt3.
198- Added FreeBSD support, based on patches from Gentoo/FreeBSD.
199- Makefile:
200  + Fixed few portability issues reported by Gentoo developers.
201- libutempter: Linked with -Wl,-z,defs.
202- utempter:
203  + Fixed struct utmp initialization on 64-bit architectures
204    with 32-bit backwards compatibility enabled (like x86_64).
205  + Linked with -Wl,-z,now, i.e., marked it to tell the dynamic
206    linker to resolve all symbols when the program is started.
207    Suggested by Gentoo developers.
208
209* Thu Aug 18 2005 Dmitry V. Levin <ldv@altlinux.org> 1.1.3-alt1
210- Restricted list of global symbols exported by the library.
211- Updated FSF postal address.
212
213* Sun Sep 05 2004 Dmitry V. Levin <ldv@altlinux.org> 1.1.2-alt1
214- Added multilib support.
215
216* Fri Feb 14 2003 Dmitry V. Levin <ldv@altlinux.org> 1.1.1-alt1
217- iface.c: don't block SIGCHLD; redefine signal handler instead.
218
219* Mon Dec 23 2002 Dmitry V. Levin <ldv@altlinux.org> 1.1.0-alt1
220- Changed soname back to libutempter.so.0, introduced versioning.
221
222* Tue Sep 24 2002 Dmitry V. Levin <ldv@altlinux.org> 1.0.7-alt1
223- If helper execution fails, try saved group ID.
224
225* Tue May 21 2002 Dmitry V. Levin <ldv@altlinux.org> 1.0.6-alt1
226- New function: utempter_set_helper.
227
228* Mon Dec 10 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.5-alt1
229- iface.c: block SIGCHLD instead of redefine signal handler.
230
231* Wed Nov 21 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.4-alt1
232- utempter.h: do not use "__attribute ((unused))".
233
234* Tue Nov 13 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.3-alt1
235- Added compatibility declarations to ease upgrade of old applications.
236- Added small README file.
237- Corrected provides.
238
239* Thu Nov 08 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.2-alt1
240- Added compatibility library to ease upgrade of old applications.
241
242* Mon Nov 05 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.1-alt1
243- Indented code a bit (Solar request).
244
245* Mon Oct 15 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.0-alt1
246- Rewritten the code completely.
247- Renamed to libutempter.
248- Corrected the package description.
249- FHSificated (yes, there are no more {_sbindir}/utempter).
250- Libificated.
251
252* Fri Oct 12 2001 Dmitry V. Levin <ldv@altlinux.ru> 0.5.2-alt4
253- {_libdir}/utempter sounds better so use it as helper directory.
254
255* Thu Oct 11 2001 Dmitry V. Levin <ldv@altlinux.ru> 0.5.2-alt3
256- Specfile cleanup.
257- Owl-compatible changes:
258  + added utempter group;
259  + utempter binary moved to {_libdir}/utempter.d,
260    owned by group utempter with 710 permissions.
261
262* Thu Jun 28 2001 Sergie Pugachev <fd_rag@altlinux.ru> 0.5.2-alt1
263- new version
264
265* Tue Dec 05 2000 AEN <aen@logic.ru>
266- build for RE
267
268* Tue Jul 25 2000 Thierry Vignaud <tvignaud@mandrakesoft.com> 0.5.1-4mdk
269- BM
270
271* Fri May 19 2000 Pixel <pixel@mandrakesoft.com> 0.5.1-3mdk
272- add -devel
273- add soname
274- spec helper cleanup
275
276* Sat Apr 08 2000 Christopher Molnar <molnarc@mandrakesoft.com> 0.5.1-2mdk
277- changed group
278
279* Tue Oct 26 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
280- 0.5.1
281- fix utmp as group 22.
282- strip utempter.
283- defattr to root.
284
285* Thu Jun 10 1999 Bernhard Rosenkraenzer <bero@mandrakesoft.com>
286- Mandrake adaptions
287
288* Fri Jun  4 1999 Jeff Johnson <jbj@redhat.com>
289- ignore SIGCHLD while processing utmp.
Note: See TracBrowser for help on using the repository browser.